You've got that signal "count", which goes high for one clock-cycle when your counter is reloaded. This signal goes to your output, "pulse". So....
If you do a simulation of this it should be obvious to you.
Just as a point of style, there's no reason to have a signal called "count" which then gets connected to an output with a totally different name, "pulse". That makes things a LOT harder to follow; you could have just assigned "pulse" inside your process. On the occasions where you need to read the value of an output(and, thus have to use a signal, for instance your clk_out/div_clk thing) what I usually do is give the signal a name similar to the output, for example port name=clk_out; signal name=clk_out_s. Otherwise you can spend a lot of time tracking down signals if they keep changing name along the path.