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Chapter 1: Introduction

Translating CAD data between various systems can be difficult. Different CAD
systems have different representations of data. For instance, some systems contain
the concept of a hole and some do not. Differences in translation formats often cause
data to be lost or transformed.

In Advanced Design System, translating graphical designs is initiated from the
layout window using the File > Import and File > Export menu commands.The
program’s import/export translators are highly configurable. Each translator has
associated options that you can set from the Import and Export dialog boxes. These
options control how the translator works. For example, with the IGES and GDSI|
format flatten option, a layout can be translated as a flat, non-hierarchical design.
Similarly, the merge option for these formats creates two new polygons from two
intersecting closed shapes.

Other options include arc conversions, treatment of holes and text, and in the layers
file, specification of layer translation tables. The IGES translator has the greatest
number of options because IGES is such a broad standard. System defaults are
included with the product and are automatically used if no others are specified.

Translating schematic designs is initiated from the ADS Main or Schematic window
using the File > Import and File > Export menu commands. Similar to the Layout
translators, each schematic translator has associated options that control how the
translator works.

Layout Export Considerations

Before starting a layout, you should consider how the final output could affect the
layout process. Different output formats impose different restrictions. The
restrictions imposed by GDSII are very different from those imposed by DXF, HPGL,
Mask, or Gerber.

With all export formats, you must consider layout units and data base precision. The
units and precision used in layout should match those you want in the final output.

Usually no problems are associated with translating units that are in the same
measurement system (such as, mils to inches or centimeters to millimeters).
However, round-off errors can occur when translating from metric-to-English units or
vice versa.

Layout Export Considerations 1-1
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Similarly, no problem is associated with translating a less precise data base

resolution in the program to a more precise output resolution. However, the reverse

process (such as, 0.001 Layout to 0.01 GDSII) can result in loss of data.

Available File Formats

The Import and Export commands enable you to import and export files in a variety
of different formats. You can import files through Advanced Design System’s Main,
Schematic, or Layout window. All file export is currently done from the ADS Layout
window with the exception of Intermediate File Format (IFF) files. Table 1-1shows

the available file formats and the individual import/export options.

Table 1-1. Available Formats and Import/Export Options

Available File Formats ADS Main ADS Schematic ADS Layout
and File Extensions Window Window Window

DXF (.dxf) - Import/Export
EGS Archive (_a) - Import/Export
EGS Generate (_g) Import Import/Export
GDSII Stream (.gds) - Import/Export
Gerber (.gbr) - Export
Gerber Viewer (.msk, .gbr) - Export
HPGL/2 (.hpg) Import Import/Export
IFF (.iff) Import Import/Export Import/Export
IGES (.igs) - Import/Export
Mask File (.msk) Import Import/Export
MGC/PCB (.iff) - Export
SPICE (.cir, .cki) Import Import

For detailed information on SPICE file import, refer to “Importing a SPICE File” in

the ADS SPICE Netlist Translator documentation.

Steps for importing and exporting these files are outlined in Chapter 2, Importing
and Exporting Schematic and Layout Designs.

1-2 Available File Formats




DXF

The Drawing Exchange Format (DXF) was developed by Autodesk for its AutoCAD
product and is widely used to transfer geometric data between systems. Like the
mask file format, it provides a simple geometric representation of data. DXF files can
be transferred between PC-based or UNIX-based systems. For details, see Chapter 3,
DXF Translator.

EGS (Archive/Generate)

Engineering Graphics System (EGS) format is a general graphics format used for
capturing manually entered designs. EGS has been applied to ICs, Micro-circuits,
Hybrids, and PC Board design applications. Using this format, you can easily
exchange data with other programs using EGS formats. In addition, EGS facilitates
better artwork translation with Advanced Design System.

The layout portion of Advanced Design System has adopted many of the primitive
types and styles that are part of the EGS standard, but has a more enriched set of
capabilities that structure information not representable in EGS. For example, EGS
files cannot represent embedded arcs.

Two variations of the EGS format are:

= The Generate format is a flattened list of EGS primitives specified in the
user-defined unit space. No additional information is supplied.

= The Archive Format is a hierarchically organized list of EGS primitives
specified in the user-defined unit space. Information such as drawing shapes,
layout units, database precision, and grid spacing is included.

For details, see Chapter 4, EGS Archive Files and Chapter 5, EGS Generate Files.

GDSII Stream

GDSII Stream Format (Calma) is an industry standard for translating final mask
data to foundries. The Advanced Design System reads GDSII versions 4.0 through
6.0 and writes GDSII version 6.0.

Unlike other data formats, GDSII stream format is binary. You cannot easily view or
edit a stream format file using a text editor. This format is easily translated between
different CAD systems because it represents a highly restrictive data type. However,
the format has a number of significant limitations; these limitations are discussed in
Chapter 6, GDSII Stream File Translator.

Available File Formats 1-3
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Gerber

Gerber refers to various data input formats that Gerber Scientific uses to drive its
photoplotters. The Gerber format is used by photoplotters produced by other
manufacturers also. The program supports various types of Gerber output via mask
files to either the Gerber or DXF translator. For details, see Chapter 7, Gerber
Artwork Translator and Gerber Viewer.

Gerber Viewer

Gerber Viewer appears as an export file option. It is not a file format, but is placed on
the export file menu so you can open the Gerber Viewer at any time. In addition, you
can access the Viewer during a DXF or Gerber export (see “Using the Gerber Viewer”
on page 7-19).

You can use the Gerber Viewer to view Gerber or mask files to help verify the
correctness of your data. In order to be viewed, the files must meet the following
criteria:

= Use either absolute or incremental data coordinates
= Support apertures from D10-D999
< Have data formats from 0.1 to 4.5

Also, you can use the Gerber Viewer to configure mask file data for photoplotting.

HPGL/2

HPGL/2 output is a subset of the HPGL/2 printer/plotter language. When creating a
graph or chart in another tool, you can write the graphics data to an HPGL/2 output
file, then import the file into Advanced Design System.

In Advanced Design System, the HPGL data is transformed into forms and shapes
that can be edited and manipulated like any other drawing. Additional text,
annotation, scaling or editing may be added. For details, see Chapter 8, HPGL/2
Files.

IFF

The Intermediate File Format (IFF) is an ASCII file with a simple, line-oriented
command structure and a fairly rich set of constructs. This format is machine- and
application-independent, thus simplifying design data transfer.

1-4 Available File Formats



IFF files are used as the exchange mechanism when transferring designs between
Advanced Design System and third-party EDA tools such as Mentor Graphics Design
Architect and Cadence Analog Artist. For more information about these framework
links, contact your Agilent Technologies sales representative. For details, see Chapter
9, IFF Files.

IGES

The Initial Graphics Exchange Specification (IGES) is an approved ANSI standard of
the U.S. Department of Commerce (ANSI Y14.25M) that is used extensively
throughout the computer-aided design and manufacturing world. The IGES format
can represent both mechanical and electrical design data in two and three
dimensions.

Because IGES is such a broad standard, the government has attempted to further
define a stricter standard of IGES for the transfer of electrical design data. This
standard is known as CALS specification. The CALS specification for IGES is
officially contained in the military specification MIL-D-28000, Digital Representation
for Communication of Product Data: IGES Application Subsets.

The Advanced Design System supports version 4.0 and 5.0 IGES formats. The
program reads and writes IGES CALS Level 1 (technical illustration) and Level 3
(electrical/electronic applications) files. Level 2 (engineering drawings) is not fully
supported since Level 2 is used primarily for drafting applications.

Even with the CALS standards, CAD systems accept very different IGES formats.
Although it is impossible to accommodate every format, you can use a number of
options to configure various IGES translators, including translators supplied by
Autodesk, Mentor Graphics, and Cadence. For details, see Chapter 10, IGES
Translator.

Mask File

Mask file format is a simple flat (non-hierarchical) geometric description. The format
facilitates the transfer of simple geometric data for final mask processing. Only
geometric forms are described in a mask file; simulation data, element parameters,
substrate definitions, and hierarchy are not included.

The optional Gerber and DXF translators use the mask file format as an
intermediate file when converting data to Gerber and DXF. For details, see Chapter
11, Mask Files.

Available File Formats 1-5
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MGC/PCB

MGC/PCB files are IFF files that are used exclusively for Mentor Graphics design
transfers. Although this format is available from the Advanced Design System layout
export menu only, you can transfer both schematic and layout information.

MGC/PCB files write to a specific location each and every time. When you select this
format, the filename and location of the IFF transport is determined automatically.

Each translator has associated options that can be set from the Options dialog box,
invoked from the Import and Export dialog boxes. The settings are retained
throughout the current and subsequent sessions. For details, see Chapter 12,
MGC/PCB Files.

SPICE

Simulation Program with Integrated Circuit Emphasis (SPICE) is a simulation tool
used by engineers throughout the world for simulating circuits of all types. Since its
development at the University of California Berkeley, SPICE has been
commercialized and modified by a large number of vendors and also adopted and
modified by electronics companies for their own in-house use. Many designers and
companies have large investments in existing subcircuits or device models described
by SPICE netlists that they want to use with the Advanced Design System from
Agilent Technologies.

For detailed information on SPICE file import, refer to “Importing a SPICE File” in
the ADS SPICE Netlist Translator documentation.

1-6 Available File Formats



Chapter 2: Importing and Exporting
Schematic and Layout Designs

This chapter provides information on importing and exporting schematic and layout
files as well as how to use the Advanced Design System Layer Editor.

Importing a Schematic

In Advanced Design System, you can Import a Schematic in these formats:
= EGS Generate Format
e HPGL/2
- IFF
= Mask File (.msk)
= SPICE

The procedure for importing each format is generally the same, however the available
options differ. For options relating to a particular file format, see the appropriate
chapter.

To import a schematic design:
1. Open a project and choose File > Import . The Import dialog box appears.
2. Select the appropriate file format from the File Type drop-down list.

3. To define options for the imported file, click the More Options button. The
Import Options dialog box appears.

Note The program translators are controlled by translator options files. A
system-wide options file exists for each translator. These files can be found in
the $HPEESOF_DIR/config directory. The default system file is automatically
read when you click More Options in the Import dialog box (unless a local
options file already exists in the current project directory). When you make
changes in the options dialog box and click OK, a local copy of the options file is
written to the current project directory.

4. To specify the path and filename of the file you want to import, click Browse .

Importing a Schematic 2-1
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5.

6.

7.

8.

Double-click as needed to locate the directory containing the design. By default,
all files are listed that have the file suffix appropriate for the chosen file format.

Select the design you want to import and click OK. You are returned to the
Import dialog box and the selected filename appears in the field labeled Import
File Name (Source).

Where applicable, type a new name for your imported design in the New Design
Name (Destination) field.

Note For certain file types, the translator uses the existing filename to
determine the new design name.

Click OK to import the design and dismiss the Import dialog box.

Exporting a Schematic

In Advanced Design System, you can Export a Schematic in this format:

IFF

The procedure for exporting IFF files is the same as the import, but the available
options differ. For options relating to the IFF file format, see “IFF Files” on page 9-1.

To export a schematic design:

1.
2.
3.

Open your design and choose File > Export . The Export dialog box appears.
Select IFF file format from the File Type drop-down list.

To set export options, click the More Options button. The Export Options dialog
box appears.

. Change options as needed and click OK.

. To specify a path for the exported file, click Browse .

6. Double-click as needed to locate the directory for the exported design. By

default, all files are listed that have the file suffix appropriate for the chosen file
format.

. Click OK.

. Type a new filename in the Export dialog box, following the path, and click OK.

The file is written to the specified directory.

2-2 Exporting a Schematic



Importing a Layout

In Advanced Design System, you can import files in these formats:
= EGS Archive Format

EGS Generate Format

GDSII Stream Format

HPGL/2

IFF

IGES

Mask File (.msk)

The procedure for importing each format is the same, but the available options differ.
For options relating to a particular file format, see the appropriate chapter.

To import a layout file:

1. In the Advanced Design System layout window, choose File > Import to open the
Import dialog box.

Ai Import:4 I |
File Type

GDSII Stream Format _"”WI
Import File Hame (Source)

i Browse...
Detautty Dogian

<

Hew Doshs Mane [Dogtintiont
| B, ..
Layers File Hame
| Browse...

0K | Cancel _Help |

2. In the File Type field, click the arrow in the right-hand corner to display a
drop-down list of available formats. Select the format you want to import.

Importing a Layout 2-3
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3. Click the More Options button to define the options for your selected format.

=] Import GDSII Options:4 |

Atthbutes ———— | pefine Layers...

_I Data Type Property

Text Size

Note Each format has its own set of import options. Refer to the appropriate
chapter in this book.

4. Click Define Layers to set the layer options. For information on the Layer Editor,
see “Defining Layers” on page 2-12.

2-4  Importing a Layout



_-i Layer Editor:4 ' |
Basic ]Mvanceﬂ visiility |

- D | Hame | ColoriPattem Ins Sel Vis Shape Display  Line Style Reverse

2D [efanie X ® Outline /| Solid *

j 1 [pond ® X Filled | Solid 7
2 |bond2 ® ®  Filled 7| Solid 7
B |iesi ® ® Filled | Solid i
A [miel [ 4 X x Filled /| Solid v
1z [iel2 [ [ 4 & & [Filled /| Solid ¥
|5 |hote B -+ F & [Filled 4| Solid T
& |pend T U o % = Filled /| Selid v
7 |Bymbel [ E=J X X Filled /| solid 7

ﬂ B [Rext [ I ® ® Filled | Solid i

— Select Visible Shape Display Line Style Layer

A | tone|| a1 | Hone /| o mew an | pastl

Search For Layer: Messages:

i |

1 oK | Apply | Reset | Save...| Read...| Cancel |

5. In the Import Options dialog box, click OK to save your settings and return to

the Import dialog box.

6. In the Import File Name (Source) field enter the full path of the source file.

Alternatively, click Browse to open the Import File Selection dialog box and

locate the file you want. After locating the file, click OK to accept the selection

Importing a Layout

2-5



Importing and Exporting Schematic and Layout Designs

and return to the Import dialog box. The appropriate suffix (.dsn) is appended
to the filename automatically.

=] Import File Selection:11

Filter

|:cutt,’SlDt_dilee_prj/*.gds“:

Directories Files
Slot_dipole_prj/. RN

ISlot_dipole_prjf..
f3lot_dipole_prjfdata
[Slot_dipole_prjifmom_dsn
ISlot_dipole_prifnetworks
ISlot_dipole_prjfsubstrates

El E B

Selection

|'S,ﬁ’crscutthlut_dipule_prj,{

|| ok | Fiter | cancel| Help |

7. In the New Design Name (Destination) field, enter the full destination path and a
name for the new file. Alternatively, you can click Browse to open the Design
File Selection dialog box and locate the destination path. After locating the file,

2-6 Importing a Layout



click OK to accept the selection and return to the Import dialog box. The
appropriate suffix (.dsn) is appended to the filename automatically.

= Design File Selection:11

Filter

|._dipole_prj /networks/*.dsn

Directorie: Files
prics/. i A_Readme.dsn =
DHESS.. dipole.dsn

dipole_us.dsn
dipole_us_denseMesh.dsn

S S

Selection

ASlot_dipole_prj/networks]

|| ok | Fiter | cancel| Help |

Note New Design Name (Destination) cannot be specified for EGS Archive
Format, GDSII Stream Format, IFF, or IGES files.

. In the Layers File Name field, enter the full path and name of the layers file to be
referenced during import. If the name you enter does not exist, a .lay file will be
created using the information defined in the Layer Editor.

Caution The file entered in the Layers File Name field is overwritten by the
layer information defined in the Layer Editor. To ensure you do not overwrite a
customized layers (.lay) file, choose More Options > Define Layers from the
Import dialog box and then Read and Apply your customized layers file into the
Layer Editor. For more information on the Layer Editor, refer to “Defining
Layers” on page 2-12.
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Alternatively, you can click Browse to open the Layers File Selection box and
locate the path and file name. After locating the file, click OK to accept the
selection and return to the Import dialog box. The appropriate suffix (.lay) is
appended to the filename automatically.

=] Layers File Selection:11

Filter

|:c:ott/'510t_dipole_prjf>k. lay

Directories Files

~ |layoutiay —
._dipole_prjf..

- dipole_prjfdata

- dipole_prjifmom_dsn
-_dipole_prjfnetworks
._dipole_prjfsubstrates

El = 0=

Selection

'sfcrscott/Slot_dipole_prj/]

|| ok | Fiter | Cancel|  Help |

The specified layers file contains the layer definition from the file you are
importing, as well as layers automatically added as necessary during import.
All designs created during the import reference this layers file.

Note Layers File Name cannot be specified for HPGL/2, IFF, or Mask files.

9. Click OK to accept the selections and start the import process. One or more files
may be created.

Exporting a Layout

In Advanced Design System, you can export files in these formats:

2-8 Exporting a Layout



= DXF

= EGS Archive Format
= EGS Generate Format
= GDSII Stream Format
= Gerber

e HPGL/2

= IFF

« IGES

« Mask File (.msk)

< MGC/PCB

The procedure for exporting each format is the same, but the available options differ.
For options relating to a particular file format, see the appropriate chapter.

Note Gerber Viewer appears as an export file option. It is not a file format, but is
placed on the export file menu so you can open the Gerber Viewer at any time. In
addition, you can access the Viewer during a DXF or Gerber export (see “Using the
Gerber Viewer” on page 7-19).

To export a layout file:

1. In the Advanced Design System layout window containing your design, choose
File > Export . The Export dialog box appears.

=] Export:11 |

File Type
GDSII Stream Format _-"l More Options...|

Mew File Hame (Destination)

I dipole. gds | Browse... |

QK Cancel Help
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2. In the File Type field, click the arrow in the right-hand corner to display a drop
down list of available formats. Select the format you want to export.

3. Click the More Options button to define the options for your selected format.

=] Export GDSII Options:11 |

— Attributes ————— | Maximum Number of Yertices

_I Paths As Polygons | | 32766 |

_I Holes As Folygons Layers To Exclude
_{ Aatten i
| Auto Merge Define Layers...
Data Type Propert:
- P S Text Size
_I Plex Property 10 |
OK Cancel Help

Note Each format has its own set of import options. Refer to the appropriate
chapter in this book.

4. Click Define Layers to set the layer options. For information on the Layer Editor,
see “Defining Layers” on page 2-12.

5. In the Export Options dialog box, click OK to save your settings and return to
the Export dialog box.

6. In the New File Name (Destination) field enter the full path of the destination file.
Alternatively, click Browse to open the Export File Selection dialog box. After
locating the destination directory, click OK to accept the selection and return to
the Export dialog box. Enter a filename. The appropriate suffix (.dsn) is
appended to the filename automatically.
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= Export File Selection:11

Filter

‘:cott/’S lot_dipole_prj/*.gds

Directories Files
Slot_dipole pri;. = 1B

{Slot_dipole_pyr..
{Slot_dipole_prjfdata
{3lot_dipole_prjfmom_dsn
{Slot_dipole_prjmetwrorks
{Slot_dipole_prjfsubstrates

Selection

's/fcrscott/Slat_dipole_prj/

| ok | Fiter | Cancel|  Help |

Note New File Name (Destination) cannot be specified for MGC/PCB files.
MGC/PCB files are written to the same predetermined location each and every
time. For more information on this file type, see Chapter 12, MGC/PCB Files.

7. Click OK to accept the selections and start the export process. Additional dialog
boxes display for the DXF, Gerber, IFF, and MGC/PCB formats. To complete
translation of these formats, refer to the appropriate chapter in this book.
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Importing and Exporting Schematic and Layout Designs

Defining Layers

Using the Advanced Design System Layer Editor (More Options > Define Layers) in
the Import or Export dialog box, you can define design layers and add, delete, or
rearrange layer priority. The contents of this dialog box change to reflect the layer
assignments associated with the open design. For information on the defining layers
using the ADS Layer Editor, refer to “Layer Editor” in the ADS “Layout” manual.

Ai Layer Editor:4 : |
Basic ]Mvanceﬂ visibility |
- D | Hame | colorfPattem Ins Sel Vis Shape Display  Line Style Reverse
D [defaule % ® Outline /| Solid T
j 1 |kond ® ® Filled | Solid 7
2 |pond2 ® ®  Filled 1| Solid ¥
B [Fesi ® ®  Filled 7| Solid 7
B [giel ® ®  Filled | Solid 7
12 [mi=12 ® ®  Filled | Solid 7
5 |hole ® ® Filled | Solid v
B |bond ® X Filled | Solid 7
7 [bymel ® ®  Filled | Solid 7
ﬂ B [iext ® ® Filled | Solid 7
— Select Visible Shape Display  Line Style Layer
_All | Hone| Al | rione| o o | mew | cut | paste]
Search For Layer: Messages:
i |
I OK | Apply | Reset 3ave... Read... Cancel|
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Chapter 3: DXF Translator

The DXF translator enables you to convert ADS designs into AutoCAD’s DXF file
format as well as convert DXF files into ADS designs. DXF is a very simple file format
and can be read by most any CAD program that supports DXF. Advanced Design
System supports import from and export to AutoCAD versions 12, 14, and 2000.

How you want to use DXF output—including layer numbering, use of holes, and
polygon shapes—should be considered before beginning your layout design. Setting
up the proper layout rules in ADS can save a lot of time in generating acceptable DXF
output. For specific considerations or limitations, consult your AutoCAD
documentation.

Advanced Design System provides two different DXF translators, a hierarchical
translator and a flattened translator. The DXF (hierarchical) translator is a
bidirectional translator that supports both full hierarchy and all layer separation.
The DXF (flattened) translator supports export only with limited capability.

Importing DXF (hierarchical) Files

The procedure for importing each format is generally the same, however the available
options differ. For a step-by-step tutorial on importing a layout file, refer to
“Importing a Layout” on page 2-3. For specific import options related to importing
DXF files, refer to “Import DXF (hierarchical) Options” on page 3-2. For information
on mapping DXF files to EGS Archive files to ADS files, refer to “Mapping DXF to
ADS” on page 3-6.

In order to import a DXF file, you must use the DXF (hierarchical) translator as
opposed to the DXF (flattened) translator. When importing files using the DXF
(hierarchical) translator, the program first accesses the DXF file. This file is then
translated into EGS Archive file format as shown in Figure 3-1. The file can then be
opened up in an Advanced Design System Layout window.

dxf2egs AutoCAD
Advanced
Sesian - egs- = B DXE . or

g archive > > Mechanical
System egs2dxf CAD

Figure 3-1. DXF (hierarchical) Block Diagram
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Import DXF (hierarchical) Options

This section describes the definable options available for importing files in the DXF
hierarchical format.

File > Import > DXF (hierarchical) > More Options

The Import DXF (hierarchical) Options dialog box enables you to specify Unit
Conversion, Attributes, Arc Extrapolation and Layers to control the import of DXF
format files.

~| Import DXF (hierarchical) Options:2
Unit Conversion ——— [ iayars
SutoCAD Units ADS Units Banbade {ovaregy
mil A omil S
Attributes
X Auto Scale

® Link Zero-Width Elements

Arc Extrapolation

frc Resolution Arc Sag Sphech A Dosplpol S8
(in degrees) Distance

IIS | |?D Hearch o Laymrs
0K Cancel Help
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Unit Conversion

Unit conversion must be specified for both the DXF file and EGS Archive file. The
AutoCAD Units (DXF file) and ADS Units (EGS Archive file) drop-down menu
selections display the available units. These units are described in Table 3-1.

Table 3-1. Available Units

Unit Meaning
um micrometer
mm millimeter
cm centimeter
mil mils

in inches

AutoCAD Units

Specifies the DXF file’s units. This information is not included in the DXF file. The
default is mil.

ADS Units
Specifies the EGS Archive file’s units. The default is mil.

Attributes

The Attributes section enables you to set an auto scale and/or the ability to link
zero-width elements.

Auto Scale

The Auto Scale attribute is used to automatically scale each length in the DXF file to
the specified ADS units. The default is active.

Link Zero-Width Elements

The Link Zero-Width Elements attribute is used to merge adjacent line segments into
polygons. This feature is especially useful when sending data to Momentum, because
Momentum can only mesh and simulate bounded elements. The default is active.

For more information on Momentum mesh and simulation, refer to “Mesh” and
“Simulation” in the Momentum manual.
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Arc Extrapolation

The Arc Extrapolation section enables you to optimize arcs for a particular
application.

Arc Resolution (in degrees)

The Arc Resolution defines the arc segment in degrees. The lower the value of the Arc
Resolution, the smoother the arc. The default value for Arc Resolution is 5 degrees.

20 deg.

Figure 3-2. Arc Resolution
Arc Sag Distance

The Arc Sag helps to compensate for the triangle flat caused by each of the arc
segments. By working with the dimension between the flat and the peak of the arc,
the arc becomes gradually smoother. The default value for Arc Sag Distance is 0. The
units for Arc Sag distance are defined in the Unit Conversion section.

Figure 3-3. Arc Sag Distance

Note Use Arc Resolution and Arc Sag together for optimum results.

Layers

When importing large DXF files, you can save valuable computation time by
including only specific layers. The following fields enable you to select particular
layers that you want to include in your import. In order to obtain information about
the DXF file'’s layers, ADS scans the DXF file and stores the layer information in a
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yr file of the same name. If no DXF file was specified in the Import dialog box, the
Layers options are left desensitized. If a DXF file was entered and ADS has already
created a .lyr file for it, the list of layers is automatically displayed in the Include
Layer(s) field. If a DXF file was entered but ADS cannot find a .lyr file for it, no layers
are displayed and the Search for Layers button becomes active.

Include Layer(s)

This field displays all of the layers found within the DXF file. From this list, you can
select specific layers to include when importing the file. If no specific layers are
selected, ADS will import all layers by default.

Select All / Deselect All

Click the Select All button to select ALL layers for import. Click the Deselect All
button to deselect ALL layers for import.

Search for Layers

If ADS cannot find a .lyr file with the same name as the import file, this button
becomes active. Clicking this button causes the program to scan the DXF file and
produce a .lyr file containing information about the file’s layers. Once the .lyr file is
created, the Include Layer(s) field is updated with all of the layers found within the
DXF file, the Search for Layers button becomes desensitized, and you are now able to
choose specific layers to include in your import.

Note If ADS has already created a .lyr file for a particular DXF file, and the DXF file
is later modified, delete the old .lyr file before attempting to import only certain
layers of the new DXF file.
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Mapping DXF to ADS

Table 3-2 represents the mapping of DXF (hierarchical) file shapes to EGS Archive

file shapes.

Table 3-2. Mapping of DXF File Shapes to ADS File Shapes

DXF (hierarchical)

Advanced Design System Layout
Equivalent

Line with width =0 Polyline
Line with width > 0 Path
Polygon with width = 0 Polygon

Polygon with width > 0

Polygon with cutline on longest segment

Rectangle with width = 0

Rectangle

Rectangle with width > 0

Polygon with cutline on longest segment

Circle with width =0

Circle

Circle with width > 0

Polygon with cutline to the right

Arc with width =0

Polyline

Arc with width > 0

Polygon
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Exporting DXF (hierarchical) Files

When exporting files using the DXF (hierarchical) translator, the program first
creates an intermediate EGS Archive file. This file is then translated into DXF
format as shown in Figure 3-1.

To export DXF (hierarchical) files:

1. Follow the steps as outlined in “Exporting a Layout” on page 2-8. For available
options (accessed via More Options in the Export dialog box), see “Export DXF
(hierarchical) Options” on page 3-7.

=] Export:1 |

File Type
DXF (hierarchical) ‘| wore Options...|

Mew File Hame (Destination)

I | Browse... |

0K Cancel Help

2. After clicking OK in the Export dialog box, the translator converts your ADS
Layout to EGS Archive format, then translates the EGS Archive file into DXF
format as shown in Figure 3-1. Once in DXF file format, the file is available for
use in AutoCAD or other Mechanical CAD systems.

Export DXF (hierarchical) Options

The Export DXF (hierarchical) Options dialog box enables you to set Attributes and
Hole Format. This dialog also provides access to the Layer Editor.
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Export DXF (hierarchical) Options:2

— Atthhutes

1 All Filled I Aatten Components

-1 Auto Merge _| Generate R14 Output

I Flatten All I Paths As Polygons

— Hole Format

_J) Holes As Polygons

Define Layers...
@ Holes As Cutlines #

) Frpapres Hadpd

OK | Cancel Help

Attributes

The Attributes section enables you to select various design attributes in the
translation. All attributes are deselected as the default.

All Filled

When All Filled is selected, all data is transferred as filled. This option is deselected
as the default.

Auto Merge

When Auto Merge is selected, all shapes for every mask layer that intersect or overlap
are merged. This option is deselected as the default.

Flatten All

When Flatten All is selected, all levels of hierarchy are automatically removed and a
single flat design is exported. There are no references from the top-level structure to
any other structure in the design. This option is useful when your post-processor does
not support or correctly translate hierarchy in EGS Archive files. But beware: if a
substructure was instanced more than once, selecting this option can substantially
increase the size of the file. This option is deselected as the default.

Flatten Components
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When Flatten Components is selected, all parameterized components are flattened.
This option is deselected as the default.

Generate R14 Output

When Generate R14 Output is selected, an AutoCAD version R14 database is
generated. This option is deselected as the default.

Paths as Polygons

When Paths As Polygons is selected, the design paths or traces are exported as
polygons. This should be selected for the following conditions:

= Paths or traces have mitered or curved corners that need to be preserved in the
translation.

= The EGS Archive file has paths with endpoint types other than flush that need
to be preserved in the program database.

This option is deselected as the default.

Hole Format

The Hole Format section enables you to define how the translator deals with holes in
a design.

Holes As Polygons

When Holes As Polygons is selected, holes are converted into polygons. When Holes
As Polygons is not selected, polygons with holes are translated as single-segment
polygons, the false edge segment becoming part of the polygon. Some systems may
not be able to tolerate this type of complex polygon. For these systems, make certain
that Holes As Polygons is selected. This option is deselected as the default.

Holes As Cutlines

When Holes As Cutlines is selected, holes are converted into cutlines. This option is
selected as the default.

Preserve Holes

This option is not available for DXF (hierarchical) Export. This option is desensitized
as the default.
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Define Layers

Clicking this button invokes the Layer Editor. For information on the Layer Editor,
see “Defining Layers” on page 2-12.

Mapping ADS to DXF (hierarchical)

The DXF file created by the DXF (hierarchical) translator is as simple as possible so
that as many DXF parsers, even primitive ones, can read the file. When exporting a
layout in DXF format, a very simple header is created with an entry for each layer
defined in the EGS Archive file. The DXF translator performs the following mapping
between EGS Archive and DXF files.

Table 3-3. Hierarchical DXF Output

EGS Archive

Entity DXF Entity Comment

Line zero-width closed polyline The difference between closed filled and

Polygon zero-width closed polyline closed empty is lost.

Line open zero width polyline

Circle circle The difference between circle and hole
. is lost.

Rectangle circle

Polygon layer name

Line point Any bad mask entity (one with zero area

or length) is mapped to a point.

Exporting DXF (flattened) Files

When exporting files using the DXF (flattened) translator, the program first creates
an intermediate mask file. This file is then translated into DXF format as shown in
Figure 3-4.
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Advanced
Design
System

B

To export DXF (flattened) files:

AutoCAD

Mask File

mask2dxf

or

DXF File |»

Mechanical

CAD

Figure 3-4. DXF (flattened) Block Diagram

For information on the Mask File format, refer to “Mask File” on page 1-5 and
Chapter 11, Mask Files.

1. Follow the steps as outlined in “Exporting a Layout” on page 2-8. For available
options (accessed via More Options in the Export dialog box), see “Export DXF
(flattened) Options” on page 3-16.

=

Export:11

File Type

D¥F (flattened)

_"l More Options...|

Hew File Hame {Destination)

Browse... |

oK |

Cancel

Help

2. After clicking OK in the Export dialog box, the following window appears:
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— Mtools v3.26 (Mar 12,1998) | -]

Mtools +3.26 (Mar 12,1998) HPUX Key SOFTWARE

Activated Modules:

Mask to DXF

¥ Keep History

Under the heading Activated Modules, you will see the entry Mask to DXF. The
DXF translator converts your design into a mask file before outputting it in DXF
format.

Keep History is selected by default. When this option is selected, the preferences
you specify are saved and used as the default for future translations. If you do not
want your settings saved, deselect this option.

3. Click OK to proceed. The Mtools Log window and DXF translator interface
appeatr.

4. Verify that the Mtools Log contains the correct information, editing as
necessary. To dismiss the log window, click OK.
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Note You may view the Mtools Log at any time by clicking the DXF tab in the
translator interface.

5. In the DXF translator window, the Mask Files and Output DXF File paths
should be set appropriately. If not, change the paths as desired. (Click Browse to
view your directories.)
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=] Mtools v3.26 (Mar 12, 1998)
DXF|

Mask Files

|thfsx'd1x’usersx’daniwi 11/ads/Slot_dipole/ Browse...

Output DXF File

|/’ a/new/learn?/d1/users/daniwill/S1lot_di Browse...

Scale Factor

DXF Line Type
() Polyline =
|;1 000000
_JLine
Translate |
View Mask |

: Exit | About| Help |

6. Set the DXF Line Type as desired. Polyline is the default.

You can configure the translator to use either lines or polylines when building each
mask figure. The advantage of using polylines is that all segments forming the
figure are connected into a single group. However, a few non-AutoCAD programs
may not read polylines correctly.

Though lines are easier to edit, we recommend that you use polylines.
7. Set Scale Factor as desired. The default value is 1.000000.

The DXF output can be multiplied by a scale factor. This feature is useful when the
mask file units are represented in mils, but the DXF file units need to be in inches.
By setting a scale factor of 0.001, each length in the mask file is multiplied by
0.001 and effectively scaled to inches.
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8. To invoke the Gerber Viewer and view the mask file, click View Mask . The
Gerber Viewer window appears.

~| xgbrvu — dipole.job, mask.apt | £ |J|
File View Tools Info Plot ﬂelpl
Fill |Layer| Aperture| Plot Screen| Plot Window| Highlight Apt.
| 0.0/|

Configuring Layer Settings...
—— Finished Layer Settings ——
Configuring Aperture Settings...

- Finished Aperture Settings --—

_|.___| = ;

The Gerber Viewer presents a number of viewing options. For details, see Chapter
7, Gerber Artwork Translator and Gerber Viewer.
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9. When you are finished viewing the file, choose File > Exit Xgrovu to exit the
Gerber Viewer. You may re-invoke the Viewer any time prior to exiting the
translator interface by clicking View Mask .

10. To export the DXF file, click Translate . A dialog briefly appears stating that the
mask file is being converted into DXF format.

11. When the translation is complete, the Mtools Log appears, detailing the DXF
file information. To exit the log window, click OK.

12. To exit the DXF translator window, click Exit.

The export process is now complete.

Export DXF (flattened) Options

The Export DXF (flattened) Options dialog box enables you to define Units and Scale,
perform layer definition, set an Etch Factor and Miter Angle and set Attributes and
Hole Format.

~| Export DXF (flattened) Options:2
Units Scale X Scaley | (unbutes
T _f| |11.|:| | 1.0 -l futo Merge
1 Arcs As Polygons
Define Layers...

— Hole Format
Layers

Layer Number{s)

Holes As Polygons
@ Include | J A

@ Holes &s Cutlines

_) Exclude | Layer File Hame(s}

| L) Presoree Holes

Etch Factor  Miter Angle
o 0.0

oK Cancel Help
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Units

These are the units that the DXF file will be written in. You may select from the
following options: same, mil, inch, um, mm, cm. The default is same. When same is
selected, the design is written in the same units that are stored in the design file. For
more information on choosing layout units, refer to “Setting Units/Scale Factors” in
the Advanced Design System Layout manual.

Scale X, Scale Y

The DXF output can be multiplied by a scale factor. This feature is useful when the
mask file has units of mils (common in microwave design) and the DXF file is in units
of inches. By setting a scale factor of 0.001, each length in the mask file is multiplied
by 0.001 and effectively scaled to inches.

The default value for both Scale X and Scale Y is 1.0.

Define Layers

Clicking this button invokes the Layer Editor. For information on the Layer Editor,
see “Defining Layers” on page 2-12.

Layers Include, Layers Exclude

These buttons enable you to specify layers to either include or exclude.

< Include - exports information only from layers specified in the Layer Number(s)
and Layer File Name(s) fields (see descriptions below).

= Exclude - exports all layers except those specified in the Layer Number(s) field
(it is not necessary to fill in the Layer File Name(s) field).

Include is selected as the default. Unless you specify layer numbers to include in the
Layer Number(s) field, all layers are automatically included.

Layer Number(s)

The numbers of the layers to be included or excluded in the export process. Entries
are separated by commas. For example:

1,6,20
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Layer File Name(s)
This option is used only when Layers Include is selected.

Each mask layer is exported to a separate DXF file as defined here. The information
must be presented in pairs, as follows:

<layer_number> <layer_name> <layer_number> <layer_name>...
where all are separated by spaces. For example:
1 mskl 3 msk3

Auto Merge

When Auto Merge is selected, all shapes for every mask layer that intersect or overlap
are merged. This option is deselected as the default.

Arcs As Polygons

When Arcs As Polygons is selected, arcs are exported as line segments (polygons).
This option is deselected as the default.

Holes Format

The Hole Format section enables you to define how the translator deals with holes in
a design.

Holes As Polygons

When Holes As Polygons is selected, holes are converted into polygons. When Holes
As Polygons is not selected, polygons with holes are translated as single-segment
polygons, the false edge segment becoming part of the polygon. Some systems may
not be able to tolerate this type of complex polygon. For these systems, make certain
that Holes As Polygons is selected.

This option is deselected as the default.
Holes As Cutlines

When Holes As Cutlines is selected, holes are converted to cutlines. This option is
selected as the default.

Preserve Holes

This option is not available for DXF (flattened) Export. This option is desensitized as
the default.
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Etch Factor

The etch factor applies a global over/under size amount to each shape translated.
This is meant to compensate for etch effect during processing. However, using this
option can be problematic. Thus, we recommend that you retain the default setting of
0.

If you use Etch Factor, carefully verify the correctness of the compensation to
minimize problems. Limitations include the following: When a figure has a side
smaller than the etch factor, this function may fail. If two boundaries butt up against
one another before compensation, because each boundary is handled independently,
such boundaries will either overlap or show a gap when compensation is specified.
When Etch Factor is applied, re-entrant polygons may be transformed into illegal
polygons.

Miter Angle

This is the angle cutoff used with the etch factor. The miter angle controls acute angle
edge over-extension. Any angle below the miter angle amount is mitered. The default
value is 90.0.

Mapping ADS to DXF (flattened)

The DXF file created by the DXF (flattened) translator is as simple as possible so that
as many DXF parsers, even primitive ones, can read the file. When exporting a layout
in DXF format, a very simple header is created with an entry for each layer defined in
the mask file. The DXF translator performs the mapping between mask and DXF
files as shown in Table 3-4.

Table 3-4. DXF Output

Mask Entity DXF Entity Comment

closed filled zero width closed polyline The difference between closed filled and
closed empty zero-width closed polyline closed empty is lost.

open open zero width polyline

circle circle The difference between circle and hole
hole circle Is lost.

layer name layer name

zero length point Any bad mask entity (one with zero area

or length) is mapped to a point.
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Chapter 4: EGS Archive Files

The EGS Archive format is an ASCII text format that represents multiple
hierarchical designs. EGS Archive files include information such as drawing shapes,
layout units, database precision, grid spacing and, optionally, a layers definition
including layer colors, numbers, and names. They do not contain information about
the connectivity of a layout design.

Originating from a former Hewlett-Packard product called the Engineering Graphics
System (EGS), the EGS Archive format is useful as an intermediate file for
transferring input/output to various third-party translators. It is also the best format
for translating graphic shapes into the Series IV and MDS products. In addition, the
EGS Archive format is easy to parse and read, so if you have created your own
software tools, this is a very useful format for transferring graphics shapes into these
tools.

When importing an EGS Archive file into Advanced Design System, you may specify
a Layers File Name for the creation of a layers definition file (the Layers File Name
field is located in the Import dialog box). This file will be automatically created and
will contain the layer information from the EGS Archive file, as well as layers
automatically added as necessary during import. All designs created during import
reference this layers file.

Oval or hatch shapes of the EGS Archive format are not supported in Advanced
Design System.

Importing EGS Archive Files

The procedure for importing each format is generally the same, however the available
options differ. For a step-by-step tutorial on importing a layout file, refer to
“Importing a Layout” on page 2-3. For specific import options related to importing
EGS Archive Files, refer to “Import EGS Archive Options” on page 4-1. For
information on mapping EGS Archive files to ADS, refer to “Mapping EGS Archive to
ADS” on page 4-2.

Import EGS Archive Options

File > Import > EGS Archive Format > More Options

Other than layer characteristics, there are no definable options available for
importing files in the EGS Archive format.
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—| Import EGSARC Options:11 |

Define Layers...

OK |  Cancel|l  Help |

The Define Layers button invokes the Layer Editor. For Layer Editor options, see
“Defining Layers” on page 2-12.

Mapping EGS Archive to ADS

Table 4-1 represents the mapping of EGS Archive file shapes to Advanced Design
System layout shapes.

Table 4-1. Mapping of EGS Archive File Shapes to Advanced Design System Shapes

EGS Archive Object Advanced Design System Layout Equivalent
Line with width =0 Polyline

Line with width > 0 Path

Polygon with width = 0 Polygon

Polygon with width > 0 Polygon with cutline on longest segment
Rectangle with width =0 Rectangle

Rectangle with width > 0 Polygon with cutline on longest segment
Circle with width =0 Circle

Circle with width > 0 Polygon with cutline to the right

Arc with width = 0 Polyline

Arc with width > 0 Polygon

Exporting EGS Archive Files

The procedure for exporting each format is generally the same, however the available
options differ. For a step-by-step tutorial on exporting a layout file, refer to

4-2 Exporting EGS Archive Files



“Exporting a Layout” on page 2-8. For specific export options related to exporting
EGS Archive Files, refer to “Export EGS Archive Options” on page 4-3. For
information on mapping ADS to EGS Archive files, refer to “Mapping ADS to EGS
Archive” on page 4-5.

Export EGS Archive Options
File > Export > EGS Archive Format > More Options

= Export EGSARC Options:11

— Attrbutes

[ 1 nclude Mask Layers| i AN Filled

-l Paths As Polygons I Fatten All
.l Holes As Polygons Ll Auto Merge

~I Fatten Components

Define Layers...
0K Cancel Help

Include Mask Layers

When this option is selected, a list of mask layers is included with the translated
design. This option is deselected as the default.

Paths As Polygons

When Paths As Polygons is selected, the design paths or traces are exported as
polygons. This should be selected for the following conditions:

= Paths or traces have mitered or curved corners that need to be preserved in the
translation.

= The EGS Archive file has paths with endpoint types other than flush that need
to be preserved in the program database.
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This option is deselected as the default.

Holes As Polygons

When this is selected, holes are converted to polygons. When Holes As Polygons is not
selected (this is the default), polygons with holes are translated as single-segment
polygons, the false edge segment becoming part of the polygon. Some systems may
not be able to tolerate this type of complex polygon. For these systems, select Holes As
Polygons.

This option is deselected as the default.

Flatten Components

When Flatten Components is selected, all parameterized components are flattened.
This option is deselected as the default.

All Filled

When this is selected, all data is transferred as filled. This option is deselected as the
default.

Flatten All

When Flatten All is selected, all levels of hierarchy are automatically removed and a
single flat design is exported. There are no references from the top-level structure to
any other structure in the design. This option is useful when your post-processor does
not support or correctly translate hierarchy in EGS Archive files. But beware: if a
substructure was instanced more than once, selecting this option can substantially
increase the size of the file.

This option is deselected as the default.

Auto Merge

When Auto Merge is selected, all shapes for every mask layer that intersect or overlap
are merged. This option is deselected as the default.

Define Layers

The Define Layers button invokes the Layer Editor. For Layer Editor options, see
“Defining Layers” on page 2-12.
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Mapping ADS to EGS Archive

Table 4-2 represents the mapping Advanced Design System layout shapes to EGS
Archive file shapes.

Table 4-2. Mapping Advanced Design System Shapes to EGS Archive File Shapes

Advanced Design System Layout Object EGS Archive Equivalent
Polyline Line

Path with PathsAsPolygons Polygon

Path without PathsAsPolygons Line

Circle Circle

Rectangle Rectangle

Polygon Polygon

Wire Line
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Chapter 5: EGS Generate Files

The EGS Generate format is an ASCII text format representing a single, flat design.
It is a subset of the EGS Archive format that contains only the shape information. If
an hierarchical design is exported, it is automatically flattened during the export
process.

Originating from a former Hewlett-Packard product called the Engineering Graphics
System (EGS), the EGS Generate format is useful as an intermediate file for
transferring input/output to various third-party translators. Also, the EGS Archive
format is easy to parse and read, so if you have created your own software tools, this
is a very useful format for transferring graphics shapes into these tools.

When importing an EGS Generate file into the Advanced Design System, you may
specify a Layers File Name for the creation of a layers definition file (the Layers File
Name field is located in the Import dialog box). This file will be automatically created
and will contain the layer information from the EGS Generate file, as well as layers
automatically added as necessary during import. All designs created during import
reference this layers file.

Oval or hatch shapes of the EGS Generate format are not supported in the Advanced
Design System.

Importing EGS Generate Files

The procedure for importing each format is generally the same, however the available
options differ. For a step-by-step tutorial on importing a layout file, refer to
“Importing a Layout” on page 2-3. For specific import options related to importing
EGS Generate Files, refer to “Import EGS Generate Options” on page 5-1. For
information on mapping from EGS Generate files to an ADS layout, refer to
“Mapping EGS Generate to ADS” on page 5-2.

Import EGS Generate Options

File > Import > EGS Generate Format > More Options

Other than layer characteristics, there are no definable options available for
importing files in the EGS Generate format.
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—| Import EGSGEN Options:11

Define Layers...

OK |  Cancel|l  Help |

The Define Layers button invokes the Layer Editor. For Layer Editor options, see
“Defining Layers” on page 2-12.

Mapping EGS Generate to ADS

Table 5-1 represents the layout mapping from EGS Generate format to Advanced
Design System layout.

Table 5-1. Mapping from EGS Generate Files to Advanced Design System Layouts

EGS Generate Object Advanced Design System Layout Equivalent
Line with width =0 Polyline

Line with width > 0 Path

Polygon with width = 0 Polygon

Polygon with width > 0 Polygon with cutline on longest segment

Rectangle with width = 0 Rectangle

Rectangle with width > 0 Polygon with cutline on longest segment

Circle with width =0 Circle

Circle with width >0 Polygon with cutline to the right
Arc with width = 0 Polyline

Arc with width > 0 Polygon

Exporting EGS Generate Files

The procedure for exporting each format is generally the same, however the available
options differ. For a step-by-step tutorial on exporting a layout file, refer to
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“Exporting a Layout” on page 2-8. For specific export options related to exporting
EGS Generate Files, refer to “Export EGS Generate Options” on page 5-3. For
information on mapping ADS to EGS Generate files, refer to “Mapping ADS to EGS
Generate” on page 5-5.

Export EGS Generate Options

File > Export > EGS Generate Format > More Options

=| Export EGSGEN Options:11

— Attnbutes

[ 1 include Mask Layers| _i Al Filled

-I Paths As Polygons I Aatten All
.1 Holes As Polygons I Auto Merge

_I Flatten Components

Define Layers...

Include Mask Layers

This option does not apply to the EGS Generate format. With this format, the design
is always flattened.

Paths As Polygons

When Paths As Polygons is selected, the design paths or traces are exported as
polygons. This should be selected for the following conditions:

= Paths or traces have mitered or curved corners that need to be preserved in the
translation.

= The EGS Generate file has paths with endpoint types other than flush that
need to be preserved in the program database.
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This option is deselected as the default.

Holes As Polygons

When this is selected, holes are converted to polygons. When Holes As Polygons is not
selected (this is the default), polygons with holes are translated as single-segment
polygons, the false edge segment becoming part of the polygon. Some systems may
not be able to tolerate this type of complex polygon. For these systems, select Holes As
Polygons.

This option is deselected as the default.

Flatten Components

This option is irrelevant for EGS Generate files. The EGS Generate design is
automatically flattened.

All Filled

When this is selected, all data is transferred as filled. This option is deselected as the
default.

Flatten All

This option is irrelevant for EGS Generate files. The EGS Generate design is
automatically flattened.

Auto Merge

When Auto Merge is selected, all shapes for every mask layer that intersect or overlap
are merged. This option is deselected as the default.

Define Layers

The Define Layers button invokes the Layer Editor. For Layer Editor options, see
“Defining Layers” on page 2-12.
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Mapping ADS to EGS Generate

Table 5-2 represents the layout mapping from Advanced Design System layout to
EGS Generate format.

Table 5-2. Mapping from Advanced Design System Layout to EGS Generate Format

Advanced Design System Layout Object EGS Generate Equivalent
Polyline Line

Path with PathsAsPolygons Polygon

Path without PathsAsPolygons Line

Circle Circle

Rectangle Rectangle

Polygon Polygon

Wire Line
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Chapter 6: GDSII Stream File Translator

The end result of many MMIC designs is a Calma or GDSII stream format file.
Advanced Design System’s Layout provides a flexible GDSII translator for both
reading and writing this format.

The GDSII Stream File Translator is a bi-directional graphics file translator. It can
create files in GDSII Stream file format from Advanced Design System layouts, and it
can translate graphics files from GDSII Stream file format into Advanced Design
System layouts.

The GDSII Stream file format links the Advanced Design System directly to
mask-making equipment that uses the popular GDSII Stream file format. This
format, in turn, gives access to a wide range of photoplotters, coordinatographs,
E-beam machines, and pattern generators.

The opposite transfer (from GDSII Stream file format into the Advanced Design
System) makes it easy to use the cell libraries offered by many GaAs semiconductor
foundries.

Translation from a layout in the Advanced Design System into GDSII Stream file
format is done automatically with the menu command File > Export > GDSII Stream
Format.

GDSII has some limitations that may affect your layout, including:

= No support for arcs or circles

Limit of 200 vertices per shape

No support for holes or empty regions

32-character name limitation

Limit of 255 mask layers

Curved Element Limitation

Although the Advanced Design System has options for re-mapping layer numbers
and structure names, it does not have the full ability to overcome the GDSII
limitations regarding curved elements. The program stores arcs as true arcs. When
translating arcs to GDSII format, the program converts each arc into line segments.
This number can be controlled via the Arc Resolution dialog box (select Edit > Modify
> Arc/Circle Resolution from the Layout window). However, a shape with several
arcs, such as a transmission line with curved elements, may not be approximated
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with sufficient resolution given the 200 vertex limitation. Therefore, some
consideration should be given to the use of curved elements and the extensive use of
arcs and circles in your layout design.

Lack of Support for Holes

Lack of support for holes is usually not a problem, but should be considered. The
Advanced Design System can convert shapes with holes into contiguous single
polygons by inserting an extra edge (shown below). Inserting an edge is valid for
GDSII output, but may be a problem for certain mask generation software.

Shape with a hole. Extra edge inserted for
GDSII translation.

Filename Limitation

If very long names are used for networks (greater than 32 characters), a translation
table can be generated to map these names to shorter, unique names.

Limit on the Number of Layers

If your layout has more than 255 layers, some of these can be re-mapped to appear on
the same GDSII layer.

Conclusion

GDSII limitations can affect how you design your layout. The limitation that bears
particular consideration is the fact that GDSII Stream format is limited to 200
vertices per polygon/polyline and does not include arcs.

In the Advanced Design System, arcs are stored as true arcs, but are evaluated as
polygon segments when translated to GDSII. Although the number of vertices used to
approximate an arc can be controlled via the Arc Resolution dialog box (see “Curved
Element Limitation” on page 6-1), the 200 vertices limit may prevent the program
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from correctly evaluating polygons consisting of several arcs. Therefore, it is best to
consider the number of arcs your shapes contain before designing your layout.

GDSII does not have the ability to empty a polygon or create a hole. The translator

can output polygons with holes as single-segment polygons with an extra edge added,
or as separate polygons. If this is not acceptable, you may want to prohibit the use of
holes in your design.

Table 6-1 is a mapping table for GDSII elements and their Advanced Design System
layout equivalents.

Table 6-1. GDSII Elements and Advanced Design System Layout Equivalents

Calma/GDSII Element

Layout Equivalent(s)

Box element Rectangle
Boundary element Polygon
Path element Path

Boundary element Circle, polygon
Element Text
Boundary element Hole
Structure element Design
Sref element Instance
None Pin

Path element Wire
Path element Trace
Plex None
Array Instances
Node None

Importing GDSII Files

The Advanced Design System reads GDSI| files into a layout design without circuit
or schematic information, internally converting the drawing data to the current

layout units.

For a step-by-step tutorial, see “Importing a Layout” on page 2-3. For import options,

see “Import GDSII Options” on page 6-5.
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Guidelines/Considerations

= When transferring a GDSII file via FTP, you must specify the binary option.

= When transferring a file via tape, the 2048 block size must be preserved. To
write fixed-block sized tapes for transfer to other systems, refer to your
computer system documentation.

< When reading a GDSII file, the Advanced Design System ignores reference
libraries, font files, generations, format types, and nodes. Element flags
(ELFLAGS), complexes (PLEX), data types, path types, extensions, and element
properties are also skipped.

= Reading a GDSII file may also fail if the file is the wrong version or has been
corrupted. Because the GDSII stream is a block-structured binary file, it can
easily be corrupted when transferring the file from one system to another.

Filenames Versus Instance Names

When importing a GDSII file into the Advanced Design System, the design name on
the Layout title bar may differ from the GDSII filename. The reason for this is as
follows.

The GDSII file format can contain multiple top-level instances that may or may not
be related to one another. Because of this, the GDSII filename may not be identical to
the top-level instance name.

When importing a GDSII file, the top-level instance is automatically displayed in the
Layout window. The name of that instance is reflected in the Layout title bar. In some
cases, this name does not match that of the imported file.

GDSII file instance names simplify the tracking of hierarchies within the file.
Exporting a GDSII file under a new name will have no effect on the named data
contained in the file.
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Import GDSII Options

The Import GDSII Options dialog box enables you to specify certain attributes to
control the import of GDSII Stream files. An x appears in the box to the left of
selected attributes. To select or deselect an attribute, click it.

=] Import GDS1I Options:4 |

Attributes ———— | pefine Layers...

_| Data Type Property

Text Size
I Plex Property B0

Note To control attributes globally, click the Define Layers button to invoke the
Layer Editor. For more information on the Layer Editor, see “Defining Layers” on
page 2-12.

Data Type Property

Selecting Data Type Property enables import of GDSII files that use the Data Type
record in GDSII and retain the information in a property attached to the
corresponding Advanced Design System data structure. When enabled, any Data
Type records encountered on Boundary or Path structures while importing a GDSII
file cause a property named Data Type to be created and attached to the resulting
data group in the Advanced Design System. The value of the property is set to the
integer value found in the GDSII record. In the reverse manner, Data Type records
are created in the GDSII file when enabled for data groups that have a Data Type
property with integer value.

Plex Property

Selecting Plex Property enables import of GDSII files that use the PLEX record in
GDSII and retain the information in a property attached to the corresponding
Advanced Design System data structure. When enabled, any PLEX records
encountered on Boundary, Path, SREF, AREF, and TEXT structures while importing
a GDSII file cause a property named PLEX to be created and attached to the
resulting structure in the Advanced Design System. The value of the property is set
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to the integer value found in the GDSII record. In the reverse manner, PLEX records
are created in the GDSII file when enabled for structures that have a PLEX property
with integer value.

Define Layers

This button invokes the Layer Editor. For Layer Editor options, see “Defining Layers”
on page 2-12.

Text Size

The size, in layout units, for text in the imported design. The default value is 1.0. The
same size is assumed for all fonts in the GDSI| file.

Exporting GDSII Files

When writing a Calma/GDSl| file, the GDSII 6.0 release format is used.

For a step-by-step tutorial on exporting files, see “Exporting a Layout” on page 2-8.
For export options, see “Export GDSII Options” on page 6-8.

Guidelines/Considerations

= You can create a bidirectional GDSI|I file from the current design file.
Translated GDSII files appear in layout representation only. Although no
electrical connectivity information is included, hierarchy and mask layer
information is preserved.

= The Advanced Design System writes the layout representation of a hierarchical
design into GDSII stream format using the current layout units and precision.

= The GDSII file created is of fixed-block size (2048 bytes), and is a proper subset
of the stream format.

= Valid GDSII layer numbers are from 0 to 255. The data type for all objects is set
to 0.

= Note that only some object attributes are translated:

= A polyline is translated as a path with no specified width, path type, or
extension.
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= When paths are converted, the endpoint type is ignored and the type 0 is
applied (square-ended at digitized point).

= Holes in the program are translated as filled polygons, or as a single polygon
with the hole joined to other polygons by a new edge.

= Circles are converted to polygons and arcs are converted to chords.

= Text is translated with a bottom left justification. A scale factor showing
magnification of the text height over one user unit and an optional rotation
angle are also translated.

= Relative mirroring, translation, scaling, and rotation are transferred.
Absolute rotation and magnification are not supported.

= Data groups with more than 200 vertices are not translated (GDSII 200
vertex limit).

< When you attempt to translate shapes with more than 200 vertices, a warning
message is printed to an error log. Error and warning messages generated
during translation are also printed to the log file. After the translation, this file
can be viewed.

= Precision and unit information is stored differently in the GDSII Stream format
than in Advanced Design System, but no information is lost in translation. A
database-unit to user-unit size appears in the GDSII format; this is equivalent
to the Advanced Design System’s data base precision. This measurement
specifies the smallest dimension obtainable in a design. In the Advanced Design
System, this is established as a power of ten. For example, a precision of 3
indicates that .001 is the smallest dimension achievable in the design. Since
GDSII format contains database to user units, a 3 precision in the Advanced
Design System becomes 1000 database to user units in GDSII.

GDSII dB/user unit = 10 | dB precision |

GDSII further employs user units in terms of number of user units to a meter.
Since Advanced Design System units can be inches, microns, mils, etc., the GDSII
number of user units to meters is equal to the program dB unit converted to
meters.

When reading a new GDSI| file, the program precision and units should be set to
match those that are in the GDSI| file, otherwise information may be lost
(especially if the program’s database precision is less than that of the GDSII
Stream file).
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Export GDSII Options

The Export GDSII Options dialog box enables you to specify certain attributes to
control the export of GDSII Stream files. An x appears in the box to the left of selected
attributes. To select or deselect an attribute, click it.

=| Export GDSII Options:11 |

— Attrbutes ————— | Maximum Humber of Yertices
I Paths As Polygons | | 32766 |

-1 Holes As Folygons Layers To Exclude
-1 Flatten |
| Auto Merge Define Layers...
Data Type Propert:
- * nery Text Size
_1 Plex Property 10
oK Cancel Help

Note To control attributes globally, click the Define Layers button to invoke the
Layer Editor. For more information on the Layer Editor, see “Defining Layers” on
page 2-12.

Paths As Polygons

When Paths As Polygons is selected, the program paths or traces are exported as
polygons and GDSII paths are imported as polygons. This should be selected for the
following conditions:

= Paths or traces have mitered or curved corners that need to be preserved in the
GDSII translation.

= The GDSII file has paths with endpoint types other than flush that need to be
preserved in the program database.

This option is deselected as the default.
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Holes As Polygons

When this is selected, holes are converted to polygons. GDSII has no concept of holes.
When Holes As Polygons is not selected, polygons with holes are translated as
single-segment polygons, the false edge segment becoming part of the polygon. Some
systems may not be able to tolerate this type of complex polygon. For these systems,
select Holes As Polygons.

This option is deselected as the default.

Flatten

When Flatten is selected, all levels of hierarchy are automatically removed and a
single flat design is translated. There are no references from the top-level structure
to any other structure in the design. This option is useful when your post-processor
does not support or correctly translate hierarchy in GDSII Stream files. But beware:
if a substructure was instanced more than once, selecting this option increases the
size of the file.

This option is deselected as the default.

Auto Merge

When this attribute is selected, the program outputs shapes and forms with data
from simulator elements (mlins, slins) and performs an or operation on each layer
before outputting. The original dataset is not modified. This option is deselected as
the default.

Data Type Property

Selecting Data Type Property enables export of GDSII files that use the Data Type
record in GDSII and retain the information in a property attached to the
corresponding Advanced Design System data structure. When enabled, any Data
Type records encountered on Boundary or Path structures while importing a GDSII
file cause a property named Data Type to be created and attached to the resulting
data group in the Advanced Design System. The value of the property is set to the
integer value found in the GDSII record. In the reverse manner, Data Type records
are created in the GDSII file when enabled for data groups that have a Data Type
property with integer value.

This option is deselected as the default.
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Plex Property

Selecting Plex Property enables export of GDSII files that use the PLEX record in
GDSII and retain the information in a property attached to the corresponding
Advanced Design System data structure. When enabled, any PLEX records
encountered on Boundary, Path, SREF, AREF, and TEXT structures while exporting
a GDSII file cause a property named PLEX to be created and attached to the
resulting structure in the Advanced Design System. The value of the property is set
to the integer value found in the GDSII record. In the reverse manner, PLEX records
are created in the GDSII file when enabled for structures that have a PLEX property
with integer value.

This option is deselected as the default.

Maximum Number of Vertices

This enables you to define the maximum number of vertices allowed for one polygon.
Valid values are 1 - 32766 inclusive. The default value for this option is 32766.

Layers To Exclude

This enables you to exclude one or more layers from the output file by specifying the
layer numbers to exclude, separated by commas. For example:

1,4,9

Define Layers

This button invokes the Layer Editor. For Layer Editor options, see “Defining Layers
on page 2-12.
Text Size

The size, in layout units, for the text in the exported design. The default value is 1.0.
The same size is assumed for all fonts in the GDSII file.
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Chapter 7: Gerber Artwork Translator and
Gerber Viewer

The Gerber Artwork Translator can translate artwork directly from circuit layouts
created with Advanced Design System into Gerber format. It exports Advanced
Design System layouts into ASCI| files that control Gerber photoplotting equipment.

The Gerber Viewer is a companion program included with the Gerber translator. The
Viewer is used for viewing artwork on a computer monitor and for printing it to a
graphics printer before creating artwork on the Gerber photoplotter. It is also used
for generating drill data and tooling reports.

Limitations and Considerations

How you want to use the Gerber output—including layer numbering, use of holes,
and polygon shapes—should be extensively considered before beginning your layout
design. Setting up the proper layout rules can save a lot of time in generating
acceptable Gerber output. For specific considerations or limitations, particularly in
relation to apertures and film wheels, consult with your photoplotter vendor.

Gerber Command Format

The Gerber format is a numerical control language developed to generate photo
artwork. The output of this translator is an ASCII file that contains the following
Gerber commands:

GO1E = linear interpolation
G54 = aperture select

D01 = shutter open

D02 = shutter close

D03 = flash

MO02 = end of program

X and Y = coordinates

* = end of block
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Coordinates are absolute, with implied decimal point and optional leading zero
suppression. However, the literal string values may be modified in the message file.
For example, GO1 may be changed to HP. A sample listing of the Gerber file
commands, with interpretation to the right, might look like this:

G54D16* <- select aperture 16 (20 mil circle trace)
G01X90Y85D02* <- move the shutter to 90,85

Y185D01* <- open the shutter and draw to 90,185

X190* <- while shutter remains open, draw to 190,185
Y85* <- draw to 190,85

X90* <- draw to 90,85

G54D45* <- select aperture 45 (60 mil circle flash)
X140Y135D02* <- close shutter and move to 140,135

DO3* <- flash expose

X0YOD02*M02* <- return to the origin and stop

This example would produce the following figure.

+ Origin

The output files are:
The Gerber Drawing File (.gbr) is the actual Gerber command file.

The Aperture Usage Report (.apt) reports primitive counts, aperture utilization,
and the total distance traveled by a mechanical photoplotting system.

The photoplotter vendor receives both output files.

Exporting Gerber Files

To export Gerber files:
1. In the layout window containing your design, choose File > Export .
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2. The Export dialog box appears. In the File Type field, click the arrow in the
right-hand corner to display the available formats. Select Gerber.

|

Export:11

File Type

Gerher

_"l More Options...|

Mew File Hame (Destination)

I dipole. ghr

| Browse... |

Cancel

oK |

Help

3. To define export options, select More Options . Set the options that apply. For
available options, see “Export Gerber Options” on page 7-16. Click OK to save
your settings or Cancel to retain the default settings.

4. In the New File Name (Destination) field enter the new file name . The file name
is automatically appended with the appropriate suffix. Alternatively, you can
select the Browse button to locate a destination directory and file name.

5. Clicking OK to accept the settings. The status window appears:

|

Mtools v3.26 (Mar 12,

1998) |-

Mtools v3.26 (Mar 12,1998) HPUX Key SOFTWARE

Activated Modules:

Mask to Gerber

W Keep History
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The entry Mask to Gerber displays under the heading Activated Modules. The
Gerber translator converts your design into a mask file before outputting it in
Gerber format.

The option Keep History is selected as the default. When this option is selected,
the preferences you specify are saved and used as the default for future
translations. If you do not want your settings saved, deselect this option.

Click OK to proceed. The Mtools Log and Gerber Translator Interface window
appear.

6. Verify that the Mtools Log contains the correct information. If necessary, edit
the information. To dismiss the Mtools Log window, click OK.

~| Mtools Log

File Search

'EFi lename: Shfs/dl/users/danivill fads/Slot_di
Mask Version: 3,000
Generated By: PIE 1.0

Date: Fri Jan 15 18:46:50 1999

Units: mn

¥ Extents: (-35.,90 , 35,80 )
Y Extents: (-3.42 16,14 )
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Note You may view the Mtools Log at any time by clicking the GERBER tab in the
translator interface window.

7. In the Gerber Translator Interface window, set the Mask Files and Aperture File
paths. The Mask Files field displays the mask file created in the Export dialog
box. This is the file that the Gerber translator converts into Gerber format.

The Aperture File field displays the configuration file used to hold all of the
translation parameters and Gerber apertures. When performing a translation,
you can create a new configuration file or reuse the same file. To modify this file,

see “Gerber File Options” on page 7-7
To view the Mask Files and Aperture File paths, click the adjacent Browse
button.
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—| Mtools v3.26 (Mar 12, 1998)

GERBER| |
Mask Files
‘E/hfs,fd 1/users/daniwill/ads/Slot_dipole/ Browse...
Aperture File
‘E:metriu: .apt Browse...

Gerber File Options

Translation Settings

Translate

View Mask

|
|
Edit Apertures |
|
|
|

View Gerber

1 Exit | About| Help |-

8. Select Gerber File Options , Translation Settings , and Edit Apertures to specify
settings. Select View Mask to invoke the Gerber Viewer for DXF and Gerber
translations and View Gerber for Gerber translations only. For details on Gerber
translator interface options, see the appropriate section: “Gerber File Options”
on page 7-7, “Translation Settings” on page 7-9, “Edit Apertures” on page 7-11,
and “Using the Gerber Viewer” on page 7-19.

9. Click Translate to select the layers you want to include in the translated file (see
“Translate” on page 7-14). After selecting the layers, click OK to complete the
translation. A window appears briefly, indicating that the file is being converted
to Gerber format.

10. When the translation is complete, the Mtools Log appears, detailing the export
information. Examine the log file, searching for any warnings or errors that
may have occurred during translation.
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When you are finished viewing the log file, click OK to dismiss the MTools Log
and exit the Gerber translator.

Gerber File Options

You can view or edit the translator settings, by selecting Gerber File Options in the
Gerber Translator Interface window.
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— Gerher File Options |

Gerber Unit INCH —
Format 3.3 =
Zero Suppress Leading —

Data Mode Adsuhide
Circular 360 —

EOB Character u

EO.J String B

CR/LF Suppress —

) oK ‘ Cancel| Help| ]

A dialog appears, providing access to these options:
Gerber Unit. Available units are INCH or MM. MM is the default.

Format. The number of integers placed before and after the decimal point. If
chosen incorrectly, Gerber data resolution can be poor. The default is 3.3.

Zero Suppress. Available settings are Leading and None. Leading (the default)
removes all leading zeros in the coordinate data, making the Gerber file smaller. If
the setting is inappropriate, the Gerber data display is nonsensical.

Data Mode. The program always writes out absolute coordinates.

Circular. Available settings are 360 or Off. When Off is selected, arcs are
fractured. When 360 is selected, arcs are written by means of GO2/GO3 with 360
interpolation. The default is 360.

EOB Character. Sets the character that denotes the end of a Gerber data block.
Currently set as an asterisk (*).

EOJ String. This string, inserted at the end of the Gerber file, indicates that the
plot is complete. Currently set as MO?2.
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CR/LF. Available settings are Include or Suppress. Some Gerber files include a
carriage return/line feed (CR/LF) at the end of each command. When the CR/LF is
suppressed, the file size is reduced by twenty percent and the translation is
completed more quickly. Suppressing the CR/LF does not effect your ability to view
the Gerber data in the Gerber Viewer. Suppress is selected as the default.

Note After you have set these options, you do not need to do so again unless you
deselect the Keep History option in the initial Mtools dialog (see “Exporting Gerber
Files” on page 7-2).

Translation Settings

You can control how the program converts the mask data into Gerber format by
selecting Translation Settings in the Gerber Translator Interface window. These
settings, crucial to correct output, are described in this section.
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Global Parameters
Line DCode. Open figures output to this D-code.
Scale Factor. Output data is scaled up or down according to this factor.
ArcRes. Value, in degrees, by which arcs are broken up.

APT Out. Drop-down list for selecting aperture output from popular CAM
software.
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Outline/Fill

= Outline or Fill. Each closed area is either outlined or filled, depending upon
selection.

= Filled. D-codes used for outlining the closed filled figures.
= Empty. D-codes used for outlining the closed empty figures.

= StartApt. The smallest aperture used to start the filling.

Compensation

= Compensate for etch factor by the given inch amount, shrink or swell, as
needed.

Output Offset

= The Gerber data coordinates are moved by the amount defined in the X and Y
fields.

Gerber Output Format

= The flavor of Gerber output: standard RS274D, extended RS274X or MDA
with the Autoplot header. Barco DPF is planned for the future.

When setting these options, consider the following:

= Qutline vs. Fill - Outline is much more efficient if your vendor accepts it. (Use
POEX aperture for polygon fill as needed.)

= Compensation - We recommend that you leave the default setting of None. The
compensation available in the Gerber translator is not intelligent and does not
take butting or overlapping polygons into account.

= Gerber Output Format - RS274X is the best choice if your vendor accepts it. This
format already contains an embedded aperture list. RS274X and RS274D do not
currently support empty polygons.

Edit Apertures

When you click Edit Apertures, a table listing the aperture settings appears.
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— Click DCode to select the desired aperture type.

N
N

ﬂ Poex §o o :
ﬂ Poex §o o

PgUp| PgDn| Hume| End| Clear LinE| At Ehrawe | Auto Flash |

—-| Aperture (1.07) — metric.apt
DCode Type ¥ (inch) ¥ Block Name
10 |§Ruund ‘50.92500 ‘}@ .02500 | ~ Save
11 |§Ruund ‘Eo.@sooo 9.05000 |
- - - - Save As
12 |;Ruund ‘;o. 10000 0. 10000 |
13 |§Round ‘Eo 20000 |B9.200080 | Cancel
14 |§Round ‘E@ L40000 [0 . 40080 |
3 2 B ? Help
15 |;Round ‘;@ .B00B0 |10 80000 |
16 |§Raund ‘1 .50000 |'1.50000 |
17 |§Raund ‘1 .00000 |'1.00000 |

1" Add Default Set | Clear All | FIashCircIes| Fiash Ftor ‘ |

Gerber files use apertures much like plotters use pens. Defining available
photoplotter apertures is very similar to installing pens into a pen plotter carousel.

To insert a standard set of apertures into the list, click Add Default Set in the
Aperture dialog box.

To add a setting, change a coordinate, or change an aperture type, click in the section
you wish to change and enter the desired value. You can also change the aperture
type via the Dcode dialog:

1. Click the D-code number under the heading DCode. A dialog box appears,
listing the available aperture types.
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—| Dcode = D10

Type Block
Round ______JllI-NONE-|
Donut
Square
Rect
Thermal
Target
Octagon
Oblong
Poex
Poin

Thmsyg
Custom

L 0K Cancel| |

2. Select the desired type and click OK. The dialog box disappears.

Among the available aperture types are POEX and POIN. These are special
apertures for the FIRE 9000 laser plotter. This plotter can take outline data and fill
the inside of each polygon. If you are using such a plotter, the D-codes should be
defined for POEX and POIN and the translator should be run in outline mode (see
“Translation Settings” on page 7-9.). For more information about this plotter, see
“FIRE 9000 Photoplotter Configuration” on page 7-45.

To scan the mask file for circles and holes, and create a block name for each unique
size, click Flash Circles . The created block names can then be assigned to unique
apertures.

When you are satisfied with the aperture settings, click Save or Save As, or click
Cancel to return to the default settings. The Aperture settings window disappears.
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Translate

|

Select Translation Layers

Layer

GDSIl Layer Name

3
3

8

4 slot
39 momentum_ref_offset

- SelectAll| ClearAll| OK | Cancel | |

This button invokes the Select Translation Layers dialog. This dialog enables you to
select the layers to be included in the translated file. (The Gerber translator creates a
Gerber file for each layer in the mask file.) All layers are selected as the default.

Note Layers are selected when they are highlighted.

To select or deselect a layer, click it. You may also choose Select All or Clear All.

To complete the translation, click OK. A dialog briefly appears, informing you that the
mask file is being converted into Gerber format. When the translation is complete,
the Mtools Log appears. Inspect the log to verify that the file was translated as

expected. (To dismiss the log window, click OK.)
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View Mask

g

This button invokes the Gerber Viewer to display the mask file. For information on
the Gerber Viewer, see “Using the Gerber Viewer” on page 7-19.
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View Gerber

Once the translation is complete, click this button to launch the Gerber Viewer and
load the Gerber file(s). The Gerber Viewer enables you to view your file(s) and
generate drill data.

Check the bottom of the Viewer window for messages or instructions.

For more information on the Gerber Viewer, see “Using the Gerber Viewer” on
page 7-19.

Export Gerber Options

= Export GERBER Options:11

Units Scale X Scaley | Hinbules

Same _’l |1_D | 1o -l futo Merge
I Arcs As Polygons
Define Layers...

Layers

_I Rectangles As Polylines

Layer Humber({s)
| — Hole Format

@ Include

_J) Holes As Polygons

_) Exclude | Layer File Hame(s)

| /@ Holes s Cutlines

_J) Preserve Holes

Etch Factor  Miter Angle
i 0.0

oK Cancel Help

Units

These are the units that the Gerber file will be written in. You may select from the
following options: same, mil, inch, um, mm, cm. The default is same. When same is
selected, the design is written in the same units that are stored in the design file. For
information on choosing layout units, refer to the Advanced Design System Layout
manual.

7-16 Exporting Gerber Files



Scale X, Scale Y

These are the fields for inputting the scale factors for shapes in the direction of X and
Y. The default settings are 1.0, 1.0.

Define Layers

Clicking this button invokes the Layer Editor. For Layer Editor Options, see
“Defining Layers” on page 2-12.

Layers Include, Layers Exclude

These buttons enable you to specify layers to either include or exclude.

= Include. Exports information only from layers specified in the Layer Number(s)
and Layer File Name(s) fields. Include is selected as the default. Unless you
specify layer numbers to include in the Layer Number(s) field, all layers are
automatically included.

= Exclude. Exports all layers except those specified in the Layer Number(s) field
(it is not necessary to fill in the Layer File Name(s) field).

Layer Number(s)

The numbers of the layers to be included or excluded in the export process. Entries
are separated by commas. For example:

1,6,20

Layer File Name(s)

The numbers and names of the layers to be included in the export process. The
information must be presented in pairs, as follows:

<layer_number> <layer_name> <layer_number> <layer_name>...
where all are separated by spaces. For example:

1 mskl 3 msk3

Auto Merge

When Auto Merge is selected, all shapes for every mask layer that intersect or overlap
are merged. This option is deselected as the default.

Exporting Gerber Files 7-17



Gerber Artwork Translator and Gerber Viewer

Arcs As Polygons

When Arcs As Polygons is selected, the design arcs are exported as line segments (or
polygons). This option is deselected as the default.

Rectangles As Polylines

When Rectangles As Polylines is selected, all rectangles are translated as open plane
figures bounded by straight lines. When this option is deselected, all rectangles are
translated as closed plane figures bounded by straight lines. This option is deselected
as the default.

Holes As Polygons

When Holes As Polygons is selected, holes are converted into polygons. When Holes
As Polygons is not selected, polygons with holes are translated as single-segment
polygons, the false edge segment becoming part of the polygon. Some systems may
not be able to tolerate this type of complex polygon. For these systems, make certain
that Holes As Polygons is selected. This option is deselected as the default.

Holes As Cutlines

When Holes As Cutlines is selected, holes are converted into cutlines. This option is
selected as the default.

Preserve Holes

This option is not available for DXF (hierarchical) Export. This option is desensitized
as the default.

Etch Factor

The etch factor applies a global over/undersize amount to each shape translated. This
is meant to compensate for etch effect during processing. However, using this option
can be problematic. Thus, we recommend that you retain the default setting of O.

If you use Etch Factor, carefully verify the correctness of the compensation to
minimize problems. Limitations include the following: When a figure has a side
smaller than the etch factor, this function may fail. If two boundaries butt up against
one another before compensation, because each boundary is handled independently,
such boundaries will either overlap or show a gap when compensation is specified.
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When Etch Factor is applied, re-entrant polygons may be transformed into illegal
polygons.
Miter Angle

This is the angle cutoff used with the etch factor. The miter angle controls acute angle
edge over-extension. Any angle below the miter angle amount is mitered. The default
value is 90.0.

Using the Gerber Viewer

The Gerber Viewer enables you to view mask (.msk) and Gerber (.gbr) files. The
Gerber viewer can be invoked from the layout window File menu, or during export
from the Mtools DXF or Gerber translator window.

Launching the Viewer from a Layout Window

1. From an Advanced Design System layout window, choose File > Export . The
Export dialog box appears.

2. Select Gerber Viewer as the file type.

= Export:11 |

File Type

| Gerher Viewer _"I sdpre Gpbisis...

Mewr File Name {Destination)

| dipole. ghg Browse...
OK Cancel Help

3. In the New File Name (Destination) field, enter the name of the file you wish to
view. Alternatively, you can click Browse and the Export File Selection dialog
box appears, enabling you to browse your directories for the desired file.

4. Click OK and the following window appears:
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[<]  Mrwolsva.26 (Mar12,1998) || |

5. In this window, click OK. The Mtools translator and log windows appear.

6. To dismiss the Mtools Log window, click OK in the window. You may review it at
any time by clicking the GERBER tab in the translator window.

7. In the Mtools translator window, enter the name of the file to view in the Mask
Files field. This file must carry the extension .msk.
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8. To invoke the Gerber Viewer, click either View Mask (for DXF and Gerber
translations) or View Gerber (for Gerber translations only). The Gerber Viewer

appears.
For information about Gerber Viewer options, see “Gerber Viewer Menu Options”
on page 7-26. For information on the buttons available from the Gerber translator

interface, see “Exporting Gerber Files” on page 7-2.

9. To exit the Viewer, select File > Exit Xgbrvu .

Launching the Viewer During File Export
You can launch the Gerber Viewer from the Mtools translator window when
exporting DXF or Gerber files.
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1. From the Mtools translator window, click View Mask (for DXF and Gerber
translations) or View Gerber (for Gerber translations only).The Gerber Viewer
appears.

=l Muwolsvaze(Marizieme)
enaen

sl e ik 1S elyme |
fopdoy |

For information about Gerber Viewer options, see “Gerber Viewer Menu Options”
on page 7-26.. For information on Gerber translation options, see “Exporting
Gerber Files” on page 7-2. For information on the options available from the
Mtools DXF translator interface, see Chapter 3, DXF Translator.

2. To exit the Viewer, select File > Exit Xgbrvu .

Loading a File to View

1. Choose File > Open/Import
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If there is a file in current memory (that is, you have initiated the Viewer during a
file export) and it is not yet loaded, that file is automatically loaded at this time.
There is no need to proceed with the following steps.

Otherwise, the Open Job/Import Gerber dialog appears.

~| Open Job / Import Gerher

" ACS Job / Standard RS274D
MDA

_ JRS274-X

__IR8274 Dark Mode

__JR8274 Reverse Mode

_ )DSN/GAP

_JGAP

JALLEGHO

_ JMENTOR

_JPROTEL

_)TANGO

i 0K Cancel| |

This dialog enables you to load an existing file, or to create a new job file. (The job
file is used for purposes internal to the Viewer and is not required by the vendor.)

2. Select the desired file type and click OK. A browser dialog that is specific to the
file type you selected appears. For example, if you chose ACS Job/Standard
RS274D, the Select/Create Job dialog appears.
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—-| Select/Create Job

Filter
|11,fads/5 lot_dipole/x. joH

Directories Files
B /dipole.job

. 3/dipole2. job
data x/dipole_us. job
mom_dsn x/test.job
networks

substrates

synthesis

to_mgc

el ] el [
Selection

5/51ot_dipole/dipole.jok

|| ok | Fiter | cCancell

3. Select the file you want to load or create and click OK.

If you cannot remember the name of the file you want to load, you can use a

wildcard (*). The browser will display all files that match the wildcard
specification.

If the file you choose does not exist, a dialog appears asking if you want to
create it. Click Yes to create the file, or No to cancel.

4. The Select/Create Aperture dialog appears. Select the file you want to load or
create and click OK.

If the file you choose does not exist, a dialog appears asking if you want to create
it. Click Yes to create the file, or No to cancel.
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5. The Gerber Settings dialog appears. Set options as desired and click OK. (For
more information, see “Gerber Settings” on page 7-31.)

[| " Gerher Settings - mask.apt |

6. The Layer dialog appears. Select layers as desired and click OK. (For more
information, see “Layer” on page 7-30.)

7. The Aperture dialog appears. Set apertures as desired (see “Aperture” on
page 7-36) and click Save.

8. Set options, view, and plot as desired. See “Gerber Viewer Menu Options” on
page 7-26.
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Gerber Viewer Menu Options

This section describes the Gerber Viewer menu options. A message area at the
bottom of the Viewer window provides information specific to your situation.

The two file display options are: Outline or Fill. Click the button to change the
window display. The button title changes to reflect the display.
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— Display Area

— File Display Options
— xgbrvu = dipole. job, mask.apt 4 J|
kile ¥iew Tools Info Plot Help |
Fill | Layer| Aperture| Plot Screen| Plot Window| Highlight Apt.
| 0.0]| 0.0]

Configuring Layer Settings...
—— Finished Layer Settings --
Configuring Aperture Settings...

—— Finished Aperture Settings ——

Message Area

Gerber Viewer Menu Options
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File
Click File and a drop-down menu containing the following options appears:

= Open/Import loads the job file. The job file contains the name of the aperture
file, data units, and Gerber files to load. For more information, see “Loading a
File to View” on page 7-22.

Layer invokes the Gerber Viewer Layer menu. For more information, see the
section “Layer” on page 7-30.

Aperture invokes the Gerber Viewer Aperture menu. For a description of this
menu, see the section entitled “Aperture” on page 7-36.

Preferences leads to the following menu choices:

= Gerber Settings invokes the Gerber Settings dialog. See “Gerber Settings” on
page 7-31.

= Grid/Snap Settings opens the Snap Settings dialog. See “Snap Settings” on
page 7-32.

* Poex Check

Exit Xgbrvu dismisses the Gerber Viewer.

View
The following display options are available:
= All displays the extents of the data. This is the default option.

= Window enables you to use the mouse to draw a window around the area you
wish to view.

In zooms in, or magnifies, the view by two times.

Out zooms out by two times

Pan enables you to pan the display window.

Last restores the previous view.

Redraw refreshes the screen.

Tools

The Tools menu contains the following options:
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= Drill enables you to select your drill output. Available choices are listed below.
When you click your selection, the Drill Output dialog appears, stating layer,
drill output and tool count. To dismiss this dialog, click Close.

= Excellon (Suppress Leading Zero) is the default option.
< Excellon (No Zero Suppress)
< XY Table outputs a drill summary table.

= Report displays the Gerber Report dialog. This dialog provides a text summary
of the current file, including layer and aperture information. To dismiss this
dialog, click Close.

= Film Merge invokes the Gerber Merge dialog. For more information, see “Gerber
Merge” on page 7-33.
Info
The Info menu provides the following options:

= Vertex Query searches for the vertex point nearest to where you click the mouse.

Window Query summarizes the trace information of a specified area.+

Flash Query identifies the flash point nearest to where you click the mouse.

Measure measures the distance between two points.

Highlight Apertures invokes the Highlight Aperture dialog. For more
information about this dialog, see “Highlight Apt.” on page 7-38.

When you select (click) an option, information and instructions appear in the
message area at the bottom of the Gerber Viewer window. To quit a task, press the
ESC key.

Note Actions prompted for in the Viewer message area (such as pressing ESC to
abort) are effective only when the mouse is pointed in the Viewer display area.

Plot
The following options are available from the plot menu:

= Plot/Page Setup invokes the Page/Plotter Setup dialog, enabling you to specify
page setup, plot format, output, and setup strings.

Gerber Viewer Menu Options  7-29



Gerber Artwork Translator and Gerber Viewer

= Plot Screen plots only the area displayed on the screen.

= Plot Window enables you to plot a selected area. You use the mouse to draw a
box around the specific area you wish to plot. For instructions on how to do this,
see the Gerber Viewer message area at the bottom of the Viewer window.

< Plot Window Coords invokes the Plot Window dialog, enabling you to specify
plot coordinates.

—| Plot Window

Extents (MinX, MinY)

Extents [Max>, MaxY)

L QK Cancel| [

Outline/Fill

This button reads as either Outline or Fill, depending upon the display type
activated. That is, if Outline appears, the file is displayed in outline form, and if Fill
appears, it is displayed as filled.

To change the display from outlined to filled, or vice-versa, click this button.

Layer

This button invokes the Gerber Viewer Layer menu. (You can also choose the menu
command File > Layer to open the Layer menu.)

The Layer menu enables you to select which layer files are loaded for display;
whether these are displayed as paint, scratch, or negative; and the color they are
displayed in. Up to 48 layers may be simultaneously displayed. For information, see
Layer Menu.
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Note Changes to the Layer dialog options do not affect the raw Gerber data. They
change the display only.

Gerber Settings

File > Preferences > Gerber Settings

~| Gerber Settings — mask.apt
Gerber Unit MM
Format 5.4

Zero Suppress MNone —
Data Mode Absolute —
Circular 360 —

Arc Resolution |90

L 0K Cancel| |

Gerber Unit. The units the Gerber data adopts when it is loaded. You may select
either INCH or MM. MM is the default.

Format. Gerber data does not contain the decimal point. For coordinate data, you
must tell the program the number of digits to insert before and after the decimal
point. The default Format value is 3.3. Other common formats are 2.3 and 4.4.

Data formats from 0.1 to 6.3 are acceptable. However, arithmetic problems may arise
when very large data values are rendered precisely. For example, if you have a circuit
board that extends out 20 inches from the origin and you require 4-place accuracy
across the board, you may find that some data points out at the 20,20 coordinate have
only 3-place accuracy. This may cause the program to incorrectly fill polygons in this
region.
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Zero Suppress. Gerber files are normally compressed by suppressing either the
leading or trailing zeros of the Gerber data. You may specify Leading, Trailing, or
None. Leading is the default. If you choose the wrong setting, the Viewer displays
nonsensical data.

Data Mode. The data coordinates can represent either absolute or incremental values
relative to 0,0. Absolute is the default. When Incremental is selected, each coordinate
represents the distance from the previous coordinate. Selecting an incorrect data
mode results in an incoherent display of the data.

Circular. You may select either 90 or 360. Older photoplotters used 90 degree arc
interpolation. Newer machines support 360 degree interpolation. The default setting
is 360.

If your arcs display incorrectly, try changing this setting.

Arc Resolution. To display Gerber circular commands (G01/G02), the Gerber Viewer
uses small, straight segments to approximate the data. How fine the approximation
is depends upon the Arc Resolution value. The default value of 9 degrees is
appropriate in most cases. This value offers a good compromise between speed and
resolution. Valid values are between 0.5 and 30 degrees.

Snap Settings
File > Preferences > Grid/Snap Settings

~| Snap Settings

Grid Spacing

0.0066 1

_| Snap On
_ | Grid On

L 0K Cancel| |

Grid Spacing. Use this field to set the grid spacing as desired.

Snap On. Click the selection box to turn this option on or off. This option is selected
as the default.
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Grid On. Click the selection box to turn this option on or off. This option is deselected
as the default.

Gerber Merge

To invoke the Gerber Merge dialog, select Tools > Film Merge
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3

-
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Films. The current filename is displayed in this field. To enter a filename, click in the
entry box and type the desired file path. You can also click the ellipses box (...) in the
right-hand side of the Film field to select a file from the Working Directory browse
dialog.

Negative Image. Click the selection box to turn this option on or off. This option is
deselected as the default.
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Gerber Files. Your Gerber files are listed in this field. You may delete or undelete
these by clicking the Delete/Undelete button below this field.

Output Type. You may select RS274D, RS274X, or MDA Autoplot as the output
format. RS274D is selected as the default.

Gerber File. List the Gerber files that you wish to merge in this column.
Delete. This field is disabled.
Paint/Scratch. This field is disabled.

View Film. Click the selection box to select or deselect this option. View Film is
selected as the default.

Layer Options

To load your Gerber files, click on a Layer number button. A file selection dialog box
appears, enabling you to select the file(s) you want loaded. You may select display
options as desired.

The Layer dialog and its options are shown in the figure.
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Click the Layer number
to open the Select
Gerber File dialog.
Browse your directories,
select the file(s) you
desire, and click OK.

o
N
e
n
e
o
—
N

— Type the full name of the Gerber  Click this button to specify

or mask file in this field. Paint, Scratch, or Negative.
Alternatively, click the Layer For more information on these
number to open the Select display types, refer to the text
Gerber File dialog and select following this figure.

the file from your directories

(see left).

Lt

[

Click the
Color field to
open the
Layer Color
palette. Click
the desired
layer color.

This field toggles the layer display. When
highlighted, the layer is displayed. To turn all
layers on or off, use the All On or All Off buttons
at the bottom of this dialog.
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Paint displays the layer data normally.

Scratch performs an XOR operation on all data previously loaded. The resulting
display mimics the effect of scratch behavior available on many photoplotters.

Negative reverses the polarity of the layer and is useful for displaying ground planes.

Aperture

File > Aperture

The aperture button in the Gerber Viewer Options window invokes the Aperture
menu, enabling you to define apertures from D10 through D999 and assign drill tools
to create Excellon drill codes.
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To accurately display your data, you must set the correct apertures.

DCode. You may define D-codes from D10 through D999. Click in this field and the
Dcode dialog appears, enabling you to select one of 12 standard types (see below).

Type. Twelve types are available: round, donut, square, rectangle, thermal, target,
octagon, oblong, poex, poin, thmsq, and custom.

To specify a type, click in the Type field and enter the desired type. Alternatively, click
the DCode number and the Dcode dialog appears, presenting the available types for
selection.

X, Y. These are the aperture dimensions in units of inches or millimeters (mm),
depending on the Gerber unit selected (see “Gerber Settings” on page 31). Some
apertures, such as round pads, have only an X value; others require X and Y values.

Tool #. This field is for specifying an Excellon drill data tool. This field is optional and
need only be specified when converting Gerber flashes to Excellon drill commands.
Valid ranges are TO1 through T99.

Drill Dia. Enter the drill tool diameter in this field. This field is optional. Valid
ranges are 0.001 inch to 0.99 inch.

Add Default Set. When you click this button, a standard set of apertures is inserted
into the list.

Plot Screen

You may select this option by clicking the Plot Screen button on the Gerber Viewer
menu bar or by selecting the menu command Plot > Plot Screen. The screen is plotted,
and the plot information appears in the message area at the bottom of the Viewer.

Plot Window

You may select this option by clicking the Plot Window button on the Gerber Viewer
menu bar or by selecting the menu command Plot > Plot Window. This option enables
you to plot a portion of the screen by using the mouse to draw a box around the area
you wish to plot. This is done by clicking the mouse on the first and second corners,
diagonally, of the plot window. Instructions and plot information appear in the
message area at the bottom of the Viewer.

Gerber Viewer Menu Options  7-37



Gerber Artwork Translator and Gerber Viewer

Highlight Apt.

This button opens the Highlight Aperture dialog. This dialog enables you to select
apertures to be highlighted on the display.

~| Highlight Aperture

Double click an aperture to highlight

D10 Round 0.025 0.025 —
D11 Round 0.05% 0.05
D12 Round 0.1 0.1
D13 Round 0.2 0.2
D14 Round 0.4 0.4
D15 Round 0.8 0.8
D16 Round 1.5 1.5
D17 Round 1 1

All traces associated with a highlighted aperture appear in light gray rather than in
the assigned layer color.

Page/Plotter Setup

This dialog box contains four tabs: Page Setup, Plot Format, Output, and Setup
Strings. The options available from each tab are as follows. To access this dialog box,
select Plot > Plot/Page Setup

Page Setup. This tab provides access to page size, margin values, and orientation
options.
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Plot Format. This tab provides access to the plotter driver type, print type, scaling
factor, raster memory size (in MBytes), and dpi (dots per inch).
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Output. This tab enables you to select the output file name and designate a printer
path.
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Setup Strings. This tab enables you to set up headers and trailers.
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Gerber Viewer Keyboard Commands

You can access many Gerber Viewer commands either through the mouse or the
keyboard. In fact, a few commands are available only through the keyboard.

Special shortcut keys for operating the Gerber Viewer are outlined in Table 7-1.
Table 7-1. Keyboard Shortcuts for the Gerber Viewer

Cancels command or moves up one level in the menu structure.
_ Toggles the grid on and off.
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Table 7-1. Keyboard Shortcuts for the Gerber Viewer

Key Action

+ Zooms in 2X.

- Zooms out 2x.

Ins Same as Pan command.

Home Zooms to extents. Same as All command.

Configuring the Gerber Translator for Photoplotters

Types of Photoplotters
There are two types of photoplotters: vector and raster.
Vector Photoplotters

Vector photoplotters process each draw and flash command directly from the Gerber
database. These are normally mechanical plotters with an X-Y table, a light head,
and an aperture wheel. Examples of vector plotters include the Gerber 3200 and 4000
series flatbed plotters.

Raster Photoplotters

Raster photoplotters rasterize the input Gerber data using a computer, and then use
the resulting bitmap to modulate a laser that is scanned across the film. What is
interesting about raster plotters is that many of them can accept polygons in addition
to draws and flashes. The ability of a photoplotter to fill a polygon is extremely useful
to the microwave and RF designer. Examples of powerful raster plotters that support
polygons include the Gerber Crescent family of plotters and the Cymbolic Sciences
family of FIRE 9000 plotters.

Vector Plotter Configuration

The mask file input to the Gerber translator is essentially a collection of polygons
that need to be filled. Therefore, when you run the translator you should:

= Set the Translation Settings option Outline/Fill to FILL.

= Have a reasonable selection of round apertures available to fill. The smallest
aperture diameter should be at least 2-3 times less than your smallest line
width, otherwise you may not get a good representation of your design.
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.008
.006
.004
.002 .002
Ideal Size Diameters Too Far Apart

Typical D-code diameters range from 0.001 inch up to 0.200 inch. Most mechanical
photoplotters support up to 24 D-codes.

The Gerber translator uses an advanced multi-aperture fill instead of what we call a
pen plotter fill. The multi-aperture fill generates Gerber files with the same
resolution as a pen plotter fill, but creates data files 5-10 times smaller.

Aperture Too Large to Resolve Small Aperture Smaller than Critical

“o—H =

Polygon Filling Rules
Each polygon is filled independently of any other polygon in the mask file.

Any arcs that are part of a polygon boundary are broken into segments using the
ArcRes parameter. This parameter is the number of degrees per segment. The default
of ArcRes is 9 degrees. If you need smoother arcs in your film, reduce the number to 6
or even 4 degrees.

The routines start filling at the inner edge of the polygon with the smallest aperture
(the one you specify as the Start Aperture in the translation configuration menu).
This aperture is normally used twice and is offset from the edge of the polygon by 1/2
diameter (see A below). The first two strokes overlap by 1/2 diameter (see B below).
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The routines then select a larger aperture (but normally no larger than 2 times the
starting aperture) and repeat this process.

The interior of most large polygons is scan-filled with a fat aperture. There is no
overlap between strokes once the routines jump into scan-fill mode.

Empty Polygons

Because the Gerber translator fills each polygon as it encounters it in the data
stream, when it encounters an empty polygon it cannot clear away areas already
filled. Therefore, for vector photoplotters, avoid using empty polygons in your layout.
(This limitation is not in effect for some raster plotters.)

The translator issues a warning in the log file when it does encounter an empty
polygon so that you do not accidentally plot over it.

If you have used empty polygons in your design, you may select the Advanced Design
System Gerber export option Auto Merge, enabling you to merge filled and empty
polygons to form a single filled polygon. This creates what we call a re-entrant
polygon and is supported by the Gerber translator. However, while we recommend
this function for relatively simple structures, we do not recommend you use such a
function where hundreds of drill holes must appear in a power plane.

Compensation

Compensation works by swelling or shrinking each polygon prior to filling it. Again,
because the translator views polygons independently, it cannot take into account
spatial relationships between polygons. If you attempt to use a shrink compensation
with butting polygons, a narrow gap will form between them.

FIRE 9000 Photoplotter Configuration

The Cymbolic Sciences FIRE 9000 photoplotter is a raster laser plotter that is ideal
for creating microwave and RF artwork. Not only does this photoplotter have a very
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high resolution (typically 1/8 mil), but its RIP front end supports two very important
extensions to standard Gerber (RS274D) data:

= POEX - external polygons (filled areas)

< POIN - internal polygons (empty areas)

Because of these high level commands, the Gerber translator can translate a mask
file with empty polygons directly into a stream of POEX and POIN commands.
Configuring the translator for MDA output is the only mode that supports empty

figures in the mask file.

Not only does configuring the translator for MDA output eliminate the need to stroke
out the interior of each polygon, but the resulting artwork is limited only by the
precision of the photoplotter. The FIRE 9000 autoplot format also embeds all Gerber
format, unit, and data mode information into its header so that a separate aperture
and information list is not needed.

We highly recommend (if possible) that you send your data to a photoplot or board
shop equipped with a raster photoplotter such as the FIRE 9000.

The Gerber Viewer can properly view both POEX and POIN data so that you can
verify the correctness of the output.

Recommended Settings for FIRE 9000 Output

The proper settings for FIRE 9000 output are summarized in the table below. When
Outline/Fill is set to OUTLINE, each mask polygon is outlined. If a polygon is filled,
then it is sent to either D20 or D21, these are both assigned as POEX. If it is an
empty polygon or a hole, it is assigned to D22 or D23 which correspond to a POIN.
Any open mask entities are sent to D10, which is a standard round aperture.

Table 7-2. Gerber Translator Settings for FIRE 9000 Output

Gerber File Options Translation Settings Apertures (inches)

Option Setting Option Setting D-Code |Type Inch (X,Y)

Unit INCH or MM Line DCode d1o0 10 Round |0.005

Format 4.40r4.3 Scale Factor 1 20 Poex 0.000

Zero

Suppression Leading Outline/Fill Outline 21 Poex 0.000

Circular 360 Filled D-codes d20, d21 22 Poin 0.000
(POEX)
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Table 7-2. Gerber Translator Settings for FIRE 9000 Output

Gerber File Options Translation Settings Apertures (inches)
CRI/LF Suppress Empty D-codes d22, d23 23 Poin 0.000
(POIN)
Compensation None
Output Offset 0,0
Gerber Output MDA Autoplot
Format

RS274X Output Configuration

Gerber Scientific’s laser photoplotters read the extended RS274X specification. These
photoplotters also support a polygon definition. Unfortunately, however, “empty”
polygons are not supported. If you use empty figures in the mask file they will be
covered up.

Other photoplotters may also support the RS274X specification, but before using
them you should verify that they properly support the G36/G37 command used to
switch into polygon mode.

Table 7-3. Recommended Gerber Translator Settings for RS274X Output

Gerber File Options Translation Settings Apertures (inches)
Option Setting Option Setting D-Code |Type Inch (X,Y)
Unit INCH or MM Line DCode di0 10 Round |0.005
Format 440r43 Scale Factor 1 20 Poex 0.000
Zero
Suppression | Leading Outline/Fill Outline 21 Poex 0.000
Circular 360 Filled D-codes d20, d21

(POEX)
CRI/LF Suppress Compensation None

Output Offset 0,0

Gerber Output RS274X

Format
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Creating an Excellon Drill File from an ADS Layout

This section describes the procedure for creating an Excellon drill file from an ADS
Layout. Excellon drill files define x and y coordinates for hole location and drill size.
These files are used to automate the drilling process in manufacturing environments.

To create a drill file:

1. In the layout window containing your design, choose File > Export . The Export
dialog box appears.

2. Select Gerber from the File Type drop down list then specify the file name in the
New File Name (Destination) field. Click OK. The Mtools status window
appears.

3. Click OK in the Mtools status window to accept the settings. The Mtools Log
and Gerber Translator Interface windows appear.

-
Mtools v3.40 (Apr 27,15999)
GERBER

Mask Files

Aperture File

h. apt Browse...

o

[ Gerver File Options
[ Editapertures
[ Tramslate
[ ViewMask
[ View Gerber

Exit  |About [Help

Figure 7-1. Gerber Translator Interface Window
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4. From the Gerber Translator Interface window, click Edit Apertures . A table
listing the aperture settings appears.

5.In the Aperture dialog box, click Flash Circles . A Map Circles/Holes dialog box
appears.

)

Count Diameter (inch) Block

Block
Names

~| Update Aperture (OK [Cancel |Help

6.In the Map Circles/Holes dialog box, verify that the circle Count and Diameter
for each Block are correct. Ensure that the Update Aperture box is checked.
Note the Block name of each of the circles in the Map Circles/Holes dialog box.
Click OK in the Map Circles/Holes dialog box.

In the Aperture dialog box, using the information from step 6, note which
D-codes have the Block names that were mapped to circles and then click Save.
A small dialog box asking if you want to save the changes appears. Click OK.
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Aperture (1.10) - english.apt

DCode Type ¥ ({inch) Block Hame

DCodes

PgUp |PgDn |Home (End Clear Line Auto FAash
fdd Default Set Clear All Fash Circles |

7. From the Gerber Translator Interface window, click Translate to select the
layers you want to include in the translated file (see “Translate” on page 7-14).
After selecting the layers, click OK to complete the translation. A window
appears briefly, indicating that the file is being converted to Gerber format.

8. When the translation is complete, the Mtools Log appears, detailing the export
information. Examine the log file, searching for any warnings or errors that
may have occurred during translation.
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File Search

9.When you are finished viewing the log file, click OK to dismiss the MTools Log
and exit the Gerber translator. You can also save the MTools Log before exiting
using the File > Save As menu pick.

10.From the Gerber Translator Interface window, click View Gerber. The GBRVU
dialog appears with a Gerber view of your layout.

11.From the GBRVU dialog, click Aperture . The Aperture dialog box appears.

12.1n the Aperture dialog box, enter the Tool # (integer only) and Drill Dia. for each
of the D-codes that were noted in step 7. Click Save. A small dialog box asking if
you want to save the changes appears. Click OK.

13.From GBRVU, choose Tools > Drill > Excellon . Choose whether or not to suppress
the leading zero’s. The Drill Output dialog box appears.
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14.Click the appropriate Drill Output and then click Report. The GERBER
VIEWER - DRILL REPORT file is displayed. This file contains a DRILL TOOLS
TABLE that lists tool numbers, tool size, quantity and remarks.

Example Drill Report:
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15.Use any ASCII text editor to open and view the drill file (file extension .drl)
stored in the current ADS project directory.

Example Drill File:

M48

INCH, TZ

VER,1

FMAT,2
DETECT,ON

%

M72

GO05

T01C.025
X-03000Y001000
X-03050Y-00500
X-01500
X002000
X001500Y000000
T02C.125
X-01500Y001000
Y000500
X-01000
Y001000

M30

Note Both the drill report and drill file are created in the ADS project
directory with the layer name as a prefix and .rpt and .drl as suffixes.
Example: layer_name.rpt is the drill report and layer_name.drl is the drill file
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Chapter 8: HPGL/2 Files

The HPGL/2 format is a subset of the HPGL/2 printer/plotter language. When
creating a graph or chart, you can write the graphics data to an HPGL/2 simulator
output file, then import the file into the Advanced Design System.

In the Advanced Design System, the HPGL/2 data is transformed into forms and
shapes. These forms can be edited and manipulated like any other drawing.
Additional text, annotation, scaling or editing may be added.

Importing HPGL/2 Graphics Files

The procedure for importing each format is generally the same, however the available
options differ. For a step-by-step tutorial on importing a layout file, refer to
“Importing a Layout” on page 2-3. For specific import options related to importing
HPGL/2 Files, refer to “Import HPGL/2 Options” on page 8-1.

Import HPGL/2 Options

The Import HPGL/2 Options dialog box enables you to set Units and Precision,
access the Layer Editor and specify a list of mask files to be read by the translator.

—| Import HPGLi2 Options:3 |

Units Precision

Same _"’l -3 _fl

Define Layers...

Mask To Layer

I |
OK |  Cancel| Help |
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Units

These are the units with which the HPGL/2 file will be imported. You may select from
the following options: same, mil, inch, um, mm, cm. The default is same. When same
is selected, the design is read in with the same units that are stored in the original
design file. For more information on choosing layout units, refer to “Setting
Units/Scale Factors” in the Advanced Design System Layout manual.

Precision

This value should be the same as the precision with which the drawing file was
created. A warning is generated if the precision is less than the drawing file
precision. Possible values are -2 or —3. The default is -3.

Define Layers

This button invokes the Layer Editor. For Layer Editor Options, see “Defining
Layers” on page 2-12.

Mask To Layer

This field enables you to specify a list of mask files to be read and the layer numbers
to be created within them. The information must be presented in pairs, as follows:

<layer_number> <file_name> <layer_number> <file_name>...

where all entries are separated by spaces.

Exporting HPGL/2 Graphics Files

The procedure for exporting each format is generally the same, however the available
options differ. For a step-by-step tutorial on exporting a layout file, refer to
“Exporting a Layout” on page 2-8. For specific export options related to exporting
HPGL/2 Files, refer to “Export HPGL/2 Options” on page 8-2.

Export HPGL/2 Options

The Export HPGL/2 Options dialog box enables you to set Units, Precision, Scale,
Attributes, Etch Factor and Miter Angle as well as access the Layer Editor and specify
layer options.
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—|  Export HPGLfZ Options:3 |

Units Precision

S & e _-"| =3 _fl

Define Layers...

OK |  Cancell  Help

Units

These are the units with which the HPGL/2 file will be exported. You may select from
the following options: same, mil, inch, um, mm, cm. The default is same. When same
is selected, the design is written in the same units that are stored in the design file.
For more information on choosing layout units, refer to “Setting Units/Scale Factors
in the Advanced Design System Layout manual.

”

Precision

This value should be the same as the precision with which the drawing file was
created. A warning is generated if the precision is less than the drawing file
precision. Possible values are -2 and -3. The default is -3.

Define Layers

The Define Layers button invokes the Layer Editor. For Layer Editor options, see
“Defining Layers” on page 2-12.
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Chapter 9: IFF Files

The Intermediate File Format (IFF) is an ASCII intermediate file. The file has a
simple, line-oriented command structure with a fairly rich set of constructs, thus
simplifying design transfer between Agilent Technologies products and third-party
EDA tools. This format is machine- and application-independent.

The types of information that can be represented in the IFF format include:
= Design Objects
= Symbols
= Layouts
= Schematics
= Connectivity
= Design Object Hierarchy
= Hierarchical and Design Object Properties

IFF files are used as the exchange mechanism when transferring designs between
Advanced Design System and third-party EDA tools such as Mentor Graphics Design
Architect and Cadence Analog Artist.

Importing IFF Files

The procedure for importing each format is generally the same, however the available
options differ. For a step-by-step tutorial on importing a layout file, refer to
“Importing a Layout” on page 2-3. For specific import options related to importing
IFF Files, refer to “Import IFF Options” on page 9-1.

Import IFF Options

The Import IFF Options dialog box that appears is dependent upon where you
execute the IFF import from. If the import is invoked from the ADS Main or Layout
window, the following Import IFF Options dialog box appears.

Importing IFF Files 9-1



IFF Files

=] Import HPIFF Options:4

I Remove IFF Fle After Import

| Log verhose messages

I Synchronize ports to symbol using node name

¥ Use layouts from libraries instead of building local copies from IFF file

Default Library Name For Library Parts
Iﬁlpeesoflib

Trace Handling

@ Trace

_) Path

_J Polygon

oK Cancel Help

Remove IFF File After Import

When this option is selected, the .iff file is removed once the file is successfully
imported. This option is not selected as the default.

Log verbose messages

When this option is selected, ALL translation information is recorded in the
ifftolib.log file resulting in step-by-step description of what happened internally
during your translation. This option is primarily intended to be used as a diagnostics
tool so the default mode for this option is deselected. Note that error and warning
messages will always appear in your status window regardless of this selection.

Synchronize ports to symbol using node name

When this option is selected, the IFF import resets the symbol pin numbers to match
port numbers based on the node name of the schematic port. By default, symbol pin
numbers are matched to schematic port numbers based on the port’s instance name.
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Use layouts from libraries instead of building local copies from IFF file

When this option is selected, library elements that already exist in the system
libraries are not recreated for the imported file. Instead, these elements are read from
the local libraries; if an element does not exist in a local library, then it is newly
created. This option is deselected as the default, and all elements are
created/recreated in the local project.

Default Library Name For Library Parts

When the IFF file does not specify a library name for a component that needs to be
created, the library name specified in this field is used. This is necessary for
environments that do not support the concept of a library.

Note The Default Library Name For Library Parts field is identical to the field of the
same name in the Export IFF Options dialog box. Changes made to this field will
modify the contents of the field in the Export IFF Options dialog box.

About Component Libraries

A component library in ADS consists of a collection of component definitions. Each
primitive component has an associated component name, symbol and predefined
component parameters that include relevant physical and electrical characteristics.

The IFF translator can be used as the initial step in creating an ADS component
library however, this topic is outside of the scope of this manual. Creating an ADS
component library using IFF requires specialized tools and training. If you're
interested in learning more about this topic, contact Agilent EEsof-EDA’s Solution
Services.

Trace Handling

Trace Handling enables you to select how you want your meander elements
interpreted during a translation.

Trace When this option is selected, meander elements are translated as
simulatable traces with pins. This is the default setting.

Path When this option is selected, meander elements are translated as primitive
data type with center line and width. The default for this option is deselected.
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Polygon When this option is selected, meander elements are translated as
polygons. The default for this option is deselected.

Note If you choose Use layouts from libraries instead of building local copies from
IFF file in the Import IFF Options dialog box, choose Path in the Trace Handling
options. Fixed artwork is not simulatable, therefore it is not necessary for the
interconnects to be simulatable.

Importing from a Schematic Window

If the import is invoked from the ADS Schematic window, the following Import IFF
Options dialog box appears.

=] Import HPIFF Options:3

I Remove IFF File After Import
_| Log verbose messages
I Synchronize ports to symbol using node name

Default Library HName For Library Parts
I:[hpeesoflih |

0K Cancel| Help |

Note that the same options are used with the exception of the Use layouts from
libraries instead of building local copies from IFF file check box and the Trace
Handling options. For information on these options, refer to “Import IFF Options” on
page 9-1.

Exporting IFF Files

To export an IFF file:

1. Follow the steps as outlined in “Exporting a Layout” on page 2-8. For available
options (accessed via More Options in the Export dialog box), see “Export IFF
Options” on page 9-6.

2. When the translation is complete, the following message window appears:

9-4 Exporting IFF Files



5]

Click OK to dismiss this window.
3. The IFF Export log appears:

Review the log, searching for any warnings or error messages generated during
export.

The log file appears in the hpeesofedit window by default. This window is provided
as a means of viewing the file and is not intended for editing.

4. To dismiss the log window, choose File > Quit .
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Export IFF Options

=] Export HPIFF Options:3 |

— Destination IFF File name:

II | Browse...

IFF File Overwrite Options  Qyeorwrite IFF File

| Output disabled instances to the IFF file
| Output ADS Item Definition properties
I Put a space between numbers and the scalarfunit

Default Library Mame For Library Parts
|_§_hpeesoflib

Schematic Hierarchy Option

Current Design, Selected Projects and Mo Library Farts L

Project Hierarchy e Projects Included During Schematic Export
=z InClude ==
Mfsiil locallusersicrscott/ADS_Test_prj Mifsfdlfocal/usersicrscott/ADS_Test_py

»> Include All ==
<« Remove <<
<< Remove All <<

oK Cancel Help

Destination IFF File name

Use the Destination IFF File name field to enter the full path of the destination file.
Alternatively, you can click Browse to open the Export File Selection dialog box and
locate the destination path. After selecting the destination path and entering the file
name, click OK to accept the selection and return to the Export IFF Options dialog
box. The appropriate suffix is appended to the filename automatically.

IFF File Overwrite Options

Overwrite IFF File  When writing to an existing file, the contents of that file are
overwritten.
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Append to IFF File  When writing to an existing file, the new data is appended to
the existing file. This is the default setting.

Output disabled instances to the IFF file

When this option is selected, if an instance is disabled in the schematic, it will still be
output into the IFF file. If the checkbox is deselected (default), disabled instances will
not be exported. This option can be utilized to omit certain components from being
transferred to remote environments that might not support the components (e.g.
disable the simulation components prior to creating an IFF file to send to Cadence,
which does not have any definitions for the simulator components). Activate this
option if you want to get everything. Deactivate this option if you want to filter out
the unused/unwanted components.

Output ADS Item Definition properties

When this option is selected, ADS Item Definition properties are utilized to recreate
the information necessary to simulate a component for ADS. For example, if you have
parameters on a resistor, some Item Definition properties are created in the IFF file
(e.g. R_LADS_UNIT=1), which allow the IFF importer to exactly recreate the
component as it exists in ADS. However, other tools will not recognize the Item
Definition parameters, and may misinterpret the properties as being separate. If
library symbols are being exported to other environments that do not recognize the
ADS Item Definition parameters, the option should be turned off. This option is
deselected by default.

Put a space between numbers and the scalar/unit

When this option is selected, parameter values are exported as they normally appear
in ADS (i.e. with a space between the number and the scalar, e.g. “1 pF”). If the
checkbox is deactivated, the exporter converts the values into the IFF value
specification, which is to have no space between a number and a scalar (e.g. "1pF").
Ideally, an IFF exporter should interpret either form of number, and set the value
internally to whatever is normal for that environment. Some environments (e.g.
Mentor Graphics) do not interpret the IFF property values in any way. For Mentor IC,
this means the numbers need to have no space in them, because, when they are used
within SPICE simulations, the space will cause syntax errors in the simulator.
However, for Mentor Board, they require the ADS components to have a space in
them, because the RF Architect ADS library is set up to expect values to have a space
between a number and a scalar/unit.
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If you are exporting designs to Mentor Boardstation, you must select this option for
IFF imports to work into their environment. An additional issue can come up if you
create variables, and then assign scalar values to the variable (e.g. "R1 kOhms").
When this is exported, if the option is not set, it would convert to "R1koh", which
could no longer be interpreted correctly. Note that this second option is considered
bad practice (the scalar should be included in the variable value for R1, and no units
should be specified); however, ADS does allow you to format variables in this way. If
you are using variables in this way, you must set this option to true. This option is
deselected by default.

Default Library Name For Library Parts

When the IFF file does not specify a library name for a component that needs to be
created, the library name specified in this field is used. This is necessary for
environments that do not support the concept of a library.

Note The Default Library Name For Library Parts field is identical to the field of the
same name in the Import IFF Options dialog box. Changes made to this field will
modify the contents of the field in the Import IFF Options dialog box.

About Component Libraries

A component library in ADS consists of a collection of component definitions. Each
primitive component has an associated component name, symbol and predefined
component parameters that include relevant physical and electrical characteristics.

The IFF translator can be used as the initial step in creating an ADS component
library however, this topic is outside of the scope of this manual. Creating an ADS
component library using IFF requires specialized tools and training. If you're
interested in learning more about this topic, contact Agilent EEsof-EDA’s Solution
Services.

Schematic Hierarchy Option

The Schematic Hierarchy Option drop-down list enables you to establish how much of
the schematic hierarchy is exported:

Current Design Only ~ Write current level only. Complete design information for the
current design is exported. Instance-specific information (parameter values and
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coordinates identifying position) is also exported. Detailed definitions of a
referenced design are not exported.

Current Design, Selected Projects and No Library Parts Complete design
information for the current design is exported. Referenced designs that reside in a
project selected for inclusion during export and are part of the current design’s
hierarchy are also exported. Library parts are not exported. This is the default
setting.

Current Design, Selected Projects and All Library Parts Complete design
information for the current design is exported. Referenced designs that reside in a
project selected for inclusion during export and are part of the current design’s
hierarchy are also exported. In addition, library parts are exported.

Project Hierarchy

Displays the current project. If hierarchical, all included projects are listed in the
appropriate order.

Projects Included During Schematic Export

The projects for which schematic design information is exported. You may customize
this list if the current project is hierarchical. (Note that complete layout hierarchy is
always exported.)

To add a project to this list:

1. In the Project Hierarchy list, click the desired project.

2. Click the Include button. The project is added to the Projects Included list.
To include all projects, click Include All .
To remove a project from the Projects Included list:

1. In the Projects Included list, click the entry you want to remove.

2. Click the Remove button. The project is removed from the list.

To remove all entries from the Projects Included list, click Remove All .
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Chapter 10: IGES Translator

IGES (Initial Graphics Exchange Specification) is a neutral graphics database format
designed primarily for data exchange between mechanical CAD systems. The IGES
file format links mechanical CAD systems to Advanced Design System.
Two-dimensional geometry can be used to interchange layout or package outline
information.

The Advanced Design System IGES translator can either create or read an IGES
ASCII form file. The basic input requirements for the translator are the file to be
translated and the configuration message file. The output is the translated file.

The IGES translator can be run via the layout window menu commands
File > Import and File > Export.

The IGES format can represent both mechanical and electrical design data in two
and three dimensions.

For IGES output, it is important to consider the limitations and capabilities of the
intended receiving system. IGES is a very general language. Many IGES translators
understand only a sub-set of IGES entities. If the receiving system is CALS Level 1
compliant, there should be no problem. If it is not, before you begin layout carefully
review the types of entities the receiving system is able to accept and what options
are available in the layout output translator. The translator is extremely
configurable, but may still be unable to output every entity in a form acceptable to
another system.

Translator Description

The Advanced Design System’s IGES output is compatible with IGES versions 4.0
and 5.0. The output is CALS Level 1 compliant. However, because many IGES
pre-processors accept different types of IGES files, the translator is designed to be
highly configurable through the use of the Import and Export Options dialog boxes.
For more information on the options provided in these dialog boxes, see the sections
“Import IGES Options” on page 10-2 and “Export IGES Options” on page 10-3 later in
this chapter.
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Importing IGES Files

The procedure for importing each format is generally the same, however the available
options differ. For a step-by-step tutorial on importing a layout file, refer to
“Importing a Layout” on page 2-3. For specific import options related to importing
IGES Files, refer to “Import IGES Options” on page 10-2.

Import IGES Options

=| Import IGES Options:3 |

Precision

-3 ) Define Layers...

Font Translation ———————

Hershey Roman

Hershey Roman Marrow |i13

OK | Cancel Help |

Precision

This value should be the same as the precision with which the drawing file was
created. A warning is generated if the precision is less than the drawing file
precision. Possible values are 0, -1, -2, -3, -4, or -5. The default is -3.

Define Layers

The Define Layers button invokes the Layer Editor. For Layer Editor options, see
“Defining Layers” on page 2-12.

Note that the layer-to-IGES level number is controlled in the Layer Editor IGES
Layer entry field for each program layer.
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Font Translation

In versions 1.0 and 1.1 of the Advanced Design System, the Font Translation fields
Hershey Roman and Hershey Roman Narrow are not applicable.

Exporting IGES Files

The procedure for exporting each format is generally the same, however the available
options differ. For a step-by-step tutorial on exporting a layout file, refer to
“Exporting a Layout” on page 2-8. For specific export options related to exporting
IGES Files, refer to “Export IGES Options” on page 10-3.

Export IGES Options

=] Export IGES Options:3 |
IGES Extension - Attributes
I igs | Define Layers... [® Create Top I Polygons As Open Polylines
Units Addnl. Scale Factor X Include Al I Polygons As Segments
Same _!l ‘1 ¥ Include Text _I Explicitly Define Defaults
Exponent Character Precision * Holes As Polygons _I ZerohllSequence Numbers
E X | -2 1 | L1 Ratten ¥ ZeroFillTenminate Section
Author Organization _1 Reverse Arcs .1 Hame Properties
‘ ‘ I Conv Arc to Lines
0K | Cancel Help |

IGES Extension

If you do not specify an output file name when exporting the file, the program takes
the input file name and appends this extension to create the output file name. The
default extension is igs, but any three character string can be used.
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Units

These are the units that the IGES file will be written in. You may select from the
following options: same, mil, inch, um, mm, cm. The default is same. When same is
selected, the design is written in the same units that are stored in the design file. For
more information on choosing layout units, refer to “Setting Units/Scale Factors” in
the Advanced Design System Layout manual.

Exponent Character

For case sensitive post processors, this option enables you to specify either upper-case
(E) or lower-case (e) exponents. The default is E, or upper-case.

Author

Your name. This is written into the Global Section (the first three lines of the IGES
file) and is not required.

Define Layers

The Define Layers button invokes the Layer Editor. For Layer Editor options, see
“Defining Layers” on page 2-12.

Addnl. Scale Factor

If this value is other than 1.0, the output coordinates are multiplied by that value.
The default is 1.0. You may enter any integer or double precision float number to
multiply the output by.

Precision

This value should be the same as the precision with which the drawing file was
created. A warning is generated if the precision is less than the drawing file
precision. Possible values are 0, -1, -2, -3, -4, or -5. The default is -2.

Organization

Name of your company or organization. This is written into the Global Section (the
first three lines of the IGES file) and is not required.
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Create Top

When selected, this adds a Substructure Instance Entity to the IGES file at the top
level of hierarchy. Create Top is selected as the default.

Include Fill

This is selected as the default. However, not all post-processors support fill patterns.
To eliminate fill patterns in filled polygons, deselect this item.

Include Text

This is selected as the default. However, not all post-processors support text. When
this option is deselected, text is eliminated from the IGES file.

Draw Holes

This is selected as the default. However, not all post-processors support holes in
polygons. When Draw Holes is deselected, polygons are written with false edges.

Flatten

When Flatten is selected, all levels of hierarchy are automatically removed and a
single flat design is translated. There will be no references from the top level
structure to any other structure. This option is useful when your post-processor does
not support or correctly translate hierarchy in IGES files. But beware: if a
substructure was instanced more than once, selecting this option increases the size of
the file.

This option is deselected as the default.

Reverse Arcs

When selected, the program writes all arc— as arc+ by interchanging the start and
end points. This forces polygons to be written as line segments. This option is
deselected as the default.

Conv Arc to Lines

When selected, the program translates an arc into of line segments. You should select
this option if your post-processor places random arcs on a drawing. This option is
deselected as the default.
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Polygons As Open Polylines

When selected, closed polygons are written as open contours. This retains arcs in
outline form. This option is deselected as the default.

Polygons As Segments

When selected, all copious data entities are changed to composite curve entities. Arcs
are retained in outline form. This is useful for post-processors that cannot read IGES
solids. However, when this option is selected, the size of the output file greatly
increases because each line segment is written on a separate line, and each
coordinate that is a vertex gets written twice. Also, knowledge of segments belonging
to a polygon is not retained.

This option is deselected as the default.

Explicitly Define Defaults

If your post-processor complains because there are blanks in the Directory Entry
Section fields, or that the parameter and record delimiters are not specified, select
this option. Otherwise, Explicitly Define Defaults is deselected as the default.
ZeroFillSequenceNumbers

If your post-processor complains because the sequence numbers do not have zero fill,
select this option. Otherwise, ZeroFillSequenceNumbers is deselected as the default.
ZeroFillTerminateSection

If your post-processor complains because the terminate section has zero fill, deselect
this option. Otherwise, ZeroFillTerminateSection is selected as the default.

Name Properties

When selected, all Name Properties are preserved and exported with the IGES file.
This option is deselcted as the default.

Overcoming Limitations of Other IGES Readers

You may encounter problems when attempting to read IGES files produced by the
program into other systems. Some of the more common problems and their solutions
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are listed in the following table (Table 10-1). These solutions are implemented
through the IGES Export Options dialog box in the Advanced Design System.

Table 10-1. Third-Party IGES Reader Problems and Advanced Design System Export

Solutions
IGES Reader Problem Advanced Design System Solution
Can't read clockwise arcs Convert arcs to lines (Conv Arc to Lines)
Can't read hierarchical IGES Flatten the design
Can't read IGES solids Reverse arcs (polygons are converted to line sets)
Can't read lower-case exponent Specify Exponent Character as E (or )
Text won't transfer Deselect Include Text
Defaults not explicitly defined Select Explicitly Define Defaults
Zero fill in termination section Deselect ZeroFillTerminateSection
Zero fill not in sequential numbers Select ZeroFillSequenceNumbers
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Chapter 11: Mask Files

Created by Agilent EEsof-EDA for use with its EDA tools, the mask format is a
simple ASCII format that provides a flat geometric representation of a layout.
Because of its simplicity, this format offers great flexibility when transferring designs
between the Advanced Design System and other design environments.

The optional Gerber and DXF translators use the mask file format as an
intermediate file when converting data to Gerber and DXF. The mask format is also
used and an intermediate file when translating other formats such as HPGL/2. In
addition, the simplicity of the mask file format makes it an appealing option for
post-processing designs and extracting drill hole file information (you will need to
create your own programs for these tasks).

Mask files can include multiple layers of data, but this data describes geometric
forms exclusively. Simulation data, element parameters, substrate definitions, and
hierarchy are not included.

Importing Mask Graphics Files

For a step-by-step tutorial, see “Importing a Layout” on page 2-3.

Import MASK Options

—|  Import MASK Options:1

Scale X scale ¥

[Eo ] [0
Define Layers...

Mask To Layer

OK |  Cancel|  Help
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Scale X, Scale Y

These are the fields for inputting the scale factors for shapes in the direction of X and
Y. The default settings are 1.0, 1.0.

Define Layers

This button invokes the Layer Editor. For Layer Editor options, see “Defining Layers”
on page 2-12.

Mask To Layer

This field enables you to specify a list of mask files to be read and the layer numbers
to be created within them. The information must be presented in pairs, as follows:

<layer_number> <file_name> <layer_number> <file_name>...

where all entries are separated by spaces.

Exporting Mask Graphics Files

For a step-by-step tutorial, see “Exporting a Layout” on page 2-8.
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Export MASK Options

= Export MASK Options:1

Units Scale X Scaley | fitrbutes

I Arcs As Polygons
Define Layers...

Layers

— Hole Format
Layer Number({s)
|? _J Holes As Polygons

@ Include

# Holes As Cutlines

) Exclude Layer File Hame(s)

Etch Factor  Miter Angle
) 80,0

_J) Preserve Holes

oK Cancel Help

Units

These are the units that the mask file will be written in. You may select from the
following options: same, mil, inch, um, mm, cm. The default is same. When same is
selected, the design is written in the same units that are stored in the design file. For
more information on choosing layout units, refer to “Setting Units/Scale Factors” in
the Advanced Design System Layout manual.

Scale X, Scale Y

These are the fields for inputting the scale factors for shapes in the direction of X and
Y. The default settings are 1.0, 1.0.

Define Layers

Clicking this button invokes the Layer Editor. For Layer Editor Options, see
“Defining Layers” on page 2-12.
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Layers Include, Layers Exclude
These buttons enable you to specify layers to either include or exclude.

= Include - exports information only from layers specified in the Layer Number(s)
and Layer File Name(s) fields (see descriptions below).

= Exclude - exports all layers except those specified in the Layer Number(s) field
(it is not necessary to fill in the Layer File Name(s) field).

Include is selected as the default. Unless you specify layer numbers to include in the
Layer Number(s) field, all layers are automatically included.

Layer Number(s)

The layer numbers to include or exclude in the mask file output. Entries are
separated by commas. For example:

1, 6, 20.

Layer File Name(s)

This option is used only when Layers Include is selected. The information must be
presented in pairs, as follows:

<layer_number> <layer_name> <layer_number> <layer_name>...
where all are separated by spaces. For example:
1 mskl 3 msk3

Auto Merge

When Auto Merge is selected, all shapes for every mask layer that intersect or overlap
are merged. This option is deselected as the default.

Arcs As Polygons
When Arcs As Polygons is selected, the design arcs are exported as line segments (or
polygons). This option is deselected as the default.

Holes As Polygons

When Holes As Polygons is selected, holes are converted into polygons. When Holes
As Polygons is not selected, polygons with holes are translated as single-segment
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polygons, the false edge segment becoming part of the polygon. Some systems may
not be able to tolerate this type of complex polygon. For these systems, make certain
that Holes As Polygons is selected. This option is deselected as the default.

Holes As Cutlines

When Holes As Cutlines is selected, holes are converted into cutlines. This option is
selected as the default.

Preserve Holes

This option is not available for DXF (hierarchical) Export. This option is desensitized
as the default.

Etch Factor

The etch factor applies a global over/undersize amount to each shape translated. This
is meant to compensate for etch effect during processing. However, using this option
can be problematic. Thus, we recommend that you retain the default setting of 0.

If you use Etch Factor, carefully verify the correctness of the compensation to
minimize problems. Limitations include the following: When a figure has a side
smaller than the etch factor, this function may fail. If two boundaries butt up against
one another before compensation, because each boundary is handled independently,
such boundaries will either overlap or show a gap when compensation is specified.
When Etch Factor is applied, re-entrant polygons may be transformed into illegal

polygons.

Miter Angle

The angle cutoff used with the etch factor. The miter angle controls acute angle edge
over-extension. Any angle below the miter angle amount is mitered. The default is
90.0.

Exporting Mask Graphics Files 11-5



Mask Files

11-6 Exporting Mask Graphics Files



Chapter 12: MGC/PCB Files

MGC/PCB files are IFF files that are used exclusively for Mentor Graphics design
transfers. This format is available from the Advanced Design System layout export
menu only, yet it enables the transfer of both schematic and layout information.

When you select the MGC/PCB export format from an Advanced Design System
Layout window, both a layout and schematic IFF file are exported in a single step.
The design data is exported into a standard directory tree contained in the program’s
project directory structure. The standard directory is called to_mgc. The exported
files are placed within this directory in a subdirectory that is named the same as the
design being exported. This subdirectory contains an information file and the
translated schematic and layout IFF files. Thus, if you were translating a design
called test, the exported files (design_info, schematic.iff and layout .iff) would found in
a directory called to_mgc/test.hpxfer.

From the Mentor Graphics Design Manager, a single command called import_hpeesof
imports the schematic and layout data into Boardstation and Design Architect. This
command automates to a single procedure the steps required to transfer both the
schematic and the layout.

Mentor PCB products do not accept layout hierarchy, so the entire layout is flattened
prior to building the Mentor layout.

Exporting MGC/PCB Files

This section outlines the procedure for translating designs into MGC/PCB format.
For more information on transferring designs between the Advanced Design System
and the Mentor Graphics Falcon Framework, contact your Agilent Technologies sales
representative.

To export an MGC/PCB file:

1. Follow the steps as outlined in “Exporting a Layout” on page 2-8. For available
options (accessed via More Options in the Export dialog box), see “Export
MGC/PCB Options” on page 12-4.

2. If the option Prompt For User Message was selected (see “Export MGC/PCB
Options” on page 12-4), a message dialog appears:
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= MGCIPCB User Message |

,_.
mi—

| oK | Print | Help |

| |
Enter any messages to be included with the design transfer. This information is
used only by the import_hpeesof utility (see Chapter 12, MGC/PCB Files) and is
not kept with the design.

If you do not wish to include a message in the file, you may leave this window
empty. If you want to print the message, click Print .

To proceed with the transfer, click OK.
3. When the translation is completed, the following message window appears:

| |
=| Information Message

] MGCIPCB export completed

o]

Click OK to dismiss this window.

4. The IFF Export log appears:
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Review the log, searching for any warnings or error messages generated during
export.

The log file appears in the hpeesofedit window by default. This window is provided
as a means of viewing the file and is not intended for editing.

5. To dismiss the log window, choose File > Quit .
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Export MGC/PCB Options

=] Export MGC/PCE Options:1

IFF File Overwrite Options
Overwrite IFF File

Default Library Hame For Library Parts
I hpeesoflib |

| Output disabled instances to the IFF file

% Output ADS Item Definition properties

-1 Put a space hetween numbers and the scalariunit
Schematic Hierarchy Option

Current Design, Selected Projects and No Library Parts ¥

Project Hierarchy

Projects Included During Schematic Export
=» Include >= - .
Mfsfdl AocaliusersicrscottfSlot_dipole_pr Mfsidl ocalfusers/crscott/Slot_dipole_pn

== Include All ==
<< Remove <<
<< Remove All <<

X Prompt For User Message

0K Cancel Help

IFF File Overwrite Options
= Overwrite IFF File

When writing to an existing file, the contents of that file are overwritten. This is
the default setting.

= Append to IFF File

When writing to an existing file, the new data is appended to the existing file.
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Default Library Name For Library Parts

The name of the library to which the library parts are written. Design objectives are
stored in a group that uses the same name as the project directory, but library parts
are stored in either the default library hpeesoflib or a library that you specify.

Note The default library name can contain only alphabetic and numeric characters.

Output disabled instances to the IFF file

When this option is selected, if an instance is disabled in the schematic, it will still be
output into the IFF file. If the checkbox is deselected (default), disabled instances will
not be exported. This option can be utilized to omit certain components from being
transferred to remote environments that might not support the components (e.g.
disable the simulation components prior to creating an IFF file to send to Cadence,
which does not have any definitions for the simulator components). Activate this
option if you want to get everything. Deactivate this option if you want to filter out
the unused/unwanted components.

Output ADS Item Definition properties

When this option is selected, ADS Item Definition properties are utilized to recreate
the information necessary to simulate a component for ADS. For example, if you have
parameters on a resistor, some Item Definition properties are created in the IFF file
(e.g. R_ADS_UNIT=1), which allow the IFF importer to exactly recreate the
component as it exists in ADS. However, other tools will not recognize the Item
Definition parameters, and may misinterpret the properties as being separate. If
library symbols are being exported to other environments that do not recognize the
ADS Item Definition parameters, the option should be turned off. This option is
deselected by default.

Put a space between numbers and the scalar/unit

When this option is selected, parameter values are exported as they normally appear
in ADS (i.e. with a space between the number and the scalar, e.g. “1 pF”). If the
checkbox is deactivated, the exporter converts the values into the IFF value
specification, which is to have no space between a number and a scalar (e.g. "1pF").
Ideally, an IFF exporter should interpret either form of number, and set the value
internally to whatever is normal for that environment. Some environments (e.g.
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Mentor Graphics) do not interpret the IFF property values in any way. For Mentor IC,
this means the numbers need to have no space in them, because, when they are used
within SPICE simulations, the space will cause syntax errors in the simulator.
However, for Mentor Board, they require the ADS components to have a space in
them, because the RF Architect ADS library is set up to expect values to have a space
between a number and a scalar/unit.

Schematic Hierarchy Option
This establishes how much of the schematic hierarchy is exported:
= Current Design Only

Write current level only. Complete design information for the current design is
exported. Instance-specific information (parameter values and coordinates
identifying position) is also exported. Detailed definitions of a referenced design
are not exported.

= Current Design, Selected Projects and No Library Parts

Complete design information for the current design is exported. Referenced
designs that reside in a project selected for inclusion during export and are part of
the current design’s hierarchy are also exported. Library parts are not exported.

This is the default setting.
= Current Design, Selected Projects and All Library Parts

Complete design information for the current design is exported. Referenced
designs that reside in a project selected for inclusion during export and are part of
the current design’s hierarchy are also exported. In addition, library parts are
exported.

Project Hierarchy

Displays the current project. If hierarchical, all included projects are listed in the
appropriate order.

Projects Included During Schematic Export

The projects for which design information will be exported. You may customize this
list if the current project is hierarchical. (Note that complete layout hierarchy is
always exported.)

To add a project to this list:
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1. In the Project Hierarchy list, click the desired project.

2. Click the Include button. The project is added to the Projects Included list.

To include all projects, click Include All .

To Remove a project from the Projects Included list:
1. In the Projects Included list, click the entry you want to remove.
2. Click the Remove button. The project is removed from the list

To remove all entries from the Projects Included list, click Remove All .

Prompt For User Message

When selected, a user message window appears before the transfer is initiated. This
window enables you to enter any messages that you want included in the translated
file. For more information about the user message, see “Export MGC/PCB Options”

on page 12-4.

This option is selected as the default.

Exporting MGC/PCB Files

12-7



MGC/PCB Files

12-8 Exporting MGC/PCB Files



Index

A
aperture files, 7-5
and Gerber Viewer, 7-24
apertures
and Gerber files, 7-12
Gerber, editing, 7-11
POEX, 7-13
POIN, 7-13
arcs
and GDS Il files, 6-7
and random placement, 10-5
clockwise, and IGES reader error, 10-7
converting to lines, 10-5
converting to polygons, 3-18, 7-18, 11-4
retaining in outline form, 10-6
reversing, 10-5
attributes
defining
for EGS Archive files, 4-3
for EGS Generate files, 5-3
for GDS 11 files, 6-8
for IGES files, 10-3
for importing GDS |l files, 6-5
translated in GDS Il files, 6-6
AutoCAD, 1-3, 3-1

B

boundaries
gaps between, 11-5
overlapping, 11-5

C
Cadence, 1-5
CALS specifications, 1-5, 10-1
carriage return/line feed

in Gerber files, 7-9
cell libraries

and GDS Il Stream file format, 6-1
charts

translating, 1-4
circles

and GDS |l files, 6-7
clockwise arcs

and reading error, 10-7
commands

Gerber file, 7-1

components

flattening, 4-4, 5-4

copious data entities

converting to composite curve entities, 10-6

corners, 4-3
CR/LF

and Gerber file options, 7-9

curved corners

preserving, 4-3, 5-3, 6-8

curved elements

and GDS Il files, 6-1

curves

D

composite, from copious data entities, 10-6

data

lost, 1-2
verifying correctness, 1-4, 2-9

data type records

and GDS |l files, 6-5, 6-9

D-codes

in Gerber aperture files, 7-12

defaults

undefined, and IGES error, 10-7

delimiters, parameter/record

unspecified, 10-6

designs

simplifying transfer of, 1-4

drill files, 7-48
DXF entities, 3-10, 3-19
DXF files

and scale factor, 3-14
features, 3-1
limitations of, 3-1
mapping, 3-10, 3-19
output, 3-1, 3-7, 3-10
overview, 1-3, 3-1
translating, 3-16

DXF Line Type, 3-14
DXF translator

Mtools interface, 3-12
options, 3-13-3-16
Translate command, 3-16

Index-1



E
EGS Archive files
exporting, 4-2
importing, 4-1
mapping shapes for export, 4-5
mapping shapes for import, 3-6, 4-2
overview, 1-3
EGS Generate files
exporting, 5-2
import options, 5-1
mapping, 5-2, 5-5
overview, 1-3
endpoints
preserving
in EGS Archive files, 3-9, 4-3
in EGS Generate files, 5-3
in GDS Il files, 6-8
EOB characters
and Gerber file options, 7-8
EQJ strings
and Gerber file options, 7-8
errors
delimiters not specified, 10-6
IGES reader, 10-6
and text transfer, 10-7
and undefined defaults, 10-7
and zero fill sequence numbers, 10-6
and zero fill terminate section, 10-6
unreadable clockwise arcs, 10-7
unreadable exponents, 10-7
unreadable hierarchies, 10-7
unreadable IGES solids, 10-7
zero fill and sequential numbers, 10-7
zero fill in terminate section, 10-7
zero fill sequence numbers, 10-6
zero fill terminate section, 10-6
etch factor, 3-19, 11-5
limitations of, 11-5
exponents
IGES reading error, 10-7
in IGES files, 10-4
Export command, 2-2
exporting
EGS Archive files, 4-2
EGS Generate files, 5-2
GDS Il files, 6-6
Gerber files, 7-2

Gerber Viewer menu option, 1-4
HPGL/2 files, 8-2

IFF files, 9-4

IGES files, 10-3

mask files, 11-2

MGC/PCB files, 12-1
paths/traces as polygons, 5-3, 6-8
procedure described, 2-2

F
file formats

DXF, 1-3, 3-1

EGS Archive, 1-3

EGS Generate, 1-3

GDS 11, 1-3

Gerber, 1-4

IFF, 1-4,12-1

IGES, 1-5

mask, 1-5

MGC/PCB, 1-6
file size

increased, 4-4, 5-4, 6-9, 10-5, 10-6
filename

limitations (GDSII), 6-2
files

corrupted, 6-4

viewing, 1-4
fill

data, 4-4, 5-4

patterns, eliminating, in IGES files, 10-5
FIRE 9000 laser plotters, 7-13
flash circles

Gerber, 7-13, 7-49
framework links

and EGS Archive files, 4-1

and EGS Generate files, 5-1

G
GDS Il elements
and layout equivalents, 6-3
GDS Il files
and curved elements, 6-1
and Data Type records, 6-5, 6-9
and holes, 6-2
and layer numbers, 6-2, 6-6
and multiple instances, 6-4
and PLEX records, 6-5, 6-10
bidirectionality of, 6-6
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export options, 6-8 H

exporting, 6-6 , hierarchies
filename doesn’t match display name, 6-4 and IGES
import options, 3-2, 6-5 reading error, 10-7
importing, 6-3 project
overview, 1-3 and IFF files, 9-9
tracking hierarchies in, 6-4 and MGC/PCB files, 12-6
Gerber File Options removing
ESIJLE' 79 7.8 and EGS Archive files, 4-4, 5-4
Gebor piang. - and GDS 11 files, 6-9
and apertures, 7-12 hand |GES files, 10-5
command format, 7-1 schematic
commands in, 7-2 and IFF files, 9-8
editing apertures in, 7-11 and MGC/PCB files, 12-6
export options, 7-16 tracklng, in GDS Il files, 6-4
exporting, 7-2 translating, 3-8, 4-4
limitations of, 7-1 holes _
options, 7-7 and GDS |l files, 6-2, 6-7
output format, 7-11 converting to polygons, 3-18, 4-4, 5-4, 6-9,
overview, 1-4 ;0-5
translation settings, 7-9 hpeesoflib, 12-5
Gerber translator HPGL/2 files
creating drill files, 7-48 export options, 8-3
options, 7-6 exporting, 8-2
viewing mask files, 7-15 import options, 8-1
Gerber Viewer importing, 8-1
accessing, 1-4, 2-9 |
and DXF files, 3-15 .
aperture files IFF files, 1-6 _
creating, 7-24 and Mentor Graphics (c), 12-1
loading, 7-24 appending, 9-6, 12-4

export options, 9-6

exporting, 2-9 exporting, 9-4

job files _ _
i import options, 9-1
creating, 7-23 _ :
loadin g7-23 importing, 9-1
Iaunchingg’ overview, 1-4

overwriting, 9-6, 12-4
removing after import, 9-2
synchronizing ports to symbol, 9-2

during DXF export, 3-15
during file export, 7-21

from layout window, 7-19 IGES files
loading files into, 7-22 adding Substructure Instance Entity, 10-5
menu options, 7-26 and exponent characters, 10-4
overview, 1-4 exporting, 10-3
using, 7-19 . extension of, 10-3
viewing Gerber files, 7-16 importing, 10-2
graphs limitations of, 10-6
translating, 1-4 options, 1-1
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output compatibility, 10-1
overview, 1-5
reader problems, overcoming, 10-7
IGES solids
and reader error, 10-7
IGES translator
options, 1-1
Import command, 2-1
import_hpeesof utility, 12-1
importing
EGS Archive files, 4-1
failures and GDS |l files, 6-4
GDS Il files, 6-3
HPGL/2 files, 8-1
IFF files, 9-1
IGES files, 10-2
mask files, 11-1
including
list of mask layers
with EGS Archive design, 4-3
projects
during IFF export, 9-9
during MGC/PCB export, 12-6
instance names
and GDS Il files, 6-4
intermediate files, 1-4

J
job files
and Gerber Viewer, 7-23

K
Keep History option
and Gerber files, 7-9

L
layer editor, 2-12, 4-4, 5-4
invoking, 3-17, 4-2
layer numbers, 3-17, 7-17, 11-4
and GDS Il files, 6-6
layers
and GDS Il limitations, 6-2
defining, 2-12, 3-17, 4-2, 4-4, 5-2, 5-4, 6-6,
6-10, 7-17, 8-2, 8-3, 10-2, 10-4, 11-2,
11-3
excluding, 3-17,7-17, 11-4
excluding from GDS Il files, 6-10
file names, 3-18, 7-17, 11-4

including, 3-17, 7-17, 11-4
translation, selecting for Gerber, 7-14
layers definition files
creating, 4-1, 5-1
referencing, 4-1, 5-1
layouts
translating, 1-1
library names
and MGC/PCB files, 12-5
limitations
of DXF files, 3-1
of Gerber files, 7-1
line feed
in Gerber files, 7-9

M
mapping
EGS Archive shapes, 3-6, 4-2, 4-5
EGS Generate shapes, 5-2, 5-5
mask entities, 3-10, 3-19
mask files
and DXF, 3-1, 3-7, 3-10
and DXF translator, 3-12
and Gerber output, 7-4
export options, 11-3
exporting, 11-2
importing, 11-1
overview, 1-5
specifying for HPGL/2 import, 8-2
specifying import layers, 11-2
viewing, 3-15
mask layers
and EGS Generate files, 5-3
include list
with EGS Archive files, 4-3
mask processing, 1-5
Mask to Gerber specification, 7-4
MDS
and EGS Archive files, 4-1
translating graphic shapes into, 4-1
Mentor Graphics (c), 1-5
and MGC/PCB files, 1-6
and transferring layouts/schematics, 12-1
import_hpeesof utility, 12-1
MGC/PCB files
export options, 12-4
exporting, 12-1
messages in, 12-2, 12-7
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overview, 1-6

predetermined location for, 2-11
miter angle, exporting

DXF, 3-19

Gerber, 7-19

mask graphics, 11-5
mitered corners

preserving, 4-3, 5-3, 6-8
modules, activated

and DXF translator, 3-12
Mtools Log, 3-16, 7-4, 7-6, 7-50

viewing, 3-13

N
numbers
sequential, and IGES error, 10-7

@)
openlink ../layout/lo02.fm
Setting Units Scale Factors, 3-17, 8-2, 8-3,
10-4,11-3
outputs
of DXF files, 3-1, 3-7, 3-10
of Gerber files, 7-11
resolution, 1-2

P
parameter delimiters
unspecified, and IGES files, 10-6
paths
exporting as polygons, 4-3, 5-3, 6-8
translated in GDS Il files, 6-7
photoplotters
FIRE 9000, 7-13
POEX apertures, 7-13
POIN apertures, 7-13
polygons
as open contours, 10-6
as segments, 10-6
exporting paths/traces as, 4-3
from arcs, 3-18, 7-18, 11-4
from holes, 3-18, 4-4, 5-4, 6-9
illegal, 3-19, 7-18, 11-5
polylines
and GDS Il files, 6-6
in DXF files, 3-14
precision
information, in GDS Il files, 6-7

of drawing files, 8-2
setting
for GDS |1 files, 6-7
for HPGL/2 files, 8-2, 8-3
for IGES files, 10-2, 10-4
project hierarchies
and IFF files, 9-9
and MGC/PCB files, 12-6
projects
including with IFF export, 9-9
including with MGC/PCB export, 12-6

R
record delimiters
unspecified, and IGES files, 10-6
resolution
of output, 1-2
restrictions
of translations, 1-1

S
scale factor

in DXF files, 3-14
scaling

DXF output, 3-17

Gerber output, 7-17

IGES output, 10-4

mask output, 11-2, 11-3

text in GDS Il files, 6-7
schematic hierarchies

and IFF files, 9-8

and MGC/PCB files, 12-6
schematics

translating, 1-6
Select Translation Layers dialog, 7-14
sequence numbers

and IGES reader error, 10-7

zero fill, and IGES files, 10-6
Series IV

and EGS Archive files, 4-1

translating graphic shapes into, 4-1
shapes

and etch factor, 3-19, 7-18, 11-5

merging, 3-18, 4-4, 5-4, 6-9, 7-17, 11-4
simplify

design transfers, 1-4
solids

and IGES reader error, 10-7
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terminate section

and IGES reader error, 10-7
zero fill, and IGES files, 10-6

text

eliminating from IGES files, 10-5

IGES transfer error, 10-7

in GDS Il files, 6-7

size
and GDS 11 export, 6-10
and GDS Il import, 6-6

to_mgc directory, 12-1
traces

exporting as polygons, 4-3, 5-3, 6-8

transferring

both schematics and layouts, 1-6

data as filled, 4-4, 5-4

transfers

simplifying, 1-4

Translate command

in DXF translator, 3-16

translating

graphs and charts, 1-4
layouts, 1-1

translation settings

for Gerber files, 7-9

translations

U

and restrictions, 1-1

undefined defaults

and IGES reader error, 10-7

units

\Y,

and GDS Il files, 6-7
divergent, 3-17, 7-17
setting
for DXF export, 3-17
for GDS 11 files, 6-7
for Gerber export, 7-16
for Gerber translation, 7-16
for HPGL/2 export, 8-3
for HPGL/2 import, 8-2
for IGES export, 10-4
for mask export, 11-3

View Mask option, 3-15

viewing
DXF files, 3-15
files, and Gerber Viewer, 1-4
mask files, 3-15

Z
zero fill
and IGES reader error, 10-7
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