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Chapter 1: Momentum Basics
Momentum is a part of Advanced Design System and gives you the simulation tools
you need to evaluate and design modern communications systems products.
Momentum is an electromagnetic simulator that computes S-parameters for general
planar circuits, including microstrip, slotline, stripline, coplanar waveguide, and
other topologies. Vias and airbridges connect topologies between layers, so you can
simulate multilayer RF/microwave printed circuit boards, hybrids, multichip
modules, and integrated circuits. Momentum gives you a complete tool set to predict
the performance of high-frequency circuit boards, antennas, and ICs.

Momentum Optimization extends Momentum capability to a true design automation
tool. The Momentum Optimization process varies geometry parameters
automatically to help you achieve the optimal structure that meets the circuit or
device performance goals.

Momentum Visualization is an option that gives users a 3-dimensional perspective of
simulation results, enabling you to view and animate current flow in conductors and
slots, and view both 2D and 3D representations of far-field radiation patterns.

If you are unfamiliar with Advanced Design System, refer to the Quick Start  in the
online documentation, and to Schematic Capture and Layout. For information on the
interactions between Layout and Momentum, refer to Appendix B, Drawing Tips.

Momentum Major Benefits

Momentum enables you to:

• Simulate when a circuit model range is exceeded or the model does not exist

• Identify parasitic coupling between components

• Go beyond simple analysis and verification to design automation of circuit
performance

• Visualize current flow and 3-dimensional displays of far-field radiation

Momentum Major Features

Key features of Momentum include:

• An electromagnetic simulator based on the Method of Moments

• Adaptive frequency sampling for fast, accurate, simulation results
1-1
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• Optimization tools that alter geometric dimensions of a design to achieve
performance specifications

• Comprehensive data display tools for viewing results

• Equation and expression capability for performing calculations on simulated
data

• Full integration in the ADS circuit simulation environment allowing
EM/Circuit co-simulation

Momentum Overview
Momentum commands are available from the Layout window. The following steps
describe a typical process for creating and simulating a design with Momentum:

1. Create a physical design . You start with the physical dimensions of a planar
design, such as a patch antenna or the traces on a multilayer printed circuit
board. There are three ways to enter a design into Advanced Design System:

• Convert a schematic into a physical layout

• Draw the design using Layout

• Import a layout from another simulator or design system. Advanced Design
System can import files in a variety of formats.

For information on converting schematics or drawing in Layout, refer
Schematic Capture and Layout. For information on importing designs, refer to
the manual, Importing and Exporting Designs.

2. Choose Momentum or Momentum RF mode.  Momentum can operate in two
simulation modes: microwave or RF. You can select the mode based on your
design goals. Use Momentum (microwave) mode for designs requiring full-wave
electromagnetic simulations that include microwave radiation effects. Use
Momentum RF mode for designs that are geometrically complex, electrically
small, and do not radiate. You might also choose Momentum RF mode for quick
simulations on new microwave models that can ignore radiation effects, and to
conserve computer resources. For more information comparing the Momentum
and Momentum RF modes, see “About the Simulation Modes” on page 1-4.
1-2 Momentum Overview



3. Define the substrate characteristics. A substrate is the media upon which the
circuit resides. For example, a multilayer PC board consists of various layers of
metal, insulating or dielectric material, and ground planes. Other designs may
include covers, or they may be open and radiate into air. A complete substrate
definition is required in order to simulate a design. The substrate definition
includes the number of layers in the substrate and the composition of each
layer. This is also where you position the layers of your physical design within
the substrate, and specify the metal characteristics of these layers. For more
information, refer to the chapter, Chapter 3, Substrates.

4. Solve the substrate. Momentum calculates the Green’s functions that
characterize the substrate for a specified frequency range. These calculations
are stored in a database, and used later on in the simulation process. For more
information, refer to Chapter 3, Substrates.

5. Assign port properties. Ports enable you to inject energy into a circuit, which is
necessary in order to analyze the behavior of your circuit. You apply ports to a
circuit when you create the circuit, and then assign port properties in
Momentum. There are several different types of ports that you can use in your
circuit, depending on your application. For more information, refer to Chapter
4, Ports.

6. Add a box or a waveguide. These elements enable you to specify boundaries on
substrates along the horizontal plane. Without a box or waveguide, the
substrate is treated as being infinitely long in the horizontal direction. This
treatment is acceptable for many designs, but there may be instances where a
boundaries need to be taken into account during the simulation process. A box
specifies the boundaries as four perpendicular, vertical walls that make a box
around the substrate. A waveguide specifies two vertical walls that cut two
sides of the substrate. For more information, refer to Chapter 5, Boxes and
Waveguides.

7. Create Momentum components.  Momentum components can be used in the
schematic design environment in combination with all the standard ADS active
and passive components to build and simulate circuits including the parasitic
layout effects. The Momentum engine is automatically invoked to generate an
S-parameter model for the Momentum component during the circuit
simulation. For more information on the Momentum Components and
EM/Circuit cosimulation feature, refer to Chapter , Layout Components.

8. Set up and generate a circuit mesh. A mesh is a pattern of rectangles and
triangles that is applied to a design in order to break down (discretize) the
Momentum Overview 1-3
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design into small cells. A mesh is required in order to simulate the design
effectively. You can specify a variety of mesh parameters to customize the mesh
to your design, or use default values and let Momentum generate an optimal
mesh automatically. For more information, refer to Chapter 7, Mesh.

9. Simulate the circuit . You set up a simulation by specifying the parameters of a
frequency plan, such as the frequency range of the simulation and the sweep
type. When the setup is complete, you run the simulation. The simulation
process uses the Green’s functions computed for the substrate, plus the mesh
pattern, and the currents in the design are calculated. S-parameters are then
computed based on the currents. If the Adaptive Frequency Sample sweep type
is chosen, a fast, accurate simulation is generated, based on a rational fit model.
For more information, refer to Chapter 8, Simulation.

10. View the results. The data from an Momentum simulation is saved as
S-parameters or as fields. Use the Data Display or Visualization to view
S-parameters and far-field radiation patterns. For more information, refer to
Chapter 10, Viewing Results Using the Data Display and Chapter 11,
Momentum Visualization Basics.

About the Simulation Modes
With ADS 1.5, Momentum added an RF simulation mode to its existing microwave
mode. The microwave mode is called Momentum; the new RF mode is called
Momentum RF. Momentum RF provides accurate electromagnetic simulation
performance at RF frequencies. At higher frequencies, as radiation effects increase,
the accuracy of the Momentum RF models declines smoothly with increased
frequency. Momentum RF addresses the need for faster, more stable simulations
down to DC, while conserving computer resources. Typical RF applications include
RF components and circuits on chips, modules, and boards, as well as digital and
analog RF interconnects and packages.

When compared to the Momentum mode, the Momentum RF mode uses new
technologies enabling it to simulate physical designs at RF frequencies with several
useful benefits. The RF mode is based on quasi-static electromagnetic functions
enabling faster simulation of designs. The star-loop technology provides
low-frequency stability down to DC. The mesh-reduction algorithms allow quick
simulation of complex designs, and require less computer memory and CPU time.
Additionally, Momentum RF has the same use-model as Momentum in ADS, and
works with Momentum Visualization and Optimization. The following table shows
how each mode supports Momentum product features. For a detailed comparison of
1-4 About the Simulation Modes



the two simulation modes, see “Comparing the Microwave and RF Simulation Modes”
on page A-20.

Selecting the Correct Mode

In the Layout window, the Momentum menu label displays the current simulation
mode. To select the mode, toggle the mode setting.

• To switch the mode from Momentum to Momentum RF, choose Momentum  >
Enable RF Mode .

• To switch the mode from Momentum RF to Momentum, choose Momentum RF  >
Disable RF Mode .

In each case, the menu label in the Layout window changes to the current mode.

Deciding which mode to use depends on your application. Each mode has its
advantages. In addition to specifically RF applications, Momentum RF can simulate
microwave circuits. The following graph identifies which mode is best suited for
various applications. As you can see, some applications can benefit from using either
mode depending on your requirements. As your requirements change, you can
quickly switch modes to simulate the same physical design. As an example, you may
want to begin simulating microwave applications using Momentum RF for quick,
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initial design and optimization iterations, then switch to Momentum to include
radiation effects for final design and optimization.

Figure 1-1. Choose the mode that matches the application.

Momentum RF is usually the more efficient mode when a circuit

• is electrically small.

• is geometrically complex.

• does not radiate.

For descriptions about electrically small and geometrically complex circuits, see
“Matching the Simulation Mode to Circuit Characteristics” on page A-20.

Planar Antennas

High-Speed Digital (SI, BGA)
RF Board (FR4, Duroid)
RF Package (Plastic)

RFIC (Silicon)

RF Module (MCM, LTCC)

Microwave - hybrid (Alumina)

Microwave - IC (GaAs)

Initial design &
optimization

Final design &
optimization
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Locating Example Projects
Examples of designs that are simulated using Momentum and Momentum RF can be
found in the Examples directory.

To open an example project:

1. From the Main window, choose File  > Example Project .

2. From the Open Example Project dialog box, position the mouse in the
Directories field and double-click Momentum.

3. In the Directories field, double-click one of the example directories: Antenna,
Microwave, Optimization, or RF.

4. Select a project from the Files field, then click OK.

Several of these examples are referred to in the documentation to highlight
applications of various Momentum features.
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Chapter 2: Getting Started with Momentum
This chapter is intended to help you get started with Momentum. It illustrates basic
tasks and exercises using Momentum. The subsequent chapters contain more
in-depth reference information and examples.

Layout Basics
There are two basic ways to create a layout:

• From a schematic (in a Schematic window)

• Directly (in a Layout window)

The best approach to creating a layout depends on the design and the designer.

This section describes how to create a layout automatically from a finished schematic,
and how to use the basic features in a Layout window to create a layout directly.

Note When you are through working in layout, release the Layout license so that it
is available to another user. To do this, select File > Release Layout License  from the
Layout window.
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Creating a Layout from a Complete Schematic

If all data are contained in the schematic, it is very simple to create a layout.

1. In the Schematic window, build the schematic shown here, then choose the
menu command Layout > Generate/Update Layout (the schematic is the source
representation). The Generate/Update Layout dialog box appears.

By default, the layout will begin with P1, at 0,0, with an angle of 0 degrees.
There is no existing layout, so the Equivalence (the layout component that
2-2 Layout Basics



corresponds to the starting component in the schematic) is shown as not
created.

At this point, all of the elements in the schematic are highlighted, indicating
that they all need to be generated.

2. Click OK.

The Status of Layout Generation dialog box appears. It displays the number of
designs processed, the number of items regenerated (created) in the layout, the

Start
generation

Starting item for generation

Place P1 in layout at 0,0 with
angle of 0.0 degrees

Fix or free the position of P1 (so that it will or will
not be re-positioned in subsequent generations).
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number of items that are oriented differently in the layout than in the schematic,
and the number of schematic components that were not placed in the layout.

The program automatically opens a Layout window and places the generated
layout in it. The orientation of the layout is different from that of the schematic,
because the layout is drawn from left to right across the page, beginning at the
Starting Component .
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Creating a Layout Directly

Launch Advanced Design System and create a project. To display a Layout window,
choose Window  > Layout  from a Schematic window.

The following tasks are performed the same way in a Layout window as they are in a
Schematic window:

• Selecting components

• Placing and deselecting components

• Changing views

• Hiding component parameters

• Coping and rotating components

• Using named connections

Connecting Components with a Trace

As in a Schematic window, you can connect components without having them actually
touch. In a Layout window, this is done by placing a trace between the component (in
the same way a wire is used in the Schematic window). Either choose Component >
Trace , or click the Trace button in the toolbar.

Unlike wires in a Schematic window, a trace in a Layout window may be inserted
alone (click twice to end insertion).

Drawing Area
Component
Palette

Palette List

Component History

Create a Trace

Current insertion layer
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Shapes

In Layout you can insert shapes, using either Insert commands or toolbar icons:

With each shape, you can either click and drag to place it, or define points by
coordinate entry (choose the shape, then choose Insert > Coordinate Entry ).

• path : starting point, segment end (click), and end point (double-click)

• polygon : starting point, vertex (click), and end point (double-click) that closes
the shape

• polyline : starting point, segment end (click), and end point (double-click)

• rectangle : two diagonal corners

• circle : center and circumference point

• arc : (Insert command only) center and circumference point

Experiment by drawing different shapes to get the idea of how each is created.

rectangle
polygon

circlepath
polyline

Insert commands
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Layers

In a Layout window, items are placed on a layer. The name of the current insertion
layer is displayed in the toolbar and in the status bar.

Changing the Insertion Layer

There are many ways to change the insertion layer:

• In the toolbar, retype the name of the layer and press Enter.

• In the toolbar, click the arrow next to the layer name. Choose a name from the
list of currently defined layers.

• Choose the command Insert > Entry Layer  and select a layer from the list.

• Choose the command Options > Layers and select a layer from the list of defined
layers in the Layer Editor dialog box.

• Choose the command Insert > Change Entry Layer To , and click an object whose
layer you wish to make the current insertion layer.

Experiment with placing shapes on different layers. Remember to click OK to accept a
change in a dialog box.

Current Insertion Layer

Current Insertion Layer
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Copy to a Different Layer

Experiment with copying shapes from one layer to another; use the command
Edit > Copy/Paste > Copy to Layer  Note that the copied shape is placed at exactly the
same coordinates as the original. Move one to see them both.

Default Layer Settings

Choose the command Options > Layers to display the Layer Editor. This is where you
can edit the parameters of any defined layer, add layers, or delete existing layers.

Clicking Apply  updates layer definitions but does not dismiss the dialog box.

Experiment with layer parameters. Note that you can toggle the visibility of all items
on a layer. Protected means you can not select items on that layer.
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Other Layout Defaults

The Options  > Preferences  command displays the Preferences for Layout dialog box.
This dialog box has 12 tabs; clicking a tab brings the corresponding panel to the front.

Click the Grid/Snap tab.

This panel is where you set the snap grid and display grid parameters.

The display grid appears on the screen as a series of vertical and horizontal lines or
dots that you can use for aligning and spacing items in the drawing area.
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Adjust Grid Visibility and Color

1. In the Display area, choose Major, Minor, or both.

2. Choose the Type of display (Dots or Lines). You may have to zoom in to see the
grid display.

3. Click the colored rectangle next to the word Color, and choose the desired color
for the grid. Click OK to dismiss the color palette.

4. Click Apply . Experiment with different settings

Note The drawing area color is the Background color under the Display  tab.

Adjust Snap and Grid Spacing

The ability to display a major grid as an increment of the minor grid enables you to
gauge distances and align objects better in a layout.

1. In the Spacing area, change the Minor Grid display factors for both X and Y.
The larger the number, the wider the grid spacing.

2. Click Apply . Experiment with different settings. If a display factor makes the
grid too dense to display, it is invisible unless you zoom in.

3. Now experiment with the Major Grid.

Adjust Pin/Vertex Snap Distance

Pin/vertex snap distance represents how close the cursor must be to a pin of a
component or a vertex of a shape before the cursor will snap to it.

A large value makes it easier to place an object on a snap point when you are unsure
of the exact location of the snap point. A small value makes it easier to select a given
snap point that has several other snap points very near it.

Place several components and several shapes in the drawing area and experiment
with different settings of Pin/Vertex Snap.

Screen pix specifies sizes in terms of pixels on the screen. For example, if you
choose 15, the diameter of the snap region is 15 pixels.

User Units specifies sizes in terms of the current units of the window. For example,
if you are using inches and choose 0.1 user units, the diameter of the snap region is
0.1 inch.
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Experiment with Snap Modes

Snap modes control where the program places objects on the page when you insert or
move them; you can change snap modes when inserting or moving a component, or
drawing a shape. When snap is enabled, items are pulled to the snap grid.

Experiment with different snap modes turned on or off to see how they affect the
placement of items in a Layout window.

Angle Snapping automatically occurs when only Pin snapping is enabled and you
place a part so that the pin at the cursor connects to an existing part. The placed part
rotates so that it properly aligns with the connected part.

For example, if you have a microstrip curve at 30° and place a microstrip line so that
it connects to it, the microstrip line will snap to 30° so that it properly abuts the
curve.

Enable Snap  toggles snap mode on and off. You can also toggle snap mode from the
Options menu itself, and there are snap mode buttons on the toolbar.

Except for pin snap, the pointer defines the selected point on the inserted object.

Snap Mode Priority

You can restrict or enhance the manner in which
the cursor snaps by choosing any combination of
snap modes. This table lists the snap modes, and
their priorities.

Pin 1

Vertex

2
Midpoint

Intersect

Arc/Circle Center

Edge 3

Grid 4
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When you set all snap modes OFF, you can insert objects exactly where you release
them on the page. This is sometimes called raw snap mode. Like other snap modes,
the raw snap mode also applies when you move or stretch objects.

Pin When a pin on an object you insert, move, or stretch is within the snap distance
of a pin on an existing object, the program inserts the object with its pin connected to
the pin of the existing object. Pin snapping takes priority over all other snapping
modes.

Vertex When the selected location on an object you insert, move, or stretch is within
the snap distance of a vertex on an existing object, the program inserts that object
with its selected location on the vertex of the existing object.

In vertex snap mode, a vertex is a control point or boundary corner on a primitive, or
an intersection of construction lines.

Midpoint When the selected location on an object you insert, move, or stretch is
within the snap distance of the midpoint of an existing object, the program inserts
that object with its selected location on the midpoint of the existing object.

Intersect When the selected location on an object you insert, move, or stretch is
within the snap distance of the intersection of the edges of two existing objects, the
program inserts that object with its selected location on the intersection of the
existing objects.

Arc/Circle Center When the selected location on an object you insert, move, or stretch
is within the snap distance of the center of an existing arc or circle, the program
inserts that object with its selected location on the midpoint of the existing arc or
circle.

Edge When the selected location on an object you insert, move, or stretch is within
the snap distance of the edge of an existing object, the program inserts that object
with its selected location on the edge of the existing object. Once a point snaps to an
edge, it is captured by that edge, and will slide along the edge unless you move the
pointer out of the snap distance.

Because edge snapping has priority 3, if the cursor comes within snap distance of
anything with priority 1 or 2 while sliding along an edge, it will snap the selected
location to the priority 1 or 2 item.

Grid When the selected location on an object you insert, move, or stretch is within
the snap distance of a grid point, the program inserts that object with its selected
location on the grid point.

All other snap modes have priority over grid snap mode.
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Tip Whenever possible, keep grid snapping on. Once an object is off the grid, it is
difficult to get it back on.

Use 45 or 90° angles to ensure that objects are aligned evenly, and to reduce the
probability of small layout gaps due to round-off errors.

Designing a Microstrip Line
This chapter is made up of an exercise that takes you through the process of creating
a schematic, converting to a planar (Layout) format, preparing the layout for
simulation, simulating, and generating analysis plots.

This exercise uses many default settings and a simple circuit (a microstrip line with
step in width), and illustrates how quickly a design and analysis can be
accomplished.

In this exercise, you will:

• Draw a simple microstrip line with step in width as a schematic, then generate
a corresponding layout

• Create a simple substrate

• Define a mesh

• Perform a simulation

• Examine the results

Terms such as substrates and meshes may be unfamiliar, so they are explained in the
course of the exercise.

This and later exercises assume that you have an introductory working knowledge of
Advanced Design System, such as understanding the concept of projects, and being
familiar with Schematic and Layout windows and placing components.

Drawing the Circuit

The basic steps to making the microstrip line with step in width circuit include:

• Creating a new project
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• Adding microstrip components to the schematic

• Converting the schematic to a layout

The schematic and layout representations are shown here. The sections that follow
describe how to create both.

Creating a New Project

You should start this exercise in a new project.

1. From the Main window, choose Options > Preferences . Ensure that Create Initial
Schematic Window  is enabled. Click OK.

2. From the Main window, choose File > New Project . The New Project dialog box
appears.

3. In the Name field, type step1 .

4. Click OK.

A Schematic window appears, which is where you will enter the design.

Adding Microstrip Components to the Schematic

The steps in this section describe how to select a component. In the next section, it
will be placed in the Schematic window.
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Refer to the this figure to select the microstrip line component from the Microstrip
Transmission Lines palette:

2 Click TLines-Microstrip. The

3 Click the MLIN button. This selects

1 Click Palette List arrow once.
The Palette List drops down.

palette list closes and the
Microstrip Component palette
is displayed.

the Libra Microstrip Line component.
Crosshairs and a ghost icon of the
component appear as you move the
cursor over the design window.
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Placing the Components

The steps in this section describe how to place two microstrip lines in the Schematic
window.

1. Move the crosshairs to the Schematic window and click once to place the
component. A schematic representation of the component is placed in the
Schematic window.

2. Move the cursor so that the crosshairs are directly over the right pin of the first
component, and then click once to place a second component.

Cancelling Commands

If you continue to click without ending the current command, you will add another
component with each click.

1. Click the arrow button . The crosshairs disappear.

2. You can also end a command by pressing the Esc  key.

You will use the end command frequently in this and other exercises, so be sure
you are familiar with it.

Click here to place a component

Position cursor here
and click to add another
component
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Editing Component Parameters

Below the schematic representation of each component are some of the editable
parameters of the component. This section describes how to change the width of one
of the strips. The result is a microstrip step in width transmission line.

1. Click twice on the second component that you placed. The Libra Microstrip Line
dialog box opens.

2. In the Select Parameter field, select the W (width) parameter. When the field to
the right shows the value of the width, change the value in this field to 35 mil.
Click Apply.

3. Click OK to dismiss the dialog box.

Note If a parameter for a component is displayed in the Schematic window,
you can also edit that parameter by clicking on the value and entering a new
value.

4. Verify that the width of component on the left is set to 25 mil, and if needed,
change the value of this parameter.
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Adding Ports to the Circuit

To complete the circuit, you must add ports, one at the beginning of the microstrip
step in width and one at the end. For Momentum, ports identify where energy enters
and exits a circuit. This section describes how to add ports.

1. In the menu bar, click the Port button. Move the cursor over the Schematic
window and note the orientation of the ghost icon of the port. The ports
should be positioned as shown in the schematic below at the end of these steps.

2. You may need to rotate the port to the necessary orientation. If so, click
the Rotate button and move the cursor back into the Schematic window.
Note the rotation of the port outline, and repeat until it is correct.

3. Move the cursor over the open pin on the left side of the left component, then
click.

4. The command to insert a port remains active. To insert a second port, change
the orientation appropriately, move the cursor over the open pin on the right
side of the right component, then click.

5. End the current command. Your schematic should now look like this figure. It is
a microstrip line step in width. The width of the first part of the line is 25 mil,
and it increases to a width of 35 mil. The overall length is 200 mil.

Note  All of the components are connected. Diamond-shaped pins indicate that
pins are not connected, and you will need to select and move components to
make complete connections.
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Saving the Design

It is good practice to save your work periodically. This section describes how to save
the schematic.

1. Choose File  > Save. When the Save dialog box appears, enter the name of the
project, in this case, type step1 .

2. Click OK.

Generating the Layout

A powerful feature of Advanced Design System is the ability to convert a schematic to
a layout automatically. Since Momentum requires a circuit be in Layout format, this
gives you the option of drawing your circuits either as schematics or as layouts. Note
that if you do choose to draw in a Schematic window, footprints of the components you
use must also be available in Layout. Components that are available in Layout
include transmission lines and lumped components with artwork.

This section describes how to covert the microstrip line step in width schematic that
you just finished to a layout.

1. In the Schematic window, choose Layout > Generate/Update Layout . The
Generate/Update Layout dialog box appears. It is not necessary to edit fields.

2. Click OK.

3. A Status of Layout Generation message appears indicating that the conversion
is complete

4. Click OK.

5. A Layout window appears, showing a layout representation of the schematic.
This window may be hidden by the Schematic window, so you may need to move
some windows to locate the Layout window.

6. From the Layout window, choose File > Save. Name the layout step1 . You now
have a layout and a schematic as part of your project.
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Creating a Simple Substrate

A substrate is required as part of your planar circuit. The substrate describes the
media where the circuit exists. An example of a substrate is the substrate of a
multilayer circuit board, which consists of:

• Layers of metal traces

• Layers of insulating material between the traces

• Ground planes

• Vias that connect traces on different layers

• The air that surrounds the circuit board

 Momentum includes predefined substrates that you can add to a layout, or you can
make your own. Complete details about substrates, including where substrates are
saved, are in Chapter 3, Substrates.

The steps in this section describe how to define a substrate.

For the microstrip line step in width example, a substrate with the following layers
will be used:

• A ground plane

• A layer of insulation, such as Alumina

• A metal layer for the microstrip

• An air layer above the microstrip
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1. From the Layout window, chose Momentum > Substrate > Create/Modify . The
Create/Modify dialog box opens, showing the Substrate Layers options and
parameters.

2. In the Substrate Layers field, select FreeSpace. Move to the Substrate Layer
Name field and change it to read Air. Leave all other parameters at their
default values and click Apply .

3. Keep the default layers Alumina and ///GND///, but highlight and Cut  any
other layers that may be showing. Click Apply .

You currently see three of the four substrate layers that you need. The fourth
(metal) layer can be found by clicking the Metallization Layers  tab.
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The metal layer is automatically positioned between the layers of Alumina and
air. The microstrip line is assumed to be on this layer.

4. Click OK to dismiss the dialog box.

5. To save the substrate with the project, choose Momentum > Substrate > Save As .
Type step1  in the Selection field and click OK. The substrate step1.slm is saved
in the project networks folder.

Some other information about saving substrates:

• A substrate definition is automatically saved with the design when
File > Save is invoked from the Layout window

• The command Substrate > Save As  enables you to save the substrate
definition in
slm that can be saved anywhere and used with another design

• When a design is opened, the substrate definition that was saved with the
design is automatically loaded
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Precomputing the Substrate

In order to perform a simulation, Green’s functions that characterize the behavior of
the substrate must be computed. Substrates that are supplied with Momentum
already include the computations. If you are:

• Reusing a substrate

• Have previously computed Green’s functions for the substrate

• Created a substrate that is identical to one that already exists

the attempt to perform the computations will be ignored, since the calculations are
saved in a database. In these cases, only if you extend the computation frequency
range will additional calculations be performed.

The steps in this section describe how to precompute the substrate. Note that for this
example, computations will not be performed. The substrate that was defined in the
previous example is, in fact, identical to one that is supplied with Momentum.

1. Choose Momentum  > Substrate  > Precompute Substrate Functions . Set the
Minimum Frequency to 1 GHz and Maximum Frequency to 4 GHz. This is the
range that the simulation will cover. You should check that computations exist
for the entire range that you intend to simulate, but if you do not, an error will
be displayed if you need to run any computations.

2. Click OK.

• If a dialog box opens to ask if you want to compute the substrate, click Yes.
Calculations will be performed.

• If a dialog box informs you that substrate calculations exist, click OK. The
calculations will not be recomputed.

A status window also opens. You can leave this status window on the screen as
you proceed with this exercise.

Note The preceding applies to Momentum microwave mode only. In Momemtum RF
mode the substrate is precomputed for all frequencies and it is not necessary to set a
mimimum and maximum frequency.
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Setting up Mesh Parameters

A mesh is required in order to perform a simulation. The simplest method for
generating a mesh is to skip the Mesh menu entirely and let Momentum
automatically generate the mesh for your circuit, but you can choose to edit
parameters that control how the mesh is generated.

A mesh is a grid-like pattern of triangles and rectangles that is applied the surfaces
of a circuit. Using the mesh, the current within each triangular or rectangular area is
calculated, and any coupling effects in the circuit can also be calculated during the
simulation. From these calculations, S-parameters are then calculated for the circuit.

Complete details about mesh definitions and generation are in Chapter 7, Mesh.

The steps in this section describe how to set the frequency range for mesh
computations. All other options will remain at the default values.

1. In the Layout window, select Momentum > Mesh > Setup Controls . A
Create/Modify dialog box appears.

2. Set the value in the Mesh Frequency field to 4 GHz and click OK.

All that is required is the
mesh frequency.
Momentum uses defaults
to generate a valid mesh for
the circuit.
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Precomputing the Mesh

If you want to view the mesh before simulation, you can precompute the mesh. The
mesh will not be precomputed for this exercise.

This completes the process for generating a mesh.

Performing the Simulation

The Momentum simulation process combines the Green’s functions that were
calculated for the substrate, plus the mesh information, and solves for currents in the
circuit. Using the current calculations, S-parameters are then calculated for the
circuit.

There are a variety of options to select to set up a simulation. Details are in Chapter
8, Simulation. This section describes the minimal steps for running a simulation.

1. From the Layout window, choose Momentum > Simulation > Simulate Circuit . The
Simulation Control dialog box appears.

2. Set the Sweep Type to Linear and confirm that the following parameters are
set:

• Start = 1 GHz

• Stop = 4 GHz

• Frequency Step = 1 GHz

By choosing this sweep type, a linear simulation will be performed over the 1-4
GHz frequency range, selecting the frequency points to be simulated based on
the step size.
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3. Click Add to Frequency Plan List. The dialog box should resemble the figure
here.

4. Ensure that the field Open data display when simulation completes is enabled.

5. Click Simulate . The simulation will be performed. The simulation progress and
its completion will be indicated in the Simulation Status window.

6. When the simulation is complete:

• The layout is overlaid with the mesh that was generated and used during the
simulation process.

• The S-parameter simulation results are automatically displayed on both
rectangular plots and Smith charts in a Data Display window. This is
because the field Open data display when simulation is complete was enabled
as a default in the simulation setup. Choose View > View All  or click the View
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rostrip
 how
All button to view all of the plots, then zoom in on individual plots. An
example of one S-parameter result is illustrated here.

This completes the first Momentum design exercise.

Designing a Microstrip Filter
This section is made up of an exercise that takes you through the process of designing a mic
coupled-line filter. It is similar to the previous exercise, but uses fewer defaults and explores
to:

• Create a more complex substrate

• Specify port properties

• Use a box to simulate the filter within a metal enclosure

• Specify mesh parameters

Drawing the Circuit

This section is very similar to the drawing instructions in the previous exercise. The
circuit is drawn as a schematic, then converted to a layout. If you need more
information on how to perform certain steps, refer to the previous exercise.

Opening a New Project

Like the previous exercise, start the filter design in a new project.

1. From the Main window, choose File > New Project .
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width,
2. Name the project filter.

3. Click Length Unit . Select millimeter to set the layout units for this circuit. Click
OK to set the units.

4. Click OK in the New Project dialog box to create the new project.

Adding Components to the Schematic

The steps in this section describe how to select microstrip filter components.

1. In the Schematic window, click the Palette List arrow. The Palette List drops
down.

2. Scroll and select T-lines Microstrip from the Palette List.

3. In the component palette, locate and click Mcfil . This selects the Libra
Microstrip Coupled-Line Filter Section component.

4. Crosshairs and a ghost icon of the component appear as you move the cursor
over the Schematic window. Position the cursor and click.

5. End the command either by clicking the Cancel Command button or by choosing
Insert or the arrow button.

Editing the Component

This section describes how to edit several component parameters, such as the length and 
and also how to change the parameters that are displayed below the component.

1. To edit the component parameters, double click the component.

2. In the dialog box that appears, select one of the parameters listed below, and
edit the value. Also, enable Display parameter on schematic so that the
parameter will be displayed below the component in the Schematic window.
Select another parameter, and continue to set the values for these parameters:

• W = line width = 0.25 mm

• S = spacing between lines = 0.044 mm

• L = line length = 1.8 mm

• W1 = width of the line that connects to pin 1 = 0.25 mm

• W2 = width of the line that connects to pin 2 = 0.25 mm

3. Click OK to accept the edits and dismiss the dialog box.
2-28 Designing a Microstrip Filter



Copying and Placing another Component

This section describes how to make a copy of the filter section and add it to the
schematic.

1. From the Schematic window, choose Edit  > Copy/Paste  > Copy.

2. Click the filter section component that is on the schematic. A black outline
appears around it.

3. Move the crosshairs so that they are directly over the left connector of the first
component and click.

4. End the current command.

Adding Ports

Ports are required on a circuit. If you forget to add ports to the schematic, you can
always add them later after the schematic is converted to a layout. In this exercise,
ports will be added to the layout.

With Momentum, you can define additional characteristics to a port. This also will be
performed later in this exercise.

Your schematic should now look like the figure here. Be sure that all components are
connected correctly.
Designing a Microstrip Filter 2-29



Getting Started with Momentum
Saving the Design

It is good practice to save your work periodically.

1. Choose File  > Save.

2. Enter filter  as the file name.

3. Click OK.

Generating the Layout

This section describes how to covert the microstrip coupled-line filter schematic that
you just finished to a layout.

1. From the Schematic window, choose Layout > Generate/Update Layout . The
Generate/Update Layout dialog box and a Layout window appear.

2. From the Layout window, choose Options > Preferences . Click the Layout Units
tab and set the Resolution to 0.001. Click OK.

3. In the Generate/Update Layout dialog box, enter -1.8 in the X field and 0.294 in
the Y field. This step identifies the placement of P1 on the layout. This step is
usually optional, but specifying the location will be helpful later when the box is
added to enclose the filter. Click OK.

4. A window displaying the results of the conversion is displayed. Click OK.

A layout representation of the schematic appears in the Layout window. It should
resemble the figure here.

5. From the layout window, choose File > Save. Name the layout filter . You now
have a layout and a schematic as part of your project.
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Defining a Substrate

This circuit uses a relatively simple substrate. In this exercise, the thickness of some
of the layers is modified. A more important task is that ground planes are added to
the top and bottom of the substrate. These ground planes form the top and bottom of
the metal box in which the filter will be enclosed. The substrate will have the
following layers:

• A ground plane representing the top of the box

• A layer of air

• The microstrip filter traces

• A layer of alumina

• A ground plane representing the bottom of the box.

1. From the Layout window, chose Momentum > Substrate > Create/Modify .

2. Select the top layer in the Substrate Layers field. In the Boundary list, select
Closed. The top ground plane is added to the substrate.

3. In the Substrate Layers list, select Free_Space. Change the Thickness to 2846
um . This sets the layer of air to an appropriate thickness.
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4. In the Substrate Layers list, select Alumina. Change the Thickness to 254 um .

5. Keep the bottom ground plane, but select and Cut  any other layers that may
appear in the substrate.

6. Click Apply.

Note The top and bottom of the box enclosure are defined with groundplanes,
the sides of the enclosure will be defined later in this exercise.

You currently see four of the five substrate layers that you need. The metal
layer for the microstrip filter can be found by clicking the Metallization Layers
tab.

In this instance, the metal layer is automatically positioned between the
Alumina and air.

Note the following points about this layer:

• Metal layers are identified by a dashed line.

metal layer
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• The word cond identifies the layout layer that is mapped to this position.
Refer to the Layout window, and you will see that the microstrip circuit was
automatically applied to the layout layer named cond during the translation
process.

• The word strip defines the layer such that the microstrips are metal and
what surrounds the microstrips on that layer is air or dielectric. Other
choices are slot and via. These are described in the exercise in the next
chapter.

7. Choose Momentum  > Substrate  > Save As . Use the file name filter  and click OK.
The substrate file filter.slm is saved as part of the project.

8. Choose Momentum > Substrate > Precompute Substrate Functions . Set Minimum
Frequency to 1 GHz and Maximum Frequency to 40 GHz. Click OK. If a dialog
box appears and asks if you want to compute the substrate, click Yes.

There are instances when the computations will not be performed. This was
discussed in the previous exercise. If they are performed, a window opens that
indicates the status of the computations and when they are complete.

You can choose Momentum  > Substrate  > View Substrate Summary at any time
and see a summary of the substrate calculations that have been completed.

Adding Ports to the Layout

In Momentum, you can define the ports in your circuit to be one of several types.
Depending on the type you choose, the ports will be characterized in different ways.
This can impact the result of a simulation, because the simulation can take these
characteristics into account. With different port types, you can select one that best
matches the intended application of your layout.

More detailed information about the various port types can be found in Chapter 4,
Ports.

Ports are defined in a two-step process. First, ports are added to a circuit when the
circuit is drawn. Then, in Momentum, you specify the port type in order to tailor the
port to your circuit. Note that you can add the port components at any time as you
draw the circuit, but before a port type can be specified, a substrate must be defined
for the circuit.

This section describes how to add ports to a layout and how to specify a port type for
them.
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1. From the Layout window, click the port icon. A Port dialog box appears. If
necessary, set layer  = cond . The ports must be on the same layout layer as the
microstrip filter. Click OK.

2. Move the cursor over the open port on the left side of the layout and click. Move
the cursor over the open port on the right side of the layout and click. End the
command. The layout should resemble the figure here.

3. From the Layout window, choose Momentum > Port Editor . The Port Properties
Editor dialog box.

4. If necessary, drag the dialog box away from the Layout window so that both
ports are visible. Click the connector P1.
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5. The Port Properties dialog box will change so that you can select a port type to
be applied to P1.

6. Select Internal from the Port Type drop down list and click Apply .

7. Click the connector P2. Select Internal from the Port Type drop down list. Click
OK to accept the port type and dismiss the dialog box.

The internal port type is selected because it can be applied to the interior of a
circuit. While normally this placement of the ports on the filter would not be
considered internal, they are in this case because the filter is enclosed within
the box. More information on this and other port types is in Chapter 4, Ports.

Finishing the Box around the Filter

Boxes and waveguide enclosures are useful because they introduce horizontal
boundaries to the design. Adding a box enables you to look at box resonance, which
can have a significant effect on S-parameters in a small band centered around the box
resonance frequency. More information about boxes, waveguides, and their uses are
in Chapter 5, Boxes and Waveguides.
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Recall that when you defined the substrate, you defined ground planes as the top and
bottom of the metal box that will enclose the filter. This section describes how to
specify the dimensions and location of the sidewalls of the box.

1. From the Layout window, choose Momentum > Box & Waveguide > Add Box .

2. You will enter specific x, y coordinates for the left and right sides of the box.
Choose Insert > Coordinate Entry . Type -4.5, -4.5 in the X,Y fields of the
Coordinate Entry dialog box and click Apply .

3. Type +4.5, +4.5 in the X,Y fields of the Coordinate Entry dialog box and click
Apply . The box appears as shown below (you may need to click View All to see the
box). Click Cancel  to close the dialog box.

Generating a Mesh

This section describes how to specify additional mesh parameters.

1. From the Layout window, choose Momentum > Mesh > Setup Controls .

2. Set the following options and values:

• Mesh Frequency = 40.0 GHz. You should set the mesh frequency to the
highest frequency to be simulated.
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• Number of Cells per Wavelength = 20. This will be used to determine the
density of the mesh. A mesh needs to be made up of small cells, but a mesh
that is too dense over the entire circuit slows a simulation without adding
much accuracy to results.

• Edge Mesh is enabled, and Edge Width = 0.05 mm. The edge mesh adds a
relatively dense mesh along the edges of objects. Since most current flows
along the edges of objects, using a denser mesh only on the edges can improve
the speed and accuracy of a simulation.

Leave the other settings as they appear.

3. When these selections are completed, click OK.

4. Choose Momentum > Mesh > Precompute Mesh . The mesh will be computed and
displayed on the layout, like the figure here. If you have trouble seeing the
mesh, choose Options > Layers  and reset the color and pattern values for the
cond  layer.

5. Save your work by choosing File > Save  from both the Layout window and the
Schematic window. Use the file name filter for both of them; Advanced Design
System can distinguish the layout from the schematic and will not overwrite
one with the other.

Performing the Simulation

This section describes how to set up and run the simulation. In this exercise, the
adaptive sweep type is used in the simulation process. This the preferred sweep type,
because it used a fast, highly accurate method of comparing simulated data points to
a rational fitting model. Unlike the linear sweep type, where simulated data points
are chosen in a linear fashion based on step size, adaptive sweep type data points are
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chosen based on where the most variance seen. Wherever S-parameters vary from
the rational fitting model the most, more samples are taken.

1. From the Layout window, choose Momentum > Simulation > Simulate Circuit .

2. Select the Adaptive  Sweep Type and set these parameters to the following
values:

• Start = 1 GHz

• Stop = 40 GHz

• Sample Points Limit = 50

3. Click Add to Frequency Plan List .

4. Make sure that Open data display when simulation completes is enabled The
S-parameters will automatically be plotted and displayed at the end of the
simulation.

5. Click Simulate . The simulation will be performed and its progress and
completion will be indicated in the status window.

6. Click Momentum > Simulation > View Summary and saved simulation details will
be displayed. You can print the report if you wish.
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Viewing Simulation Results

The S-parameter simulation results are automatically displayed on both rectangular
plots and Smith charts in a Data Display window. An example of S12 plotted on a
rectangular plot is shown here.

Designing a Coplanar Waveguide Bend
This exercise, like the previous exercises, takes you through all of the steps that are
necessary when designing with Momentum: creating a layout, defining a substrate,
adding ports to the circuit, defining a mesh, simulating, and viewing results. Unlike
the previous exercises, this one explores the following design topics:

• Creating a layout that is drawn on more than one layer

• Using vias as connections between layers

• Specifying new port types

• Working with new mesh parameters
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This circuit drawn in this exercise is a coplanar waveguide bend. A coplanar
waveguide is, generally, slots filled with a dielectric or air, surrounded by metal, as
shown in the figure here.

There are two basic methods for constructing coplanar waveguides in Layout, one is
used in this exercise, the other is discussed in Chapter 5, Boxes and Waveguides.

Creating the Layout

In this example, the circuit is created entirely within the Layout window, and a
schematic representation is not used. Be sure to save your work periodically.

The layout consists:

• Coplanar waveguide slots

• Bridges that span the two slots

• Vias that vertically connect the bridges to the slots

The slots will be drawn on one layer, the bridges will be drawn on a second layer, and
the vias on a third layer. This will be important for when these layers are mapped to
the substrate. An illustration of the circuit is shown on the left, the layout is on the
right.

slots

metal ground plane

slots

bridge

bridge
vias
2-40 Designing a Coplanar Waveguide Bend



1. From the Main window, choose File > New Project . Name the project cpw_bend .
Click Length Unit , and set the units to millimeter . Click OK.

2. Set your preferences so that a Layout window will open instead of a Schematic
window. From the Main window, choose Options > Preferences and enable Create
Initial Layout Window. Disable Create Initial Schematic Window.

3. Click OK in the open dialog boxes.

4. From the Layout window, choose Options  > Preferences . Scroll to the Layout
Units  tab. Set the layout units to um  and the resolution to 0.001. Click OK.

5. There is a difference between the length units that you chose when you created
the new project, and the units that you just set. The units chosen when you
created the project set the units of the layout window in which you are working.
The units chosen through Options > Preferences sets the units for objects that
are drawn in the Layout window.

6. You will rename the layout layers that are used for drawing the slots, bridges,
and vias of the coplanar waveguide bend. Using more descriptive names can
help identify which layer that each part of the circuit is drawn on. Choose
Options > Layers . From the Layers list, select cond . In the Name and Layer
Binding List fields, enter slot . Click Update  (located just below the Layers list).
Select cond2 . In the Name and Layer Binding List fields, enter bridge . Click
Update . Select hole . In the Name field only, enter via  and click Update . Click OK.

Drawing the Waveguide Slots

The section describes how to draw the coplanar waveguide slots.

1. Verify that slot is the current layer. The slots will be drawn on this layer. The
name of the current layer is displayed in the tool bar and at the bottom of the
Layout window. If slot is not displayed, select it from the list.

select a layer

current layer and its color
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2. Choose Insert > Coordinate Entry , then choose Insert > Rectangle . The toolbar
arrow is activated and the Coordinate Entry dialog box opens.

3. You will define four rectangles to make two waveguide bends. Establish the
following values in the X,Y coordinate window, and click Apply  after each entry:

4. Click View All  to see your drawing.

5. End the command. The drawing in the layout window should resemble the
figure here.

Drawing the Bridges

The slots that make up the coplanar waveguide have been drawn on one layer. On a
different layer, you will draw the bridges that span the two slots. This is important,
because the slots and bridges will be treated differently in Momentum. This will
become more clear when the substrate is applied to the circuit, later in this exercise.

X, Y coordinates Define

0, 0 First corner of first rectangle

+45, +290 Second corner of first rectangle

0, +335 First corner of second rectangle

+335, +290 Second corner of second rectangle

+110, 0 First corner of third rectangle

+155, +180 Second corner of third rectangle

+110, +180 First corner of fourth rectangle

+335, +225 Second corner of fourth rectangle
2-42 Designing a Coplanar Waveguide Bend



1. From the layer list on the toolbar, select the layer bridge and click OK.

Note The slot layer is still visible. You will not do so here, but it can be made
invisible if you go to the Layout window and choose Options > Layers , select the
slot layer, and turn Visible off.

2. Choose Insert  > Rectangle .

3. You will define two rectangles that make the bridges. Establish the following
values in the X,Y coordinate window, and click Apply  after each entry:

4. End the current command. The drawing in the Layout window should now look
like the figure here.

Drawing a Via

The vias must be drawn on a third layer. This is necessary for when the vias are
mapped to the substrate, later in this exercise.

X, Y coordinates Define

0, +170 First corner of first bridge

+155, +180 Second corner of first bridge

+155, +180 First corner of second bridge

+165, +335 Second corner of second bridge
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The position and size of a via is very important. The various snap modes in Layout
can aid in drawing vias, as shown in this part of the exercise. More information on
how to draw vias and other drawing tips are in Chapter B, Drawing Tips.

1. From the layout layer list on the toolbar, select via.

2. Choose Options > Preferences . Scroll to and select Grid/Snap . Under Active Snap
Modes, enable Vertex  and clear Grid . Click OK.

By using the vertex snap mode, the vias that you draw will snap to the vertex of
a nearby object (a bridge) and not to a grid point. This ensures that the vias will
be positioned precisely on the edges of the rectangles.

3. Choose Insert > Polyline . Referring to the points identified on the drawing below,
create the line segments shown by performing these steps:

• Click once on A1 and click twice on A2.

• Click once on B1 and click twice on B2.

• Click once on C1, click once on C2, and click twice on C3. Then click the
toolbar arrow. The drawing in the Layout window should now appear as
shown below.

A1

A2

B1 B2

C1
C2

C3
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Opening a Substrate

This exercise uses a substrate that is supplied with Momentum. It will not be
necessary to make any changes to it, but it will be reviewed to clarify how layout
layers can be mapped to a substrate.

1. From the Layout window, choose Momentum  > Substrate > Open . To the
question, Open a supplied substrate?, click Yes.

2. Locate and select the substrate file cpw_bend_example.slm, then click OK. You
are notified that the substrate has been opened. Click OK.

3. Choose Momentum  > Substrate > Create/Modify. Select the Metallization Layers
tab.

The metallization layers are identified by dashed lines, except in the case of
vias. For the used metallization layers, you see the type of layer (Strip, Via, or
Slot) and the name of the layout layer that is mapped to it (bridge, via, and
slot). You can see how the metallization/layout layers are mapped in between
the Free_Space, air, and GaAs layers:

• There is a small layer of air between the bridges and the slots.
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• The vias are mapped the directly to the air substrate layer. The vias,
although they are drawn as lines, are extruded by Momentum and effectively
cut vertically through this layer of air, connecting the edges of the slots and
the bridges.

• All three types of metallization layers, strip, slot, and via, are used here. A
strip defines the layer such that the bridges are metal and what surrounds
the microstrips on that layer is air. A slot is the opposite of a strip: the layout
layer would be treated as a ground plane, and the bends that you have drawn
are treated as open areas in the ground plane. Vias represent vertical
sections that cut through other layers vertically.

Adding Ports

This section describes how to add ports to the layout and how to apply the coplanar
port type to them.

Coplanar is one of the several port types that are available in Momentum. It is
designed specifically for coplanar waveguide circuits, where an electric field is likely
to build up between two ports. Each of the two ports is excited with the same absolute
electrical field, but with opposite polarity. The currents are equal but in opposite in
direction. For more information, refer to Chapter 4, Ports.

1. The ports must be added to the waveguide slots and so they must be drawn on
the same layer as the slots. From the Layout Layers list box, select slot .

2. The ports must also be positioned in the center of each slot edge. To help
position the ports, set the following snap modes:

• Enable Options  > Midpoint Snap

• Enable Options > Edge Snap

• Disable Options > Vertex Snap  and other enabled snap modes (but make sure
that Options > Enable Snap  remains enabled)

3. Click the Port icon. The Port dialog box appears.

4. Verify that layer=cond  is displayed in the Select Parameter field. If it is not, set
layer to cond . Verify that Num=1 . If it is not, select Num and set it to 1. Click OK.

5. Note the ghost image of the port. If it appears very large, or if it cannot be seen,
cancel the command. Depending on your system defaults, you may need to
change the value of the Port/Ground Size (Options  > Preferences  > Placement )
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and the value of the Font Definition Size (Options  > Preferences  > Component
Text) before your ports and labels will be an appropriate size for this layout.

6. When you are ready to add ports, apply them in the order and direction as
shown here, then end the port command.

7. From the Layout window, chose Momentum > Port Editor . The Port Properties
Editor dialog box appears. You may need to drag the box away from the layout
in order to have access to the ports on the layout.

8. In the Layout window, click P1. In the Port Editor, select Coplanar from the Port
Type list. Set the Polarity to Normal . Do not change any other values. Click
Apply .

9. Click P2. Select Coplanar  and set the Polarity to Reversed . Type 1 in the field
Associate with port number. Click Apply .

10. Click P3. Select Coplanar  and set Polarity to Normal . Click Apply .

11. Click P4. Select Coplanar  and set Polarity to Reverse . Type 3 in the field
Associate with port number. Click Apply .

12. Click OK.
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Generating the Mesh

This section describes how to use additional mesh parameters. Because this circuit is
on multiple layers, it is possible to set mesh parameters for each layer. Thus, you can
set a relatively dense mesh on a specific layer. In this example, you will apply an edge
mesh to the slot and via layers, but you will not use an edge mesh on the bridge layer.

1. From the Layout window, choose Momentum > Mesh > Setup Controls .

2. Set the following Global parameters:

• Mesh Frequency = 40 GHz

• Number of Cells per Wavelength = 100

• Enable Edge Mesh

Global parameters will be applied to all layers, unless other values are specified
from the Layer  tab.

3. Select the Layer  tab.

4. In the Layout Layers list, select bridge . Set the Number of Cells per Wavelength
to 100 and disable Edge Mesh. These mesh parameters will be applied to the
objects drawn on the bridge layer only.

5. Click OK.
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6. Select Momentum > Mesh > Precompute Mesh . Click OK to start the
computations. The mesh will be computed and displayed on the layout, as
shown here. Zoom in for a closer look at the mesh.

7. Zoom in on the ports. You can see that additional arrows have been added to
each port. The new arrow indicate the direction of the voltage over the slot.

Performing a Simulation

1. From the Layout window, choose Momentum > Simulation > Simulate Circuit .

2. From the Sweep Type list, select Adaptive  and set these parameters:

• Start = 1 GHz

• Stop = 40 GHz

• Sample Points Limit = 50

3. Click Add to Frequency Plan List.

4. Make sure that Open data display when simulation completes is enabled.

5. Click Simulate .
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Viewing Simulation Results

The figure shows some of the automatically plotted simulation results.

To save your work, choose Yes to All  when you are asked to save your work when you
close the project.

This concludes the third exercise.
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Chapter 3: Substrates
A substrate definition describes the media where a circuit exists. An example is the
substrate of a multilayer circuit board which consists of layers of metal traces,
insulating material, ground planes, vias that connect traces, and the air that
surrounds the board. A substrate definition enables you to specify properties such as
the number of layers in the substrate, the dielectric constant, and the height of each
layer for your circuit.

A substrate definition is made up of substrate layers and metallization layers.
Substrate layers define the dielectric media, ground planes, covers, air or other
layered material. Metallization layers are the conductive layers in between the
substrate layers, and they are used in conjunction with the layout layers. By mapping
layout layers to metallization layers, you can position the layout layers that your
circuit is drawn on within the substrate. An example of a substrate is shown below. It
contains four substrate layers and two microstrips with a via.

Substrate definitions can be saved and used with other circuits. A variety of
predefined substrates are included with Advanced Design System, which can be used
“as is” or modified to your design specifications.

Free_Space
top layer = open (air)

Layout layer
(strip in between
Alumina_0 and
Free_Space)

Substrate Layers:

Alumina_0
(dielectric)

Alumina
(dielectric)

////// GND //////
Layout layer (via through
Alumina_0)

Layout layer
(strip in between
Alumina and
Alumina_0)
3-1



Substrates
The steps for defining a substrate include:

• Defining the substrate layers

• Mapping the layout layers to metallization layers

• Specifying metallization layer conductivity

• Solving the substrate

Details on how to work with existing substrate definitions and create new ones follow.

Selecting a Predefined Substrate
Momentum includes a number of predefined substrate definitions, so it may not be
necessary to create a substrate from scratch. A predefined substrate may be suitable
so that it can be used it as is or modified to suit your design. Substrate files end with
the extension .slm.

To open a predefined substrate:

1. In the layout window, select Momentum > Substrate > Open.

2. If you want to open a supplied substrate, click Yes. A list of supplied substrate
files appears.

If you want to open a substrate that has been saved as part of the project, click
No. A list of substrate files that are saved as part of the project appear.

For more information on locating substrate files, refer to “Identifying Where
Substrates are Saved” on page 3-4.

3. Select the substrate file, then click OK.

To edit the substrate, refer to “Defining Substrate Layers” on page 3-5.
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Reading a Substrate Definition from a Schematic
Choose Momentum > Substrate > Update From Schematic to update a substrate
under the following conditions:

• You have used a substrate component on a schematic, such as MSUB or SSUB

• You have already generated a layout from the schematic using Layout >
Generate/Update Layout

• You then change the substrate definition on the schematic, and need to transfer
it to the layout

In order to retrieve the new substrate information, you must use Momentum >
Substrate > Update From Schematic. Using Layout > Generate/Update Layout will
not transfer the new substrate information to the layout.

To update a substrate definition from a schematic:

1. Choose Momentum > Substrate > Update From Schematic . The substrate on the
correct schematic is read and the new information is entered in the Momentum
substrate definition.

Saving a Substrate
A substrate definition can be saved to a file. This enables you to store the definition
outside of the current project, making it easier to use the substrate definition in other
designs. To save a substrate:

1. Choose Momentum > Substrate > Save As .

2. Type a name for the file and click OK. Substrate files end with the extension
.slm.

To save a named file, choose Momentum > Substrate > Save . The substrate information
is saved in a file called <substrate_name>.slm under /networks in the current project
directory.
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Identifying Where Substrates are Saved

Substrates are saved in one of two locations:

• In the directory containing supplied substrates, which is
$HPEESOF_DIR/momentum/lib/substrates. You should not use this location
for substrates that you have created or modified.

• The location that the environment variable $HOME points to. If this variable is
not defined, substrates are saved in the current project folder.

Creating/Modifying a Substrate
To create or modify (edit) a substrate definition, use the procedures in “Defining
Substrate Layers” on page 3-5 and “Defining Metallization Layers” on page 3-12.

Changing Substrates
If you no longer want to use the substrate definition assigned to your design, or to
choose a different substrate use the procedure in “Selecting a Predefined Substrate”
on page 3-2.

Deleting a Substrate
This command erases the substrate file that you select. If the substrate has been
precomputed, the calculations remain in the database.

To delete a file:

1. Choose Momentum > Substrate > Delete .

2. Select the name of the file that you want to delete.

3. Click OK.
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Defining Substrate Layers
You can define a substrate from scratch or edit an existing one. A substrate must
have, at the minimum, a top plane and a bottom plane.

Note Do not use substrate components that might appear on layout component
palettes. You must use the dialog box under Momentum > Substrate > Create/Modify
to create or edit substrate definitions.

To define substrate layers:

1. Choose Momentum > Substrate > Create/Modify .

2. If this is a new definition, three default layers appear in the Substrate Layers
Field:

• Free_space (top plane)

• Alumina (dielectric)

• GND (bottom plane)

These layers represent a basic substrate definition that includes the three types
of substrate layers in Momentum.

• Free_Space represents the top plane of the substrate. In this definition, it is
defined as an open boundary.

• Alumina represents a dielectric layer of finite thickness. These layers are
also referred to as interface layers.

• GND represents the bottom plane of the substrate. GND defines a closed
boundary. Closed boundaries define ground planes or other closed
boundaries, such as the lid or bottom of an enclosure.

For an existing substrate definition, you may see more layers with different
names, but they will all be one of these three basic types of layer, and the
substrate will have a top and bottom plane. A substrate definition must have a
top plane and a bottom plane, and these planes can be defined either as open
boundaries or closed boundaries.

3. Select the layer of interest.
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4. To create a substrate, you will edit these layers, rename them, and add to them
as desired. For more information on how to perform these tasks, refer to the
sections below.

5. When you are finished defining the substrate, click OK to dismiss the dialog box.

Defining an Open Boundary

An open boundary represents a layer of infinite thickness, such as air. An open
boundary can be used to define other gases or infinitely-thick materials by editing the
relative permeability and permittivity values of the boundary.

To define an open boundary:

1. Select the Free_Space layer or another open boundary layer.

2. Select Open  from the Boundary list.

3. From the Permittivity (Er) listbox, select a format for the relative permittivity
of the boundary. You can enter the components of relative permittivity as:

• Real and imaginary

• Real and loss tangent

• Real and conductivity, conductivity in Siemens/meter

The real portion of the relative permittivity, , is a dimensionless quantity and
is identical to the material’s relative dielectric constant, . For more

information on this parameter, refer to “Dielectric Permittivity” on page 3-24.

To represent a dielectric that dissipates the power of a high-frequency electric
field, enter the dielectric loss tangent, , of the material in the Loss
Tangent field. The smaller the loss tangent, the less lossy the material. For
more information on this parameter, refer to “Dielectric Loss Tangent” on
page 3-25.

Enter the components of the relative permittivity in the fields below the listbox.

ε′
εr

ε″ ε′⁄
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4. From the Permeability (Mu) listbox, select a format for the relative
permeability of the boundary. You can enter the components of relative
permeability as:

• Real and imaginary

• Real and loss tangent

The real portion of the relative permeability, , is a dimensionless quantity
and is identical to the material’s relative permeability constant. For more
information on this parameter refer to “Dielectric Relative Permeability” on
page 3-26.

To represent a dielectric that dissipates the power of a high-frequency magnetic
field, enter the magnetic loss tangent, , of the material in the
Permeability Loss Tangent field. The smaller the loss tangent, the less lossy the
material. For more information on this parameter, refer to “Dielectric Magnetic
Loss Tangent” on page 3-27.

Enter the components of the relative permeability in the fields below the
listbox.

5. Click Apply  to accept the open boundary definition.

Tip You can create a ground plane from a open boundary layer by selecting the layer
and choosing Close from the Boundary list.

Defining an Interface Layer

Interface layers have finite thickness, and they can be characterized using relative
permittivity and permeability values. The thickness of a layer can be an arbitrary
value, with these considerations:

• Thin substrates are substrates less than one micron in thickness, and they
require special meshing considerations. Substrates less than 0.1 micron should
be avoided.

• Thick substrates should be less than 0.5 wavelength in thickness. The
recommendation for thick substrates is based upon typical design values. For
example, a 10 mil substrate with a cover height (air) of 300 mils would be
acceptable for frequencies up to 20 GHz, which is 0.5 wavelength.

µ′

µ″ µ′⁄
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To edit an interface layer:

1. Select the Alumina layer or other interface layer of interest.

2. Enter the thickness of the layer in the Thickness field and select the
appropriate units in the adjacent listbox.

3. From the Permittivity (Er) listbox, select a format for the relative permittivity
of the boundary. You can enter the components of relative permittivity as:

• Real and imaginary

• Real and loss tangent

• Real and conductivity, conductivity in Siemens/meter

The real portion of the relative permittivity, , is a dimensionless quantity and
is identical to the material’s relative dielectric constant, . For more

information on this parameter, refer to “Dielectric Permittivity” on page 3-24.

To represent a dielectric that dissipates the power of a high-frequency electric
field, enter the dielectric loss tangent, , of the material in the Loss
Tangent field. The smaller the loss tangent, the less lossy the material. For
more information on this parameter, refer to “Dielectric Loss Tangent” on
page 3-25.

Enter the components of the relative permittivity in the fields below the listbox.

4. From the Permeability (Mu) listbox, select a format for the relative
permeability of the boundary. You can enter the components of relative
permeability as:

• Real and imaginary

• Real and loss tangent

The real portion of the relative permeability, , is a dimensionless quantity.
For more information on this parameter refer to “Dielectric Relative
Permeability” on page 3-26.

To represent a dielectric that dissipates the power of a high-frequency magnetic
field, enter the magnetic loss tangent, , of the material in the
Permeability Loss Tangent field. The smaller the loss tangent, the less lossy the
material. For more information on this parameter, refer to “Dielectric Magnetic
Loss Tangent” on page 3-27.

ε′
εr

ε″ ε′⁄

µ′

µ″ µ′⁄
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Enter the relative permeability components in the fields below the listbox.

5. Click Apply  to accept the layer definition.

Defining a Closed Boundary Layer

A closed boundary represents a plane, such as a ground plane. It is a layer with zero
thickness. It can be defined as a perfect conductor, or you can specify bulk
conductivity or sheet impedance to characterize it as a lossy conductor.

To edit a ground plane:

1. Select the ///GND/// layer of interest.

2. Select Closed from the Boundary list.

3. From the Plane listbox, select a format for the ground plane. You can specify the
ground plane using these parameters:

• Perfect conductor

• Bulk conductivity in Siemens/meter

• Sheet impedance in Ohms/square

Conductivity is entered as a real number. Impedance is entered as the real and
imaginary components of a complex value.

Enter the ground plane parameters in the field below the listbox.

4. Click Apply  to accept the closed boundary definition.

Tip You can create an open boundary layer from a ground plane by selecting the
ground plane and choosing Open from the Boundary list.
Defining Substrate Layers 3-9



Substrates
Renaming a Layer

To rename a layer:

1. Select a substrate in the Substrate Layers list.

2. The name appears in the Substrate Layer Name field. Edit the name as desired.

3. Click Apply .

Note A ground plane is identified as ///GND/// and its name cannot be changed.

Deleting, Adding, and Moving Layers

To organize your substrate layers in the correct order, you can delete, add, and move
layers.

To delete a substrate layer:

1. Select a substrate in the Substrate Layers list.

2. Click Cut . The layer definition is deleted.

To add a substrate layer:

1. Select a substrate in the Substrate Layers list that has the same basic property
(open boundary, closed boundary, or finite thickness) as the layer you are
adding.

2. Click Add .

3. The new layer is highlighted. To rename the new layer, edit the Substrate Layer
Name field.

4. To move the layer, refer to the steps below.

To move a substrate layer:

1. Select the substrate that you want to move from the Substrate Layers list.

2. Click Cut .

3. Select the substrate that you want positioned below the substrate that you are
moving.

4. Click Paste .
3-10 Defining Substrate Layers



Defining Silicon Substrate Layers

The electrical behavior of Silicon material is usually specified using the dielectric
constant and a resistivity (or conductivity value).

For the dielectric constant, a value for  of 11.8 or 11.9 is usually used.

Resistivity ( ) values are normally specified in ohm cm, and a typical value is 10.

In Momentum, you can specify the conductivity ( ) in S/m (inverse of the resistivity).

For more information, see “Dielectric Conductivity” on page 3-25.

Calculating Conductivity from Resistivity

Conductivity is simply the inverse of resistivity. Make certain that the units of
resistivity are ohms m before inverting.

Example:

1.  = 10 ohm cm

2.  = 10 ohm cm = 0.1 ohm m

3.  = 1/rho = 10 S/m

Defining Conductivity

To define conductivity for silicon substrates:

1. Choose Momentum > Substrate > Create/Modify .

2. In the Create/Modify  dialogue box, select RE, Conductivity under Permittivity
(ER).

3. Specify the substrate dielectric constant and conductivity (S/m).

4. When you are finished, click OK to dismiss the dialog box.
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Defining Metallization Layers
Metallization layers enable you to:

• Define the position of layout layers in the substrate

• Specify which parts of the layer are conductive

• Define the conductivity of the layout layers

In order to identify which areas of a layout layer are conductive, a layer can be
specified as:

• Strip—The objects on the layout layer are conductive, the rest of the layer is not

• Slot—The inverse of a strip, the objects on the layout layer are not conductive,
but the rest of the layer surrounding the objects is conductive. When simulated,
Momentum considers the electric field distribution (the equivalent magnetic
current flow) in the slot.

the hairpin filter objects are conductive and
mapped to a strip metallization layer

Physical Slot

metal

Slot metallization
layer in Momentum

metal
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• Via—The objects on the layout layer are conductive and cut vertically through
one or more substrate layers. For more information on how to draw and apply
vias, refer to “Applying Vias” on page 3-32 and “Drawing Vias in Layout” on
page B-8.

Some examples of using strips and slots include:

• The patches of the Double_Patch antenna example. They are drawn on the
layout layer named top_met, and are conductive. This layer is mapped to a
metallization layer that is defined as a strip.

• The slots of the Slot_dipole antenna example. The slots are drawn on the layout
layer named slot. The slots are not conductive, but the area surrounding the
slots is. This layer is mapped to a metallization layer that is defined as a slot.

Note that a layout can have many other layers that are not part of the actual circuit,
such as text or error reporting layers. For the purposes of an Momentum simulation,
they are ignored. If layout layers containing parts of the circuit are not mapped to
metallization layers, they are ignored as well.

The steps for defining metallization layers are:

• Mapping a layout layer to a metallization layer

• Defining the conductivity of the layer

• Setting overlap precedence

Details for performing these steps are presented in the following sections.

bridge

via

strip

Examples of vias as sheets and cylinders

via

strip
via
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Mapping a Layout Layer

Layout layers that contain any shapes or components that are part of the circuit must
be mapped to metallization layers. If layout layers are not mapped to metallization
layers, they will not be included in the simulation.

To map a layout layer:

1. Choose Momentum > Substrate > Create/Modify .

2. Click the Metallization Layers tab.

3. Select a layer from the Layout Layers list box. Note that the layout layer
default cannot be mapped to a metallization layer, the first valid layer is cond.

4. To map the layer as a slot or strip, select from the Substrate Layers list a
dashed line to position the slot or strip in between two substrate layers, then
click Strip  or Slot .

If you make a mistake, click Unmap , then click the correct choice.

• A Strip defines the objects on the layout layer as conductive, the area
surrounding the objects is not.

• A Slot is the inverse of a strip, it defines the objects on the layout layer as not
conductive, but the area of this layer surrounding the objects is conductive.
When simulated, Momentum considers the electric field distribution (the
equivalent magnetic current flow) in the slot.

5. To map the layer as a via, select the substrate layer that you want the via to cut
through, then click Via.

If you want the via to cut through more than one layer, select the next layer,
then click Via again.

• A Via defines the objects on the layout layer as conductive and they vertically
cut through one or more substrate layers.

6. To define the conductivity characteristics of this layer, refer to “Defining
Conductivity” on page 3-15.

7. If you have or suspect that you have overlapping layers, you need to set overlap
precedence. Refer to “Setting Overlap Precedence” on page 3-19.

8. Click the Apply  button.
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Unmapping a Layer

If you want to change the location of a layer or remove one from the substrate
definition, use Unmap.

To unmap a layer:

1. Choose Momentum > Substrate > Create/Modify .

2. Click the Metallization Layers tab.

3. In the Substrate Layers list, select the substrate layer or the interface where
the layout layer is mapped.

4. Click Unmap . This removes all layout layers assigned to this position.

5. To remap a layer, refer to the steps in “Mapping a Layout Layer” on page 3-14.

Defining Conductivity

You can define a layout layer as a conductor or a resistor. If the layout layer is defined
as a strip or via, you define the conductivity of the strip or via. If the layout layer is
defined as a slot, you define the conductivity of the metal around the slot.

To define conductivity:

1. Choose Momentum  > Substrate  > Create/Modify .

2. Choose Metallization Layers .

3. Select a mapped layout layer from the Layout Layers list.

4. Select the conductivity definition from the Definition list:

• Perfect conductor

• Sigma, using real and conductivity values

• Sigma, using real and imaginary values

• Impedance

Perfect Conductor means the strip, via, or metal around the slot is a perfect
conductor and is lossless. No further definition is required.

Sigma (Re, thickness) enables you to specify conductivity in terms of bulk
conductivity and thickness. Enter bulk conductivity as a real value in the
Conductivity field, in Siemens/meter or Siemens/centimeter. Enter the metal
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thickness in the Thickness field and select the appropriate units. These values
will be used to calculate the dc and high frequency loss mechanisms when
determining the equivalent surface impedance. For example, the bulk
conductivity of gold is 41,000,410 Siemens per meter with any arbitrary
thickness. The equivalent DC sheet impedance that will be used when
conductivity and thickness is specified as:

whereσ is the conductivity (S/m) and t is the thickness of the conductor (m).

At high frequencies, the equivalent sheet impedance will be equivalent to:

whereδ is the skin depth given by:

with f as the frequency (Hz) andµ0 the free space permeability. This high frequency loss

specification corresponds to a single sheet skin-effect loss model, meaning that it assum
current at high frequency is assumed to be concentrated on one side of the finite thickne
conductor.

Note  A double sheet skin effect loss model can be activated by setting the following
variable in the momentum.cfg file:

MOM3D_USE_SHEETLOSSMODEL=2

The default for this variable is ‘1’, which means a single sided skin effect loss.

This configuration flag should only be used when conductors with finite thickness are
simulated are not expanded as finite thickness conductors. The double sided skin effe
model results in identical DC losses as the single sided skin effect loss model. Howev
high frequencies, the single sided skin effect loss model assumes a concentration of 
current on one side of the conductor, whereas the double sided skin effect formula as
an equal current distribution on both sides of the conductor.

ZDC
1

σt
------=

ZHF
1 j+
2σδ
------------=

δ 1
πf µ0σ
----------------=
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Sigma (Re, Im) specifies bulk conductivity as a complex number. Enter the real
and imaginary component of the value in the Real and Imaginary fields,
respectively, in Siemens/meter or Siemens/centimeter. The bulk conductivity
will be used to calculate the high frequency loss mechanisms, which are then
applied to all frequencies when determining the equivalent surface impedance.
The imaginary value is important for super-conductivity applications. Note that
the single sheet skin-effect model is used and that this model will result in a
equivalent sheet impedance equal to zero (or lossless) at DC. The ZHF formula
is basically used at all frequencies.

Impedance (Re, Im) specifies conductivity in terms of sheet impedance, in
Ohms/square. Enter the real and imaginary component of the value in the Real
and Imaginary fields, respectively.

5. When you are finished with the definition, click Apply .

6. Repeat these steps for the remaining mapped layout layers.

7. When you are finished, click OK to dismiss the dialog box.

Automatic 3-D Expansion for Thick Conductors

Conductors with finite thickness can be modeled in Momentum using the 3D metal
expansion feature. This feature will automatically expand the mask of a conductor
with finite thickness in the direction orthogonal to the layered medium, using the
specified thickness of this conductor.

Automated 3D expansion is activated by selecting either the Thick Conductor (up) or
Thick Conductor (down) expansion. In both cases, an extra dielectric layer is included
in the internal Momentum substrate model. This is done for each metal layer that is
expanded. The thickness values of the dielectric layers in between the metal layers
are not changed, which will preserve the capacitance value between two conductors
lying on top of each other in the substrates.

To select 3-D Metal Expansion Substrate items:

1. Choose Momentum > Substrate > Create/Modify .

2. Click the Metallization Layers tab.

3. In the Substrate Layers list, select the substrate layer or the interface where
the layout layer is mapped.

4. Select the Type  drop-down list from the Layout Layer dialog box.
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5. Choose either Thick Conductor (up)  or Thick Conductor (down)

Simulations with automatic expansion require more simulation time and memory,
but result in more accurate simulation results. Typically, when the width/height
aspect ratio is bigger than a factor of 5, the effect of accounting for the finite
thickness of the conductors will need to be allowed for in Momentum simulations.

The following figure illustrates the internal substrate model when using an “up” and
“down” expansion for a conductor. In both cases, an extra dielectric layer is inserted
(indicated with [new] in the figure), which in the case of an “up” expansion has the
dielectric properties of the layer above the metal layer. In the case of a “down”
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expansion, the new layer has the material properties of the layer below the metal
layer.

Note Extra internal metallization layers are automatically added in Momentum to
model the currents on all four sides of the finite thickness conductor.

Setting Overlap Precedence

Overlap precedence specifies which layout layer has precedence over another if two or
more layout layers are assigned to the same metallization layer and objects on the
layers overlap. Precedence is used by the mesh maker so that objects on the layer

‘down’ expansion

‘up’ expansion
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with the greatest precedence number are meshed and any overlap with objects on
layers with lesser numbers is logically subtracted from the circuit. If you do not set
the precedence, and there are overlapping objects, a mesh will automatically and
arbitrarily be created, with no errors reported. Resistive layers generated from
schematics are automatically set to the highest precedence.

In some cases, you may be designing with an intentional overlap because of
manufacturing layout guidelines. In this case, assign a precedence number to the
layout layers that overlap with precedence order in reverse numerical order (largest
to smallest). The system will draw the boundary at the edge of the higher numbered
layer without returning an error.

Precedence affects only how the mesh is created, it does not affect or alter the layout
layers in your design.

To specify overlap precedence:

1. Choose Momentum > Substrate > Create/Modify .

2. Choose Metallization Layers.

3. Select one of the overlapping layout layers in the list of Substrate Layers.

4. Assign its order of precedence in the Overlap Precedence field. Either type a
value directly into the field or use the arrow keys to select a value.

5. Click Apply .

6. Repeat these steps for the remaining overlapping layers.

7. When you are finished, click OK to dismiss the dialog box.

Overlap removed, geometry of object on top layer is altered

Precedence = 1 Precedence = 2
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Precomputing the Substrate Function
In order to perform a simulation and to calculate a mesh, Green’s functions
characterizing the behavior of the substrate must be computed:

• If you intend to precompute a mesh before you simulate, you must precompute
the substrate first. For more information on precomputing a mesh, refer to
“Precomputing a Mesh” on page 7-11.

• If the Green’s functions are not computed before you start a simulation, they
will be calculated and then the simulation will run.

If you are using a substrate that is supplied with Advanced Design System, you do
not need to precompute the substrate functions. If you have edited the substrate or
created a new one, you must precompute the substrate function.

When the computations (Green’s functions) are complete, the data is stored in a
database, and it will be used in the simulation of any design that uses this substrate.
If the substrate has been precomputed before and there has been no changes to the
substrate, it will not be recomputed unless the frequency range has been extended.
The frequency range can be set when using the Momentum mode, but not in
Momentum RF mode. In RF mode, the frequency range (start-stop) is not requested.
Since the RF mode uses the quasi-static Green’s functions, they are calculated at
quasi-static frequencies automatically chosen by the program. Substrate functions
calculated in Momentum mode are reusable in RF mode if they are calculated from
DC to some upper frequency.

For more information about the precomputation process, refer to Appendix A, Theory
of Operation.

To precompute the substrate function:

1. Choose Momentum > Substrate > Precompute .

2. To specify the frequency range of the computations, enter starting frequency in
the Minimum field and select the frequency units. Enter the stopping frequency
in the Maximum field and select the frequency units. (Not available in RF
mode.)

Be sure that the frequency range includes all frequencies that you want to
simulate.

3. Click OK to start the computations.
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Once the computations are completed, you do not need to perform this step again
unless the substrate is edited.

Note Be aware that the greater the number of layout layers in the substrate, the
more time required to perform the calculation.

Viewing Substrate Computation Status

After the substrate calculations are started, any messages regarding the calculations
will appear in the Momentum Status window. Messages usually refer to any errors
found, and indicate when the calculations are complete.

If you close the status window and want to reopen it, from the Layout menu bar
choose Window > Restore Status.

Stopping Substrate Computations
To stop the substrate calculations:

1. From the Momentum Status window, choose Simulation/Synthesis > Stop
Simulation .

The computations will stop and no information will be saved.

Viewing the Substrate Summary
If the simulation is successful, you can view substrate, mesh, and solution statistics.
Some of the information returned includes time to solve, the resources required, and
cell information. An example of solution statistics is given next.
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To view the summary, choose Momentum > Substrate > Summary.

======================================================================
                    --- STATUS SERVER MESSAGES ---
======================================================================

Simulation / Synthesis Messages

Substrate to be computed from 9 GHz to 11 GHz!

Status / Summary

---------Momentum Simulation ------------------

Version: Momentum 4.0 (*) 150.100 Sep 25 2000
Simulation mode: microwave
Design: circular_polarization

Start compute substrate functions on Tue Oct 03 10:11:16 2000
Computation 0.0% complete.
Computation 2.6% complete.
======================================================================

Reusing Substrate Calculations
Substrate definitions and substrate computations can be reused for other designs, if
the substrate database is accessible. If you are unsure about access to the database,
consult your system administrator.

Before a calculation begins, several folders are searched to determine if a solution has
already been generated. The folders searched, in order, are:

• The project networks folder

• The home directory or the site directory (made available by your system
administrator)

• The folder containing the Momentum supplied substrates
($HPEESOF_DIR/momentum/lib)

If the Substrate Calculator finds the same substrate definition, regardless of the
name, it uses the one it finds instead of recomputing the same information.
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About Dielectric Parameters
The sections below give additional detail about the following dielectric parameters:

• “Dielectric Permittivity” on page 3-24

• “Dielectric Loss Tangent” on page 3-25

• “Dielectric Conductivity” on page 3-25

• “Dielectric Relative Permeability” on page 3-26

• “Dielectric Magnetic Loss Tangent” on page 3-27

Dielectric Permittivity

The relative permittivity of all dielectrics is assumed to be complex:

which can also be expressed as:

where  is the real portion of  and  is the dielectric loss tangent.

Examples of materials and their typical permittivity are shown in Table 3-1.

Note The values listed in the table are for illustrative purposes only; use values
specifically measured for the materials that you are using.

Table 3-1. Materials and Permittivity

Material
Relative
Permittivity

Alumina 9.8

Sapphire 9.3 - 11.7

Berrylia 6.0

Rutile 100.0

GaAs 12.9
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Dielectric Loss Tangent

The dielectric loss tangent associated with a material is a function of frequency.
Examples of dielectric loss tangents for 10 GHz fields are shown inTable 3-2.

Note These values are listed for illustrative purposes only. Use values specifically
measured for the materials that you are using.

Dielectric Conductivity

For some materials (for example, Silicon), the substrate loss effects are better
described using the combination ( ,  = conductivity) instead of ( , loss tangent).
The complex dielectric constant is related to ( , conductivity) using the following
formula:

where:

 = 2  frequency

 = 8.85e-12 F/m (absolute dielectric constant free space)

Often, resistivity ( ) is specified instead of conductivity. The relationship between
resistivity and conductivity is

Resistivity is usually specified in  cm, conductivity is specified in S/m.

Table 3-2. Materials and Dielectric Loss Tangent

Material
Dielectric
Loss Tangent

Alumina .0002

Glass .002

Berrylia .0001

Rutile .0004

GaAs .0016
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Example:

A typical value for resistivity of a Silicon material is

 = 10  cm

which corresponds to a conductivity value of

 = 10 S/m.

Dielectric Relative Permeability

The relative permeability of all dielectrics is assumed to be complex:

which can also be expressed as:

where  is the real portion of  and  is the magnetic loss tangent.
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Examples of relative permeabilities are shown in Table 3-3.

Note The values listed above are for illustrative purposes only. Use values
specifically measured for the materials that you are using.

Dielectric Magnetic Loss Tangent

The magnetic loss tangent associated with a material is a function of frequency. An
example of a material with a magnetic loss tangent is polyiron which, at 30 GHz, has
a loss tangent of 0.0208.

Table 3-3. Materials and Relative Permeability

Material
Relative
Permeability

Gold .99996

Air 1

Aluminum 1.00002

Nickel 250

Iron 4000
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Substrate Definition Summary
The entire substrate definition includes:

•  Vias, in the same manner that they are part of the fabrication process.

•  Air bridges, including their height and their associated vias.

• Holes in ground planes, if they are part of a slot signal path (slot or coplanar),
or if they are relief holes for vias passing through a ground plane are also part
of the media.

•  Dielectric layer properties (Er, Mu, and loss).

• Ground plane losses and cover properties (conductivity or impedance).

Not included as part of the media or substrate definition are metal loss of strip and
via layers. The numerical computation process, used by the substrate calculator, can
take as little as one minute for stripline circuits. It can take several minutes for
microstrip or even a few hours for an arbitrary multi-layered substrate with several
vias.

Every change to a substrate definition requires a complete re-computation. The
system checks for duplicate definitions, regardless of the name, and uses previously
computed data if it exists.

Substrate Examples
Use the following examples to help you set up your own circuits:

• “Substrate for Radiating Antennas” on page 3-29

• “377 Ohm Terminations and Radiation Patterns” on page 3-29

• “Substrate for Designs with Air Bridges” on page 3-29
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Substrate for Radiating Antennas

To define a substrate for an antenna that radiates into air, you can set up the
following substrate definition:

Both layers are defined as open boundaries with the characteristics of air (for
permittivity and permeability, Real = 1, Loss Tangent = 0). The antenna design is
positioned on the metallization layer in between the two layers of air.

377 Ohm Terminations and Radiation Patterns

It is possible to define the top and bottom layers of a design with 377 ohm
terminations, then calculate radiation patterns for these structures after simulation.
For such applications, note the following considerations:

• The actual value of the termination may be between 376 and 378 ohms.

• When replacing top or bottom ground layer with a 377 ohm termination, a thick
layer of air in between the circuit and the 377 ohm termination is required in
order to get agreement (both for S-parameter results and radiation patterns)
with the simulation results with infinite top or bottom layer. An air layer of
10-20 substrate thicknesses is generally thick enough.

• There is a test on the impedance value prior to calculating the radiation
patterns. The impedance value must be in the interval (377 - 10) to (377 + 10)
ohm.

Substrate for Designs with Air Bridges

In order to designing a substrate definition for a design that contains an air bridge,
you need to first identify components of the air bridge and their placement on layout
layers. Refer to the illustration that follows.
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A basic air bridge between two components consists of the follow items:

• A via that connects the bridge to the first component

• The bridge itself

• A second via to complete the path to the second component

• The layer of air underneath the bridge

The layout must be drawn on at least three independent layers:

• The vias must be on at least one layer

• The bridge must be on a different layer

• The components must be on yet another layer

No two items that comprise the air bridge (except for the vias) can be on the same
layer. For this illustration, the components that are connected by the air bridge are
on the same layer.

The substrate definition would consist of the following items:

• An open boundary of air

• An interface layer of air at a finite thickness. This represents the layer of air
under the bridge.

• An interface layer of dielectric material

You map the layout layers to the substrate as follows:

• The bridge is mapped to the metallization layer that is in between the open air
substrate layer and the finite layer of air

• The vias are mapped to cut through the finite substrate layer of air

• The components are mapped to the metallization layer in between the finite
layer of air and the dielectric layer

It is not required for the components that the bridge connects to be on the same
layout layer or mapped to the same metallization layer. Nor do the vias need to be on
the same layout layer. Just be sure that the substrate definition has the correct
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number of substrate layers and that the components, vias, and bridge are mapped to
the appropriate metallization layers.

Substrate Layer Setup

Air, boundary is Open

Air under bridge, thickness is specified

Dielectric, thickness is specified

Metallization Layer Mapping

Map bridge here
Map vias here

Map strips here

Physical Circuit

bridge

via via

strip strip
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Applying Vias
Momentum creates a via by extruding the object that is mapped as via through the
substrate layer it is applied to. So, for example, for a sheet via, you draw a line, for a
cylinder via you draw a circle. When the shape is mapped to a via in Momentum,
another dimension is added to the object in order for the shape to cut through the
substrate. Thus a line becomes a sheet, a circle becomes a cylinder.

Regardless of how you draw vias, avoid having them extend over the sides of the
objects that they connect to. Vias must be on the edge or inside the object. Any
portion of the via outside of the object boundaries will not be taken into account
during the simulation. The figure here illustrates vias connecting two strips.

Vias can be applied to multiple layers so that they cut through one or more layers.

representations of
vias in Layout

strip strip

via
via

bridge

via

vias extruded through
a substrate layer in
Momentum

Circular Via:
Correct, but may not be efficient.
Use an appropriate arc
recognition.

Incorrect.
Via overlaps the object edges.

Efficient via:
Sheet via with width
matching width of strip.

Correct, but not as efficient as
sheet via with matching width
to strip.
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Chapter 4: Ports
Ports enable energy to flow into and out of a circuit. Energy is applied to a circuit as
part of the simulation process. A circuit solved using Momentum can have, at the
minimum, one port.

Ports are defined in a two-step process. First, ports are added to a circuit when the
circuit is drawn. Then, in Momentum, you specify the type of port in order to tailor
the port to your circuit. This facilitates the simulation process.

This chapter begins with suggestions to keep in mind when adding ports to a circuit
that will be simulated using Momentum. The remainder of this chapter describes the
various port types in Momentum and gives instructions on how to specify a port type.

Adding a Port to a Circuit
You can add a port to a circuit either from the Schematic window or a Layout window.
For instructions on how to add a port to a circuit, refer to “Adding a Port to a Circuit”
on page B-4. The procedures include considerations for adding ports to a circuit that
will be simulated using Momentum.

Considerations

Keep the following points in mind when adding ports to circuits to be simulated using
Momentum:

• The components or shapes that ports are connected to must be on layout layers
that are mapped to metallization layers that are defined as strips or slots. Ports
cannot be directly connected to vias. For information on how to define strips and
slots, refer to “Defining Metallization Layers” on page 3-12.

• Make sure that ports on edges are positioned so that the arrow is outside of the
object, pointing inwards, and at a straight angle.

• Make sure that the port and the object you are connecting it to are on the same
layout layer. For convenience, you can set the entry layer to this layer; the
Entry Layer listbox is on the Layout tool bar.

• A port must be applied to an object. If a port is applied in open space so that is
not connected to an object, Momentum will automatically snap the port to the
edge of the closest object. This will not be apparent from the layout, however,
because the position of the port will not change.
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• If the Layout resolution is changed after adding ports that are snapped to edges,
you must delete the ports and add them again. The resolution change makes it
unclear to which edges the ports are snapped, causing errors in mesh
calculations.

Note Do not use the ground port component (Insert > Ground) in circuits that will be
simulated using Momentum. Ground components placed in layout are not recognized
by Momentum. Either add ground planes to the substrate or use the ground reference
ports that are described later in this chapter.

Ground port component toolbar button:

Determining the Port Type to Use
There are five port types in Momentum. The purpose of ports is to inject energy into a
circuit and to allow energy to flow into and out of a circuit. The different port types
enable you to tailor the ports in your circuit according to your type of circuit and its
function in the circuit. In general, you should select the port type that best matches
the intended application of your layout.

The table below gives a brief description of each port type. You can use a combination
of port types in your circuit, although note that port types have limitations on where
they can be applied. Only the Single port type can be applied to objects that are on
either strip or slot metallization layers. Only the Internal and Ground Reference
types can be applied to ports that are on the surface of an object, the remaining types
can be applied to ports that are connected to an edge of an object.

Note Strips and slots refer to metallization layers. For more information on these
layers, refer to “Defining Metallization Layers” on page 3-12.

If you elect not to assign port types, any port in the circuit will be treated as a Single
port type during simulation.
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Note All port types can be defined in both of Momentum’s simulation modes
(microwave and RF). However, de-embedding (reference offset) is not available in RF
mode.

Additional details about each port type and how to define them are given in the
following sections.

Port Type Description
Port Connected
to Object on

Single (default) The port is calibrated to remove any
mode mismatch at the port boundary.
Single ports on slot layers have polarity.
Unless a port is given another type, it will
be treated as a single port.

Edge of object Strip or slot
layer

Internal The port is not calibrated. It is useful for
making a connection with lumped
elements or for representing other
connections in the circuit.

Edge or surface
of object

Strip layer

Differential Two ports with opposite polarity. The port
pair is simulated as a single port.

Edge of object Strip layer

Coplanar Two ports with opposite polarity. The port
pair is simulated as a single port.

Edge of object Slot layer

Common mode Two or more ports excited with the same
absolute potential and the same polarity.
The ports are simulated as a single port.

Edge of object Strip layer

Ground
reference

An explicit ground for a single (strip),
internal, or common mode port.The
implicit ground is made available through
the closest infinite metal.

Edge or surface
of object

Strip layer
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Defining a Single Port
Single is the default port type. It has the following properties:

• It is connected to an object that is on either a strip or slot metallization layer.

• It can be applied only to the edge of an object.

• The port is external and calibrated. The port is excited using a calibration
process that removes any undesired reactive effects of the port excitations
(mode mismatch) at the port boundary. This is performed by extending the port
boundary with a half-wavelength calibration (transmission) line. The frequency
wavelength selected during the mesh or simulation process is used to calculate
the length of the calibration line. For more information about the calibration
process, refer to “Calibration and De-embedding of the S-parameters” on
page A-7.

• The port boundary can be moved into or away from the geometry by specifying a
reference offset. S-parameters will be calculated as if the port were at this
position. For more information, refer to “Applying Reference Offsets” on
page 4-6.

• When two or more single ports are on the same reference plane, coupling effects
caused by parasitics affects the S-parameters. The calibration process groups
the ports so that any coupling in the calibration arms is included in the
S-parameter solution. For more information, refer to “Allowing for Coupling
Effects” on page 4-9.

• If the port is connected to an object on a strip layer, the substrate definition
must include at least one infinite metal layer: a top cover, ground plane, or a
slot layer, or a ground reference must be used in addition to the port. For more
information on ground references, refer to “Defining a Ground Reference” on
page 4-20.

• If the port is connected to an object that is on a slot layer, the port has polarity.
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Tip It is not necessary to open the Port Editor dialog box to assign this port
type. Any port without a port type specified is assumed to be a single port.

To define a single port type:

1. Choose Momentum > Port Editor .

2. Select the port that you want to assign this type to.

3. In the Port Editor dialog box, under Port Type, select Single.

4. Enter the components of the port impedance in the Real and Imaginary fields,
and specify the units.

5. You can shift the port boundary, also referred to as the port reference plane.
Shifting the boundary enables a type of de-embedding process that effectively
adds or subtracts electrical length from the circuit, based on the characteristic
impedance and propagation characteristic of the port. Enter the offset in the
Reference Offset field, and select the units. A positive value moves the port
boundary into the circuit, a negative value moves the port boundary away from
the circuit.

6. Click Apply  to add the definition to the port.

Physical port boundary

Calibration arm
removes mismatch

p1

p2
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Avoiding Overlap

Be aware that when using single ports, the calibration arm applied to a port may be
long enough to overlap another element in the circuit. In this case, the port will be
changed to an internal port type, and no calibration will be performed on it. If this
occurs, a message will be displayed during simulation in the Status window
indicating the change. For information about internal ports, refer to “Defining an
Internal Port” on page 4-10.

Applying Reference Offsets

Reference offsets enable you to reposition single port types in a layout and thereby
adjust electrical lengths in a layout, without changing the actual drawing.
S-parameters are returned as if the ports were placed at the position of the reference
offset.

p1

p2

The calibration arm overlaps the
strip. An internal port will be
used instead.

p1 p2
p1 p2

S-parameters will be
calculated based on the
positions of p1 and p2

S-parameters will be calculated as if
p1 and p2 were positioned at the
reference offsets

no reference offset reference offsets
applied to p1 and p2
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Why Use Reference Offsets?

The need to adjust the position of ports in a layout is analogous to the need to
eliminate the effect of probes when measuring hardware prototypes. When hardware
prototypes are measured, probes are connected to the input and output leads of the
Device Under Test (DUT). These probes feed energy to the DUT, and measure the
response of the circuit. Unfortunately, the measured response characterizes the entire
setup, that is, the DUT plus the probes. This is an unwanted effect. The final
measurements should reflect the characteristics of the DUT alone. The
characteristics of the probes are well known, so measurement labs can
mathematically eliminate the effects of the probes, and present the correct
measurements of the DUT.

There are significant resemblances between this hardware measurement process and
the way Momentum operates. In the case of Momentum, the probes are replaced by
ports, which, during simulation, will feed energy to the circuit and measure its
response. The Momentum port feeding scheme also has its own, unwanted effect:
low-order mode mismatch at the port's boundary, although this is eliminated by the
calibration process. However, in order for this calibration process to work well, it is
necessary that the fundamental mode is characterized accurately. This can only be
accomplished when the distance between the port boundary and the first
discontinuity is sufficiently large, that is, there exists a feedline that is long enough
to provide this distance.

As a basic example, consider a linewidth that varies abruptly in some part of your
circuit, as shown in the example below.

Strictly speaking, all you need is to characterize is the variation of the step-in-width
itself, as shown below.

p2p1
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As mentioned previously, it takes a little distance for the fundamental mode to settle,
which means that this “short” structure might not yield the accuracy that you expect
from an Momentum simulation. In this case, allow for some feed line length:

Now the simulation will yield accurate results, but the results will also contain the
extra line lengths. To remedy this, use reference offsets. Although the circuit has
been calculated with the long lines, reference offset shifting allows you to produce the
S-parameters as if the short structure had been simulated instead:

The effect of the extra feed lines is mathematically eliminated from the S-parameter
solution.

This process of adding or subtracting line length is generally referred to as
de-embedding. This is the basic process:

During the solution process, the impedance and propagation constant has been
calculated for the ports, based on their physical location in the circuit. When you
know the impedance, propagation constant, and the distance of de-embedding, you
can cancel out the extra lengths of line from the S-parameter results, by
compensating for the loss and phase shifts of those lines. The net result is a set of
S-parameters, calculated as if the extra line lengths were not there.

De-embedding Considerations

It is possible to de-embed right up to the discontinuity itself. However, make sure
that you do not shift the reference offset beyond the first discontinuity. This would
yield incorrect simulation results, as there is another linewidth beyond that

p2p1

p1 p2

apply reference offsets at
these locations
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discontinuity, which means that there is another set of impedance and propagation
values that applies there.

Note You can de-embed away from the circuit, by placing reference offsets beyond
the edges of the layout. This enables you to simulate the effect of a long feed line that
was not drawn in the simulated structure.

Note that for calculation speed purposes, the impedance and propagation constant for
grouped ports are approximated instead of explicitly calculated. The only way to have
impedance and propagation constant explicitly calculated in all cases is to de-embed
some small distance. This will cause some lengthy calculations, but the results
should be more accurate for users who want to look at accurate impedance and
propagation constants.

Allowing for Coupling Effects

If you have two or more single ports that lie on the same reference plane, the
calibration process will take into account the coupling caused by parasitics that
naturally occurs between these ports. This yields simulation results that more
accurately reflect the behavior of an actual circuit.

The figure below helps illustrate which ports will be grouped in order for the
calibration process to account for coupling among the ports. In this setup, only the
first two ports will be grouped, since the third port is an internal port type and the
fourth port is on a different reference plane. Note that even though the second port
has a reference offset assigned to it, for this process they are considered to be on the
same plane and their reference offsets will be made equal.
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If you do not want the ports to be grouped, you must add a small thickness of metal to
the edge of the object that one of the ports is connected to. The ports will no longer be
on the same plane, and will not be considered part of the same group.

Defining an Internal Port
Internal ports enable you to apply a port to the surface of an object in your design. By
using internal ports, all of the physical connections in a circuit can be represented, so
your simulation can take into account all of the EM coupling effects that will occur
among ports in the circuit. These coupling effects caused by parasitics are included in
your simulation results because internal ports are not calibrated. You should avoid
geometries that allow coupling between single and internal ports to prevent incorrect
S-parameters.

An example of where an internal port is useful is to simulate a bond wire on the
surface on an object. Another example of where an internal port is necessary is a
circuit that consists of transmission lines that connect to a device, such as a
transistor or a chip capacitor, but this device is not part of the circuit that you are
simulating. An internal port can be placed at the connection point, so even though the
device is not part of the circuit you are simulating, the coupling effects that occur
among the ports and around the device will be included in your simulation.

Internal ports are often used in conjunction with ground references. For more
information, refer to “Defining a Ground Reference” on page 4-20 and to “Simulating
with Internal Ports and Ground References” on page A-10.

port 1

port 2

port 3

port 4

reference plane

single

single, with
reference offset

internal

single
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An internal port type has the following properties:

• It can be applied to the interior of a circuit by applying it to the surface of an
object.

• It can be applied to the edge of an object.

• It can be applied to objects that are on strip layers only.

• The orientation of the port is not considered if it is on the surface of an object.
(For a description of port orientation, refer to “Adding a Port to a Layout” on
page B-5.)

• No calibration is performed on the port.

Because no calibration is performed on the port, the results will not be as accurate as
with a single port. However, the difference in accuracy is small.

To define an internal port:

1. Choose Momentum > Port Editor .

2. Select the port that you want to assign this type to.

3. Click Apply .

Ports 1 and 2 are
internal ports

1

2

3

4

5
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Defining a Differential Port
Differential ports should be used in situations where an electric field is likely to build
up between two ports (odd modes propagate). This can occur when:

• The two ports are close together

• There is no ground plane in the circuit or the ground plane is relatively far
away

• One port behaves (to a degree) like a ground to the other port, and polarity
between the ports is developed.

• The ports are connected to objects that are on strip metallization layers.

The electric field that builds up between the two ports will have an effect on the
circuit that should be taken into account during a simulation. To do this, use
differential ports.

Differential ports have the following properties:

• They can be applied to objects on strip layers only.

• They are assigned in pairs, and each pair is assigned a single port number.

• Each of the two ports is excited with the same absolute potential, but with the
opposite polarity. The voltages are opposite (180 degrees out of phase). The
currents are equal but opposite in direction when the ports are on two
symmetrical lines, and the current direction is approximated for other
configurations.
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• The two ports must be on the same reference plane.

Note Port numbers for differential ports are treated in the following manner: on the
layout, you will continue to see the port numbers (instance names) that were
assigned to each port when they were added to the layout. Use the Momentum Port
Editor dialog box to identify which pair of ports will be treated as a differential port.

When Momentum simulates designs containing non-consecutive port numbers, the
ports are remapped to consecutive numbers in the resulting data file. The lowest port
number is remapped to 1, and remaining numbers are remapped in consecutive
order. The port numbers are not changed in the design itself. A message in the Status
window announces the change, and lists the mappings.

For example, if you are simulating a design with ports numbered 1 and 3, the
following status message informs you of the changes:

Layout has non-consecutive port numbers.
Output files will have consecutive port numbers.

layout port -> output port

An electric field will likely
build up between these two
lines. Assign the ports as
differential ports. They will
be treated as one port and
assigned the same port
number.

Assign as differential ports. They will
be treated as one port and assigned
the same port number.

strip port 1 +

strip port 1 _

port
  3
  +

port
  3

_
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1 -> 1
3 -> 2

Also, when you view results, you will see S-parameters for the differential port
numbers. In the example above, the layout would show p1, p2, p3, p4. The
S-parameter results will be for combinations of the original P1 and P3 only.

To define a differential port:

1. Choose Momentum > Port Editor .

2. Select the port that you want to assign this type to. Note the port number.

3. In the Port Editor dialog box, under Port Type, select Differential .

4. Under Polarity, make sure that Normal  is selected.

5. Click Apply .

6. Select the second port.

7. In the Port Editor dialog box, under Port Type, select Differential .

8. Under Polarity, select Reversed .

9. Under Associate with port number, enter the number of the previously-selected
port.

10. Click Apply .

11. Repeat these steps for other differential port pairs in the circuit.

12. Click OK to dismiss the dialog box.

Defining a Coplanar Port
This type of port is used specifically for coplanar waveguide (CPW) circuits. It is
similar to a differential port, but coplanar ports are applied to objects on slot layers
(that is, where slots are used in the design). Coplanar ports should be used in
situations where an electric field is likely to build up between two ports. This can
occur when:

• The two ports are close together

• Polarity between the ports develops

• The ports are connected to objects that are on slot metallization layers
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The electric field that builds up between the two ports will have an effect on the
circuit that should be taken into account during a simulation. To do this, use coplanar
ports.

Coplanar ports have the following properties:

• They can be applied to objects on slot layers only.

• They are assigned in pairs.

• Each of the two ports is excited with the same absolute potential, but with the
opposite polarity. The voltages are opposite (180 degrees out of phase). The
currents are equal but opposite in direction when the ports are on two
symmetrical lines, and the current direction is approximated for other
configurations.

• The two ports must be on the same reference plane.

The illustration below shows ports pairs applied to a layout of coplanar waveguide
slots. The coplanar port type is applied to each pair of ports in the design. The arrows
in this illustration indicate the polarity assigned to each port and the direction of the
voltages over the slots (arrows indicate the direction of the voltages).

—

—

+

+ ——

ground
planes

slots

port 3
(normal
polarity)

port 3
(reversed
polarity)

Arrows indicate orientation (polarity) of
the voltages over the slots.

(reversed polarity)
port 1

port 1
(normal polarity)
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Note Port numbers for coplanar ports are treated in the following manner: on the
layout, you will continue to see the port numbers (instance names) that were
assigned to each port when they were added to the layout. Use the Momentum Port
Editor dialog box to identify which pair of ports will be treated as a coplanar port.

When Momentum simulates designs containing non-consecutive port numbers, the
ports are remapped to consecutive numbers in the resulting data file. The lowest port
number is remapped to 1, and remaining numbers are remapped in consecutive
order. The port numbers are not changed in the design itself. A message in the Status
window announces the change, and lists the mappings.

For example, if you are simulating a design with ports numbered 1 and 3, the
following status message informs you of the changes:

Layout has non-consecutive port numbers.
Output files will have consecutive port numbers.

layout port -> output port
1 -> 1
3 -> 2

Also, when you view results, you will see S-parameters for the coplanar port
numbers. In the example above, the layout would show p1, p2, p3, p4. The
S-parameter results will be for combinations of the original P1 and P3 only.

Be careful when assigning polarity to coplanar ports. An incorrect choice of polarity
can change the phase of transmission type S-parameters by 180 degrees. To verify
polarity, zoom in on a coplanar port. You will notice two sets of arrows applied to the
port. One appears when you add the port component to the circuit. The second will
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appear after the mesh is computed. It indicates the direction of the voltage over the
slot.

This arrow appears after
the mesh is computed and
indicates the direction of
the voltage over the slot.

This arrow is part of
the port component
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To define coplanar ports:

Note Coplanar ports can be applied to objects on slot layers only.

1. Choose Momentum > Port Editor .

2. Select the port that you want to assign this type to. Note the port number.

3. In the Port Editor dialog box, under Port Type, select Coplanar .

4. Under Polarity, make sure that Normal  is selected.

5. Click Apply .

6. Select the second port.

7. In the Port Editor dialog box, under Port Type, select Coplanar .

8. Under Polarity, select Reversed .

9. Under Associate with port number, enter the number of the previously-selected
port.

10. Click Apply .

11. Repeat these steps for other differential port pairs in the circuit.

12. Click OK to dismiss the dialog box.

Defining a Common Mode Port
Use common mode ports in designs where the polarity of fields is the same among
two or more ports (even modes propagate). The associated ports are excited with the
same absolute potential and are given the same port number.

Common mode ports have the following properties:

• They can be applied to objects on strip layers only

• A ground plane or other infinite metal (such as a cover) is required as part of
the design

• Two or more ports can be associated

• Associated ports are excited with the same absolute potential (and same
polarity)
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• The ports must be on the same reference plane

Note Port numbers for common ports are treated in the following manner: on the
layout, you will continue to see the port numbers (instance names) that were
assigned to each port when they were added to the layout. Use the Momentum Port
Editor dialog box to identify which group of ports will be treated as a common port.

Also, when you view results, you will see S-parameters for the common port numbers.
In the example above, the layout would show p1, p2, p3. The S-parameter results will
be for combinations of P1 only.

To define a common port:

1. Choose Momentum > Port Editor .

2. Select the port that you want to assign this type to. Note the port number.

3. In the Port Editor dialog box, under Port Type, select Common Mode .

4. Click Apply .

5. Select the second port.

6. In the Port Editor dialog box, under Port Type, select Common Mode .

7. Under Associate with port number, enter the number of the port that you
selected first.

Make sure that the value in the Associate with port number field is the same for
additional ports. For example, if you were associating three ports and the first port
was assigned as port 1, for the second and third port, the value entered into the

Three ports are treated as one after they are
associated as common mode ports.

Before After

p1

p2

p3

p1

p1

p1
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Associate with port number field would be 1. (For the first port you choose, no
value is entered in this field.)

8. Click Apply .

9. Repeat these steps for other common mode ports in the circuit.

10. Click OK to dismiss the dialog box.

Defining a Ground Reference
Ground references enable you to add explicit ground references to a circuit, which
may be necessary if no implicit grounds exist in your design.

Implicit ground is the potential at infinity, and it is made available to the circuit
through the closest infinite metal layer of the substrate. Implicit grounds are used
with internal ports and with single ports that are connected to objects on strip
metallization layers.

There are instances where the distance between a port and its implicit ground is too
large electrically, or there are no infinite metal layers defined in the substrate. In
these cases, you need to add explicit ground references to ensure accurate simulation
results. For more information on using ground references, refer to “Simulating with
Internal Ports and Ground References” on page A-10.

You can apply ground references to the surfaces of object. The object must be on strip
metallization layers.

Note Multiple ground reference ports can be associated with the same port. To be
associated with a single port, the ground reference port should be a port attached to
an edge of an object in the same reference plane as the single port.

To add a ground reference:

1. Choose Momentum > Port Editor .

2. Select the port that you want to assign as the ground reference.

3. In the Port Editor dialog box, under Port Type, select Ground Reference .

4. Under Associate with port number , enter the number of the single or internal
port that you want to associate with this ground reference. Make sure that the
distance between the port and ground reference is electrically small.
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5. Click Apply .

Editing a Port
For best results, use the Port Editor (Momentum > Port Editor... ) to change port
properties. You edit the port in the same manner as when you entered the initial
definition.

Note Be aware that it is possible to edit port properties by selecting the port and
choosing Edit > Properties from the Layout menu bar, however, this method is not
recommended.

For more information on setting port definitions see the appropriate section:

“Defining a Single Port” on page 4-4

“Defining an Internal Port” on page 4-10

“Defining a Differential Port” on page 4-12

“Defining a Coplanar Port” on page 4-14

“Defining a Common Mode Port” on page 4-18
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Remapping Port Numbers
Some designs contain non-consecutive port numbers. This results in simulation data
files that are difficult to use. When Momentum simulates designs containing
non-consecutive port numbers, the ports are remapped to consecutive numbers in the
resulting data file. The lowest port number is remapped to 1, and remaining numbers
are remapped in consecutive order. The port numbers are not changed in the design
itself. A message in the Status window announces the change, and lists the mappings.

For example, if you are simulating a design with ports numbered 37 and 101, the
following status message informs you of the changes:

Layout has non-consecutive port numbers.
Output files will have consecutive port numbers.

layout port -> output port
37          -> 1
101         -> 2

Port number remapping is done only for sampled and AFS CITIfiles and their
corresponding S-parameter datasets. It is not done for Visualization and far field
files. The remapping is done at the CITIfile level, and propagates to the dataset file.
After remapping, all datasets are in sync with the new port numbering.
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Chapter 5: Boxes and Waveguides
When you specified the substrate definition of a circuit (from the Momentum >
Substrate menu), you specified only the vertical dimension of the substrate and not
the horizontal dimension. Given this definition, the substrate layers extend all the
way to infinity in the horizontal direction. For many circuit designs this is not
relevant and does not affect the simulation. However, there may be instances where
you want to introduce horizontal boundaries. For these instances, you can use boxes
or waveguides.

Boxes and waveguides enable you to specify substrate boundaries in the horizontal
direction. A box enables you to set boundaries on four sides of the substrate. A
waveguide enables you to set boundaries on two sides. These effects are available
only when using the Momentum (microwave) simulation mode, and not with the
Momentum RF mode.

More specifically, for a box, you define four, perpendicular vertical planes of perfect
metal as the horizontal boundaries of the substrate. These four vertical planes, or
walls, form a rectangle, if you are looking at the circuit from the top, along the z-axis.
A box can be used only where the top and bottom layers in the substrate definition
are groundplanes or impedance termination. Thus, the four vertical metal walls, plus
the top and bottom groundplanes result in a box, hence the name (the walls are the
sides, and the top and bottom ground planes are lid and base of the box).

A waveguide is similar, although for a waveguide you specify only two parallel walls.
The substrate is therefore only bounded in the horizontal direction perpendicular to

box

A box can represent a highly resonant
metallic enclosure. Its effect will be taken
into account during simulation.
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these walls. In the horizontal direction parallel to these walls, the substrate still
extends to infinity. The top and bottom layers of the substrate must also be defined as
groundplanes. The two sidewalls in combination and the top and bottom covers form
a waveguide.

The next section describes how to apply a box or waveguide to a circuit. For more
information about applications for these items, refer to “About Boxes and
Waveguides” on page 5-5.

Adding a Box
A box defines the boundaries on four sides of the circuit substrate. Either one box or
one waveguide can be applied to a circuit at a time. A box can be applied to a circuit
only if the top and bottom layers of the substrate definition are defined as
groundplanes or impedance termination. The walls of the box are perfect metal. The
ground planes can be defined either as perfect metals or a lossy metal.

Adding a box to the circuit enables you to analyze the effects of enclosing the circuit
in metal, for example, to identify box resonance. Box resonance can have a significant
effect on S-parameters in a small band centered around the box resonance frequency.
When a simulation is performed, the resonance frequencies will be noted in the
status window when the circuit is simulated, along with the frequency bands where
no smooth S-parameters can be calculated.

During a simulation, all current directions on the sidewalls of the box are taken into
account.

A waveguide enables you to take into account the
effects of sidewalls near the circuit, or verify that
sidewalls do not affect your design.waveguide
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Note Calibrated ports in the circuit (i.e., Single, Differential, Coplanar and Common
mode ports) must be located on and perpendicular to the box edge, or an error will
occur. Internal (uncalibrated) ports may be placed anywhere in the circuit and point
in any direction.

To add a box:

1. Choose Momentum > Box-Waveguide > Add Box .

2. Insert the box using one of the following two methods:

• Position the mouse and click to define a corner of the box. Move the mouse to
the diagonal corner and click.

• From the Layout menu bar choose Insert > Coordinate Entry  and use the
Coordinate Entry X and Coordinate Entry Y fields to specify a corner of the
box. Click Apply . Enter the coordinates of the diagonal corner and click Apply .
Click Cancel  to dismiss the dialog box.

The box is displayed in the layout.

Editing a Box

Once the box is applied, you cannot change its dimensions. If you want to change the
size, you must delete the current box and add a new one.

Deleting a Box

To delete a box:

1. Choose Momentum > Box-Waveguide > Delete Box .

The box is removed from the layout.

Viewing Layout Layer Settings of a Box

The box is defined as a layout layer named momentum_box. You may review the
layout layer settings, but it is a protected layer, so you should not change the settings
of this layer.

To view the box layer specifications:
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1. Choose Options > Layers .

2. Select momentum_box from the Layers list. The layer settings are displayed. For
more information on these parameters, refer to the Schematic Capture and
Layout manual.

3. Click Cancel  to dismiss the dialog box.

Adding a Waveguide
A waveguide defines the boundaries on two, parallel sides of the circuit substrate.
Either one box or one waveguide can be applied to a circuit at a time. A waveguide
can be applied to a circuit only if the top and bottom layers of the substrate definition
are defined as groundplanes or impedance termination. The walls of the waveguide
are perfect metal. The ground planes can be defined either as perfect metals or metal
with loss.

During a simulation, all current directions on the sidewalls of the waveguide are
taken into account.

To add a waveguide:

1. Choose Momentum > Box-Waveguide > Add Waveguide .

2. Select the direction of the waveguide. To insert the waveguide parallel to the
x-axis, click X-axis . To insert the waveguide parallel to the y-axis, click Y-axis .

3. Insert the waveguide using one of the following two methods:

• Position the mouse and click to define one wall of the waveguide. Move the
mouse to the position of a point on the second wall and click.

• From the Layout menu bar choose Insert > Coordinate Entry  and use the
Coordinate Entry X and Coordinate Entry Y fields to specify a point on the
edge of the substrate. Click Apply . Enter the coordinates of a point on the
second, parallel edge of the substrate and click Apply . Click Cancel to dismiss
the dialog box.

These boundaries specify the edges of the substrate and the width of the waveguide.

Editing a Waveguide

Once the waveguide is applied, you cannot change its dimensions. If you want to
change the size, you must delete the current waveguide and add a new one.
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Deleting a Waveguide

To delete a waveguide:

1. Choose Momentum > Box-Waveguide > Delete Waveguide .

The waveguide is removed from the layout.

Viewing Layout Layer Settings of a Waveguide

The waveguide is defined as a layout layer named momentum_box. You may review
the layout layer settings, but it is a protected layer, so you should not change the
settings of this layer.

To view the waveguide layer specifications:

1. Choose Options > Layers .

2. Select momentum_box from the Layers list. The layer settings are displayed. For
more information on these parameters, refer to the Schematic Capture and
Layout manual.

3. Click Cancel  to dismiss the dialog box.

About Boxes and Waveguides
There are a variety of reasons why you would want to simulate a circuit in a box or
waveguide:

• The actual circuit is enclosed in a metal box

• Nearby metal sidewalls may affect circuit performance

• The box may resonate

• Propagating modes may be present

These situations are discussed next.

Circuits are often encased in metal enclosures. By adding a box to your design, the
metal sidewalls that are present in the real structure may be included in the
simulation. This is useful is you suspect that the presence of these sidewalls will have
an immediate effect on the behavior of the circuit. For example, “broad-coupled
filters” are placed in metal enclosures (a box) and the sidewalls can have an
significant influence on the filter characteristics.
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You may want to use a box or waveguide because metal sidewalls are present in the
real structure and there may be an effect from these sidewalls on the characteristics
of the circuit. This can be a parasitic, unwanted effect. If the effects of the sidewalls
were not taken into account while designing the circuit, you can verify any effect that
the sidewalls may have on your circuit. In most cases, when the sidewalls are not too
close to the actual circuit, the effect of the sidewalls on the simulation results will be
marginal. There is, however a specific, significant condition, which is unique for
structures with sidewalls.

In the case of a box, this is the occurrence of one or more box resonances. A box
resonance is a physical effect where, under the condition of certain frequency and box
size combinations, the box actually starts resonating at a certain frequency. Because
a box resonance has a significant effect on S-parameters in a (small) band centered
around the box resonance frequency which cannot be represented by a smooth
function, no smooth adaptive S-parameters will be available in this frequency band.
When simulating such a circuit, Momentum will inform you of these box resonance
frequencies, of the frequency bands where there will not be smooth S-parameters
available and of the quality factor (a measure for the sharpness of the box resonance,
depending on the losses).

In the case of waveguide, the effect is the excitation of a waveguide mode. If your
circuit will be positioned near sidewalls, you may want to add a waveguide to
determine whether they have an effect on the performance of the circuit.

You may have a situation where there are no metal sidewalls in the structure, but the
substrate definition is bounded by other material (for example, you have a finite-size
substrate where the dielectric material abruptly ends, so you have a dielectric-air
transition). Although Momentum boxes and waveguides are defined as perfect metals
and not dielectric material, you may decide that defining a metallic enclosure in the
simulated circuit may be more representative of the real structure than using no
enclosure.

Adding Absorbing Layers under a Cover

You may want to model your box or waveguide as having absorbing layers between
the covers and the layout. You can use a substrate interface layer, define its
thickness, and its absorbing properties using ε and µ (make sure that ε and µ are
accurate specifications for this layer). Adding absorbing layers to a box would have an
effect on any box resonances that would occur by producing a weaker resonance, that
is, the quality factor of the box resonances would lower significantly.
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Boxes, Waveguides, and Radiation Patterns

If you have a structure enclosed in a box or waveguide and you want to calculate
radiation patterns for it after the simulation, you need to set the top and bottom
planes to values between 376 and 378. There are also other considerations. For more
information, refer to “377 Ohm Terminations and Radiation Patterns” on page 3-29.
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Chapter 6: Layout Components and
Advanced Model Composer
Layout Components are user-defined components that you can create from a layout
page in ADS. The component that can be inserted in a schematic page just like any
other component, and represents the (parametric) layout from the layout page. The
symbol representing this component in schematic can either be a black box or a
layout look-alike symbol.

Once the Layout Component is defined, you as a user can use it in one of the following
ways.

You can directly include the Layout Component in the schematic. When doing a
circuit simulation from the schematic environment, the Momentum planar EM solver
will be called automatically during the circuit simulation (EM/Ckt co-simulation) to
generate a Momentum model on the fly. The layout parameters and the most relevant
Momentum simulation parameters (e.g., model type, mesh density) can be set from
the schematic page. The layout components have a built-in database mechanism that
keeps track of previously calculated Momentum simulation results, that is, once the
Momentum simulation is done for a certain layout component, no new EM
simulations are required, unless there is a change in the parameters for this
component.

The second way the Layout Components can be used is as the starting point of
Advanced Model Composer. Advanced Model Composer is a generalization of Model
Composer, see “Chapter 1: Model Composer” in the Model Composer manual, and
allows to generate a parameterized electrical model for a Layout Component from
within the layout window. After defining and creating the layout component, you can
specify the ranges for the parameters (with continuous and discrete parameter range
options) and launch the Advanced Model Composer model generation tool from
within the layout environment. In contrast to the EM/Ckt co-simulation feature,
Advanced Model Composer is an up-front model generation tool. This means that the
parameterized electrical model is calculated before the component is used in a
schematic design, based on a number of Momentum simulations which are run in the
background. No EM simulations need to be performed when the component is used in
schematic and using an Advanced Model Composer component in schematic is as fast
as any other ADS built-in component. The Advanced Model Composer components
can be added to a standard ADS design kit for easy sharing between projects and
users.
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Layout Components
The Electromagnetic-Circuit cosimulation feature allows you to combine EM
(Momentum) and circuit simulations from the schematic. From a layout in Advanced
Design System, you can create and insert a (parametric) layout component in a
schematic. The symbol representing this component in a schematic can either be a
black box or a layout look-alike symbol.

You can set the layout and Momentum simulation parameters such as model type
and mesh density from the schematic. When a circuit simulation is done in a
schematic that includes a layout component, the Momentum simulation engine is
automatically called as part of the circuit simulation process.

Layout components have a built-in database mechanism that keeps track of
previously calculated Momentum simulation results. Once the Momentum
simulation is completed for a certain layout component, no new EM simulations are
required, unless there is a change in the component parameters.

Note: When a Layout Component is simulated during an EM/Circuit co-simulation
session, a work layout design <name>_work is created (where <name> is the name of
the layout component) with an instance of the layout component inserted. The work
design is then sent to Momentum for EM simulation. The simulation results are
stored back into the model database associated with the original layout component.
This work design is only used temporarily and can be ignored. It is not automatically
deleted after the simulation to enable you view the mesh used during the Momentum
simulation. This mesh is displayed on top of the work design.

Layout Look-Alike

Black Box
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Setting up a Layout
There are two basic ways to create a layout. Use the one that best complements your
own design methodology and suits your design needs:

• Layout synchronized from a schematic

• Directly drawn or imported layout

Once you have a layout, you will need to prepare it for a Momentum simulation using
the following steps before you create a layout component:

1. Set up the substrate and layer mapping

2. Use Port Type Mapping to insert ports and set the port types

You can also specify mesh settings and frequency plans if you haven’t done so in the
schematic window.

Note Only single (calibrated) and internal (uncalibrated) ports are supported with
the layout components. Other port types will be mapped to single or internal port
types during component creation. More information on port mapping is given in “Port
Type Mapping” on page 6-24.

Adding Layout Parameters
Layout components with layout parameters enable you to sweep, tune, or optimize
geometrical (shape) variations of planar layout objects. This includes:

• Typical dimensions such as lengths, widths, gaps, spacing, or diameters

• Interdependent layout modifications such as length and width varying
simultaneously

• Unconventional layout modifications such as varying port locations

There are two ways to create a parameterized layout:

• Using nominal/perturbed designs

• Using subnetwork parameters

These approaches are mutually exclusive and you cannot combine them when
defining parameters for a single component. Nominal/perturbed parameters can be
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defined when the layout is flattened and contains only ports with primitive artwork
shapes (such as polygons, rectangles, circles, etc.). When a combination of existing
(built-in or custom defined) layout components and any other type of artwork
primitives are used, the layout is hierarchical and only subnetwork parameters can
be used. For more details, refer to “Layout Parameters” on page 6-23.

Note You need a Momentum license to use layout components without layout
parameters and you need a Momentum Optimization license to use layout
components that have layout parameters.

Using Nominal/Perturbed Designs
To define a parameter you need to provide a separate design to show the program
how an incremental change in that parameter value affects your original layout. The
original layout is referred to as the nominal design and the new layout is called a
perturbed design. The program will guide you through this process. When you add a
new parameter a separate design containing a copy of the nominal design is created.
You should make your changes in this design by applying perturbations as specified
in the Edit/View perturbation dialog. The modified copy is then saved as the
perturbed design. You need to define a separate perturbed design for each parameter.

Note Parameters you define using the Momentum > Optimization command are
automatically converted into component parameters when the Component
Parameters dialog box is opened.
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Use the Layout Component dialog box (Momentum > Component > Parameters) to set
up the component parameters.

Enter a parameter name along with the nominal and perturbed values for the
parameter. The nominal and perturbed values do not have to correspond to the
changes in the layout implied by these parameters, however, in practice it makes
most sense to use values that have a physical meaning.

Note For more information on the meaning and usage of the nominal and perturbed
parameter values refer to Appendix E, Momentum Optimization - Response
Interpolation and Appendix F, Momentum Optimization - Layout Parameterization.
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Click Add  to add the parameter or Edit/View Perturbation  to display the Edit/View
Perturbation dialog box where you can specify a Linear Stretch, Radial Stretch, or
Rotation perturbation for the specified parameter.

Linear Stretch

Specifying a linear stretch for a parameter enables you to move a single selected
vertex point or a group of selected vertex points linearly using a deltaX, deltaY
specification.
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Radial Stretch

Specifying a radial stretch for a parameter enables you to move a single selected
vertex point or a group of selected vertex points radially by specifying the centerX,
centerY coordinates of the center point and a factor. The following illustration shows
the effect of the factor on the selected vertex points.
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Rotation

Specifying a rotation for a parameter enables you to move a single selected vertex
point or a group of selected vertex points by rotating over a specified angle around a
center point specified by the coordinates centerX, centerY.

Note Parameters you define using the Momentum > Optimization > Parameter
command will be picked up automatically as nominal/perturbed parameters.
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Using Existing Layout Components
A parameterized layout can be set up using a combination of several built-in
microstrip components. Use the Layout Component Parameter dialog box
(Momentum > Component > Parameters) to specify subnetwork parameters for the
layout component.

Once a subnetwork parameter is defined, it can be used to set the parameters values
of one or more component instances used in the layout.
Using Existing Layout Components 6-9



Layout Components and Advanced Model Composer
In this example, the subnetwork parameter L1 is used to set parameter value L of
the MLIN instance.

Note Only the top-level design parameters can be used to set the lower level
instance parameters. The use of any other variable is prohibited.
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Creating a Layout Component
Use the Create Layout Component dialog box (Momentum > Component >
Create/Update) to specify the appropriate settings for creating a layout component.
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Note The Add reference pin checkbox enables you to turn on or off the addition of an
extra reference pin during layout component creation. This “extra” pin is used by
Momentum to provide a reference voltage for all other pins in the layout and enables
you to model ground effects (e.g., ground bounce, imperfect ground connections, etc.).

This option should be disabled for components that are used with the Schematic  >
Generate/Update  command. The presence of this extra pin can cause an error during
design synchronization.

Once the setup is complete, click OK to create the layout component. This layout
component will have the same name as the layout design. The following actions are
performed automatically:

• The technology data is saved. For more information on technology data, refer to
“Technology Files” on page 6-17.

• A component symbol is created

• The component definition is updated

• The model database is initialized

An information dialog box will be displayed to confirm that the creation or update
was completed successfully.

Note You need to update a layout component whenever a change is made to any
layout attribute such as the parameters, ports, and the shape. You also need to
reinsert or swap existing instances of the component in a schematic using Edit >
Component > Swap Components.

Selecting a Symbol

You can choose between two schematic symbol types:
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1. A layout look-alike symbol for which the symbol shape is a scaled copy of the
layout shape.

2. A black box symbol with a generic rectangular shape.

Scaling the layout look-alike symbol can be set in three different ways:

• Setting the minimal pin-pin distance in schematic units.
One schematic unit corresponds with the size of most standard two port
components such as resistors, capacitors, and inductors. Setting the minimal
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pin-pin distance to one schematic unit (1 inch) ensures that a component with a
given symbol size will fit between two pins.

• Setting the maximum pin-pin distance in schematic units.
The following figure illustrates the scaling when the maximal pin-pin distance
is set to be equal to one schematic unit (1 inch).

• Mapping the layout unit dimensions to the schematic unit dimensions
(recommended when combining different components in the same schematic
page). The scaling is stored unless it will cause changes to be made to the
setting used in a previous component creation.

max pin-pin distance
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When you combine different layout components on a single schematic, a fixed,
absolute scaling factor is the most appropriate choice to ensure that the relative
sizes of the layout components are preserved.

Note All layout components have an explicit reference pin. This pin, which is the
reference pin at infinity, interconnects all infinite ground planes. If there are no
infinite ground planes, this reference pin has no physical meaning and should be left
unconnected.

Model Parameter Defaults

Each time a new layout component instance is inserted on a schematic page, the
model parameter default values specified during the layout component creation are
applied as the initial settings for the instance. These parameters are a subset of the
Momentum simulation control options in the Layout environment.

You can specify the following default model parameters.

• Model Type set the mode of Momentum to be used to Momentum MW or
Momentum RF

• Substrate specify the substrate description (*.slm) using the browse button

• Lowest Frequency lowest frequency to be used during the Momentum model
generation for the adaptive frequency sweep algorithm

1 layout unit
(mil) = 0.01
schematic unit
(inch)
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• Highest Frequency highest frequency to be used during the Momentum model
generation for the adaptive frequency sweep algorithm

• Mesh Density number of cells per wavelength

• Arc Resolution

• Edge Mesh on/off toggle

Note If the circuit simulation requires frequency points outside the specified range,
this is done through extrapolation.

Model Database Settings

When running a circuit simulation, Momentum is invoked to generate a model for the
layout component. This model is stored in the layout component’s model database.
During the creation or update of a layout component, you have the following options
on how to use the model database information that is generated.

• Delete previous database toggle deletes all previously calculated models for
this component.

• Add last simulation result adds the results obtained from the last Momentum
simulation invoked from the layout to the database.

Primitive and Hierarchical Components

Depending on how the layout and its parameters were set up, a primitive or
hierarchical layout component is created.

Parameters Type Component Type Artwork Type

None Primitive AEL Macro

Subnetwork Hierarchical Synchronized

Nominal/Perturbed Primitive AEL Macro
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Layout Component File Structure
The layout component is made up of a group of files that combine to define the
component. Manually modifying or deleting one or more of these files may corrupt the
component definition resulting in unexpected behavior.

Technology Files

During the layout component Create/Update process, four technology related files
are created or modified. Three of these files define the substrate technology:

1. <substrate>_layout.lay layout (or mask) layers definition file

2. <substrate>_layout.prf layout preferences file

3. <substrate>.slm Momentum substrate definition file

The names for these files are derived from the Momentum substrate name that was
chosen. The default name is the layout design name.

The fourth file is the schematic layers definition file <schematic.lay>. This file is
loaded whenever a new schematic window is opened and it specifies the drawing
layers for the schematic. In the case of a layout look-alike symbol, additional layers
are appended to this file to draw the schematic symbol for the layout component.
They can be recognized by their ‘_lay’ postfix. Keep in mind that a schematic window
that is already open does not dynamically update its layers definition. You will need
to manually load the modified schematic.lay file.
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Model Database Files

The Momentum model database is stored under the mom_dsn/<comp> directory
where <comp> is the design name of the component. A model.ndx file keeps track of
the models that are stored in the database.

Models are stored in a two level hierarchy. The top level differentiates entries
(models) based on the model parameter settings. The bottom level differentiates
entries (model samples) based on the layout parameter settings.

Two models are considered to be the same if the following model parameter settings
are identical:

• Model type (ModelType)

• Simulation control (SimControl)

• Lowest model frequency (LowFreq)

• Highest model frequency (HighFreq)

• Mesh density (MeshDensity)

• Arc resolution (ArcResolution)

• Edge mesh (EdgeMesh)

For a given model, one or more (in the case of a parameterized component) samples
can be generated and added to the database.

The models already available for a component can be viewed by choosing Momentum
> Component > Model Database. This will open the layout Component Model
Database dialog box.
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In this example one model is available in the model database. By selecting the model,
the parameter values for which the model is generated become visible in the
Description box

Using Layout Components in a Schematic
The layout components created in the layout window can be inserted in a schematic,
either by selecting the component using the library browser (select Insert >
Component > Component Library) or by typing the name of the component in the
component name entry field. The layout ports become schematic pins that can be
connected to other components.
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Note You need a Momentum license to use layout components without layout
parameters and you need a Momentum Optimization license to use layout
components that have layout parameters.

Specifying Layout Component Instance Parameters
Double click a layout component in the schematic to display the Layout Component
dialog box. This dialog box has three tabs that enable you to set the parameters and
their display for the layout component instance.
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Model Parameters

Model Type Selection

The Model Type selection list offers the following choices:

• Momentum MW S-parameter model generated by Momentum in MW mode

• Momentum RF  S-parameter model generated by Momentum in RF mode

• File Based S-parameter model available in a Dataset, CITI or Touchstone file
or model given by an ADS netlist file

• Subnetwork (for hierarchical components only) the component will be netlisted
based on the subnetwork topology in the schematic page of the component
design and use the built-in models
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Momentum Simulation Control Settings

The first three options enable you to change the settings of the most important
Momentum Simulation Control parameters.

• Schematic – schematic settings overwrite the ones found in the corresponding
layout design from where the component was created. Only a subset of all
Momentum Control parameters can be accessed and an adaptive frequency
sweep (AFS) will be performed by Momentum.

• Layout  – layout settings found in the layout design will be shown in the layout
Component dialog box entries but they will be grayed-out. During a Momentum
simulation the parameters specified in the layout design will be used. This
allows Momentum to use parameter settings that cannot be set from the layout
Component dialog box (e.g., the use of discrete frequency sweep).

Most Simulation Control parameter settings are accessible from both the Schematic
and Layout windows.

Some parameters, such as Overlap, TML mesh, Frequency Sweep type, and Sample
Points, can only be set from Layout control.

These parameters are available using Schematic control, but only with the default
settings:

• Overlap – On

• TML mesh – Off

• Frequency Sweep type – AFS

• Sample Points – 50

Other parameters, such as, Layer, Primitive, and Primitive Seed cannot be set.

Model Database Settings

All generated models are automatically stored in the layout component model
database. When performing an optimization, select the Reuse Model and Interpolate
Model options to minimize the number of EM simulations.

• Reuse Model the database will be inspected, if the model for the specified
parameters is available, it will be reused. When this option is not selected a new
Momentum simulation is launched without inspecting the database first.
Click the Select  button to display the Select Model dialog box that lists the
currently available models.
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• Interpolate Model switch interpolation on or off. When this option is selected a
linear interpolation scheme is used. The circuit simulator only invokes
Momentum for an EM simulation if the requested model sample can not be
obtained by interpolation between neighbor model samples. Neighbor model
samples must be within a normalized distance (L1 measure) smaller than one
from the requested sample. The normalization of the distance is with respect to
the interpolation delta values specified in the Set Interpolation Options dialog
box.
Click the Options  button to display the Set Interpolation Options dialog box,
which shows the interpolation type and the interpolation grid setting for each
parameter for the current model parameter settings. You can change the
interpolation grid values or reset them to their defaults (automatically
calculated based on the highest model frequency and the mesh density) by
clicking the Defaults  button.

For more information about the model database and its model interpolation refer to
“Model Database Flow During Simulation” on page 6-27.

Layout Parameters

The Parameters tab enables you to set the layout parameters (nominal/perturbed or
subnetwork) similar to any other component in ADS. Click the Optimization Setup
button to specify an optimization setup for the selected parameter.

Display Parameters

The Display tab allows you to individually select which parameters must be visible
on the schematic.
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Port Type Mapping
Only single (calibrated) and internal (uncalibrated) ports are supported with layout
components. If you are starting from a layout where ports of other port types are used
(differential, common mode, ground reference or coplanar port types), they will be
mapped automatically to either a single or internal port.

The following examples illustrate how simulations with differential, ground
reference, and common mode ports can be set up in the schematic in a way that is
equivalent to the simulations in the layout.

Differential Ports

Ports 1,3 and 2,4 are differential port combinations. A Momentum simulation in
layout with this port configuration gives a two-by-two S-parameter result with
differential excitation. In a schematic, the differential ports are mapped to single
ports, meaning that Momentum calculates a four-by-four S parameter result. This

Layout Port Type Schematic Port Type

Strip Single Single

Internal Internal

Differential Single

Common Mode Single

Ground Reference Internal

slot Single Single

Coplanar Single
6-24 Port Type Mapping



can then be converted to a differential excitation using the following illustration of a
setup for S-parameter ports.

Common Mode Ports

Ports 1,3 and 2,4 are Common Mode port combinations. In the layout component, the
Common Mode ports are mapped to Single ports. To obtain the same results as with
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the Common Mode ports in layout, use the setup illustrated in the following
schematic.

Ground Reference Ports

Ports 3 and 5 are Ground Reference ports for port 1. Ports 4 and 6 are Ground
Reference ports for port 2. In the layout component, the Ground Reference ports are
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mapped to Internal ports. To obtain the same results as with the Ground Reference
ports, use the setup illustrated in the following schematic.

Tuning
During a tuning session, models cannot be generated on the fly. Consequently, tuning
of parameters that influence a layout component is only possible when the requested
layout component model samples are already part of the database or if the database
can provide interpolated results.

If the database cannot return a valid model, tuning will fail and issue an error
message indicating that the model database is incomplete. In other words, tuning is
only possible within specific ranges that are covered by enough samples.

Model Database Flow During Simulation

The following illustration shows how the model database handles a request for a
model sample for a given layout component. Multiple requests may be generated
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during an analysis even when only one instance of the component is present. This is
the case when layout component parameters are swept, optimized, or tuned.

A first model request will propagate to the Reuse Model? point. If the Reuse Model
option is off, Momentum will be invoked to (re)calculate the model.

If the Reuse Model option is on, the model database will verify if the requested
sample is already part of the database. If this is the case, the existing model will be
reused.

If the model sample is not available yet, the component instance’s Interpolate Model
option will be checked. If this option is off, Momentum will be invoked to calculate a
new model. The following warning message will be issued to the status window:

The model for the Layout Component is not found in the Database, a new
model is generated for the requested parameter values.

If the Interpolate Model option is on, the model database will try to locate neighbor
samples. Samples are considered to be neighbor samples if they are within the
interpolation delta distance (L1 measured), which can be viewed and specified in the
Set Interpolation Options dialog box. If no neighbor sample is found, Momentum will
be invoked to calculate a new model. A warning message, which is the same as the
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one above, will be issued to the status window. In the case of a tuning session, the
following error message will be sent to the status window.

Model Database for <instanceName> is not complete for tuning. Simulate the
Layout Component first to complete the Model Database.

If at least one sample is found in the neighborhood, the database will try to
interpolate in the database. If sufficient samples are not available, they will be added
automatically based on the interpolation deltas that were specified (or their default
settings). The number of additional samples is kept as low as possible to save
computation time. When this happens, the following message is shown in the status
window:

There are not enough samples available to allow interpolation, a new
sample is generated and added to the Model Database.

Examples of Parameterized Layout Components
In this section, we will illustrate some of the possibilities the user has to define layout
parameters. We will illustrate:

• using the nominal/perturbed definition in the Layout Component use model

• using Graphical Cell Compiler

• using existing ADS component definitions to create a new Layout Component

Definition of a parallel plate capacitor

In this example, we will illustrate the usage of nominal/perturbed layout parameter
definition use model. The size of the capacitor overlap area in both vertical and
horizontal direction, as well as the widths of the feedlines will be defined as layout
parameters.

The starting layout is shown in Figure 6-1.
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Figure 6-1. Capacitor example with l and w definition

First we will setup the parameter l as the size of the overlap area of the capacitor,
using the Nominal/Perturbed use model. This parameter will indicate the size of the
overlap area in the horizontal and vertical direction. Several vertex point
perturbations will need to be defined to size of the capacitor area proportionally in all
directions. The following strategy can be used:
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Figure 6-2. Possible perturbation specification strategy

The following figure illustrates moving the vertex points indicated with “1” (the two
vertex points in the layout that form the top left corner of the capacitor plates).

Vertex points Deltax (um) Deltay (um)

1 -5 5

2 5 5

3 5 0

4 5 0

5 5 -5

6 -5 -5

7 -5 0

8 -5 0
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Figure 6-3. Figure 11 – Perturbation of selected vertex points

Similarly, the other vertex points need to be moved (you can leave the Edit/View
perturbation window open)

The width w of the feedline can also be defined using the Nominal/Perturbed use
model.

After setting up both the l and w parameters, the layout component can be created
using Momentum > Component > Create/Update.

The following figure shows a couple of different instances of the newly created
component.
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Figure 6-4. Instances of the capacitor structure

Definition of an Airbridge

This example illustrates the usage of the Graphical Cell Compiler tool to define
layout parameters. We will illustrate this for an airbridge example, where the length
of the airbridge l and the width w of the feedlines will be defined as layout
parameters.

The starting layout is indicated in Airbridge example with construction lines and
consists of two feedlines on layer cond, the airbridge on layer cond2 and two vias
connecting the airbridge to the feedlines on layer res. The name of this layout is
chosen to be AMC2MACRO.
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Figure 6-5. Airbridge example with construction lines

The two construction lines that will be used to parameterize this layout are already
drawn on the layout.

Using the Graphical Cell Compiler tool, accessible in layout under Tools > Macro, the
airbridge layout can be easily parameterized. To define the width parameter wid,
select all objects in the layout excluding the vertical construction line and use the
stretch command of Graphical Cell Compiler to define the layout parameter (Tools >
Macro > Stretch). The length parameter len can be similarly defined by selecting all
objects excluding the horizontal construction line and before using the stretch
command. After defining the stretch operations, the artwork needs to be compiled
using Tools > Macro > Compile.

More information on these commands and how to compile the can be found in the
Graphical Cell Compiler manual.

Once the artwork macro is compiled, we can use it to create a new Layout Component
and pick up the layout parameters defined in the artwork macro. To do this, first
create a new layout (e.g., called AMC2) and include the AMC2MACRO in the new
layout window. You need to add two new ports (p1 and p2) connected to the pins of the
artwork macro.
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Figure 6-6. Create the Layout Component using GCC macro

What is now left to do is to define Layout Component parameters and map those on
the parameters of the artwork macro. To do this first setup two subnetwork
parameters (e.g., w and l) in the Layout Component Parameters tab.

Figure 6-7. Create subnetwork parameters l and w
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Second step is to map these newly defined parameters to the len and wid parameter
of the artwork macro. To do this, double click on the layout artwork component
(AMC2MACRO) and assign the artwork parameter len to l and wid to w.

Figure 6-8. Map subnetwork parameters

Once this step is completed, the Layout Component can be created using

Momentum > Component > Create/Update…

The component can now be used like any other Layout component, either directly in
schematic where a Momentum model will be calculated on the fly using the EM/ckt
cosimulation feature or as the starting point for Advanced Model Composer tool.

Definition of a Spiral Inductor Component

In this example, we will use the MRINDELA and MLIN layout artwork components
in layout to create a new Layout Component. We start off by creating a layout (called
AMC3) which includes the two components as indicated in the figure below.
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Figure 6-9. Spiral component

Two layout parameters will be defined for the Layout Component created from this
layout: w (width of the lines) and n (number of segments of the spiral). First define
these two parameters as subnetwork parameters in the Momentum > Component >
Parameters dialog:

Figure 6-10. Subnetwork parameters for spiral
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After this, assign these parameters to the appropriate parameters in the MRINDELA
and MLIN components. (e.g., for MRINDELA:)

Figure 6-11. Assign parameters in component

The next step is to create the Layout Component using Momentum > Component >
Create/Update.

The following figure shows a couple of instances of the newly created component for
different values of n (n=5,9,13,17) where w was chosen to be fixed (10 um).
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Figure 6-12. Instances spiral component
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Advanced Model Composer
The Advanced Model Composer functionality combines the capabilities of the Model
Composer tool awith the generality of layout components. For more information on
ModelComposer see“Chapter 1: Model Composer” in the Model Composer manual.

With Model Composer, users can create multi-dimensional, parameterized, passive
planar models for a number of standard interconnect components such as opens,
stubs, bends and tees on custom substrates. The Model Composer tool is accessible in
the schematic environment using Tools > Model Composer.

With Advanced Model Composer, users can create multi-dimensional, parameterized,
passive planar models for arbitrary shaped and user-defined parameterized layout
components, also on custom substrates. The Advanced Model Composer functionality
is integrated in ADS layout under the Momentum menu: Momentum > Component >
Advanced Model Composer.

Both rely on a unique, patented, EM (Momentum) based modeling method, thus
providing EM accuracy and generality at traditional circuit simulation speed. The
models are generated in an up-front model generation step and added to the model
database associated with the layout component. Models generated by the Advanced
Model Composer can be recognized by their .pml extension. Once the models are
generated, they can be used in schematic without requiring EM (Momentum)
simulations.

Specifically for Advanced Model Composer, the following three steps need to be
followed:

1. Setup and define the parameterized layout component (in ADS layout), using
the use model of Layout Components. For detailed information on how to setup
a Layout Component, for details refer to “Layout Components” on page 6-2.

2. Create the model, monitor the model generation status and optionally add the
model and component to a standard ADS design kit

3. Use the model in the schematic environment like any other ADS component.

Note    Both the Advanced Model Composer license and the Momentum license are
required to generate models for user defined layout components. Once the model is
generated, no license is required when using this component in the schematic
environment.
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Note    There is an important distinction between the use of Layout Components in
schematic directly and the use of components generated with Advanced Model
Composer. When using Layout Components directly in the schematic environment,
the Momentum engine is called on the fly to generate an EM model as part of the
circuit simulation (EM/ckt cosimulation). When using Advanced Model Composer, the
parameterized EM model is generated prior to using the components in the schematic
environment, therefore not requiring Momentum to run during the circuit
simulation.

Using Layout Components to Create Models with Model
Composer

In this section, we will describe how to create an Advanced Model Composer model.
As a starting point, we assume that a parameterized layout component has been
setup and open in the ADS layout window from which the Advanced Model Composer
tool is started. This means that the layout parameters have been defined with the
Momentum > Component > Parameters dialog, see“Layout Components” on page 6-2,
and that the Layout Component has been created using the Momentum > Component
> Create/Update dialog.

In the remainder of this section, we will use the parameterized parallel plate
capacitor layout component for details refer to “Examples of Parameterized Layout
Components” on page 6-29 for an example in the screen shots and dialog boxes.
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Creating Advanced Model Composer Models

Figure 6-13. Advanced Model Composer

When invoking Momentum > Component > Advanced Model Composer > Create
Model, the dialog box of Create update dialog box pops up. This is the main Advanced
Model Composer dialog consisting of two tabs: the Model Parameter tab and the
Layout Parameter tab.

Setup Model Parameter

In the Model Parameter tab, a number of specific Momentum simulation parameters
can be set, such as mode (Momentum MW and Momentum RF), substrate name (.slm
file), lowest and highest frequency, mesh density, arc resolution and the edge mesh
toggle.
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Figure 6-14. Create update dialog box

If previous Momentum simulation models are available in the layout component
defined in the layout window, the specific Momentum settings used for generating
these models can be loaded using the Select/Reuse Momentum Simulation Settings
button.

Setup Layout Parameters

Using the Layout Parameters tab, the ranges and specific values for the layout
parameters that will be used in the generation of the Advanced Model Composer
model can be specified.

For every layout parameter, the user can choose the sweep type of the parameter.
This can either be:

• Constant Value

• Discrete List

• Continuous range
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Note A specific sweep type needs to be specified for every layout parameter. The
Constant Value option can be used for layout parameter values that are fixed.

1. Constant value

This option can be used to specify that the layout parameter does not have to be
swept.

Figure 6-15. Specifying constant value for a parameter

2. Discrete list

With the Discrete lists is a set of discrete values. When you use the component on a
schematic, you can edit the parameter to any value in this list.
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Figure 6-16. Specifying list of value for a parameter

3. Continuous range

This allows to create a model covering a range, with a minimum and a maximum
value. When you later on use the component in schematic, you will be able to specify
any value in this range.
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Figure 6-17. Specifying continuous range of values for a parameter

Although there is no hard coded limit to the number of continuous parameters, we
recommend to not using more that 2 continuous parameters. For more information
refer “Chaper 1, Troubleshooting a Library” in the Model Composer manual.

Launching Advanced Model Composer Model Generator

After clicking OK in the Advanced Model Composer > Create Model dialog, the
following information window pops up which allows you to inspect the Parameter
Sweep plan and gives general information on the model generation process.

After clicking OK in this dialog, the model generation process is started as a
background process.
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Figure 6-18. Start Advanced Model Composer dialog

Viewing and Controlling the Advanced Model
Generation Process
To check on the progress, from the Momentum menu choose Component > Model
Composer > Status/Control. This can be done from any Advanced Design system
session that is running on the same computer and started by the same user. Type in
the Component name or click Browse to locate the component of interest. The default
location for the component is under the $HOME/hpeesof/amc/components directory,
and the name of the component is the same as the name of the layout component.

This dialog box:

• Lists the status of the model generation process
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• Displays any error messages or warnings

• Enables you to stop the model generation process

Figure 6-19. Status/Control window

Creating Design Kits with Model Composer
Components
Using the Momentum > Component > Advanced Model Composer > Design Kit menu,
the Layout Component Design Kit dialog box can be opened, see Figure 6-20 Add
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Advanced Model Composer component to ADS design kit . With this menu, the
Layout Component defined in the layout window where the component is created
from can be added to a standard ADS design kit.

Figure 6-20. Add Advanced Model Composer component to ADS design kit

To add the component to standard ADS design kit, or to create a new ADS design kit,
you have to go through a 2-step process.

In the first step, you can choose the name of the component that you will add in the
design kit, add a description text and select the electrical Advanced Model Composer
model you want to use by selecting the appropriate .pml file with the Model Select
window.

In the second step, you can specify the name of the design kit and a version number.
The list of existing components is visible in the window. You can add the component
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and the selected model to the standard ADS design kit. If the design kit does not
already exist, a new one will be created.

Note Only Advanced Model Composer models can be added in a design kit.

Using Advanced Model Composer models in Schematic

When the Advanced Model Composer model generation is completed, the resulting
component with its associated electrical model can be added to a schematic like any
other Advanced Design System component.

If the component was added to a user specified design kit, for details refer to
“Creating Design Kits with Model Composer Components” on page 6-48, the design
kit can be shared and loaded like any other ADS design kit. For detailed information
on installing and enabling design kits, refer to the ADS "Design Kit Installation and
Setup" documentation. More detailed information on how to load design kits, on how
to locate a model and on how to edit component values can be found in“Chapter 1:
Model Composer” in the Model Composer manual.

Troubleshooting a Model Generation Process

The topics discussed for Model Composer in “Chapter 1, Troubleshooting a Library”
also apply to Advanced Model Composer.

Given the additional generality that is brought to the user with Advanced Model
Composer, it should be noted that this tool is designed for the purpose of component
modeling, (i.e., components that are small compared to the wavelength). When
modeling structures with resonances, the simulation time required to generate the
model can increase significantly due to the fact that more Momentum simulations
need to be performed to get a converged model and that each of the Momentum
simulations will require more frequency points.
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Note When the mesh density is set too low, mesh noise in the simulated models can
influence the model generation process in such a way that convergence of the model
generation process is not reached with a reasonable number of samples. In this case,
it is advised that you increase the mesh density.
It is a good practise to simulate the component in the extremes of the parameter
ranges prior to starting Advanced Model Composer to ensure that the Momentum
model generation process for the selected simulation control options completes
successfully.
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Chapter 7: Mesh
A mesh is a grid-like pattern of triangles and rectangles, and each triangle or
rectangle is a cell. This pattern of cells is based on the geometry of a circuit and,
optionally, user-defined parameters, so each circuit will have a unique mesh
calculated for it. The mesh is then applied to the circuit in order to compute the
current within each cell and identify any coupling effects in the circuit during
simulation. From these calculations, S-parameters are then calculated for the circuit.
The mesh that was calculated for the double patch example is shown below.

Creating a mesh consists of two parts:

• Defining mesh parameters

• Precomputing the mesh

It is not necessary to set up mesh parameters; default parameters will be used
instead. You can precompute the mesh before simulating in order to view the mesh,
otherwise the mesh will be computed as part of the simulation process. A mesh is
required in order to simulate.

This chapter describes how to define mesh parameters and calculate the mesh. It also
includes a description of how the mesh generator works and gives guidelines for
setting mesh parameters for different applications.

Rectangular cells are
applied to most of the
geometry...

...but for curved or
non-rectangular objects,
triangles are used to complete
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Defining a Mesh
Choose Momentum > Mesh > Setup to set up mesh parameters, which enable you to
control the number of cells that are used to create the mesh. The more cells, the more
accurate the simulation will be, but too many cells will slow down a simulation and
provide little improvement in accuracy. You can choose not to set up mesh
parameters, and default values will be used to create the mesh.

If you choose to define mesh parameters, you can set them for:

• The entire circuit

• The objects on a layout layer

• A single object

It is not necessary to specify parameters for all levels. You can, for example, specify
mesh parameters for a single object, and use default values for the rest of the circuit.

For more information about how a mesh is generated, refer to “About the Mesh
Generator” on page 7-14. For suggestions to consider when setting mesh parameters,
refer to “Guidelines for Meshing” on page 7-24.

Procedures for setting up mesh parameters follow.

Defining Mesh Parameters for the Entire Circuit

Global mesh parameters affect the entire circuit. To set up global parameters:

1. Choose Momentum > Mesh > Setup .

2. The Global parameters are displayed.

3. Enter the mesh frequency in the Mesh Frequency field and select the units. The
wavelength of this frequency will be used to determine the density of the mesh.
In general, set the value of the mesh frequency to the highest frequency that
will be simulated. For more information, refer to “Adjusting Mesh Density” on
page 7-14.

4. Enter the Number of Cells per Wavelength. This value will also be used to
determine the density of the mesh. The relationship between wavelength and
cells per wavelength can be described by example: if the circuit is 3 wavelengths
long and the number of cells per wavelength is 20, the length of the circuit will
be divided into 60 cells.For more information, refer to “Adjusting Mesh Density”
on page 7-14.
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5. Any curved areas in the circuit will be meshed using facets. In the Arc Facet
Angle field, enter the number of degrees that will be included in a single facet.
The maximum is 45 degrees per facet. The lower the value, the better the
resolution and the denser the mesh will be. The minimum value is equal to the
Arc/Circle Resolution which is set when the object is drawn. For more
information, refer to “Using the Arc Facet Angle” on page 7-20.

6. Enable Edge Mesh  to add a relatively dense mesh along the edges of objects.
Since most current flows along the edges of objects, the edge mesh can improve
the accuracy and speed of a simulation.

If you want the edge mesh to be sized automatically, leave the Edge Width field
blank. Otherwise, specify the edge width and select the units. For more
information about the edge mesh, refer to “About the Edge Mesh” on page 7-16.

Note An edge mesh that you specify will not be used if the edge width is larger
than the cell size set by the wavelength/number_of_cells_wavelength. This is
because such edge meshes would be very inefficient. If the edge mesh values
must be used, decrease the number_of_cells_wavelength, which is specified in
the Number of Cells per Wavelength field.

7. Enable Transmission Line Mesh to specify the number of cells along the width of
a geometry. It is most useful for circuits with straight-line geometry.

Enter the number of cells that the width will be divided into in the Number of
Cells Wide field. This will be the total number of cells along the width of the
circuit. For more information about the transmission mesh, refer to “About the
Transmission Line Mesh” on page 7-17.

Arc Facet Angle is 30 degrees Arc Facet Angle is 18 degrees
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8. Enable Thin layer overlap extraction  in order to extract objects for the following
situations:

• Two objects on different layers overlap

• The objects are separated with a thin substrate layer

If this is enabled, the geometry will be altered to produce a more accurate model
for the overlap region. For more information, refer to “Processing Object Overlap”
on page 7-22.

Note This should always be enabled when modeling thin layer capacitors.

9. If you want to revert to default parameters, click Reset .

10. Click OK to accept the global mesh parameters.

Defining Mesh Parameters for a Layout Layer

You can define mesh parameters that affect the objects on a single layout layer. If you
have global parameters set, they will not be used where mesh parameters are defined
for a layout layer.

To set up layout layer parameters:

1. Choose Momentum > Mesh > Setup .

2. Click the Layer  tab.

3. From the Layout Layer list, select the metallization layer that you want to
specify mesh parameters for.

4. Enter the Number of Cells per Wavelength. This value, along with the
wavelength of the frequency specified in the Frequency field, will be used to
determine the density of the mesh. (Recall that the frequency is a global
parameter).

The relationship between wavelength and cells per wavelength is best described
by example. If the portion of the circuit on this layer is 2 wavelengths long and
the number of cells per wavelength is 20, the length of the circuit on this layer
will be divided into 40 cells. For more information, refer to “Adjusting Mesh
Density” on page 7-14.
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5. Enable Edge Mesh to add a relatively dense mesh along the edges of the objects
on this layer. Since most current flows along the edges of objects, the edge mesh
can improve the accuracy and speed of a simulation.

If want the edge mesh to be sized automatically, leave the Edge Width field
blank. Otherwise, specify the edge width and select the units. For more
information about the edge mesh, refer to “About the Edge Mesh” on page 7-16.

6. Enable Transmission Line Mesh to specify the number of cells along the width of
the geometry on this layer. It is most useful for circuits with straight-line
geometry.

Enter the number of cells that the width will be divided into in the Number of
Cells Wide field. This will be the total number of cells along the width of the
circuit on this layer. For more information about the transmission mesh, refer
to “About the Transmission Line Mesh” on page 7-17.

7. If you want to change the settings for the selected layer, click Reset to return to
default values or Clear  to erase your settings.

8. Select another layer and repeat these steps for setting the mesh parameters.

9. Click OK to accept the mesh parameters for the layers.

Defining Mesh Parameters for an Object

You can define mesh parameters that affect a single object. If you have global or
layout layer parameters set, they will not be used where mesh parameters are
defined for an object.

To set up object parameters:

1. Choose Momentum > Mesh > Setup .

2. Click the Primitive  tab.

3. In the Layout window, select the object that you want to specify mesh
parameters for.
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4. Enter the Number of Cells per Wavelength. This value, along with the
wavelength of the frequency specified in the Frequency field, will be used to
determine the density of the mesh. (Recall that the frequency is a global
parameter).

The relationship between wavelength and cells per wavelength is best described
by example. If the object is 1/2 wavelengths long and the number of cells per
wavelength is 20, the length of the object will be divided into 10 cells. For more
information, refer to “Adjusting Mesh Density” on page 7-14.

5. Enable Edge Mesh  to add a relatively dense mesh along the edges of the object.
Since most current flows along the edges of objects, the edge mesh can improve
the accuracy and speed of a simulation.

If want the edge mesh to be sized automatically, leave the Edge Width field
blank. Otherwise, specify the edge width and select the units. For more
information about the edge mesh, refer to “About the Edge Mesh” on page 7-16.

6. Enable Transmission Line Mesh to specify the number of cells along the width of
the object. It is most useful for circuits with straight-line geometry.

Enter the number of cells that the width will be divided into in the Number of
Cells Wide field. This will be the total number of cells along the width of the
object. For more information about the transmission mesh, refer to “About the
Transmission Line Mesh” on page 7-17.

7. If you want to change the settings for the selected object, click Reset to return to
default values or Clear  to erase your settings.

8. Select another object and repeat these steps for setting the mesh parameters.

9. Click OK to accept the mesh parameters for the objects.

Seeding an Object

For the majority of circuits, it is not necessary to seed an object, and it is not
recommended because all internal mesh processes will be skipped. If an object is
seeded incorrectly, an inefficient mesh will result, affecting simulation speed and
accuracy. You should have a good understanding of electromagnetics and
computational geometry to be able to use this meshing feature efficiently.
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Primitive seeding enables you to specify the exact number of cells to be applied to a
geometry:

• Horizontally, across the o,u-axis

• Vertically, from point V to the o,u-axis

The example below illustrates the position of the o,u-axis and the position of point V
with respect to OU on a simple shape. Regardless of the object seeding is applied to,
OV must be perpendicular to OU in order to create a correct mesh. This mesh was
defined to be three cells wide along the o,u-axis, and five cells high.

To seed a primitive:

1. Determine the method for entering mesh coordinates. You can:

• Type coordinates directly into the Coordinate Entry dialog box

• Select coordinates by clicking on objects in the Layout window

If you choose select coordinates on the object, make sure that the vertex snap
mode is on, and check your other snap modes to make sure that you can
completely align the mesh with the structure. If snap modes are on when you
select a coordinate, the system will snap to the nearest point that satisfies an
enabled snap mode. This means that you may have difficulty aligning the mesh
with the object if snap modes other than vertex snap are enabled. Snap modes
can be found in the Layout window under the Options menu.

2. If a mesh is displayed on the layout, choose Momentum > Mesh > Clear .

3. Choose Momentum > Mesh > Setup .

Point V

V

O U

3 cells wide across o,u-axis

5 cells wide from V to O
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4. Click the Primitive Seed  tab.

5. In the Layout window, select the object that you want to seed. If necessary, zoom
in.

6. Specify the o,u-axis. The axis determines the orientation of the mesh. Select the
axis using one of the following two methods:

• Position the mouse and click to define the origin of the o,u-axis. Move the
mouse to the end of the axis and click.

• From the Layout menu bar choose Insert > Coordinate Entry  and use the
Coordinate Entry X and Coordinate Entry Y fields to specify the origin of the
o,u-axis. Click Apply . Enter the coordinates that define the end of the axis and
click Apply .

7. The Primitive Mesh Control dialog box is displayed. Enter the number of cells
that you want along the o,u-axis.

8. Specify point V. The point must be positioned so that OV is perpendicular to OU.
Select the point using one of the following two methods:

• Position the mouse and click to define the point and click.

• From the Layout menu bar choose Insert > Coordinate Entry  and use the
Coordinate Entry X and Coordinate Entry Y fields to specify the coordinates
of point V. Click Apply .

9. The Primitive Mesh Control dialog box is displayed. Enter the number of cells
that you want along the ov-line.

10. The following information will appear for the seeded object:

• The number and name of the layout layer that the object is on

• Data describing the seeded object, including the type of object (for example,
path or polygon) and its coordinates

• The angle of the o,u-axis with respect to the x-axis

• The length of each cell along the o,u-axis (the distance of OU divided by the
number of cells)

• The length of each cell along OV (the distance of OV divided by the number of
cells)
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An example is shown below:

11. If you want to change the settings for the selected object, click Clear  to erase
your settings.

12. Click OK to complete the command.

In the illustration below, the o,u-axis is positioned along the base of the polygon, and
it is the length of the polygon. The number of cells along the axis is set to three. The
number of cells from OU to V is set to five. The resulting mesh is displayed. Any other
mesh parameters that had been specified were used in other parts of the circuit.

Mesh Connectivity

If you choose to seed an object, and you have global, layout layer, or object mesh
parameters set, these other parameters will not be used on the seeded object. In
addition, the mesh cells must connect in an appropriate way throughout the circuit in

Layer 2 (bot_met):
Path  (-35.000000, -2.187000) (0.000000, 2.187000)
 OU angle = 0.000000 deg.

  du = 3.483500 mm, dv = 17.632979 mm

layer data
object data

OU angle

cell sizes

 U to V is 5 cells wide.

O to U is 3 cells wide.
Also, OU determines the
orientation of the mesh.

Remaining area of object is
meshed by connecting vertices.

V

U
O
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Mesh
order to achieve accurate results. This is referred to as mesh connectivity. Be aware
that in order to achieve mesh connectivity, the boundaries of seeded regions may be
transformed. The only way to correct this is to modify the seeding of the neighboring
objects. If you choose to seed one object, you should consider seeding the entire
circuit.

Which cells are altered to assure connectivity is governed by creating a mesh that
generates the fewest number of unknowns.

Resetting and Clearing Mesh Parameters

If you want to change mesh parameter setting, you can:

• Change individual parameters

• Erase a set of mesh parameter values

• Reset mesh parameters to default values

To reset or clear mesh parameters:

1. Choose Momentum > Mesh > Setup .

2. Select the tab, Global, Layout, Primitive, or Primitive Seed, that contains the
parameters you want to erase or reset.

3. Choose one of the following options:

• For layout parameters, select the layout layer name.

• For object mesh parameters or seeding, select the object from the Layout
window.

Tip You may want to clear the mesh from the layout before attempting to
select an object.

4. Click Clear  to erase the settings, or click Reset  to set them to default values.

Note If you have trouble selecting an object, exit the dialog box, select the object,
then reopen the dialog box.
7-10 Defining a Mesh



Precomputing a Mesh

Note In order to calculate a mesh, you must first precompute the substrate and
apply ports to the circuit. For information on how to precompute the substrate, refer
to Chapter 3, Substrates. For information on how to apply ports, refer to “Adding a
Port to a Circuit” on page B-4, and to Chapter 4, Ports.

Choose Momentum > Mesh > Precompute to calculate the mesh. Using the specified
frequency and any user-defined mesh parameters, a pattern of rectangles and
triangles is computed and applied to the circuit. During a simulation, the surface
current in each cell is calculated, and this information is then used to solve
S-parameters for the structure.

To precompute the mesh:

1. Choose Momentum > Mesh > Precompute .

2. In the Precompute Mesh dialog box, enter the frequency you want to use for
precomputing the mesh. The wavelength of this frequency will, in part,
determine the number of cells in the mesh. For more information about mesh
calculations, refer to “About the Mesh Generator” on page 7-14.

3. Click OK to start calculating the mesh.

When the computations are complete, the mesh will be displayed on the layout.

Viewing Mesh Status

After mesh computations have started, any messages regarding the computations
will appear in the Momentum Status window. Messages usually refer to any errors or
warnings, or indicate when the mesh is complete.

If you close the status window and want to reopen it, from the Layout menu bar
choose Window > Restore Status.
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Stopping Mesh Computations
To stop the mesh process:

1. From the Momentum Status window, choose Simulation/Synthesis > Stop
Simulation .

The mesh computations will stop and no information will be saved.

Viewing the Mesh Summary
If the mesh computation is successful, you can view mesh statistics. Some of the
information returned includes:

• The number of rectangular cells in the structure

• The number of triangular cells

• The number of vertical rectangular cells used to model the vias

• The number of unknown currents

• Computer resources used and time to solve

The number of cells and the number of unknown currents will affect simulation time.
The more cells, the denser the mesh, and the longer the simulation will be. Each
unknown current is a variable in the matrix equation that is solved by the simulator.
The greater the number of unknown currents, the larger the matrix, and the longer
the simulation time will be. The memory required to solve the structure increases as
well.
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An example of mesh statistics follows.

Viewing a Mesh Report
A mesh report can offer more information on some warnings that are displayed in the
Momentum Status window related to ports and resolution. It also reports any
unconnected vias, these are vias that do not connect at both sides.

To view a Mesh Report:

1. Choose Momentum > Mesh > Show Report .

Clearing a Mesh
You can delete the view of the mesh from the circuit. Clearing a mesh only deletes the
view from the Layout window; it does not erase the mesh calculations.

To remove the mesh from the display:

1. Choose Momentum > Mesh > Clear .

2. If you want to redisplay the mesh, choose Edit > Undo . Otherwise, you must
recompute the mesh in order to view it.

========================================================================
                       --- MOMENTUM MESH STATISTICS ---
========================================================================

                           MOMENTUM 4.0 (*) 150.100
                           Thu Oct 12 15:50:17 2000

------------------------------------------------------------------------ -

Mesh Info:
---------

Rectangular cells :       4
Triangular cells  :      51
Via cells         :       0
Unknown currents  :      60

Resources:
---------
Process size :     0.17 MB
User Time    :    0h 0m 0s
Elapsed Time :    0h 0m 5s

========================================================================
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About the Mesh Generator
The mesh generator provides the algorithm that divides the circuit geometry into
cells (rectangles and triangles). In RF simulation mode, the mesh is automatically
reduced to remove slivery cells of low quality and to remove electromagnetically
redundant cells resulting in a mesh with polygonal cells. By discretizing the surface,
it is possible to calculate a linear approximation of the arbitrary, varying surface
current. The linear approximation involves applying a rooftop function to the cells.
The better the linear approximation fits the actual current, the more accurate the
results. Thus, a dense mesh generally provides better results at microwave
frequencies.

The mesh generator attempts to apply an optimal pattern of cells so that an accurate
simulation can be achieved with a minimal number of cells. In Momentum mode, the
minimal number of cells can be rather high, resulting in a dense mesh. For a given
mesh density, the mesh reduction technology used in the RF mode achieves an
optimal mesh with significantly fewer cells, hence improving the simulation
performance with reduced memory usage and simulation time. Since the current in
each cell is calculated in a simulation, a very dense mesh can increase simulation
time.

The mesh parameters that you specify provide the mesh maker with the information
required to divide your geometry into the various cell shapes and sizes. If you do not
want to set mesh parameters, default ones will be used instead. In Momentum mode,
the default mesh setting is 20 cells/wavelength using edge mesh. In RF mode, the
default mesh setting is 20 cells/wavelength not using edge mesh.

Adjusting Mesh Density

Two mesh parameters, Frequency and Cells per Wavelength, are used in combination
in determining mesh density.

Using the wavelength of the frequency, a linear function is approximated, also
referred to as a rooftop basis function. The higher the frequency, the more
wavelengths fit across the structure. The Cells per Wavelength are the minimum
number of cells that fit under each wavelength. The more cells, the better the
sinusoid is represented, and the more accurate the simulation is. For example, if you
use 30 cells per wavelength, the maximum deviation between the sinusoid and the
linear approximation is about 1%. These parameters affect longitudinal current.
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Higher frequencies will result in a greater number of cells (increased density) for a
mesh. Similarly, increasing the minimum number of cells per wavelength will also
increase the density. In general, for optimal density, it is better to increase the
number of cells per wavelength rather than increasing the mesh frequency. The
optimal value for the mesh frequency is the highest frequency that will be simulated.
This may avoid having to recalculate the substrate frequency band if it is not
sufficient.

If you enter a value for the mesh frequency, but you have already seeded the layout,
the system will ignore the frequency you enter and the mesh frequency will only be
used to compute the mesh for the remaining areas of the circuit.

You should be aware that the value entered for the number of cells per wavelength is
only a lower limit and not the exact value used by the mesh generator. The following
discussion explains how the actual number of cells used by the mesh generator may
be greater. For example, suppose you enter 20 for Cells per Wavelength. In general,
the cell size used when the geometry is infinitely large corresponds with the number
of cells per wavelength. But when other details, edges, and user-defined mesh
settings are included, cells might appear that are smaller than  resulting in
more cells per wavelength than the value of 20 that you entered. Here are two specific
cases where the actual number of cells per wavelength is greater:

• When the layout has details that are smaller than , the mesh follows the
shape of the details. Since the mesh consists of triangles and rectangles only,
the cells will be less than .

• When you change the default settings in the Mesh Setup Controls dialog box,
such as the number of cells per transmission line width, then you directly
influence the number of cells over the width of the transmission lines. This
might lead to cells that are smaller than .

Effect of mesh reduction on simulation accuracy.

Mesh reduction is a technology that aims at removing mesh complexity that
originates from the meshing of geometrically complex shapes. In a normal situation,
the user specifies the mesh density (the number of cells per wavelength) that needs to
be used in the simulation in order to obtain a specific accuracy. However, due to
geometrical constraints, the mesher can be forced to use more cells than strictly
needed by the wavelength criterion. In this case, the mesh introduces “redundant”
degrees of freedom in the solution process. (“redundant” with respect to the
electromagnetic behavior). Mesh reduction is a technology that automatically

λ 20⁄

λ 20⁄

λ 20⁄

λ 20⁄
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removes these redundant degrees of freedom, prior to the solution of the problem.
Hence, it should have a negligible impact on the accuracy of the results.

About the Edge Mesh

The edge mesh feature automatically creates a relatively dense mesh pattern of small
cells along the edges of metal or slots, and a less dense mesh pattern of a few large
cells in all other areas of the geometry. Because most of the current flow occurs along
the edges of slots or metals, the edge mesh provides an efficient solution with greater
accuracy.

Use the edge mesh to improve simulation accuracy when solving circuits where the
modeling of current flow in any edge area is a critical part of the solution. This
includes circuits where the characteristic impedance or the propagation constant are
critical for determining the electrical model, circuits in which close proximity
coupling occurs, or circuits where edge currents dominate the circuit behavior.
Applications for using the edge mesh include:

• Tightly coupled lines

• Patch antennas

• Resonant circuits

• Delay lines

• Hairpin filters

Edge mesh is available for all levels of meshing: global, layout layer, and object
meshing.

Setting the Width of the Edge Mesh

When using an edge mesh, you can either specify the edge mesh width or leave it
blank. If you leave it blank, an appropriate width will be determined and used to
create the mesh. One way to get a visual approximation is to position the mouse on
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the primitive edge and click, then move the mouse inward and note the differential
value., which is displayed at the bottom of the Layout window.

About the Transmission Line Mesh

Use the transmission line mesh when you want to specify the number of cells
between parallel lines in a layout. This feature can save computation time and
memory because it will create a mesh that is appropriate for straight line geometry.

For example, the simulation results for a single transmission line with one or two
cells across the width will be equal. If you have coupled lines, the results will differ.

Combining the Edge and Transmission Line Meshes

Both transmission line mesh and edge mesh can be used together. The total number
of cells wide will be the total number of transmission line cells plus edge cells. The
minimum value permitted when using this combination is 3.

differential coordinates
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The edge and transmission line mesh affect the transverse current in the circuit. The
more cells specified using edge mesh and transmission line mesh, the more accurate
transverse current approximations will be.

Basic Edge Mesh

cells/width = 3

Transmission Line Mesh

cells/width = 3

Edge Mesh and Transmission Line Mesh

cells/width = 5

Cell width along the length
will be equal for this
type of mesh.
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The plot below illustrates the hairpin example simulated with and without and edge
mesh. Although the simulation that includes the edge mesh takes more time, the
results are closer to the actual measured results of the filter.

Mesh Patterns and Simulation Time

The mesh generator is relatively fast, even for complex meshes. But be aware that
the complexity of the mesh can have a significant on effect simulation time. In
particular, the number of cells in the mesh (especially triangular cells) and the
number of unknown currents, can affect simulation time.

Simulation times will be faster when the mesh consists mostly of rectangular cells. A
simple mesh is one consisting of a few rectangles of similar size. A worst-case
complex mesh would consist of many dissimilar triangles. You should try to minimize
the number of triangular cells in the mesh.

The second variable, number of unknown currents, depends on the density, or total
number of cells in the mesh. You should try to minimize the total number of cells in
the mesh. This reduces the number of unknown currents, and thus reduces the size of
the matrix to be solved during simulation. The amount of time required to solve the
matrix is N*N*N, where N is the number of unknown currents.

with edge mesh

without
edge mesh
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For example, a thru-line at a global seeding of 30 might produce a 50 x 50 matrix to
solve. Since the time required to solve the matrix is proportional to the matrix size,
the same thru-line at a seeding of 60 might produce a 200 x 200 matrix because
number of cells would be twice as dense in both X and Y dimensions. This means that
it will take longer to solve.

Adjustments to your mesh parameters can be made to control complexity of the mesh
and, in turn, the amount of time required to simulate.

For complex circuits, where simulation times may be long even with a simple mesh,
reducing the complexity of a mesh can save significant amounts of simulation time.

Mesh Patterns and Memory Requirements

The number of unknown currents, which is calculated when the mesh is
precomputed, is based on the complexity of the mesh. The more unknowns, the larger
the matrix that must be solved during simulation. The amount of memory required to
solve is proportional to N*N, where N is the number of unknown currents.

Using the Arc Facet Angle

The Arc Facet Angle parameter enables you to control the number of triangular cells
that appear in the mesh. Triangular cells are used to generate a mesh on the curved
area of an object. The larger the value in the Arc Facet Angle field, the fewer the
number of triangular segments will be used on the curved object.

The maximum value for the Arc Facet Angle is 45 degrees. The minimum value
depends on the original facetting used when the curved object was drawn. For
example, the Double Patch Antenna is drawn with an Arc/Circle Resolution of 30
degrees, and the Arc Facet Angle is set to 45 degrees. The actual value used to refacet
the object will be in between these values. The angle is chosen so that the facet length
is smaller or equal to the cell size, so refacetting will not affect the cells per
wavelength that is specified for computing mesh density.

Note In order for the mesh generator to produce an accurate mesh, the mesher must
be able to recognize the polygon translation it receives as an arc. Therefore, a poorly
defined layout resolution may prevent arc recognition and by that arc refacetting. For
more information on layout resolution, refer to “Mesh Precision and Gap Resolution”
on page 7-26.
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The VIASTUB example is shown below, the Arc Facet Angle is set to 45 degrees, the
coarsest setting, and 0.01degrees, which effectively turns off refacetting. The mesh
for a stub based on each angle setting is displayed. The simulation for the denser
mesh was longer, required more memory, and produced little improvement in the
results.

arc facet angle is 0.01 arc facet angle is 45

results are
identical
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Processing Object Overlap

The parameter Thin layer overlap extraction should be used in designs that include
thin layers that are both close together and overlapping. It is possible that mesh cells
can be generated that cross the overlap region, and this is not desirable.

As an example, consider two layers, one above the other, and close together. They
carry a large charge density where they overlap, which increases proportionally to
1/distance. If there is no metal above the layers, the charge density is nearly zero
where there is no overlap, and the change is very rapid—nearly a step—at the point
of overlap.

If no overlap extraction is performed, the mesher can create cells that will cross the
border of the overlap. In the actual circuit, this cell would have a partially high
charge density area where the overlap is present, and a partially low charge density
area where there is no overlap. However, Momentum simulates cells with a constant
charge density, and approximating the strongly-varying charge in the cell with a

Arc Facet Angle = 45 Arc Facet Angle = 0.01

Process size 6.18 MB 12.791 MB

User time 12 min 20 min

Elapsed time 15 min 24 min

Rectangular cells 96 80

Triangular cells 108 200

Via cells 16 36

Unknown currents 337 453

layer 1

dielectric

cross-section view
of layers

area of overlap
high charge density

layer 2
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constant is not an adequate representation. Thus, by enabling thin layer extraction,
no cells will be created that cross an overlap region.

Because enabling this feature for all possible overlap in a circuit would create too
dense a mesh, some empirical rules are implemented that switch the overlap
extraction off if the layers are not close (h > 0.02 estimated cell size) or if the overlap
area is small. To calculate the estimated cell size, the mesh frequency, the global
number of cells per wavelength, and an estimation of the effective refractive index of
the substrate are used.

If you are calculating your mesh at low frequencies, the estimated cell size is high,
and you may not want thin layer overlap extraction. In this case, disable the Thin
layer overlap function.

Mesh Generator Messages

When a mesh is generated, you may see a message similar to this:

On some layers, the mesher used the maximum allowable cell size for the given
substrate. You will not be able to generate a coarser mesh on these layers.

This means that the coarsest mesh has been achieved for the objects on certain
layers. This is because the maximum cell size has been limited due to the accuracy of
the Green’s functions that were calculated for the substrate.

For example, consider a layout with 20-cell mesh when the mesh frequency is 10
GHz. Generally, you would get a 10-cell mesh if you set the mesh frequency to 5 GHz.
But if, with the lower mesh frequency, the cell size would be larger that the maximum

top views of layer 1

mesh cell crosses
into area of overlap

with overlap extraction,
cells are resized, there
is no crossover into
area of overlap
About the Mesh Generator 7-23



Mesh
allowed (the limit being based on the accuracy of the Greens’ function of the
substrate), the mesh would contain more than 10 cells.

Another message that may occur at meshing reports:

“POLYLINE requires two unique points”

This occurs if the layout resolution, (set at the Layout Units tab in Options >
Preferences...) is inadequate for slanting the meshing line. Increasing the resolution
to a finer value will make the error disappear.

Guidelines for Meshing
The default mesh will provide an adequate and accurate answer for many circuit
applications. For most other circuit applications, the using the global mesh
parameters will be all that is needed to provide greater accuracy. In a few special
cases, you may need to use the layer or primitive mesh controls.

For applications such as highly accurate discontinuity modeling or for geometries
that have tightly coupled lines, the default mesh may not be dense enough in
particular areas to provide enough accuracy. In such cases, edge mesh should be used
or the mesh density must be increased. For example, noise floor and dynamic range
are typically small numbers. In some cases, geometry solutions may show a low value
of S21, like -60 dB, using a dense mesh. Such values are different for a default mesh,
which may result in -40 dB for the same circuit.

In any one design, you can use any combination of the four types of mesh control. In
general, greater mesh density can provide more accuracy. But greater density takes
more computation time (more cells to solve) and, additionally, triangles always take
longer to compute than rectangles.

Meshing Thin Layers

Thin layers must be meshed so that the mesh cells are entirely within or entirely
outside of the overlapping area. If the mesh cells and object boundaries are not
aligned correctly, the simulation data may be less accurate.

For more information, refer to “Processing Object Overlap” on page 7-22.
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Meshing Thin Lines

When the geometry has narrow lines, like thin transmission paths in a spiral, it may
be difficult to have a mesh that is more than one cell across the width if the default
global mesh is used. If needed, use Edge Mesh or Transmission Line Mesh to capture
the current distribution across the line.

Meshing Slots

Slots should be meshed exactly the same as strips—there is no difference. For
example, the edge mesh can be used for slots because the current distribution is
basically the same, that is, it is concentrated on the edges of a slot.

Adjusting the Mesh Density of Curved Objects

Vias or other curved objects, when drawn in a layout, have a default value for the
number of facets used to draw the object, based on the command Options >
Preferences> Entry/Edit >Arc/Circle Radius (degrees). If the value is small, a
relatively large number of facets are used to draw the circle, and this can result in
more triangular cells created the curved areas during the mesh process. To change
the number of facets for all arcs and circles, use the command shown above. To
change them for a single object, select the object, then choose Edit > Modify >
Arc/Circle Resolution. Then increase the number of degrees for the radius, as
desired, to reduce the number of triangles. Be aware that this does alter the geometry
of the circuit.

For information on how the mesh parameter Arc Facet Angle affects a mesh, refer to
“Using the Arc Facet Angle” on page 7-20.

Discontinuity Modeling

A microstrip transmission line with a bend, using the default mesh, may have a cell
size equal to the width of the line (one cell per line-width). If it is long and the bend is
not severe, then the default mesh may be adequate because the discontinuity is
proportionally small compared to the line length. However, if the reference planes are
moved inward or if the bend is more severe, the discontinuity and resulting parasitics
are in greater proportion to the rest of the line. In that case, the default mesh may
result in simulation data with an error.
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To correct this inaccuracy, the mesh should be increased and edge mesh used. When
the area near the discontinuity is meshed so that the cell size is equal to a third of the
line-width (three cells per line-width) the resulting error is reduced. The denser mesh
allows for current crowding (parasitic series inductance) at the interior corner of the
bend and charge build-up (parasitic shunt capacitance) at the outer edge of the bend.

Solving Tightly Coupled Lines

An example of a tightly coupled line would be a microstrip coupled line filter on a 25
mil Alumina substrate (Er = 9.8) where the line width is 25 mils and the separation
between the lines is 2.5 mils. The filter response is sensitive to coupling between the
lines and the default mesh is 1 cells per line-width. In this case, the reflection
coefficient data does not match measurement data. To solve this design properly, edge
mesh must be used.

Editing Object Seeding

The recommended way to seed primitives is to use the o,u,v-coordinate system:

1. Select the object.

2. Choose Momentum > Mesh > Setup .

3. Click Primitive Seed .

4. Click Clear.

5. Select new seed parameters.

It is possible to modify these values by editing the properties of the object. This
method is not supported or recommended. Select the object, then choose Edit >
Properties. Seed values are displayed and can be changed.

Mesh Precision and Gap Resolution

This section will apply mainly to designs that are imported into Advanced Design
System.

Mesh resolution is directly related to the Layout Precision dbu (data base units)
value. All gaps or other unresolved layout vertices will be resolved by the mesh
generator if their distance is less than 2 dbu.
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Use the Layout command Options > Preferences > Layout Units to change the units
for your fabrication or layout process as needed.

Gap is 0.1 mil actual.

Mesh recognizes gap because
precision is within the dbu
units setting.

Gap is collapsed in the mesh
because the dbu precision
value is greater than the gap.

EXAMPLE: Precision dbu set to 0.01mil.

EXAMPLE: Precision dbu set to 1 mil.
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Chapter 8: Simulation
The simulation process combines the Green’s functions that were calculated for the
substrate of a circuit, plus mesh information that was calculated for the circuit, and
solves for currents in the circuit. Using these current calculations, S-parameters are
then calculated for the circuit.

Prior to running a simulation, the following criteria must be met:

• A substrate definition must be specified for the circuit

• The circuit must include at least one port

• A mesh must be defined for the circuit

• A simulation frequency plan must be specified

If any one of the above criteria is not met, Momentum will report the error if you try
to run a simulation.

The Momentum planar solver uses information from the substrate database and the
mesh generator to perform the circuit simulation. The substrate calculations and
mesh may be computed prior to running the simulation to ensure they are valid. This
will reduce simulation time.

The steps for performing a simulation include:

• Specifying and editing frequency plans

• Selecting a process mode

• Specifying solution files

• Electing to view data

• Running the simulation

The steps for each part of this procedure follows.

Note Momentum creates several files during simulation. One of these files,
../mom_dsn/proj_cvi can be large. (This file contains the computed currents.) After you
are finished with a project and no longer need to view the currents or do far field
calculations, you may want to delete this file to free disk space.
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Setting Up a Frequency Plan
You can set up multiple frequency plans for a simulation. For each plan, you can
specify that a solution be found for a single frequency point or over a frequency range.
You can also select one of several sweep types for a plan. This collection of frequency
plans will be run as a single simulation.

To set up a frequency plan:

1. Choose Momentum > Simulation > S-parameters .

2. Select a sweep type. The choices are:

• Adaptive

• Logarithmic

• Linear

• Single point

Adaptive is the preferred sweep type. It uses a fast, highly accurate method of
comparing sampled S-parameter data points to a rational fitting model. The
value entered in the Sample Points Limit field is the maximum number of
samples used in an attempt to achieve convergence. The solutions from the final
attempt will be saved. If convergence is achieved using fewer samples, the
solutions are saved and the simulation will end. For more information about
this sweep type, refer to “About Adaptive Frequency Sampling” on page 8-20.

Logarithmic simulates over a frequency range, selecting the frequency points to
be simulated in logarithmic increments. Type the start and the stop frequencies
in the Start and Stop fields, and select frequency units for each. Enter the
number of frequency points to be simulated per decade of frequency in the
Points/Decade field, and select units.

Linear simulates over a frequency range, selecting the frequency points to be
simulated in linear increments based on the step size you specify. Type the start
and the stop frequencies in the Start and Stop fields, and select frequency units
for each. Enter the step size in the Step field, and select units.

Single simulates at a single frequency point. Type the value in the Frequency
field and select the units.

3. When you are finished setting the plan, click Add to Frequency Plan List .
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Note In a simulation, frequency plans are executed in the order in which they
appear in this list.

4. Repeat these steps to insert additional frequency plans.

5. When you are finished, click Apply .

Considerations

In general, the Adaptive sweep type is the preferred sweep type. The exception is
cases where a specific frequency point or points must be simulated, such as the need
to view antenna patterns. Since radiation patterns can be calculated only at solved
frequencies, you may want to specify a single specific frequency using the Single
sweep type, or a range using Linear or Logarithmic sweep types.

If you use one or more sweep types, make sure to set up your frequency plan list so
that plans with Adaptive sweep types are at the top of the list. Any additional plans
that use other sweep types should follow these plans.

Editing Frequency Plans

You can modify, delete, or move frequency plans in the Frequency Plans list.

To modify a frequency plan:

1. Choose Momentum > Simulation > S-parameters .

2. Select the frequency plan from the Frequency Plans list.

3. Edit the plan using the sweep type and frequency fields displayed under
Edit/Define Frequency plan. These fields are described in the previous section.

4. When you are finished editing the plan, click Update .

5. Click Apply  to save the changes.

To delete a frequency plan:

1. Choose Momentum > Simulation > S-parameters .

2. Select the frequency plan from the Frequency Plans list.

3. Click Cut .
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4. Click Apply  to save the changes.

To move a frequency plan:

1. Choose Momentum > Simulation > S-parameters .

2. Select frequency plan from the Frequency Plans list.

3. Click Cut .

4. Select the frequency plan that you want positioned below the plan that you cut.

5. Click Paste  to reenter the plan.

6. Click Apply  to save the changes.

Tip You can perform several editing tasks, then click Apply  once before you dismiss
the dialog box.

Selecting a Process Mode
You can select whether the simulation is to be performed in the foreground, the
background or is to be queued. The Foreground mode will pause a simulation if the
substrate has not yet been precomputed. In this case, you can choose to stop the
simulation or, if you choose to continue, the substrate will be precomputed and then
the simulation will be performed. The Background mode automatically precomputes
the substrate if necessary, without prompting you to stop or continue the simulation,
then performs the simulation. In either mode, the Layout window is available to build
or edit layouts. For more information on precomputing a substrate, refer to
“Precomputing the Substrate Function” on page 3-21. For information on queueing
refer to “Batch Mode Simulation” on page 8-13.

To set the process mode:

1. Choose Momentum > Simulation > S-parameters .

2. Select the process mode: choose either Foreground, Background or Queued.

3. Click Apply .
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Reusing Simulation Data
To reduce the time required to complete the current simulation, you can use sampled
data from the previous simulation. This function is useful if you extend or shift the
frequency plan and resimulate, or if you want more samples near a resonance
frequency. If you change the circuit geometry, substrate, ports, or mesh parameters,
simulation data cannot be reused.

Note Momentum does not verify that the design has not changed. Make sure that
only the frequency plan has changed before attempting to reuse data.

Enabling the function reuses previously calculated S-50 parameters.

To reuse data from the last simulation:

1. Choose Momentum > Simulation > S-parameters .

2. Enable Reuse files from previous simulation  if you want to use data from the
previous simulation. Sampled data from the previous simulation will be used in
the current simulation, which can decrease simulation time.

3. Click Apply .

Saving Simulation Data
A dataset stores the solutions for one simulation only. If you perform multiple
simulations and want to save the data from previous simulations, you must specify a
unique dataset name for each simulation.

One simulation can produce one or two datasets:

• Data at the frequency points computed by the simulator are stored in
<project_name>.ds. It is the standard dataset created from any simulation.

• If the Adaptive sweep type is used to simulate, data computed by AFS at each
sampled frequency point is stored in the dataset <project_name>_a.ds.

If you change the name in the Dataset field, the datasets will use the new name and
not the default project_name.

To specify the dataset:

1. Choose Momentum > Simulation > S-parameters .
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2. The name of the default dataset is displayed in the Dataset field. This is the file
in which the simulation data will be stored. The default name is based on the
name of the current project.

If you want to use a different dataset, either type the name of a new dataset
into the Dataset field, or click Browse to reuse a dataset. If you choose Browse , a
list of the datasets in the data folder of the current project are displayed. Select
file name and click OK.

Dataset files use the extension .ds and are stored in the data folder of the current
project.

3. Click Apply  to accept the changes.

Saving Data for Export

Momentum simulation data can be saved to a file for use in IC-CAP. Momentum
design geometry and setup information can be saved for import into Ansoft HFSS
and CST Microwave Studio without running a simulation first. For more information,
refer to Appendix C, Exporting Momentum Data.

Viewing Results Automatically
Simulation data is saved in datasets, so you can view simulation results at your
convenience. If you choose to view results immediately after the simulation is
complete, enable Open data display when simulation completes. A data display
window containing default plot types or the data display template of your choice will
be automatically opened when the simulation is finished. The defaults include
magnitude and phase plots of S-parameters, and S-parameters plotted on Smith
charts.

If you are using the Adaptive sweep type for your simulation, the data from both the
standard and adaptive datasets are displayed for comparison. Data from the
standard dataset will be displayed as discrete points, the adaptive sweep data will be
displayed as a linear trace.

To open a data display window:

1. Choose Momentum > Simulation > S-parameters .

2. Enable Open data display when simulation completes.
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3. If you want a template to be loaded into the window, type the name of the
template in the Template field or click Browse . A list of templates in the data
folder of the current project are displayed. Select a template and click OK.

Note If you want to use a template from another project or location, copy the
template into the data folder of the current project.

4. Click Apply  to accept the changes.

Starting a Simulation
The simulation process solves for currents by combining the Green’s functions that
were precomputed for the substrate and the mesh calculations. S-parameters are
then calculated and saved to the dataset.

To start a simulation:

1. Choose Momentum > Simulation > S-parameters .

2. Verify that at least one frequency plan appears in the Frequency Plans list.

3. Check that the Process Mode, Solution Files, and Data Display options are set
to your specifications.

4. Click Simulate .

Note If you select Foreground or Background in Process Mode section of the
Simulation dialog box your simulation will start immediately. If you select Queued,
your simulation will be put on a queue and must be started from the Queue Manager,
see “Batch Mode Simulation” on page 8-13.

Any messages or errors that occur are displayed in the Momentum Status window. To
indicate progress, a line of dots appears across the Status window if the number of
unknowns in the simulation is greater than 500; otherwise, only the frequencies are
displayed.

If the simulation fails for a reason related to the setup, the partial data is saved and a
message appears in the Status window.
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Viewing Simulation Status

After a simulation is started, any messages regarding the simulation will appear in
the Momentum Status window. Messages usually refer to any errors found, the
percent of completion, and simulation completion.

If you minimize the status window and want to reopen it, from the Layout menu bar
choose Window > Simulation Status.

Note Do not close the status window. Stop simulation in not available in a new
status window after closing a previous status window.

For large projects, the dots and vertical bars (there is one “|” for every nine dots) that
appear in the status/summary window are a measure of progress of the simulations
execution. A full line of 36 dots and four vertical bars means the task is completed.
Each dot represents the task as being 2.5% complete. Nine dots and one vertical bar
(.........|) represents the task as being 25% complete.

Understanding the “% Covered” Status Message

This message is generated when running Adaptive sweep types. It indicates the
percentage of the total simulation frequency range that has been accurately modeled
by rational functions. When an Adaptive sweep starts, the AFS process attempts to
represent all S-parameters with a number of rational functions. New sample points
are selected adaptively (by minimizing global error criteria). If the frequency range is
too large, the frequency range will be split into sections. If the fitting model is
accurate and stable within a subrange, the “% covered” message will be updated.
Thus, the message indicates the percentage of the total simulation frequency range
that has been accurately modeled by rational functions.

The AFS process always looks at the whole frequency range and adds samples where
the fitting errors are maximal (a global error reduction approach). If the fitting
converged in a section of the frequency range, it is likely to converge in the remaining
sections, and it will not take many extra samples to achieve full convergence. This is
why the percent completed message updates very slowly at first, but updates quickly
when the process is nearly complete.
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Stopping a Simulation
To stop a simulation:

1. From the Momentum Status window, choose Simulation/Synthesis > Stop
Simulation .

The simulation will stop and the partial data will be saved. To reuse the saved
data:

• Choose Momentum > Simulation > S-parameters , enable Reuse files from
previous simulation , click Apply , then click Simulate .

Note If a simulation is started from the queue, you must disconnect the queue,
using the Queue Manager, before stopping the simulation.

Viewing the Simulation Summary
As the simulation progresses, you can view substrate, mesh, and solution statistics.
Some of the information returned includes time to solve, the resources required, cell
information, and any messages that were displayed in the status window. An
example of solution statistics is given next.

Choose Momentum > Simulation > Summary to view the data. Click Refresh to
update the statistics as the simulation progresses. The following example shows a
(partial) summary displayed when using the Momentum microwave simulation
mode.
Stopping a Simulation 8-9



Simulation
========================================================================
                     --- MOMENTUM GENERATION STATISTICS ---
========================================================================
                           Momentum 4.0 (*)  150.999
                           Tue Jun 12 16:06:24 2001
------------------------------------------------------------------------
TOTALS
------------------------------------------------------------------------

Process size : 2.16 MB
User Time : 0h01m11s
Elapsed Time : 0h01m13s
========================================================================

--- MOMENTUM MESH STATISTICS ---
========================================================================

Momentum 4.0 (*)  150.999
Tue Jun 12 16:06:24 2001

-----------------------------------------------------------------------
Mesh Info:
---------
Rectangular cells : 148
Triangular cells : 2
Via cells : 16
Unknown currents : 252

Resources:
---------
Process size : 1.41 MB
User Time :  0h00m00s
Elapsed Time : 0h00m02s

======================================================================== =
                 ---   STATUS SERVER MESSAGES  ---

========================================================================
 Simulation / Synthesis Messages
Mesh will be generated @ 2.000000 GHz
Status / Summary
----------- Momentum Simulation --------------
Version: Momentum 4.0 (*)  150.999 Dec 13 2000
Simulation mode: microwave
Design: cir
start compute mesh on Tue Jun 12 16:06:16 2001
mesh computation successful on Tue Jun 12 16:06:24 2001
start simulate circuit on Tue Jun 12 16:06:24 2001
start calculate low frequency behavior.
simulation frequency = 0.000000 GHz
simulation frequency = 0.109000 GHz
simulation frequency = 0.218000 GHz
start adaptive frequency sweep.
simulation frequency = 2.00000 GHz
adaptive frequency sweep:   0.0 % of frequency range covered.
simulation frequency = 1.33333 GHz
simulation frequency = 0.666667 GHz
adaptive frequency sweep: 100.0 % of frequency range covered.
circuit simulation successful on Tue Jun 12 16:06:59 2001
Writing dataset files...
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The next example shows a summary from another project using the Momentum RF
mode. Notice that it contains information about the matrix size after mesh reduction
and the statistics for the quasi-static calculations.
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For examples of substrate and mesh statistics, refer to “Viewing Substrate
Computation Status” on page 3-22, and “Viewing the Mesh Summary” on page 7-12.

=======================================================================
------ MOMENTUM SUMMARY ------

Momentum RF 4.0 (*) 150.400
Tue Sep 12 13:56:05 2000

-----------------------------------------------------------------------
MESH
-----------------------------------------------------------------------
STATISTICS
----------

Rectangular cells : 295
Triangular cells : 2451
Via cells : 168
Edge currents : 3369

RESOURCES
---------

Process size : 6.20 MB
User Time : 0h 5m49s
Elapsed Time : 0h 5m52s

-----------------------------------------------------------------------
SOLVER USER TIME ELAPSED TIME MEMORY
PROCESSES (h:m:s) (h:m:s) (MB)
-----------------------------------------------------------------------
SIMULATION SET-UP
-----------------

Initialization | 0: 0: 0 | 0: 0: 2 | 2.93
Ports analysis | 0: 0: 0 | 0: 0: 0 | 0.53
Mesh reduction | 0: 0: 1 | 0: 0: 1 | 5.82
Basis creation | 0: 0: 0 | 0: 0: 1 | 6.64
Basis unknowns : 783

QUASI-STATIC CALCULATIONS
-------------------------

Green functions | 0: 0: 0 | 0: 0: 0 | 0.20
Matrix load | 0:15:56 | 0:15:58 | 9.82

1. SIMULATION FREQUENCY = 0 Hz
-------------------------

Matrix load | 0: 0: 0 | 0: 0: 0 | 6.19
Matrix solve | 0: 0:13 | 0: 0: 0 | 0.03
S parameters | 0: 0: 8 | 0: 0: 8 | 7.35
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Batch Mode Simulation
Batch mode simulations are setup and controlled using the Queue Manager dialog
box. The Queue Manager is automatically started when submitting a queued job, or it
can be invoked by selecting Tools > Queue manager in the ADS Main window. Exiting
ADS will stop the Momentum queue and all running jobs.

When the queue is running in normal operation (queue connected), the first waiting
job will automatically start after the current job finishes. If the queue is in Queue
Disconnected mode, then the first waiting job will not start automatically when the
current job finishes.

When connected, the Queue Manager can be used to view jobs in the queue. When the
queue is disconnected, or hasn’t been started, the Queue Manager not only can be
used to view jobs in the queue but can also be used to add jobs, modify or delete
scheduled jobs, or change the order of jobs in the queue.

Note Jobs cannot be modified using the Queue Manager when they are currently
active (simulating). To modify these jobs, disconnect the queue, stop the simulation,
(see “Stopping a Simulation” on page 8-9) make your modifications, and resume.

To run a batch mode simulation:

1. Define the design you want to simulate.

2. In the Momentum > Simulation > S- parameters dialog box, select Queued  in
the Process Mode and then select simulate .

3. Repeat the previous two steps to add additional simulations to the queue.

4. Select Start Simulations  in the Queue Manager to begin simulating after all
simulations are queued.

Note If the Queue Manager indicates that simulations are running when they are
not, type queue_reset() in the command line dialog box to fix the problem.
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Caution Running Momentum simulations in parallel (e.g., a direct Momentum
simulation and a queued Momentum simulation) from the same ADS session may
cause the loss of simulation data if both simulations end simultaneously

Note When Momentum batch simulations are run from different projects, the active
project directory changes when the simulation finishes if a new one needs to be
loaded from a different project.

Performing Remote Simulations
Momentum can require significant computer resources in order to perform a
simulation. Depending on your needs, it might be advantageous to install a relatively
powerful computer with a large amount of RAM, and dedicate it for running
simulations only, while using less powerful workstations for other tasks. With such a
setup, you can perform design and setup procedures from a local, less powerful
workstation, while the simulations, which require the bulk of the
computation-intensive operations, are sent off to the (remote) computer that you have
dedicated for running simulations.

Note Refer to the installation guides for instructions on performing remote
simulations with other simulators.

Momentum remote simutlation does not support the Load Sharing Facility (LSF)
function.

Momentum is designed to support remote operation. You can perform remote
simulations using these hardware configurations:

• UNIX® to UNIX

• PC to PC

The steps to perform remote simulations with these configurations are below.
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UNIX to UNIX

This section describes how to perform remote simulations from the Advanced Design
System environment using UNIX workstations.

Setting up the Remote Computer

To prepare your remote computer, perform the following steps:

1. Log in to the remote computer.

2. To launch the remote EMX daemon, set the HPEESOF_DIR variable, if this has
not been done yet.

Then, add $HPEESOF_DIR/bin to the PATH variable. Make sure that it
appears at the very beginning of PATH.

Finally, in a bourne or korn shell start the daemon using the commands:

. bootscript.sh (sets up platform-specific environment variables)
hpeesofemx -d < file_name> & (starts the EMX daemon)

Note The proceeding commands work in bourne and korn shells exclusively.

If another user has already launched the eedaemon, then it must not be launched a
second time. Subsequent remote users can connect to this daemon as well.

Setting up the Local Computer

A configuration file must to be created or modified in order to specify that Momentum
is to be run remotely, and to communicate the name of the remote server to the
Advanced Design System environment.

To create or modify the file, perform the following steps:

1. Create or locate the configuration file named:

hpeesof.cfg

2. Add the following line to the file:

MOMENTUM_SIM_PATH=<remote_computer_name>
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3. Place the file in one of four directories, which are searched in the following
order:

• The current working directory, where Advanced Design System has been
launched;

• $HOME/hpeesof/config (most used by individual users);

• $HPEESOF_DIR/custom/config (sets Momentum in remote mode for the
whole site);

• $HPEESOF_DIR/config (the preinstalled configuration, valid for the whole
site);

4. Start Advanced Design System by typing:

ads

Running the Simulation

Starting a remote Momentum simulation is no different than starting a local one.
The same menu selections apply:

• Momentum > Substrate > Precompute

• Momentum > Mesh > Precompute

• Momentum > Simulation > S-parameters

• Momentum > Post-Processing > Radiation Pattern

There are some differences between local and remote simulations in the use of files,
though. A local Momentum simulation is usually carried out in a temporary
directory; remote Momentum simulations are calculated in another directory. The
temporary directory is guaranteed to have a unique name by a call to a utility
tmpnam, but is always placed under /usr/tmp or /var/tmp. Both of these directories
can only be accessed by a remote server in very tightly coupled clusters. This is an
unnecessary severe restriction. Therefore, the remote computations write their
results under the local $HOME/mom_tmp/<temporary_name>.
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Ending Remote Operation

To end a remote simulation setup:

1. On the local machine, exit Advanced Design System.

2. Undo the modification made to the hpeesof.cfg file.

3. Kill the hpeesofemx daemon that is running on the remote server.

4. Log out from the remote server.

The next time Advanced Design System is launched, it will operate Momentum
locally again.

Restrictions

Be aware that the following restrictions apply to remote simulation:

The $HOME/mom_tmp/<temporary_name> directory has wide access permissions
(0777).

The $HOME directory, which resides on the local file system, must be visible under
the same path from the remote server (through NFS).

If a substrate computation is required, the user must set access permissions on
$HOME/substrates to 0777, and the permissions of the files under it to 0666.
However, if the user forgets to do so, the UI will test for it, and it will warn the user
that this must be done.

Under ADS 1.3 and later, remote Momentum simulation behaves exactly the same
way as under Series IV 6.1 release 305.

Momentum remote simutlation does not support the Load Sharing Facility (LSF)
function.
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PC to PC

This section describes how to perform remote simulations from the Advanced Design
System environment using PCs.

Supported PC platforms are:

• Windows® 2000 Professional SP4

• Windows XP Professional SP1

Setting up the Remote Computer

To prepare your remote computer, you must start the remote EMX daemon by
performing the following steps:

1. Set the HPEESOF_DIR variable, if this has not been done yet;

2. Add %HPEESOF_DIR%/bin to the PATH variable. Make sure that it appears at
the very beginning of PATH.

3. Start the daemon with the command (either from Windows or from an
MS-DOS® shell) by typing

hpeesofemx

or, if diagnostic messages are to be kept in a file for verification:

hpeesofemx -v -d < file_name>

Caution Do not terminate the MS-DOS window that will pop up. Doing so will
immediately kill the daemon as well.

Setting up the Local Computer

A configuration file must to be created or modified in order to specify that Momentum
is to be run remotely, and to communicate the name of the remote server to the
Advanced Design System environment.

To create or modify the file, perform the following steps:

1. Create or locate the configuration file named:

hpeesof.cfg
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Add the following line to the file:

MOMENTUM_SIM_PATH=<remote_computer_name>

2. Place the file in one of four directories, which are searched in the following
order:

• The current working directory, where Advanced Design System has been
launched

• %HOME%\hpeesof\config (most used by individual users)

• %HPEESOF_DIR%\custom\config (sets Momentum in remote mode for the
whole site)

• %HPEESOF_DIR%\config (the preinstalled configuration, valid for the
whole site)

3. Start Advanced Design System by typing:

ads

Running the Simulation

Launching Momentum simulations is no different than launching local ones. The
same menu commands apply:

• Momentum > Substrate > Precompute

• Momentum > Mesh > Precompute

• Momentum > Simulation > S-parameters

• Momentum > Post-Processing > Radiation Pattern

There are some differences between local and remote simulations in the use of files,
though. A local Momentum simulation is usually carried out in a temporary
directory; remote Momentum simulations are calculated in another directory. The
temporary directory is guaranteed to have a unique name by a call to a utility
tmpnam, but is always placed under \temp. As on UNIX, the remote computations
write their results under the local %HOME%\mom_tmp\<temporary_name>.

Ending Remote Operation

To end a remote simulation setup:

1. On the local machine, exit Advanced Design System.
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2. Undo the modification made to the hpeesof.cfg file.

3. Kill the hpeesofemx daemon that is running on the remote server.

The next time Advanced Design System is launched, it will operate Momentum
locally again.

Restrictions

Be aware that the following restrictions apply to remote simulation:

• The $HOME directory, which resides on the local file system, must be visible
under the same path from the remote server. The restriction here is that the
whole drive must be shared among the PCs.

• If a substrate computation is required, the user must set the
$HOME\substrates directory and the files under it accessible for reading and
writing. However, if the user forgets to do so, the UI will test for it, and it will
warn the user that this must be done.

About Adaptive Frequency Sampling
Adaptive Frequency Sampling (AFS) is a method of comparing sampled S-parameter
data points to a rational fitting model. In order to accurately represent the spectral
response of the circuit, the AFS feature in Momentum takes a minimal number of
frequency samples and then applies its algorithm to the sampled data. Wherever the
S-parameters vary the most, more samples are taken. When the fitting model and the
sampled data converge, the AFS algorithm is then complete and the S-parameter
data is written into the dataset. In this way, the maximum amount of information can
be obtained from the minimum amount of sampling.

By using the AFS feature, you can greatly reduce the amount of time required to
simulate circuits that have resonances or other sharp responses that are difficult to
detect. Data that would have remained hidden using other types of analyses can now
be obtained.

Even in the case of a low-pass filter, AFS can solve for the S-parameters faster and
more accurately than discrete data sampling. For example, if you were measuring a
2 GHz low-pass filter, you would enable the AFS feature and then enter a start
frequency of 500 MHz and a stop frequency of 4 GHz. AFS would then sample the two
end points, construct the fitting model, and then sample points in between as needed.
As this occurs, the model is automatically refined and appropriate sample points are
taken until the model and the sampled data converge. When convergence is reached,
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both sampled data and the AFS data are written into two separate datasets and can
be presented as S-parameter traces on a plot. If the max sample size is reached before
converging, the partial results will be saved and can be reused by simulating the
circuit again.

Note AFS data must converge in order to be accurate. Be sure the data is converged
by checking the message in the Momentum Status window. If data is not converged,
you will see inaccurate results.

AFS Convergence

Convergence is determined by how close the fitting model is to the sampled data.
Convergence is achieved when the sampled points are accurate to -75 dB, and the
overall accuracy is -60 dB.

When AFS is used, be sure that the sampled data has converged with the fitting
model. This can be checked by the messages in the status window. If converged, the
message will be that AFS is complete. If not converged, a warning will appear.
Examples of such warning messages are:

Maximum number of adaptive frequency samples reached!

Fitting models not (completely) converged.

Consider:- increasing maximum number of sample points.
- activating the reuse option.

If you encounter errors, try decreasing the frequency range of the frequency plan and
increasing the number of sample points. Theoretically, some circuits may require
several dozen points to converge if they are electrically long. This is because the AFS
program samples the data at about each 60 degree rotation, in the Smith chart, of the
S-parameter with the most phase variation.

Note If you simulation does not converge, to help you assess the quality of the
simulation, you can view convergence results in the Data Display. For more
information, refer to “Viewing Convergence Data” on page 10-6.
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Setting Sample Points

If you are using the Adaptive sweep type in a simulation, you may want to select
specific sample points to be used in the AFS process. In general, this is not necessary
(and is in fact, discouraged), but there may be instances where it is beneficial. An
application where this may be beneficial is simulating a structure that has a distinct
variation in response at some point over a frequency range, such as a resonant
structure. To set up the simulation:

1. Select the Single sweep type, enter either the value of the resonant frequency or
a value near it in the Frequency field, and add this to the frequency plan list.

2. Select the Adaptive sweep type, set up the plan, then add it to the list of
frequency plans.

For this situation, the sample point aids the AFS process by identifying an area
where there is clearly a variation in the response of the circuit.

Applying extra sample points may be necessary for visualization or far-field
calculations.

It is not beneficial to attempt to add sample points for other purposes, such as
attempting to force smoothing to occur at specific points, without taking into
consideration the response at these points. For example:

1. Selecting the Linear sweep type, adding sample points spread linearly across
the frequency range, and adding the frequency plan to the list.

2. Adding an Adaptive sweep type, selecting the same frequency range, and
adding it to the list.

For this situation, the sample points from the linear simulation will be included in
the adaptive simulation. This impedes the AFS process of selecting the optimal
distribution of samples over the frequency range, and this can produce poor
simulation results.

To remedy this situation, either run the Adaptive sweep plan first or make sure that
the frequency ranges of the two plans do not overlap.

Viewing AFS S-parameters

When viewing the S-parameters in an AFS dataset, if you zoom in you may see small,
unexpected spurious ripples or oscillations, with an amplitude less than 0.0002. The
amplitude of these oscillations is always less than the AFS accuracy level, which is
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approximately -60 dB. Generally, these ripples will only appear if the dynamic
behavior of the S-parameters is limited, for example, an S-parameter that is nearly 1
over the frequency range simulated. This is likely due to the rational fitting model
have too many degrees of freedom and being too complex for this situation
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Chapter 9: Radiation Patterns and Antenna
Characteristics
This chapter describes how to calculate the radiation fields. It also provides general
information about the antenna characteristics that can be derived based on the
radiation fields. In Momentum RF mode, radiation patterns and antenna
characteristics are not available.

About Radiation Patterns
Once the currents on the circuit are known, the electromagnetic fields can be
computed. They can be expressed in the spherical coordinate system attached to your
circuit as shown in Figure 9-1. The electric and magnetic fields contain terms that
vary as 1/r, 1/r2 etc. It can be shown that the terms that vary as 1/r2, 1/r3, ... are
associated with the energy storage around the circuit. They are called the reactive
field or near-field components. The terms having a 1/r dependence become dominant
at large distances and represent the power radiated by the circuit. Those are called
the far-field components (Eff, Hff).

Note In the direction parallel to the substrate (theta = 90 degrees), parallel plate
modes or surface wave modes, that vary as 1/sqrt(r), may be present, too. Although
they will dominate in this direction, and account for a part of the power emitted by
the circuit, they are not considered to be part of the far-fields.

The radiated power is a function of the angular position and the radial distance from
the circuit. The variation of power density with angular position is determined by the
type and design of the circuit. It can be graphically represented as a radiation
pattern.

E r ∞ θ ϕ, ,→( ) Eff θ ϕ,( )e jkr–

r
------------=

H r ∞ θ ϕ, ,→( ) Hff θ ϕ,( )e jkr–

r
------------=
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Radiation Patterns and Antenna Characteristics
The far-fields can only be computed at those frequencies that were calculated during
a simulation. The far-fields will be computed for a specific frequency and for a specific
excitation state. They will be computed in all directions (theta, phi) in the open half
space above and/or below the circuit. Besides the far-fields, derived radiation pattern
quantities such as gain, directivity, axial ratio, etc. are computed.

Note It is possible to calculate far-fields for some designs that have a top or bottom
layer that is not defined as open space. For more information on these structures,
refer to “377 Ohm Terminations and Radiation Patterns” on page 3-29.

About Antenna Characteristics
Based on the radiation fields, polarization and other antenna characteristics such as
gain, directivity, and radiated power can be derived.

Polarization

The far-field can be decomposed in several ways. You can work with the basic
decomposition in ( , ). However, with linear polarized antennas, it is sometimes
more convenient to decompose the far-fields into (Eco, Ecross) which is a decomposition
based on an antenna measurement set-up. For circular polarized antennas, a
decomposition into left and right hand polarized field components (Elhp, Erhp) is most
appropriate. Below you can find how the different components are related to each
other.

 is the characteristic impedance of the open half sphere under consideration.

Eθ Eϕ

Eff θ ϕ,( ) Eθ θ ϕ,( )iθ Eϕ θ ϕ,( )iϕ+ Eco θ ϕ,( )ico Ecross θ ϕ,( )icross+ Elhp θ ϕ,( )ilhp Erhp θ ϕ,( )irhp+= = =

Hϕ
Eθ
Zw
-------=

Hθ
Eϕ
Zw
-------–=

Zω
µ
ε
---=

Zω
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The fields can be normalized with respect to

Circular Polarization

Below is shown how the left hand and right hand circular polarized field components
are derived. From those, the circular polarization axial ratio (ARcp) can be calculated.
The axial ratio describes how well the antenna is circular polarized. If its amplitude
equals one, the fields are perfectly circularly polarized. It becomes infinite when the
fields are linearly polarized.

Linear Polarization

Below, the equations to decompose the far-fields into a co and cross polarized field are
given (  is the co polarization angle). From those, a “linear polarization axial ratio”
(ARlp) can be derived. This value illustrates how well the antenna is linearly
polarized. It equals to one when perfect linear polarization is observed and becomes
infinite for a perfect circular polarized antenna.

Note Eco is definded as colinear and Ecross implies a component orthogonal to Eco.
For a perfect linear polarized antenna, Ecross is zero and the axial ratio AR=1. If
Ecross = Eco you no longer have linear polarization but circular polarization,
resulting in AR = infnity.

max Eθ
2 Eϕ

2+( )

Elhp
1

2
------- Eθ jEϕ–( )=

Erhp
1

2
------- Eθ jEϕ+( )=

ARcp
Elhp Erhp+

Elhp Erhp–
-------------------------------------=

α

Eco Eθ α ϕ–( ) Eϕ α ϕ–( )sin+cos=

Ecross Eθ–( ) α ϕ–( ) Eϕ α ϕ–( )cos+sin=

ARlp
Eco Ecross+

Eco Ecross–
-------------------------------------=
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Figure 9-1. Co-polarization angle

Radiation Intensity

The radiation intensity in a certain direction, in watts per steradian, is given by:

For a certain direction, the radiation intensity will be maximal and equals:

Radiated Power

The total power radiated by the antenna, in Watts, is represented by:

ir

z

y

x

α−ϕα−ϕ

α−ϕ

ϕ

θ

i

θi

ϕ

α = co-polarization angle, normally chosen
parallel to main current flow on antenna.

Eco and Ecross are in iθ and iϕ plane
(perpendicular to 1, plane).

Example: α = 0 (main current flow on antenna
parallel with x-axes), results in Eco parallel with
x-axes for θ = 0, ϕ = 0.

U θ ϕ,( ) 1
2
---= Eff θ ϕ,( ) H ff∗× θ ϕ,( )( ) 1

2Zw
----------- Eθ θ ϕ,( ) 2 Eϕ θ ϕ,( ) 2+( )=

Umax max
θφ

U θ φ,( )( )=

Prad U θ ϕ,( ) dΩ⋅Ω∫
1
2
--- Eff H ff∗ dΩ⋅×Ω∫= =
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Effective Angle

This parameter is the solid angle through which all power emanating from the
antenna would flow if the maximum radiation intensity is constant for all angles over
the beam area. It is measured in steradians and is represented by:

Directivity

Directivity is dimensionless and is represented by:

The maximum directivity is given by:

Gain

The gain of the antenna is represented by:

where Pinj is the real power, in watts, injected into the circuit.

The maximum gain is given by:

Efficiency

The efficiency is given by:

ΩA
Prad

Umax
--------------=

D θ ϕ,( ) 4πU θ ϕ,( )
Prad

--------------------=

D 4π
Umax

Prad
-------------- 4π

ΩA
--------= =

G θ ϕ,( ) 4πU θ ϕ,( )
Pinj

--------------------=

G 4π
Umax

Pinj
--------------=

η
Prad

Pinj
------------ G

D
----= =
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Effective Area

The effective area, in square meters, of the antenna circuit is given by:

Calculating Radiation Patterns
To calculate a radiation pattern:

1. Choose Momentum > Post-Processing > Radiation Pattern .

2. Select the General  Tab.

3. Select a frequency from the Select Frequency listbox. The radiation pattern will
be calculated at this frequency. These are frequencies that were calculated
during the simulation.

4. Select a port from the Available Ports list to apply a steering circuit (based on
the Thevenin equivalent) to the port and inject energy into your circuit. You can
apply a steering circuit to any port.

5. In the Port Excitation fields, enter amplitude (in volts) and phase (in degrees) of
the voltage of the steering circuit of that is applied to the port.

6. In the Port Termination Impedance fields, enter the real and imaginary
components of the impedance of the steering circuit that is applied to the port.

Note You may want to terminate all ports so that the ports that are not used to
inject energy into the circuit do not cause reflections. For these ports, set the
Port Excitation voltage to zero, and set the Port Impedance to the characteristic
impedance of the port.

7. Select the display tool that you want to use. Enable either 2D Data Display or
3D Visualization. The 3D Momentum Visualization tool requires a separate
codeword. Instructions for using the tool are in following chapters.

8. If you want the display tool to open and display results automatically, enable
Open display when computation completed.

9. If you have selected to use the 3D tool, click Compute . More information on how
to use the Momentum Visualization tool are in following chapters.

Aeff θ ϕ,( ) λ2

4π
------G θ ϕ,( )=
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If you are using the Data Display, click the 2D Settings  tab and continue with
these steps.

10. Specify a dataset name where you want to store the far-field results.

11. Select the template that you want to use for formatting results, or accept the
default.

12. Select either the planar or conical Cut Type Definition:

• A planar cut is perpendicular to the circuit layout plane.

• A conical cut is a cone around the z-axis.

Refer to the diagram in the Radiation Pattern Control dialog box. For more
information, refer to “Planar (Vertical) Cut” on page 9-8 and “Conical Cut” on
page 9-8.

13. Enter the value of the cutting angle, in degrees, in the Cutting Angle field.

• For a planar cut, this angle, phi, is relative to the x-axis. Phi will be kept
constant while theta will be swept from -180 to 180 degrees.

• For a conical cut, the cutting angle, theta, is relative to the z-axis. Theta will
be kept constant while phi will be swept from 0 to 360 degrees.

14. Enter the value of the co polarization angle in the Co Polarization Angle field.
This angle will be used when decomposing the far-fields into a co and cross
polar component (see “Linear Polarization” on page 9-3).

15. Enter the threshold for displaying data in the Lower Clipping Boundary field.
Select units of dB or mag. Computed radiation pattern data that is below this
value will be displayed as zero (when units are mag) or the lower clipping
boundary (when units are dB).

16. Click Compute  to compute the radiation pattern. After computation, the
far-fields and derived antenna parameters will be stored in a dataset with the
name you specified. An _f will be appended to the dataset name. The _f
indicates that the dataset contains radiation pattern data. The dataset is stored
in the /data directory of the current project.

After the radiation calculations are performed, data is saved depending on the
display tool selected above:

• 2D Data Display was selected: all data is stored in a single dataset with the
name you specified with _f.ds appended. The _f indicates that the dataset
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contains radiation pattern data. The dataset is stored in the /data directory of
the current project.

• 3D Visualization was selected: the far-fields and derived antenna parameters
will be stored in respectively proj.fff and proj.ant in the
mom_dsn/<design_name> directory of your project.

Planar (Vertical) Cut

For the planar cut, the angle phi, which is relative to the x-axis, is kept constant. The
angle theta, which is relative to the z-axis, is swept to create a planar cut. Theta is
swept from 0 to 360 degrees. This produces a view that is perpendicular to the circuit
layout plane. Figure 9-2 illustrates a planar cut.

Figure 9-2. Planar (vertical) cut

Conical Cut

For a conical cut, the angle theta, which is relative to the z-axis, is kept constant. Phi,
which is relative to the x-axis, is swept to create a conical cut. Phi is swept from 0 to

Z axis

X

Y

 phi

theta
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360 degrees. This produces a view that is parallel to the circuit layout plane.
Figure 9-3 illustrates a conical cut.

Figure 9-3. Conical cut

Viewing Results Automatically in Data Display
If you choose to view results immediately after the far-field computation is complete,
enable Open display when computation completed. When Data Display is used for
viewing the far-field data, a data display window containing default plot types of the
data display template of your choice will be automatically opened when the
computation is finished. The default template, called FarFields, bundles four groups
of plots:

• Linear Polarization with Eco, Ecross, ARlp.

• Circular Polarization with Elhp, Erhp, ARcp.

• Absolute Fields with .

• Power with Gain, Directivity, Radiation Intensity, Efficiency.

For more information, please refer to “About Antenna Characteristics” on page 9-2.

Exporting Far-Field Data
If 3D Visualization is selected in the Radiation Pattern dialog, the normalized electric
far-field components for the complete hemisphere are saved in ASCII format in the
file <project_dir>/mom_dsn/<design_name>/proj.fff. The data is saved in the
following format:

#Frequency <f> GHz       /*  loop over  <f> */

theta (half angle opening)

Z axis

YX

phi

Eθ Eϕ Hθ Hϕ,,,
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  #Excitation #<i>         /*  loop over  <i> */
  #Begin cut               /*  loop over phi  */
<theta> <phi_0>  <real(E_theta)>  <imag(E_theta)> <real(E_phi)>
<imag(E_phi)>
                 /*   loop over <theta>    */
  #End cut
  #Begin cut
  <theta> <phi_1>  <real(E_theta)>  <imag(E_theta)> <real(E_phi)>
<imag(E_phi)>
                 /*   loop over <theta>    */
  #End cut
     :
     :
#Begin cut
  <theta> <phi_n>  <real(E_theta)>  <imag(E_theta)> <real(E_phi)>
<imag(E_phi)>
                 /*   loop over <theta>    */
  #End cut

In the proj.fff file, E_theta and E_phi represent the theta and phi components,
respectively, of the far-field values of the electric field. Note that the fields are
described in the spherical co-ordinate system (r, theta, phi) and are normalized. The
normalization constant for the fields can be derived from the values found in the
proj.ant file and equals

The proj.ant file, stored in the same directory, contains the antenna characteristics.
The data is saved in the following format:

Excitation <i> /* loop over  <i> */
Frequency <f> GHz /* loop over  <f> */
Maximum radiation intensity  <U> /* in Watts/steradian */
Angle of U_max  <theta> <phi> /* both in deg */
E_theta_max  <mag(E_theta_max)> ; E_phi_max  <mag(E_phi_max)>
E_theta_max  <real(E_theta_max)>  <imag(E_theta_max)>
E_phi_max  <real(E_phi_max)>  <imag(E_phi_max)>
Ex_max  <real(Ex_max)>  <imag(Ex_max)>
Ey_max  <real(Ey_max)>  <imag(Ey_max)>
Ez_max  <real(Ez_max)>  <imag(Ez_max)>
Power radiated  <excitation #i> <prad> /* in Watts */
Effective angle  <eff_angle_st> steradians <eff_angle_deg> degrees
Directivity  <dir> dB /* in dB */
Gain  <gain> dB /* in dB */

E_theta_max〈 〉2
E_phi_max〈 〉2

+
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The maximum electric field components (E_theta_max, E_phi_max, etc.) are those
found at the angular position where the radiation intensity is maximal. They are all
in volts.
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Chapter 10: Viewing Results Using the Data
Display
You have two tools available for displaying the results of an Momentum simulation:
the Data Display, and Momentum Visualization. The visualization tool requires a
separate codeword and is described in following chapters. This chapter describes how
to use the Data Display.

You can display the following types of results from an Momentum simulation:

• S-parameters

• Radiation patterns (far-field plots) and derived antenna parameters

Additional data is calculated during a simulation and saved in the dataset, and can
also be viewed or used in calculations:

• Propagation constant (gamma) for each port in the circuit

• Characteristic impedance of each port

• AFS convergence data

This chapter shows how to display Momentum results. For detailed information on
how to use the Data Display, refer the Data Display manual.

Opening a Data Display Window
You view simulation results using the Data Display. You can open a Data Display
window using different methods:

• Open a Data Display window automatically when a simulation is complete. For
steps on how to do this, refer to “Viewing Results Automatically” on page 8-6.

• Open a new Data Display by choosing Window > New Data Display from the
Layout Window menu bar.

• Open a saved Data Display by choosing Window > Open Data Display and
selecting a Data Display in the current project. Data Display files end in the
extension .dds.
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Viewing Momentum Data
Simulated Momentum data is saved in one or more datasets:

• Data collected at the frequency points computed by the simulator are stored in
<design_name>.ds. It is the standard dataset created from any simulation.

• If the Adaptive sweep type is used for simulation, densely resampled data,
computed by AFS at each sampled frequency point, are stored in the dataset
<design_name>_a.ds.

• If the radiation patterns are calculated and the visualization type selected is
“2D Data Display”, the results are stored in the dataset <design_name>_f.ds.

The datasets for the current project are displayed in the dataset listbox.

You can view Momentum data using any plot type:

To view Momentum data:

1. Select the plot type by clicking the appropriate plot icon, dragging the mouse
into the window, then clicking to place the plot.

2. The variables in the default dataset are displayed. Select a different dataset
from the list, if desired.

Datasets in the
current project.
The one in the menu
bar is the default.

Rectangular

Polar

Smith chart

Stacked

List
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3. Select the variables containing the data that you want to add to the plot, then
click Add .

Note Most of the simulation data is in complex format. If you are adding data
to a rectangular plot, you must choose to display the data in one of several
scalar formats.

4. You can add data from different datasets to the same plot. Repeat steps two and
three to add more data to the plot.

5. Click OK to view the data.

1. Select a dataset. 2. Select a variable. 3. Click Add. 4. Selected variables
appear here.
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Note Multiple graphs within the same view will overlay one another. To view multiple
graphs simultaneously, assign each graph to a separate view.

Viewing S-parameters
Specific information about the data available in the S-parameter datasets is given in
the following sections.

Variables in the Standard and AFS Dataset

A dataset generated from an Momentum simulation contains many variables. Below
are the names of common variables that appear in a Momentum dataset and a
description of the variable.

Variable Description

freq The independent variable frequency, which was specified during
the simulation setup. The number of data points is based on the
sweep type and frequency plans specified during simulation.

GAMMAn The (modal) propagation constant of Port n. It is used in
de-embedding, and is calculated for single, differential, and
coplanar ports only.

PORTZn The impedance of Port n as defined in the Impedance fields of the
Port Editor dialog box. If an impedance is not specified, 50 ohms is
assumed.

S S matrix, normalized to PORTZn.

S(i,j) S-parameters for each pairing of ports in the circuit, normalized to
PORTZn.

S_50 S-matrix, normalized to 50 ohms.

S_50(i,j) S-parameters for each pairing of ports in the circuit, normalized to
50 ohms.

S_CONV and
S_CONV(i,j)

Boolean results indicating AFS convergence occurred (1) or failed
(0) at a given frequency. Available in datasets from simulations
using Adaptive sweep type.
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Note Z0 values are not computed for Single Ports if more than 2 ports are used in
the same reference plane. In this case the Z0 values are set to 50 ohms. To obtain a
scalar Z0 for each port, they must be put on different reference planes.

Refer to Chapter 4, Ports, for an explanation of the S-parameters for layouts that use
differential, coplanar, and common mode ports.

Standard and AFS Datasets

If the Adaptive sweep type is used for a simulation, two datasets are created for
storing data. The first one contains data computed by the simulator at the frequency
points determined during the simulation. (This dataset is the standard one produced
by any simulation.) The second contains data computed by AFS, resampled with a
very dense frequency distribution. This “adaptive” dataset is denoted by _a appended
to the dataset name. The adaptive dataset contains the same variables as the
standard dataset, but data is calculated for a significantly greater number of
frequency points.

Typically, when viewing data in the _a dataset, you should see very smooth results,
which reflect the behavior of the circuit. Viewing the standard dataset on the same
plot will show the frequency points for which the simulator was invoked,
superimposed on the smooth curve. Those frequency points will be scattered over the
whole range, with relatively more points grouped in areas where the S-parameters
show more variation. Viewing both datasets can help you determine the quality of the
AFS process on your simulation. For more information on AFS, refer to “About
Adaptive Frequency Sampling” on page 8-20.

S_ERROR and
S_ERROR(i,j)

Estimated error for a given frequency. For frequency points that
converged, the value is below -60 dB. Points that fail to converge
will be greater than -60 dB. Available in datasets from simulations
using Adaptive sweep type.

S_Z0 S matrix, normalized to Z0.

S_Z0(i,j) S-parameters for each pairing of ports in the circuit, normalized to
Z0 of each port.

Z0n Reports the characteristic impedance of the transmission line
connected to Port n. This is not calculated for internal or coupled
ports, in these cases 50 ohms is substituted.
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Viewing Convergence Data

Viewing convergence data can be helpful if a simulation using the Adaptive sweep
type has failed. You can view where convergence has been achieved, and evaluate the
quality of unconverged fitting models.

For information on the AFS process, refer to “About Adaptive Frequency Sampling”
on page 8-20.

The sections that follow describe how to view convergence data. This requires being
familiar with using the Data Display and Equations. For more information on these
topics, refer to the Data Display manual.

Data Overview

There are two variables in the adaptive dataset (named <project_name>_a) that
contain convergence data: S_CONV and S_ERROR.

• S_CONV contains boolean values indicating where convergence has been
achieved (1) or has failed (0) for the entire S matrix. S_CONV(i,j) contains
boolean values indicating the convergence for S(i,j).

• S_ERROR contains the estimated magnitude and phase fitting error for the
entire S matrix. S_ERROR(i,j) contains the fitting error for S(i,j). The error will
be less than -60 dB if convergence is achieved. You can view S_ERROR data in
dB by adding the data to a rectangular plot.

Viewing the Data

There are two suggested methods for viewing convergence. One is to simply plot
S_ERROR(i,j) in dB on a rectangular plot and evaluate the quality of the AFS fit. In
this example, the Low_pass_filter example is simulated with a Sample Points Limit
of 19. The error for S2,1 is plotted. Convergence has been achieved over much of the
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frequency span, but not all of it, so the simulation has failed. This indicates the
quality of the simulation over the entire frequency span that was simulated.

A second way to assess the simulation is to use S_CONV to separate converged and
unconverged data for a set of S-parameters and view it on a plot.

To view convergence data:

1. Open a Data Display window and select the adaptive dataset <filename>_a
containing the convergence data as the default dataset.

2. Choose Insert > Equation . Position the equation line in the display area and
Click. Enter the following equation:

Converged_S ij=S( i, j)*S_CONV( i, j)

i,j must refer to the same sets of ports throughout the equation. This equation
will return the converged data, and zero otherwise.

3. Click OK to add the equation to the display area.

4. Choose Insert > Equation  and add the following equation:

Not_Converged_S ij=S( i, j)*(1-S_CONV( i, j))

Use the same i,j as in the previous equation. This equation returns the results
where convergence was not achieved.

5. Click OK to add the equation to the display area.

6. Insert a rectangular plot in the display area.

Several frequencies
between 8 and 11 GHz fail
to achieve convergence.
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7. The Insert Plot dialog box opens. Under the Datasets and Equations listbox,
scroll to the bottom of the list and select Equation.

8. The variables Converged_S(i,j) and Not_Converged_S(i,j) appear in the
variables list. Select one variable and add it to the plot, in dB.

9. Click OK to view the results on the plot.

10. Insert a second rectangular plot and add the second variable to it.

In the illustration below, the S2,1 convergence results for the low-pass filter,
simulated with the samples limit set to 19, is displayed.

Note that because the AFS process breaks up the entire frequency span into smaller
subsections, the variable S_CONV will be 1 for the points that achieve convergence
over an entire subsection. So, even though the data in S_ERROR indicates almost the
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entire simulation converged, the plots below indicate the frequency ranges that
converged or failed.

Considerations

For efficiency purposes, the Adaptive Frequency Sampling process splits a simulation
frequency range into smaller subranges that contain a maximum of 16 samples, and
performs calculations on these smaller frequency ranges. The convergence factor (1 or
0) will be the same for all frequencies in a subrange. If convergence is achieved for
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some subranges and not others, this will be apparent. Note that for simulations that
have less than 16 samples, the entire frequency range is treated as one internal
subrange, so the convergence data will be all zeros if convergence was not achieved.

Viewing Radiation Patterns
Specific information about the data available in the far-field dataset is given in this
section.

Variables in the Far-field Dataset

When a radiation pattern is calculated, the following variables are generated for
storing data:

Variable Description

THETA The swept parameter of a planar cut. When THETA is swept, PHI
is at a fixed angle specified in the Cut Angle field and is not
returned to the dataset.

PHI The swept parameter of a conical cut. When PHI is swept, THETA
is at a fixed angle specified in the Cut Angle field and is not
returned to the dataset.

Etheta and Ephi Absolute field strength (in volts) of the theta and phi electric
far-field components.

Htheta and Hphi Absolute field strength (in amperes) of the theta and phi magnetic
far-field components.

Elhp and Erhp Normalized field strength of respectively left-hand and right-hand
circular polarized electric far-field component.

ARcp Axial ratio, derived from left-hand and right-hand circular
polarized far-field components.

Eco and Ecross Normalized field strength of co and cross polarized electric
far-field components.

ARlp Linear polarization axial ratio, derived from co and cross
polarized far-field components.

Gain, Directivity,
Efficiency,
EffectiveArea

Gain, Directivity, Efficiency (in percent), Effective area (in m2).

Power Radiation intensity (in watts/steradian).
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Details about each of these parameters can be found in “About Antenna
Characteristics” on page 9-2.

Note The normalized far-field components (Elhp, Erhp, Eco, and Ecross) are
normalized with respect to .max Eθ θ ϕ,( ) 2 Eϕ θ ϕ,( ) 2

+( )
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Chapter 11: Momentum Visualization Basics
Momentum Visualization enables you to view and analyze these types of simulation
data:

• S-parameters

• Currents

• far-fields

• Antenna parameters

• Transmission line data

Data can be analyzed in a variety of 2D and 3D plot formats. Some types of data are
displayed in tabular form.

You can view the simulation results from any Momentum or Agilent HFSS project.

This chapter gives an overview on how to use the Momentum Visualization.
Subsequent chapters describe in detail how to use Momentum Visualization for
viewing specific types of data, such as S-parameters or currents.

Starting Momentum Visualization
To start Momentum Visualization choose Momentum > Post-Processing >
Visualization. The current project must run through a complete simulation use
Visualization to view data. If simulation has been previously completed for a project,
you can start Visualization directly to view the existing data.
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Working with Momentum Visualization Windows
The following figure highlights the basic elements of the Momentum Visualization
window.

For an overview of Momentum, refer to “Momentum Overview” on page 1-2.

Menu bar

Data
editing
controls

Data
on the
plot

Selected
plot

Plot editing
controls

View
screen
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Selecting the Number of Views

By default, the view screen displays a single view. You can optionally display four
views. By using four views, you can display up to four different plots at one time.

To display four views:

• Choose Window > Tile .

Tip  You can enlarge the viewing area by clicking Hide Controls .

To display a single view:

• Choose Window > Full Window . The currently-selected view fills the view screen.

View 1 View 2

View 3 View 4
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Selecting a View to Work in

You must choose from one of the four views to work in. You can change to a different
view at any time.

To select a view:

1. Position the mouse in the view and click.

To identify the selected view, note the title of the Plot Type - View list. This will
change to identify the selected view. For example, if you choose View 3, the title
will appear as Plot Type - View_3.

To select a view and enlarge it to a single view:

1. Choose Window > Select View .

2. Select a view from the View list.

3. Click OK. The view screen displays the new view.

identifies the
selected view
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Setting Preferences for a View

You can set the color preferences for a view, including the background, grid lines, and
text along the plot axes.

To set preferences:

1. Choose Window > Preferences .

2. Select a color for the background, the text that labels plot axes, and colors of the
major and minor axes. The major axis includes the grid lines with numbers, the
minor axis consists of grid lines that appear in between the numbered ones.

3. Click Done  to dismiss the dialog box.

Axis Label

background

major axis
minor axis

Axis Label

one line of the
major axis

one line of the
minor axis
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Working with Annotation in a View

You can add text to a view, and edit the position and color of the text, by choosing
Display > Annotation. You can save your settings so that they can be reused.

Adding Text

To add text to a view:

1. Select the view where you want to add text.

2. Choose Display > Annotation . Drag the Annotation dialog box so that any
existing text is in view.

3. Click New Annotation .

4. Type your text into the Annotation Label field. If text already appears in this
field, you can delete it and then type in your text. When you are finished, press
the Enter key.

5. Use the X Location and Y Location scroll tools to position the text on the
display.

6. Click Done  to dismiss the dialog box and view the new text.

Adding Variables

There are three variables that can be added to the annotation: %project%, %view%,
and %date%. These variables can be displayed automatically whenever Momentum
Visualization is in use.

you can add text and
position it anywhere in
a view
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Editing Text

To edit text:

1. Select the view where you want to edit text.

2. Choose Display > Annotation . Drag the annotation dialog box so that any
existing text is in view.

3. Select the text that you want to edit from the Annotations field.

4. To adjust the position of the text in the view, use the X Location and Y Location
scroll tools.

5. To change the size of the text, use the Annotation Size scroll tool to increase or
decrease the font size.

6. To change the thickness of the text characters, use the Annotation Thickness
scroll tool to make fine, normal, or bold-faced characters.

7. To change the color of the text, select one of the colors listed under Annotation
Color.

8. To change the orientation of the text, Horizontal or Vertical under Orientation.

9. To change the text, make your changes in the Annotation Label field.

10. To make changes to other lines of text, select the text from the Annotation field
and edit as desired.

11. When you are finished, click Done  to dismiss the dialog box.

Deleting Text

To delete text:

1. Select the view that you want to add text to or edit text.

2. Choose Display > Annotation . Drag the annotation dialog box so that any
existing text is in view.

3. Select the text that you want to delete from the Annotations field.

4. Click Delete Annotation .

5. Click Done  to dismiss the dialog box.
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Retrieving Plots in a View

Multiple plot types can be stored under a single view. Only one plot at a time can be
displayed in a view, but any other plots that you worked with in the view will be
saved so that you can view them again.

To retrieve a plot from a view:

• Select a view and either:

• Use the arrows keys on the keyboard to scroll through plots.

• From the Plot Type - View list, select a plot type that you worked with. The
plot and all graphical information that was added to the plot is displayed.

Refreshing the Window

Choose Window > Refresh at any time to update the displayed views. Typically, the
window refreshes automatically after a command is completed.

Data Overview
You can display these types of data in Momentum Visualization:

• S-parameters

• Currents

• far-fields

• Antenna parameters

• Transmission line data (gamma and characteristic impedance)

Select the plot
that you want to view
from this list.
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The plots and tables that are available for viewing this data can be found under these
menus.

The chapters that appear later in this manual describe in detail how to work with
these different types of data.

Working with Plots and Data
There are many plot types available, plus many types of data to display. This section
describes how to work with plots, such as adding a plot to a view, adding data to a
plot, and editing a plot.

Displaying a Plot

Momentum Visualization is designed so that for each basic type of data, such as
S-parameters or currents, there is a set of plots available for displaying the data. The
details for working with each basic data type and the available plots are in later
chapters in this manual.

Display surface currents

Display far-fields and
antenna parameters

Display Gamma,
characteristic impedance,
S-, Y-, Z-parameters

S-parameter plots
are under the Plot menu

This will plot magnitude
versus frequency
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Momentum Visualization Basics
As an example, to display an S-parameter magnitude plot:

1. Choose Plot > Mag Plot .

2. Select a matrix and set of S-parameters from the Matrix and S-parameters list.
Details about these lists appear in Chapter 11, Momentum Visualization
Basics.

3. Select a view from the View list. The plot will appear in this view.

4. Click Apply .

Adding Data to a Displayed Plot

Multiple sets of data can be added to a plot:

• For most rectangular plots, you simply repeat the steps that you took to add the
plot to the view and choose a different set of data from the dialog box. If you
want to use data from a different project, select the project from the Projects
menu first, then repeat the steps.

• For current plots, you can add items that are listed under the Display  menu.

The dialog box below illustrates how to add a second set of S-parameters to an
S-parameter magnitude plot.

use the same project
data or load data
from a different
project first

select new data to
add to the plot

select the same
view that the plot
is displayed in
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Working with Data Controls

Data controls are available for editing the appearance of the following items:

• S-parameters

• The mesh

• Currents

• Far-fields

To access data controls, select the data from the Graphs list. Click the button that
appears above the Graphs list. The illustration here is an example for S-parameter
data or other data that appears on a rectangular plot.

Data controls include:

• For rectangular plots, you can change the name of the data, the line color, and
the line type used to display the data.

• For current plots, you can alter the appearance of the mesh, or animate
currents.

• For far-field plots, you can set the translucency or constant Phi.

plot type

information about the
selected data is
displayed

click to edit the
appearance of
the data

select data from
the Graphs list
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Momentum Visualization Basics
Viewing Data from Another Project

The data from any Momentum or Agilent HFSS project can be added to a plot. After
you load new projects, you can select among any of the projects for data to display.

To load an Momentum project:

1. Choose Projects > Read Momentum Project .

2. Navigate to the folder where the project is saved (project folder) and open the
folder.

3. Under the project folder is another folder named mom_dsn. Open this folder.

4. Open the folder that contains your specific design.

5. Double-click on any file within this folder.

To load a new Agilent HFSS project:

1. Choose Projects > Read Agilent HFSS Project .

2. Select the project directory containing the project.

3. Select the project from the Projects list. Note the annotation at the bottom of
the list, it will indicate if the selected project has saved solutions or not.

4. Click OK.

To change to a different project:

1. Choose Projects > Select Project .

2. Select a project from the list of Momentum or Agilent HFSS projects.

3. Click Select Momentum or Select Agilent HFSS .

Note The title bar of the Momentum window will display the name of the currently
selected project. Data will be retrieved from this project.
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Erasing Data from a Plot

Choose Window > Erase to delete part or all of the data from a plot. When the data is
deleted, it is also removed from the Graph list.

1. Select the plot from which you want to erase the displayed data.

2. Choose Window > Erase Plot .

3. Select the data to be erased.

4. Click Apply .

5. Continue to select data and use Apply  as needed.

6. Click Done  to dismiss the dialog box.

Reading Data Values from a Plot

Data for a single point can be retrieved from any plot. The values are displayed near
the bottom of the Momentum window. The type of data that is returned is based on
the plot type. Data is not retrieved from far-field plots.

To read the values of a single data point:

• Position the mouse on the data point of interest and click.

For rectangular plots and Smith charts, the returned values include the data name,
and the values along the X and Y axes of the plot. In some cases, values may be
rounded.

S-parameters displayed
on a magnitude vs.
frequency plot

frequency, in GHz magnitude, in dB
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On current plots, you can return values selected on Objects added from the Display
menu. These are the x, y, and z drawing coordinates of the layout.

Working with Plot Controls

You can use the plot editing controls at the bottom of the Momentum window to
rotate, resize, and move plots to optimize the view of your data. When you are
working with rectangular plots, you can adjust the scale of the plot.

Rotating a Plot

The Rotate command moves a 3D plot in the X, Y, or Z direction. You can rotate
Objects and 3D far-field plots only.

To rotate a plot:

1. Click Rotate .

2. Rotate the plot using one of the following methods:

• Position the mouse anywhere on the plot, then drag the mouse up, down, or
diagonally to rotate. To fix the plot position, release the mouse button.

• Click Rotation to set X Rotation, Y Rotation, and Z Rotation values using
scroll bars. Values range from -180 to 180 degrees.

• Click Views  to select a predefined view. Choices are Front Angle , Back Angle ,
Top , Side , or Front .

The layout is displayed

Returns the x, y, and z
drawing coordinates
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Scaling a Plot

The Scale command enlarges or shrinks the size of a plot.

To scale a plot:

1. Click Scale .

2. To enlarge the plot, click anywhere on the plot and drag the mouse up or to the
right.

3. To make the plot smaller, drag the mouse down or to the left.

Moving the Centerpoint of a Plot

The Pan command moves a plot in the horizontal or vertical direction.

To move a plot:

1. Click Pan.

2. Click anywhere on the plot and drag the mouse to move the plot up, down, left,
or right.

Working with Rectangular-plot Editing Controls

Rectangular plots have additional plot controls for:

• Adjusting the x and y axes of the plot

• Adjusting the data legend on a plot

Editing the Axes on a Plot

The options in the Graph Properties dialog box enable you to change the range of data
that is displayed on a plot, to increase or decrease the number of lines in the plot grid,
and to change the text that appears along each axis.

To change the data range on a plot:

1. Click Graph Properties .

2. The current boundaries are displayed in the X Axis and Y Axis Min and Max
fields. To change the range of displayed data, type new values into the Min and
Max fields for each axis.

3. Press Enter  as you make each entry to view its effect on the plot.
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To manually scale x, y axes:

1. Click Graph Properties .

2. Enter the number of units per division in the Div field. For example, if Div is set
to 20 when Min is 0 and Max is 100, you would see 5 major divisions along the
axis.

3. Enter the number of grid lines in each division in the Ticks field. In the figure
above, Ticks is set to 1, so one line appears in each division.

4. Press Enter  as you make each entry to view its effect on the plot.

To automatically scale the axes of a plot:

1. Click Graph Properties .

2. Click Auto Scale  to automatically scale the x and y axes of a plot.

To change the text on each axis:

1. Click Graph Properties .

2. Type new text into the X Legend and Y Legend fields.

3. Press Enter  as you make each entry to view its effect on the plot.
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Editing the Legend

When several sets of data are on a single plot, the legend can help to distinguish the
data. The legend displays the colors used to display the data and the names of the
data.

You can move and resize the legend, or erase it. You can also change the name of the
data.

colors of
plotted
data

names of plotted data
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Momentum Visualization Basics
To edit the legend:

1. Click Legend Properties .

2. If the dialog box appears to be empty, enable Visible.

3. Use the X Location and Y Location scroll bars to adjust the position of the
legend in the view.

4. Adjust the font size if the title using Legend Title Size.

5. Adjust the font size of the data names using Legend Entries Size.

6. To change the title above the data names, enter a different title in the Legend
Title field.

7. Click Done  to dismiss the dialog box.

To edit the name of the data:

1. Select the data from the Graphs list.

2. Click Line Properties .

3. Under Line Legend, enter a new name for the data.

4. Click Done  to dismiss the dialog box.

Saving a Plot
You can save plotted data and the plot type to a file. The data types include:

• S-parameter magnitude or phase

• Impedance

• Transmission data

• Far-field cuts

The file is in ASCII format, so you can use the data in other applications.

You can also import these files directly into Momentum Visualization. This
eliminates the need to read in a project and then select the project in order to view
the data.
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To export plotted S-parameters:

1. Choose File > Export Plot Data .

2. Select the type of plot you want to export.

3. Under Plots, select the S-parameters that you want to apply to the plot.

4. Click Browse . Navigate to where you want to save the file and enter a file name.
An extension (.hfd) will be automatically appended to the file name. Click OK.

5. If you are satisfied with your selections, click Apply . The calculated
S-parameters and plot type are written to the file.

6. Continue to save other sets of S-parameters with other plot types, as desired.
Be sure to click Apply  so that the file is generated.

7. When you are finished, click Done  to dismiss the dialog box.

8. The file is saved in ASCII format. You can view the file in any text editor.
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Importing a Plot
Plots that have been saved to a file in .hfd format can be imported. This eliminates
the need to read in a project and then select the project in order to view the data.

To import a file:

1. Choose File > Import Plot Data .

2. Click Browse  and select the file of interest.

3. The dialog box will display the following information:

• File Name—the full path and name of the file

• Plot Type Label—the type of plot that is saved in the file

• Plot Name Label—the S-parameters that are saved in the file

• Import Name—the name that is assigned by the post processor to the
S-parameter plot. This is the name you will choose when you go to display the
plot.

4. Click Apply . Continue importing S-parameter plots as desired.

5. When you are finished loading plot files, click Done .

To view an imported plot:

1. Choose Plot > Plot Import Data .

2. Select a plot type. A list of available plots is displayed.

3. Select the name of the plot that you want to view.

4. Select a view.

5. Click Apply . Continue adding plots to views as desired.

6. Click Done  to dismiss the dialog box.
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Chapter 12: Displaying S-parameters
In Momentum Visualization, you can display S-parameters in tabular or plotted
formats. This chapter describes how to view and work with S-parameters. It also
gives general information about S-parameters.

S-parameter Overview
When viewing and working with S-parameters, you should be aware how impedance
is specified and what naming convention is used. These are described in the following
sections.

Normalization Impedance

The S-parameters that you can display are S-parameters with respect to a
normalization impedance as defined in the Impedance fields of the Port Editor dialog
box. If an impedance is not specified, 50  is assumed.

Naming Convention

The S-parameter naming convention, which is based on the name of the project,
indicates which set of S-parameters you are viewing or working with. There are only
two data sets available for a project. One is named design_name which contains the
discrete frequencies that were actually simulated. The second is design_name(afs) is
available only when an adaptive frequency sweep is specified in the simulation setup.
An adaptive frequency sweep data set contains a high resolution sampling based on
the pole-zero model fitted on the simulated frequencies.

Viewing S-parameters in Tabular Format
You can view S-parameters in tabular format. The table displays S-parameter values
for each port in these formats:

• Magnitude

• Real and imaginary components

• Magnitude and phase

The table is for viewing data only, you cannot plot data from this table.

Ω
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Displaying S-parameters
S-parameters are displayed as shown here.

To view S-parameters:

1. Choose Plot > Matrix .

2. Select the data you want to view from the S Parameters list.

3. Select the frequency of interest from the Frequencies list. Some S matrices have
data at only one frequency.

4. Select the data format:

• Magnitude Displays the magnitude of the S-parameters

• Real/Imag Displays the S-parameters as complex numbers

• Mag/Phase Displays the magnitude and phase of the S-parameters

5. Use the scroll bars to view large matrices.

6. Click OK to dismiss the dialog box.

Port number

Results in
magnitude
and phase

Results displayed
at selected
frequency

Results displayed
in the selected
format
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Plotting S-parameter Magnitude
The S-parameter magnitude plot displays magnitude in dB with respect to frequency.

To display an S-parameter magnitude plot:

1. Choose Plot > Mag Plot .

2. Select an S matrix from the Matrix List.

3. Select the S-parameters. The combinations are based on ports.

4. Select the view where you want to display the plot.

5. Click Apply .

6. You can add other S-parameters to the plot, or click Done  to dismiss the dialog
box.

Plotting S-parameter Phase
The S-parameter phase plot displays phase in degrees with respect to frequency. Note
that when viewing S-parameter phase, in some cases the phase delay is plotted. For
example, a layout of an electrical length with a phase of 60 degrees, S21 represents a
phase delay, and appears as -60 degrees. For phases greater than 180 degrees, it may
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Displaying S-parameters
appear that the phase predicted from Gamma compared to S21 is incorrect, but this is
not so if delay is taken into account.

To display an S-parameter phase plot:

1. Choose Plot > Phase Plot .

2. Select an S matrix from the Matrix List.

3. Select the S-parameters. The combinations are based on ports.

4. Select the view where you want to display the plot.

5. Click Apply .

6. You can add other S-parameters to the plot, or click Done  to dismiss the dialog
box.
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Plotting S-parameters on a Smith Chart
The Smith chart displays real and imaginary components of S-parameters.

To display a Smith chart:

1. Choose Plot > Smith Plot .

2. Select an S matrix from the Matrix List.

3. Select the S-parameters.

4. Select the view where you want to display the plot.

5. Click Apply .

6. You can add other S-parameters to the Smith chart, or click Done to dismiss the
dialog box.
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Exporting S-parameters
S-parameters can be exported to a file, in either Touchstone or CITIfile format. You
can export S-parameters to use with other tools.

To export S-parameters:

1. Choose File > Export S Matrix .

2. Select the set of S-parameters to be exported from the Matrix list.

3. Select the file format, CITIfile or Touchstone.

4. Specify the file name either by typing the full file path into the File Name field
or click Browse .

5. Click OK to complete the command.
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Chapter 13: Displaying Surface Currents
In Momentum Visualization, you can display electric surface current denisty
(Amps/meter) on finite conducting objects, and magnetic surface currents on
apertures in infinite ground planes. This chapter describes how to view currents.

Note The actual current density is 2 times greater than the value reported by
Visualization.

Setting Port Solution Weights
Before displaying a current plot, select a frequency and set the port solution weights
for that frequency. Weighting port solutions enables you to specify the amount that
any one port solution contributes to the solution at a given frequency. The weighting
will be reflected in the current plots.

A Thevenin voltage source (voltage source + source impedance in series) is attached
to each circuit port. The source impedance is either the characteristic impedance for
single, differential, and coplanar ports; or 50 ohms for all other port types. The
voltage source amplitude for each port is set to its corresponding solution weight
(magnitude + phase). The displayed currents are those that correspond with this
excitation state.

To set port solution weights:

1. Choose Current > Set Port Solution Weights .

2. Select a frequency.

3. Select a port, and enter the magnitude in the Solution Weight field, and enter
the phase in the Solution Phase field.

4. Repeat the previous step for other ports, as necessary for the same frequency.

5. Click OK to complete the command.
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Displaying Surface Currents
Displaying the Layout
An outline of the layout is loaded into a view (if it is missing) when the current plots
are displayed. If a layout is not loaded or if it was deleted, choose Display > Objects to
display the layout.

Displaying a Current Plot
The current plot displays surface currents on all objects of the simulated layout. The
plot can be animated to illustrate the currents propagating through the circuit.

Note Make sure the layout is loaded into the view. Choose Display > Objects to load
the layout if it is missing.

To display a current plot:

1. Choose Current > Plot Currents .

2. Select the graphical format:

• Arrow Plots a vector current quantity using arrows to indicate direction and
magnitude.

• Contour Displays the “equal magnitude” contours of the vector current.

• Shaded Displays a shaded plot of a magnitude of the vector current. The
magnitude being plotted is represented by a range of colors. A color scale
showing the range of values also appears on the screen.

3. Select the view that you want to use to display the plot.

4. Click OK.
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Animating Plotted Currents

The currents have a sinusoidal, or harmonic, time dependence, with steady-state

conditions assumed. There is an implied time dependence. Animation enables you
to visualize the surface currents in the time domain, illustrating the propagation
through a circuit. Changing time corresponds with changing the additional phase

introduced by the  factor. You can change this phase continuously or you can step
through the phase changes manually.

To change the phase manually:

• Use the scroll bar. This enables you to freeze the phase in the layout.

To automate the animation:

1. Click Display Properties .

2. Enable Animate .

3. The currents are animated in time. The animation repeats automatically until
Animate is disabled. The speed of the animation can be changed by editing the
Increment field. A larger value speeds the animation, smaller values slow it
down.

4. You can change the maximum value of the color scale. Depending on the
selected graphical format, you can change other options:

• For the shade and contour plots, you can set the translucency, and color of the
current.

• For the arrow plot, you can change the length of the arrow vector.

e
jωt

e
jωt
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Displaying the Mesh on a Current Plot
Choose Display > Mesh to add the mesh to a current plot.

To display a mesh:

1. Choose Display > Mesh .

2. Select the view displaying the plot to which you want to add the mesh. Meshes
can be displayed in Objects only.

3. Click OK to complete the command.

Tip Depending on the drawing order, the mesh may be under the shaded current
plot, and not visible. To see the mesh, lower the translucency of the shaded plot.
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Chapter 14: Displaying Radiation Results
In Momentum Visualization, you can view the following radiation data:

• Far-fields including E fields for different polarizations and axial ratio in 3D and
2D formats

• Antenna parameters such as gain, directivity, and direction of main radiation in
tabular format

This chapter describes how to view the data. In Momentum RF mode, radiation
results are not available for display. For general information about radiation patterns
and antenna parameters, refer to Chapter 9, Radiation Patterns and Antenna
Characteristics.

Loading Radiation Results
In Momentum, computing the radiation results is included as a post processing step.
The Far Field menu item appears in the main menu bar only if radiation results are
available. If a radiation results file is available, it is loaded automatically. The
radiation results file contains only the radiation results for a single frequency (the
one that was last calculated). Since this file is loaded only when a new Momentum
project is opened, you must reopen the project to load radiation results calculated at
another frequency.

Note The command Set Port Solution Weights (in the Current menu) has no effect on
the radiation results. The excitation state for the far-fields is specified in the
radiation pattern dialog box before computation.

You can also read in far-field data from other projects. First, select the project
containing the far-field data that you want to view, then load the data:

1. Choose Projects > Select Project .

2. Select the name of the Momentum or Agilent HFSS project that you want to
use.

3. Click Select Agilent HFSS  or Select Momentum .

4. Choose Projects > Read Field Solution .
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5. When the data is finished loading, it can be viewed in far-field plots and as
antenna parameters.

Displaying Far-fields in 3D
The 3D far-field plot displays far-field results in 3D.

To display a 3D far-field plot:

1. Choose Far Field > Far Field Plot .

2. Select the view in which you want to insert the plot.

3. Select the E Field format:

• E = sqrt(mag(E Theta)2 + mag(E Phi)2)

• E Theta

• E Phi

• E Left

• E Right

• Circular Axial Ratio

• E Co

• E Cross

• Linear Axial Ratio

4. If you want the data normalized to a value of one, enable Normalize. For
Circular and Linear Axial Ratio choices, set the Minimum dB. Also set the
Polarization Angle for E Co, E Cross, and Linear Axial Ratio.

5. By default, a linear scale is used to display the plot. If you want to use a
logarithmic scale, enable Log Scale. Set the minimum magnitude that you want
to display, in dB.

6. Click OK.
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Selecting Far-field Display Options

You can change the translucency of the far-field and set a constant phi angle:

1. Click Display Options .

2. A white, dashed line appears lengthwise on the far-field. You can adjust the
position of the line by setting the Constant Phi Value, in degrees, using the
scroll bar.

3. Adjust the translucency of the far-field by using the scroll bar under
Translucency.

4. Click Done .

Defining a 2D Cross Section of a Far-field
You can take a 2D cross section of the far-field and display it on a polar or rectangular
plot. The cut type can be either planar (phi is fixed, theta is swept) or conical (theta is
fixed, phi is swept). The figure below illustrates a planar cut (or phi cut) and a conical
cut (or theta cut), and the resulting 2D cross section as it would appear on a polar
plot.
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The procedure that follows describes how to define the 2D cross section.

To define a cross section of the 3D far-field:

1. Choose Far Field > Cut 3D Far Field .

2. If you want a conical cut, choose Theta Cut. If you want a planar cut, choose Phi
Cut.

3. Set the angle of the conical cut using the Constant Theta Value scroll bar or set
the angle of the planar cut using the Constant Phi Value scroll bar.

4. Click Apply to accept the setting. The cross section is added to the Cut Plots list.

5. Repeat these steps to define any other cross sections.

6. Click Done  to dismiss the dialog box

planar cut at

phi = 0o

conical cut at

theta = 90o
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Displaying Far-fields in 2D
Once you have defined a 2D cross section of the 3D far-field plot, you can display the
cross section on one of these plot types:

• On a polar plot

• On a rectangular plot, in magnitude versus angle

In the figure below, a cross section is displayed on a polar and rectangular plot.

To display a 2D far-field plot:

1. Choose Far Field > Plot Far Field Cut .

2. Select a 2D cross section from the 2D Far Field Plots list. The type of cut (phi or
theta) and the angle identifies each cross section.

3. Select the view that you want to use to display the plot.

4. Select the E-field format.

5. Select the plot type, either Cartesian or Polar.

6. If you want the data normalized to a value of one, enable Normalize.

7. By default, a linear scale is used to display the plot. If you want to use a
logarithmic scale, enable Log Scale. If available, set the minimum magnitude
that you want to display, in dB; also, set the polarization angle.

8. Click OK.
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Displaying Antenna Parameters
Choose Far Field > Antenna Parameters to view gain, directivity, radiated power,
maximum E-field, and direction of maximum radiation. The data is based on the
frequency and excitation state as specified in the radiation pattern dialog. The
parameters include:

• Radiated power, in watts

• Effective angle, in degrees

• Directivity, in dB

• Gain, in dB

• Maximum radiation intensity, in watts per steradian

• Direction of maximum radiation intensity, theta and phi, both in degrees

• E_theta, in magnitude and phase, in this direction

• E_phi, in magnitude and phase, in this direction

• E_x, in magnitude and phase, in this direction

• E_y, in magnitude and phase, in this direction

• E_z, in magnitude and phase, in this direction

Details about each of these parameters can be found in “About Antenna
Characteristics” on page 9-2.

Note In the antenna parameters, the magnitude of the E-fields is in volts.
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Chapter 15: Displaying Transmission Line
Data
In Momentum Visualization, you can display the following transmission line data for
all calibrated ports, except coupled ports:

• Propagation constant

• Characteristic impedance

The following port types are calibrated:

• Single

• Differential

• Coupled

• Coplanar

For each calibrated port, an infinitely long (coupled) transmission line with the same
cross section as the port is solved using a cross section solver. For single ports, the
propagation constant and characteristic impedance is a complex but scalar quantity.
For differential, coupled, and coplanar ports, those are both matrices with a
dimension equal to the number of ports involved (nodal representation). For
differential and coplanar ports, the modal gamma and characteristic impedance for
the differential or coplanar waveguide mode are calculated, too. Those are scalar
quantities again and can be visualized by Momentum Visualization.

The characteristic impedance, Z0, at each port is computed from power and current
using the relationship Z0 = 2 P / (I.I*).

You can view the data either in a table or on plots. In Momentum RF mode,
transmission line data are not available for display.

This chapter describes how to view the data. It also provides general information
about gamma and characteristic impedance.
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Displaying Transmission Line Data
Viewing Transmission Data
You can review gamma and characteristic impedance in a tabular format. The table
displays gamma and the characteristic impedance for all single, differential, and
coplanar ports present in the circuit. For all other ports, gamma is set to 0 [1/m], and
the characteristic impedance is set to 50 [ohm].

The table is for viewing data only; you cannot plot data from this table.

To view transmission data:

1. Choose Plot > Port Data .

2. Select the matrix containing the data that you want to view.

3. Use the scroll bars to view large matrixes.

4. Click OK to dismiss the dialog box.

Displaying Gamma on a Plot
The gamma plot displays the magnitude, real or imaginary components of the
propagation constant gamma. Real values indicate the decay of a wave; imaginary
values indicate the phase velocity through the media.

To display a gamma plot:

1. Choose Plot > Gamma Plot .

2. Select a matrix from the matrix list.

3. Select the port for which you want to view gamma.

4. Select the view where you want to display the plot.

5. Click Apply .

To select the component that you want to display:

1. Select the data that you just plotted from the Graphs list.

2. Click Line Properties .

3. Under Plot Type, select the component you want to display: magnitude, real, or
imaginary.

4. Click Done .
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Displaying an Impedance Plot
The impedance plot displays the characteristic impedance of a port. The value
represents the characteristic impedance of a transmission line extending from the
port and having the same cross section as the port.

To display an impedance plot:

1. Choose Plot > Impedance Plot .

2. Select a matrix from the matrix list.

3. Select the port from the Impedance list.

4. Select the view where you want to display the plot.

5. Click Apply .
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Chapter 16: Momentum Optimization
Momentum Optimization, in combination with Momentum, is an effective software
tool for automated electromagnetic (EM) design optimization of planar structures.
Momentum Optimization automatically adjusts the layout in order to improve the
circuit performance according to your design goals, and supports designs developed
using the Momentum microwave or Momentum RF mode.

Momentum is invoked directly by the optimizer for accurate EM simulations of
various layout instances. This provides the optimizer with information with which it
makes decisions on how to modify the layout.

Momentum is an analysis tool that can be used to accurately account for various EM
effects such as couplings or radiation. It is extremely valuable for design verification,
but cannot, by itself, determine the layout that meets your design goals. Physical
design is usually a trial and error process in which the designer uses Momentum to
achieve the goals. By automating this process, Momentum Optimization saves
valuable engineering time. It can significantly shorten the design cycle, facilitating
faster time-to-market, and for more complex structures, it can usually find better
designs than those found manually.

Note You may want to refer to the examples at the end of this chapter to become
familiar with terminology and basic procedures in using Momentum Optimization.

“Example - Optimizing a Microstrip Line” on page 16-23
“Example - Optimizing a Filter” on page 16-33

What can be optimized by Momentum Optimization?
Momentum Optimization enables you to optimize geometrical dimensions of 2D
layout objects (shape optimization). This includes optimizing:

• Typical dimensions such as lengths, widths, gaps, spacing, or diameters

• Interdependent layout modifications such as length and width varying
simultaneously

• Many unconventional layout modifications
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The objects can be metal strips, slots or vias. The underlining technology of object
parameterization provides for significant flexibility in layout modification. The
parameterization process is intuitive and is carried out within the ADS layout
drawing environment.

What cannot be optimized by Momentum Optimization?

This version of Momentum Optimization does not accommodate optimization of

• Material parameters such as the dielectric constant

• Layout cross-section parameters such as the substrate thickness

• Discrete parameters such as the number of turns of a spiral inductor

• Parameters changing layout topology (including changing the number of object
vertices)

What responses can be optimized by Momentum Optimization?

Momentum Optimization allows you to set design goals for the S-parameters in any
of the following forms:

• Magnitude in dB

• Magnitude

• Phase (in degrees)

• Real part

• Imaginary part

Any combination of the above forms for any selection of port indices can be optimized
simultaneously. The S-parameters available for optimization are with respect to 50
reference impedance.

Typical steps in using Momentum Optimization
In general, a typical Momentum Optimization session would take place as follows:

1. Create an ADS layout to the best of your design experience. Draw it as close as
possible to what you expect the final design to be. You do not need, however, to

Ω
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spend a lot of time selecting exact dimensions. Rather, take advantage of
drawing convenience to save time.

2. Setup an Momentum simulation: substrate, metallization, port, meshing, etc.

3. Simulate your design using the Momentum > Simulation menu option. View the
responses of interest. If you are satisfied with the circuit performances you do
not need to run Momentum Optimization.

4. Make as good a guess as possible whether some adjustments to layout
dimensions could improve your circuit performance. Consider how the layout
should be modified to achieve the desired improvement. If a fundamental
change to the layout topology is needed, do it now and repeat the simulation.

5. Define conceptually as few independent parameters as possible that could
facilitate the desired layout modifications (see Appendix F, Momentum
Optimization - Layout Parameterization for more details and hints).

6. Decide on how the circuit performance can be formally expressed by design
goals in terms of frequency points, S-parameters, and upper, lower, equality or
window specifications.

7. Save your design and invoke Momentum > Optimization menu option.

The Optimization Process

After choosing Momentum > Optimization you need to sequentially step through the
three submenu options:

1. Parameters

2. Goals

3. Run

It is recommended that you initially accept as many default settings as possible. The
necessary actions for each step are outlined as follows.

• Layout Parameterization You need to define at least one parameter to be able to
perform an optimization. Momentum Optimization allows you to define
geometrical parameters in an intuitive manner within the layout drawing
environment of ADS.

• To define a parameter you need to provide a separate design to show the
program how an incremental change in that parameter value affects your
original layout. The original layout is referred to as the “nominal design” and
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the new one is called a “perturbed design”. The program will conveniently guide
you through this process. When you add a new parameter a separate design
containing a copy of the nominal design is created. You should make your
changes in this design. The modified copy is then saved as the perturbed design.

• You need to define a separate perturbed design for each parameter.

• Design Goals You need to define at least one design goal to be able to perform
an optimization. A single design goal consists of a frequency plan (a single point
or a linear sweep), a response of interest (e.g., the magnitude of S21), the
specification type, and a numeric value that the response should either exceed
or achieve.

• For multiple design goals you can emphasize/de-emphasize their relative
importance using weights associated with each goal.

• Optimization Run In most situations you should be able to accept all default
settings in the corresponding dialog box (Optimization Control window).

• Once at least one parameter and one goal are defined you can click Start to
invoke the optimizer. The optimization progress is displayed in the Momentum
Optimization window.

The log file of the optimization progress is available for viewing and/or printing at
any time at the menu option Momentum > Optimization > Summary.

Note  A working design is created during the optimization process with the name
designName_work  (the original design file name is appended with “_work”).

When Optimization is Finished

Once the optimization process is finished the best (optimal) layout is shown in a
separate window and saved as a separate design. Furthermore, the results of all
Momentum simulations carried out during the optimization are saved in a database.
This can significantly save time in future optimization runs.

In order to assess the circuit performance after optimization is finished you need to
view the responses corresponding to the best layout found by the optimizer. You can
do it in one of the following two ways.

• Use the Display menu in the Momentum Optimization window, or
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• Invoke the Momentum > Simulation menu option from within the optimal
design layout window, perform simulation and use the Data Display Server.

Restarting Optimization

You can always go back to Momentum > Optimization > Run and restart
optimization. If you do it keeping the same starting point (the Starting Value field) as
in the previous run, the Momentum results will be quickly retrieved from the
database, and the optimization will run very quickly. If you start from a different
point, some additional Momentum simulations may be performed. The results of
those simulations will be added to the database.

Caution needs to be exercised when you want to restart optimization after making
modifications to the optimization setup (see “Removing Obsolete Databases” on
page E-3).

Working with Optimization Parameters
The geometric parameters that can vary during optimization are defined in the
Optimization Parameters Editor. Choose Momentum > Optimization > Parameters to
open the dialog box:

Close dialog
without saving
changes

Save changes
without closing
dialog

Close dialog
and save
changes

Parameters
List

Name and values of
selected parameter.
Displayed for editing

Buttons to
add or edit
parameters

Buttons to
view/control the
start design

Button to
view/define a
perturbation
Working with Optimization Parameters 16-5



Momentum Optimization
Parameters (list)

This box contains the list of parameters for optimization. Three parameter attributes
are displayed in the list:

Parameter Definition

This box contains edit fields and buttons to define a parameter:

The values do not have to be true geometrical dimensions. But it is recommended
that you use meaningful values.

Starting point for
the optimization

Optimization
result

Indicates if the
parameter will be
considered as
variable by the
optimizer (yes), or its
value is to remain
fixed (no) during
optimization.

An ASCII string to identify the parameter.
Only alphanumeric characters and the
underscore are allowed. The first character
must be alphabetic.

The value of the parameter
corresponding to the nominal project

The value of the parameter
corresponding to the perturbed design

The current value of the parameter. In optimization, this
value is used as the starting point. By default, the
starting values are set to the nominal parameter values.
You may also enter any meaningful value that is
different from both the nominal and perturbed values.

Changing the unit will not rescale
the layout
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Note  On Windows platforms (Win95, Win98, NT), parameter names are case
insensitive. They must be distinguished by some means other than case (for example,
width and Width are considered as the same name).

In general, all the defined parameters are listed in the window as candidates for
optimization variables. You can select an individual parameter as a variable by
clicking the check mark box associated with that parameter. To undo the selection,
click the check mark box again. In this way, you can select any subset of the
parameters defined as variables while the others are kept fixed at the values
specified as Starting Values. Two buttons are available to access more settings, and to
view a perturbed design. If you click More, see “Using Advanced Parameter Settings”
on page 16-8 for more details.

Two buttons are provided to view and control the start design:

Click this button to display the perturbed design
associated with the selected parameter

Click to access a dialog for more settings.

Click this button to
display the starting
design for optimization

Click this button after
optimization is finished to
update the starting values
with the optimal values
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Using Advanced Parameter Settings
Clicking More in the Optimization Parameters Editor enables to access advanced
settings. These settings apply individually to the parameter currently highlighted in
the Parameters Editor.

Lower and Upper Bounds - You may enter a lower and an upper bound for the
parameter. This forces the parameter value to stay within these bounds during
optimization.

Although the bounds are optional, they are useful for preventing the optimizer from
producing invalid layouts (for example, due to overlapping objects). If you choose not
to specify explicit bounds, the default bounds are defined to ensure that the
parameter values do not change signs during optimization:

• If both the nominal and perturbed parameter values are greater than or equal
to zero, then the default lower bound is zero and the upper bound is the layout
limit.

• If both the nominal and perturbed parameter values are lower than or equal to
zero, then the default lower bound is the layout limit and the upper bound is
zero.

• If the nominal and perturbed values have opposite signs, then the default lower
and upper bounds are the layout limit.

Note  The layout limit is controlled by the design precision. You can increase the
limit by reducing the design precision in the Layout/Units tab of the
Option/Preferences dialog.
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Interpolation Resolution - The number of interpolation intervals between the nominal
and the perturbed values. Momentum Optimization employs interpolation to
significantly enhance its efficiency. The optimizer invokes Momentum for EM
simulation only if the parameter value is moved across an interpolation interval. For
small changes in parameter values, interpolation is applied instead of EM analysis to
obtain the S-parameters. This can substantially reduce the number of Momentum
calls required for optimization. See Appendix E, Momentum Optimization - Response
Interpolation for further discussion on interpolation.
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Adding Parameters to Designs
The basic steps required for adding a parameter through the Optimization Parameter
Editor are depicted in the following figure:

A copy of the original (nominal) design is shown in the new layout window. This copy
is named <dsnName>_<paramName>.dsn, where <dsnName> is the name of your

3. Optionally, specify a
starting value, bounds
and the interpolation
resolution

4. Make sure this box is checked

6. New
parameter
appears here
and a new layout
window opens

8. Check this box if you do not
want to see this dialog again

7. An information dialog explains how you can modify the
design to describe the direction of change for the parameter.

9. Draw the changes resulting from
a variation in the parameter value

1. Enter a name

2. Specify the nominal
and perturbed values

5. Click Add
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nominal Momentum design and <paramName> is the name of the parameter. This
layout is referred to as the “perturbed design” for the parameter <paramName>.

Edit the perturbed design to reflect the changes to the structure resulting from a
variation in the parameter value. By comparing the nominal and perturbed designs,
the optimizer will automatically extract the information needed for translating a
parameter value into the corresponding geometrical coordinates.

Repeat this stepped procedure to define more parameters. When you have finished,
click OK to close the dialog and the perturbed design window. The perturbed designs
are saved automatically at that time.

Note Once you have created the perturbed designs, you should not alter the original
design.

Editing Parameters

To edit one or more parameters:

Important  If you have changed the parameter’s name, the perturbed design is
renamed automatically when you click Update. This operation cannot be undone.

To delete a parameter:

1. Choose a
parameter 2. The parameter

definition is displayed
here.

Edit name and values

4. Click to close dialog and
save changes.

3. Click Update or press
Return to apply changes.
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1. Highlight the parameter in the Parameters list box.

2. Click Delete . The entry for the parameter is deleted from the list.

3. Use Undelete  to add the parameter back if you change your mind.

Note The perturbed design associated to the parameter removed from the list is not
deleted by the program. Therefore, it can be reused if you decide to add the
parameter back after closing the dialog.

Verifying Your Changes

To verify that the incremental changes are correctly interpreted, you can have
Momentum Optimization generate the starting design, and then visually inspect the
results.

To generate the starting design:

1. Click View Start Design in the Optimization Parameters Editor.

2. A Simulation/Synthesis Message window appears. The relevant differences
between the nominal and perturbed designs are extracted to establish the
dependency of the design layout on the parameters.

3. When the comparison process is finished, the starting design for optimization is
displayed in a new layout window. It is named <dsnName>_work where
<dsnName> is the name of the nominal Momentum design.

If parameterization fails, watch for a message describing the problem in the
Simulation/Synthesis Message window:
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If an incremental change cannot be parameterized, Momentum Optimization might
open two error layout windows. The nominal design is displayed in the window
<dsnName>_errNom, while the perturbed design is displayed in the window
<dsnName>_errPer. The name of the perturbed design displayed in
<dsnName>_errPer is displayed in the Simulation/Synthesis Message window.
Shapes for which the mapping cannot be found are highlighted in these windows.
Their number can be different if connectivity problems occur or if the number of
vertices differs. For instance, if the nominal design has two rectangles and the
perturbed design one triangle and one rectangle, then only the triangle in the
perturbed design will be highlighted. After all, the one rectangle in the perturbed
design might be a valid mapping for each rectangle in the nominal design.

Viewing and Editing Your Design

You can view and edit a perturbed design by clicking View/Modify Perturbed Design:

After viewing or editing a perturbed design, you can select another parameter. The
corresponding perturbed design is then shown automatically.

Clicking OK in the dialog will close and save all perturbed designs opened for editing.

1. Choose a
parameter

2. The parameter
definition is shown
here

3. Click to view or
edit the perturbed
design. A layout
window opens

4. After editing, click to close dialog and
save changes in perturbed designs
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Working with Optimization Goals
Optimization goals express the objectives you wish to achieve through optimization.
They are defined in the Design Goals Editor. Select Momentum > Optimization > Goals
to open the dialog:

Edit/Define Goal box

The first line in the Edit/Define box enables you to specify the frequency range:

Close dialog
and save
changes

Save changes
withoutclosing
dialog

Close dialog
without saving
changes

Values of selected goal.

Displayed for editing

List of goals

Buttons to add
or edit goals

A change in one of these fields
causes the remaining field to be
calculated automatically
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The second line enables you to express the goal:

The Activated check box controls whether or not the selected goal is considered during
optimization. By default this option is on. If you turn it off, the frequency plan will be
calculated and saved in the database, but a weighting factor of zero will be assigned
to the goal. Thus, deactivating does not obsolete the database.

See “Design Goals/Specifications” on page D-2 for further information on design
goals.

Defining a Goal

In general, the definition of a goal involves the following steps:

Optional weighting factor.
The default value is 1. If
given, the weighting factor
must be a positive number.

Recognized S-parameter responses include
the magnitude, the magnitude evaluated in
dB, the phase evaluated in degrees, the real
part, and the imaginary part

1. Define the frequency range: enter the
start and end frequencies. Enter also a
frequency step or a
number of points.

2. Define a goal for
an S-parameter
response

3. Optionally, enter a
numerical value for
the weighting factor

4. Make sure this
box is checked

5. Click Add

6. New goal
appears here
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Repeat this stepped procedure for all goals you want to add. When you are through
adding goals, click OK to dismiss the dialog box.

To edit one or more parameters for a goal:

1. Highlight the goal to edit in the Goal list box.

2. The dialog box displays the parameters of the selected goal.

3. Type the new values in the parameter value editing field.

4. Click Update . The Goal list box is updated to reflect the new values.

To delete a goal:

1. Highlight the goal to delete in the Goal list box.

2. Click Delete . The entry for the goal is deleted from the list.

3. Use Undelete  to add the goal back if you change your mind.

Performing an Optimization
Before performing an optimization, you have the opportunity to set several options
that control the optimization. After setting the options, you can start the
optimization and monitor its progress. The following sections describe these topics in
detail.
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Setting Optimization Controls

A variety of optimization options are available from the Optimization Control Editor.
Choose Run in the Momentum > Optimization menu to bring up this dialog:

The Optimization Control Editor provides the following options:

Optimization Type Choice of the optimization type (algorithm and/or objective
function). You can select a specific optimization type from this list: Minimax, L1, L2,
Quasi-Newton, Random, and Simulated Annealing. See “Optimization Algorithms”
on page D-6 for further discussion on optimization types.

Interpolation Type Choice of the interpolation type. Momentum Optimization utilizes
response interpolation in order to significantly speed up the optimization process.
Circuit responses corresponding to parameter values that do not fall on a
user-defined grid are approximated by interpolating Momentum responses calculated
at the neighboring on-grid values. See Appendix E, Momentum Optimization -
Response Interpolation for further discussion on interpolation.

Close dialog without
saving changes

Save changes
without closing
dialog

Toggle button to
Start and Stop
optimization
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Stopping Criteria

• Maximum Number of Iterations This option enables you to limit the number of
iterations. If the optimization does not converge to an optimal solution before
reaching this limit, it will stop and present, as the solution, the best result up to
this limit.

• Stop / Continue The Stop option enables you to interrupt the optimization
process as soon as all the specifications are satisfied. If you prefer a
well-centered design where the responses exceed the specifications as much as
possible, select the Continue option.

See “Stopping Criteria for the Optimization Process” on page D-7 for further
discussion on the stopping criteria.

Delete Previous Database Momentum Optimization employs a database system to
avoid duplicate EM analysis. Every time Momentum Optimization invokes
Momentum, the simulation results are stored in a database together with the
corresponding parameter values. Subsequently, when Momentum analysis results
are needed, Momentum Optimization checks this database first.

You may choose to have Momentum Optimization delete the database before starting
an optimization; to do this turn on this option.

This option must be selected whenever the existing database becomes no longer
compatible with the current setup. Any re-definition made within the Parameters or
Specifications editors is likely to necessitate deletion of a previously stored database.
See “Actual EM Simulations and Database” on page E-3 for further discussion on the
database.

Starting an Optimization

To start optimization, click the button Start. A Simulation/Synthesis Message
window appears.

The relevant differences between the nominal and perturbed designs are first
extracted to establish the dependency of the design layout on the parameters. When
the comparison process is finished, the Advanced Design System invokes Momentum
Optimization which then launches its own optimization monitor and display window.
A new layout window also opens in which the starting design is shown. During
optimization, you can follow the evolution of your design in this window.
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Tip As the layout windows are made active each time a new layout is shown, you
may find helpful to minimize the windows during optimization. Also, you can
configure ADS to leave the Simulation/Synthesis Message window in the background.
To do this add the following line to the configuration file hpeesofsess.cfg :

 SIMEXEC_MAP_TO_FRONT = off

You can interrupt an optimization in progress.

To stop an optimization:

1. Open the Optimization Control Editor.

2. The Start button label is changed to Stop. Click Stop.

Viewing Optimization Status
The progress of optimization is reported in the optimization window:

Optimization techniques employ iterative algorithms. An iteration leads to
performing an optimization step, i.e., changing the optimization variables. As a
result, the objective function is normally decreased.

It is advisable to monitor how the optimization process proceeds. Occasionally, it is
possible that the optimizer makes a step in the up-hill direction. This is not an error.

You can view this
information any time
after optimization is
finished using the
summary menu
option.

Value of the
objective function

Iteration count

Optimizer stops when all
design goals are met
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It is inherent in the optimization algorithms as various search directions and steps
are being explored. The best result will be retained as the optimized solution.

Note The optimization window has a different appearance on Windows and Unix.

Viewing Optimization Results
When the optimization is finished, the optimized design is created and displayed in a
separate layout window. It is named <dsnName>_opt where <dsnName> is the name
of the nominal Momentum design. The value of the parameters can be read in the
Parameter dialog which opens automatically:

You can check if all optimization goals are met in the optimization data display:

Optimization results Optimized design

Nominal design
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On a PC

1. Choose
Rectangular to
display responses
versus frequency
or Smith/Polar to
display complex
responses

2. Select the
response to display
and, optionally,
change the display
options.

4. The response is displayed in
the optimization window. Design
goals are superimposed.

3. Click OK
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On a Unix System

1. Click display

2. The MomOpt.Display menu appears.
Click Rectangular to display responses
versus frequency or Smith/Polar to
display complex responses

3. A pop-up window appears. Select
the response to display on the “Y-axis”
line. Optionally, change the default
display settings

5. The response is
displayed in the
optimization window.
Design goals are
superimposed.

4. Click Go
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Example - Optimizing a Microstrip Line
This exercise shows how to perform an optimization on a microstrip line. The
microstrip is initially designed as a simple 100 mil L x 25 mil W line. The microstrip
substrate consists of layers of air, alumina, and a ground plane, where the microstrip
rests on the 25-mil alumina layer. The alumina layer dielectric constant is 9.8. The
metallization of the microstrip is assumed to be lossless.

The goal is to optimize the length L of the line to satisfy:

Phase S21 = -120o at f = 10 GHz

The sections that follow describe how to optimize the microstrip design to achieve
this goal.

Step 1: Creating the Project and Layout

This section describes how to create a project and draw the microstrip.

If you want to skip this and other entries, an example project containing the complete
microstrip design is in the Examples directory. Examples are in read-only format, so
to work with an example you need to make a copy of it.

The microstrip in the example project has already been simulated and optimized.
Since Momentum simulations and optimizations can reuse data, the optimization
will run rapidly.

Creating the Project

1. From the Main window, choose Options > Preferences . Ensure that Create Initial
Layout Window  is enabled. Click OK.

2. From the Main window, choose File > New Project . The New Project dialog box
appears.

3. In the Name field, type mstrip .

4. Click OK.
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Creating the Initial Layout

This section describes how to draw the microstrip layout.

1. In the Layout window, ensure that the current layer is cond . You can change the
current layer using from the layout list on the toolbar.

2. From the Layout Window, choose Insert > Rectangle . Position the cursor at 0,0
(coordinates appear at the bottom of the Layout window) and click. Move the
cursor to the position 100, 25 and click. This creates a microstrip with the
dimensions L = 100 mils, W = 25 mils.

3. Under the Options menu, enable midpoint snap and vertex snap by clicking
each name. They are located near the bottom of the menu, and a check next to
the mode indicates that it is enabled. Using these modes will assist with placing
ports in the correct positions on the microstrip.

4. Click the port button and insert a port at each end of the microstrip. Rotate the
port before applying if necessary. End the command.

In this example, it will not be necessary to use the Momentum Port Editor since
the default Momentum port type, internal, will be used and this port type is
automatically applied to any port that is not assigned a type. Your layout
should resemble the figure here.

5. From the Layout window, chose Momentum > Substrate > Create/Modify . Select
the Alumina layer. Set the Thickness to 25 mils and Er to 9.8.

6. Click Metallization layers  and verify that the cond layer is positioned between
the Alumina and Free_Space layers. Click OK.

7. From the Layout window, choose File > Save Design As  and save the design as
mstrip . This will also save the substrate definition as mstrip_lay.slm in the
networks folder of the project.

This layout that you have just created will be referred to as the nominal design. It
will serve as the baseline or reference for the optimization process.
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Step 2: Defining the Optimized Parameters

As mentioned earlier, the goals that are specified for this microstrip
(phase S21 = -120o at f = 10 GHz) will be achieved by changing the length of the
microstrip. For this exercise, there is only the one geometrical parameter, length, that
will be optimized.

The optimization process requires that for each parameter you choose to optimize,
you must create a new design and alter one parameter in the design. In this exercise,
only one parameter will be optimized, so only one new design is required. If you chose
to optimize the width as well, you would need two new designs, one with a change to
the length, and the other with a change to the width. By comparing a new project
with the initial project, Momentum Optimization will identify the parameter that you
want to optimize and proceed to optimize it.

The original project that you drew is referred to as the nominal design, the new
design containing the change to the length is referred to as a perturbed design.

This section describes how to identify the parameter that you want to optimize,
including creating a new design.

1. From the Layout window, choose Momentum > Optimization > Parameters . The
Optimization Parameters dialog box appears.

2. To define the length as an optimizable parameter, enter the following
information into the Parameter Definition fields:

Field Enter Explanation

Name length The name that you give to an optimized parameter. Use a
descriptive name.

Nominal Value 100 mil This is the value of the parameter in the nominal project. The
microstrip that you drew has a length of 100 mils.

Perturbed value 110 When you draw the perturbed project, you will draw it so that the
length of the microstrip is 110 mil.

Starting value Leave this blank.
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3. Click Add . The parameter definition is added to the list, as shown in the figure
here.
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4. When you click Add, a new Layout window appears. This is the perturbed
design, and it contains a copy of the nominal design. The perturbed design is
automatically named mstrip_length. An information dialog is also displayed,
and it explains how you can modify the perturbed design to change the
parameter length. Further detail is presented in the next steps of this exercise.
Drag the dialog box off of the Layout window. Until you become familiar with
this process, you may want to keep this dialog box open. Otherwise, click OK to
dismiss the box.
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5. To edit the layout, select the right edge of the rectangle and port P2. One way to
do this is to click and drag an area that contains a small portion of the right side
of the rectangle and the entire port. The selected area should resemble the
figure here.

6. Choose Edit > Move > Move Relative . A dialog box for changing x, y, coordinates
appears. To alter the length of the microstrip, type 10 in the X field and click
Apply . Click Cancel  to dismiss the dialog box.

7. Locate the Optimization Parameters dialog box. In the Parameter Definition
area of the dialog, click More  to examine additional settings. One setting is
interpolation resolution, it is set to 4 by default. This sets the size of the
interpolation interval. In this case, since the incremental change in length is 10
mils, the interpolation interval is 10 mils /4 = 2.5 mils. Suppose, for example,
that in some steps during optimization the parameter length varies within the
interval between 110 and 112.5. Momentum Optimization will invoke EM
simulation for the two end points: L = 110 and L = 112.5, and then use
interpolation to obtain S parameters for all other values of L between 110 and
112.5.

8. Click OK. The dialog box closes, the Layout window containing the perturbed
design is also closed, and the perturbed design is automatically saved in the
networks folder of the project. The nominal project remains open.
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Step 3: Defining Optimization Goals

This section describes how to set up the optimization goals.

1. From the Layout window, choose Momentum > Optimization > Goals . The
Optimization Goals dialog box appears.

2. Recall that the goal is Phase S21 = -120o at f = 10 GHz. The goal is at a single
frequency, so in the From and To fields, enter 10 and set the units to GHz. Skip
the Step Size field, but enter 10 in the Number of Points field. In the Response
list, select Phase S (degree) . In the Ports list, select 21. Select = and then in the
Goal field, enter -120. In the Weight field, enter 1.

3. Click Add . The dialog box should resemble the figure here.

4. Click OK to accept the goal and close the dialog box.
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Step 4: Running the Optimization

You are ready to run the optimization. This section describes how to run an
optimization.

1. From the Layout window, chose Momentum > Optimization > Run . The
Optimization Control Editor appears. It is not necessary to alter any settings.
Click Start . The optimization process begins:

• The optimization is started and a Status window opens.

• The nominal project is compared to the perturbed project. The relevant
differences are extracted to establish the dependency of the design layout on
the parameter length. This information enables Momentum Optimization to
translate any given value of L into the corresponding design.

• When the comparison process is finished, the starting design for optimization
is created in a new layout window. It is named mstrip_opt.

• The Momentum Optimization window opens and the progress of the
optimization is reported. On the UNIX platform, the window may appear
empty until the optimization is complete.
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The numerical values you actually see may be different from those shown here,
due to differences in the computer hardware and/or software versions.
Sometimes you may also see the objective function value increasing instead of
decreasing from the previous iteration. This is not unusual. It is inherent in the
optimization algorithm.

• During optimization, Momentum is invoked in the background whenever a
new EM analysis is required. For example, since the nominal project had not
been simulated, any necessary computations, such as computing the mesh
and running the simulation, will be performed and reported in the Status
window.

• You can follow the evolution of the line in the window mstrip_opt.
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Step 5: Viewing Optimization Results

When optimization is finished, the optimized design, mstrip_opt, is created and
displayed in a new Layout window. The Optimization Parameters dialog box reopens
and you can read the optimal value for the length under Parameters.

You can also verify graphically that the goals were achieved. In this case, you can
view the phase noise goal on a rectangular plot. The graphical tool is accessed from
the menu bar of the Momentum Optimization window (this is the window where the
optimization progress, in iterations, was reported). The procedure for viewing goals is
different, depending on your platform.

Unix

1. On the Momentum Optimization window, from the menu bar at the bottom of
the window, you will see MomOpt >  and two choices, Display  and Exit . Use the
mouse to highlight Display  and click.

2. At the bottom of the window, the MomOpt.Display > menu appears. Click
Rectangular . A pop up window appears.

3. The default settings in the window are for displaying S21 phase and the goal.
Click GO to accept the default settings.

PC

1. From the Momentum Optimization window, choose Display > Rectangular .

2. The default settings are for displaying S21 phase and the goal. Click OK to
accept the default settings.

The goal and the actual response of the microstrip line is displayed. Since the
optimization goal was set at a single frequency (10 GHz), both the goal and the
response are displayed as single points at 10 GHz. It appears as if there is only one
point marked on the graph, but both the goal and response are displayed, since the
goal was achieved, the response (circle) overlaps with the specification (cross).

This concludes the first optimization exercise. To save your work, from the Main
window choose File > Save All Designs , then File > Close All Designs , answering Yes to
All  if any message windows appear.
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Example - Optimizing a Filter
This exercise describes how to optimize a double folded-stub microstrip bandstop
filter, shown in the figure below. For this exercise, three parameters will be optimized:

• The distance between a folded stub and the main line. This spacing will be
referred to as S.

• The length of the spacing between the main line and folded segment, referred to
as L1.

• The length of each folded segment, referred to as L2.

Note that each when each of these physical dimensions are altered, it will be done so
that the symmetry of the layout is retained.

The optimization goal is to achieve the stopband in the frequency range of 12-14 GHz.
The goal can be defined as:

|S21| < -30 dB   for 12 < f < 14 GHz

|S21| > -3 dB   for f < 9.5 GHz or f > 16.5 GHz

S

L2

L1

L2

L1S
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Step 1: Creating the Initial Layout

This section describes how to create the project and draw the initial layout. Refer to
the previous exercises if you need additional details on how to draw in Layout, define
substrates, or apply ports.

Use the following steps to create an initial layout.

1. Create a new project and name it dfstub . Open a Layout window.

2. Draw the layout on the cond  layer with the following parameter values: L1 =
86.4 mils, L2 = 81.6 mils, S = 4.8 mils. You can do this using the Insert >
Rectangle and Insert > Coordinate Entry commands and the following coordinates
for lower-left and upper-right corners of rectangles. You may need to zoom in,
and be sure to end the commands when needed.

3. Attach a port at both ends. The default Momentum port type, internal, will be
used, so it is not necessary to access the Momentum Port Editor. You may want
to change the port component and text size, which is available under the
Options > Preferences  menu.

4. Choose Momentum > Substrate > Create/Modify  to define a substrate of air,
alumina, and a ground plane. Define the alumina layer as 5 mils thick with a
relative dielectric constant of 9.9. Be sure to save the substrate.

5. Save the design as dfstub .

(0,0)

(124.8, 4.8)
(24,9.6)

(110.4,14.4)

(14.4, -9.6)

(100.8, -4.8)
(19.2, -4.8)

(105.6, 4.8)
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Step 2: Defining the Optimized Parameters

There are three physical dimensions that are candidates for optimization:

• The spacing between each of the folded stubs and the main line, referred to as
S.

• The length of the spacing between the main line and the folded segment,
referred to as L1.

• The length of each folded segment, referred to as L2.

As part of defining the parameters, you must to create three perturbed designs, with
each design containing a change to only one parameter. This section describes how to
define the parameters and draw the perturbed designs.

1. From the Layout window, choose Momentum > Optimization > Parameters .

2. Define the first parameter by entering the listed values in these fields:

Leave the Starting Value field empty. Click Add .

3. The parameter is added to the list and a new Layout window appears. A copy of
the original layout (nominal design) is shown and named dfstub_L1 . An
information dialog is also displayed that describes how to make a change to this
layout. If you do not want to see this dialog again, check the box at the bottom of
the dialog and click OK.

Field Enter

Name L1

Nominal Value 86.4 mils

Perturbed Value 76.4 mils
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4. You will modify the physical dimension that you defined as L1 by reducing it
from 86.4 mils to 76.4 mils. You will do this by shifting the position of the folded
segments along the main line. Use the mouse to select the 6 vertices that define
the top stub. Choose Edit > Move > Move Relative . In the dialog that appears,
type -5 in the X field and click Apply . This shifts the folded stub to the left so
that the length of the spacing between the main line and the folded segment is
reduced. Select the 6 vertices of the bottom stub, type 5 in the X field and click
Apply . Keep this dialog box open.

5. Define the next parameter, L2. Return to the Optimization Parameters dialog
box and enter these values in the fields:

6. Click Add . Another copy of the original layout is displayed and named dstub_L2 .

7. You will modify the physical dimension defined as L2 by moving the edges of the
folded segments by 10 mils. Select the edge of the top folded segment, and use
the X field in the Move Relative dialog box to shift the edge of the segment 10
mils. Then move the edge of the bottom segment 10 mils.

Field Enter

Name L2

Nominal Value 81.6 mils

Perturbed Value 91.6 mils

5 mils

5 mils

10 mils

10 mils
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8. Return to the Optimization Parameters dialog box and enter the third
parameter, S. Change the perturbed layout that appears as shown here.

9. The definitions in the Optimization Parameters dialog box are shown here.
Click OK. The three perturbed designs and the parameter definitions are saved
automatically when you click OK.

Field Enter

Name S

Nominal Value 4.8mils

Perturbed Value 6.8 mils

2 mils

2 mils
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Step 3: Defining Optimization Goals

As mentioned earlier, the goal for this design is to achieve the stopband in the
frequency range of 12-14 GHz. The goal can be defined as:

|S21| < -30 dB   for 12 < f < 14 GHz

|S21| > -3 dB   for f < 9.5 GHz or f > 16.5 GHz

This section describes how to define the goals.

1. From the Layout window, chose Momentum > Optimization > Goals .

2. Add the following three goals to the list, clicking Add  after each complete goal
entry:

From To Step
Size

Response Ports Goal Weight

Entries for goal 1 12 14 GHz 0.5 Mag S(dB) S21 < -30 dB 1

Entries for goal 2 5 9.5 GHz 2 Mag S (dB) S21 > -3 dB 1

Entries for goal 3 16.5 20 GHz 2 Mag S (dB) S21 > -3 dB 1
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The completed dialog box should resemble the figure here. If you make a
mistake, select the goal from the list, modify the necessary fields, and click
Update . Click OK.
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Step 4: Running the Optimization

This section describes how to set up and run the optimization.

1. From the Layout window, choose Momentum> Optimization > Run . Under
Optimization Type, select Minimax . Use the default Interpolation Type, linear
interpolation. Set the Maximum Number Of Iterations to 30. Enable Stop as
soon as specs are met  to halt the optimization when the goals are achieved. If
you enable Delete Previous Database , any existing data will be deleted and EM
simulations will be invoked as required.

2. Click Start . The Momentum Optimization is started:

• A status window opens.

• The nominal project is first compared to the perturbed projects. The relevant
differences are extracted to establish the dependency of the design layout on
the parameters. This information enables Momentum Optimization to
translate any given set of parameter values into the appropriate design.

• When the comparison process is finished, the starting design for optimization
is created in a new layout window. Is it named dfstub_opt.

• The Momentum Optimization window opens. On the screen, the progress of
optimization is reported. The numerical values you actually see may be
slightly different from those shown here, due to differences in the computer
hardware and/or software versions.

• If you have chosen to delete the database, Momentum is invoked in the
background whenever a new EM analysis is required. Follow the evolution of
the structure in the window displaying dfstub_opt.
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Step 5: Viewing Optimization Results

When the optimization is finished, the optimized design, dfstub_opt, is created. It is
displayed is a new layout window. The Optimization Parameters Dialog is opened and
you can read the optimal values of all three parameters in the list:

You can check that the goals are met. The procedure for viewing goals is different,
depending on your platform.

Unix

1. On the menu bar at the bottom of the Momentum Optimization window, you
will see MomOpt > and two choices, Display and Exit . Use the mouse to highlight
Display  and click.

2. At the bottom of the window, the MomOpt.Display > menu appears. Click
Rectangular . A pop up window appears.

3. The default settings in the window are for displaying S21 phase and the goal.
Click GO to accept the default settings.
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PC

1. From the Momentum Optimization window, choose Display > Rectangular .

2. The default settings are for displaying S21 phase and the goal. Click OK to
accept the default settings.

The goals and the actual response of the filter is displayed.
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Appendix A: Theory of Operation
Momentum is based on a numerical discretization technique called the method of
moments. This technique is used to solve Maxwell's electromagnetic equations for
planar structures embedded in a multilayered dielectric substrate. The simulation
modes available in Momentum (microwave and RF) are both based on this technique,
but use different technologies to achieve their results.

Momentum has two modes of operation, Microwave or full-wave mode and the RF or
quais-static mode. The main difference between these two modes lies within the
Green functions formulations that are used. The full-wave mode uses full-wave Green
functions, these are general frequency dependent Green functions that fully
characterize the substrate without making any simplification to the Maxwell
equations. This results in L and C elements that are complex and frequency
dependent. The quasi-static mode uses frequency independent Green functions
resulting in L and C elements that are real and frequency independent. Because of
the approximation made in the full-wave mode, the RF simulations run a lot faster
since the matrix L and C elements only have to be calculated for the first frequency
simulation point. The approximation also implies that the full-wave mode typically
should be used for structures that are smaller than half the wavelength. Both engine
modes are using the so-called star-loop basis function, ensuring a stable solution at
all frequencies. Both engines also make use of a mesh reduction algorithm which
reduces the number of unknowns in the simulation by generating a polygonal mesh.
This mesh reduction algorithm can be turned on or off, with a toggle switch.

The sources applied at the ports of the circuit yield the excitations in the equivalent
network model. The currents in the equivalent network are the unknown amplitudes
of the rooftop expansion functions. Solving the equivalent network for a number of
independent excitation states yields the unknown current amplitudes. A port
calibration process is used to calculate the S-parameter data of the circuit from the
current solution, when calibration is requested.

The following sections in this chapter contain more information about:

• The method of moments technology

• The Momentum solution process

• Special simulation topics

• Considerations and software limitations
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The Method of Moments Technology
The method of moments (MoM) technique is based upon the work of R.F. Harrington,
an electrical engineer who worked extensively on the method and applied it to
electromagnetic field problems, in the beginning of the 1960's. It is based on older
theory which uses weighted residuals and variational calculus. More detailed
information on the method of movements and Green’s theorem can be found in Field
Computation by Moment Methods [1].

In the method of moments, prior to the discretization, Maxwell's electromagnetic
equations are transformed into integral equations. These follow from the definition of
suitable electric and magnetic Green's functions in the multilayered substrate. In
Momentum, a mixed potential integral equation (MPIE) formulation is used. This
formulation expresses the electric and magnetic field as a combination of a vector and
a scalar potential. The unknowns are the electric and magnetic surface currents
flowing in the planar circuit.

Using notations from linear algebra, we can write the mixed potential integral
equation in very general form as a linear integral operator equation:

(1)

Here,J(r ) represents the unknown surface currents andE(r ) the known excitation of the problem.
The Green's dyadic of the layered medium acts as the integral kernel. The unknown surfac
currents are discretized by meshing the planar metallization patterns and applying an expan
a finite number of subsectional basis functionsB1(r ), ...,BN(r ):

(2)

The standard basis functions used in planar EM simulators are the subsectional rooftop fun
defined over the rectangular, triangular, and polygonal cells in the mesh. Each rooftop is asso
with one edge of the mesh and represents a current with constant density flowing through tha

d∫ S∫ G r r',( ) J r( )⋅ E r( )=

J r( ) I jB j r( )
j 1=

N

∑≈
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the
(Figure A-1). The unknown amplitudes Ij, j=1,..,N of the basis function expansion determine
currents flowing through all edges of the mesh.

Figure A-1. Discretization of the surface
currents using rooftop basis functions.

The integral equation (1) is discretized by inserting the rooftop expansion (2) of the currents. By
applying the Galerkin testing procedure, that is, by testing the integral equation using test
functions identical to the basis functions, the continuous integral equation (1) is transformed into a
discrete matrix equation:

for i=1,...,N

(3)

with

(4)

(5)

The left hand side matrix [Z] is called the interaction matrix, as each element in this
matrix describes the electromagnetic interaction between two rooftop basis functions.
The dimension N of [Z] is equal to the number of basis functions. The right-hand side
vector [V] represents the discretized contribution of the excitations applied at the
ports of the circuit.

Zi j, I j
j 1=

N

∑ Vi or Z[ ] I[ ]⋅ V[ ]==

Zi j, dSBi r( )∫
S
∫ dS'G r r',( ) B j r( )⋅∫

S'
∫⋅=

Vi dSBi r( )∫
S
∫ E r( )⋅=
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The surface currents contribute to the electromagnetic field in the circuit by means of
the Green's dyadic of the layer stack. In the MPIE formulation, this Green's dyadic is
decomposed into a contribution from the vector potential A(r) and a contribution from
the scalar potential V(r):

(6)

The scalar potential originates from the dynamic surface charge distribution derived
from the surface currents and is related to the vector potential through the Lorentz
gauge.

By substituting the expression (6) for the Green's dyadic in the expression (4) for the interaction
matrix elements, yields the following form:

(7)

with

(8)

(9)

This allows the interaction matrix equation to be given a physical interpretation by constructin
equivalent network model (Figure A-2). In this network, the nodes correspond to the cells in t
mesh and hold the cell charges. Each cell corresponds to a capacitor to the ground. All nod
connected with branches which carry the current flowing through the edges of the cells. Ea
branch has in inductor representing the magnetic self coupling of the associated current ba
function. All capacitors and inductors in the network are complex, frequency dependent and
mutually coupled, as all basis functions interact electrically and magnetically (Figure A-3). The
ground in this equivalent network corresponds with the potential at the infinite metallization la
taken up in the layer stack. In the absence of infinite metallization layers, the ground corres
with the sphere at infinity. The method of moments interaction matrix equation follows from

G r r',( ) jωGA r r',( )I 1
jω
-------∇ GV r r',( )∇'[ ]–=

Zi j, jωLi j,
1

jωCi j,
-------------------+=

Li j, dSBi r( )∫
S
∫ dS'GA r r',( )B j r'( )∫

S'
∫⋅=

1
Ci j,
----------- dS∇∫

S
∫ Bi r( ) dS'GV r r',( )∇∫

S'
∫ B j r'( )⋅ ⋅=
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applying the Kirchoff voltage laws in the equivalent network. The currents in the network fol
from the solution of the matrix equation and represent the amplitudes of the basis functions

Figure A-2. The equivalent circuit is built by replacing each
cell in the mesh with a capacitor to the ground reference and

inductors to the neighboring cells.

Figure A-3. Equivalent network representation of the
discretized MoM problem.
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The Momentum Solution Process
Different steps and technologies enable the Momentum solution process:

• Calculation of the substrate Green's functions

• Meshing of the planar signal layer patterns

• Loading and solving of the MoM interaction matrix equation

• Calibration and de-embedding of the S-parameters

• Reduced Order Modeling by Adaptive Frequency Sampling

Calculation of the Substrate Green's Functions

The substrate Green's functions are the spatial impulse responses of the substrate to
Dirac type excitations. They are calculated for each pair of signal (strip, slot and/or
via) layers mapped to a substrate level. Although it is necessary to know which signal
layers are mapped to a substrate level, since only impulse responses are being
calculated, it is not necessary to know the patterns on these signal layers. This
implies that the Green's functions can be pre-calculated and stored in a substrate
database. This allows the substrate Green's functions to be reused for other circuits
defined on the same substrate.

The high frequency electromagnetic Green's functions depend upon the radial
distance and the frequency. The computations are performed up to very large radial
distances over the entire frequency band specified by the user. The frequency points
are selected adaptively to ensure an accurate interpolation with respect to frequency.
Computations performed over very wide frequency ranges can consume more CPU
time and disk space to store the results. To increase speed, the RF mode uses
quasi-static electromagnetic Green’s functions based on low-frequency
approximation.

Meshing of the Planar Signal Layer Patterns

The planar metallization (strip, via) and aperture (slot) patterns defined on the signal
layers are meshed with rectangular and triangular cells in the microwave simulation
mode. As translational invariance can be used to speed up the interaction matrix load
process, the meshing algorithm will maximize the number if uniform rectangular
cells created in the mesh. The meshing algorithm is very flexible as different
parameters can be set by the user (number of cells/wavelength, number of
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cells/width, edge meshing, and mesh seeding), resulting in a mesh with different
density. It is clear that the mesh density has a high impact on both the efficiency and
accuracy of the simulation results. Default mesh parameters are provided which give
the best accuracy/efficiency trade-off. Both the RF and microwave modes use mesh
reduction technology to combine rectangular and triangular cells to produce a mesh
of polygonal cells, thus reducing demand for computer resources. As mentioned
previously, this feature may be turned on or off with a toggle switch.

Loading and Solving of the MoM Interaction Matrix Equation

The loading step of the solution process consists of the computation of all the electromagn
interactions between the basis functions and the filling of the interaction matrix and the excit
vector. The interaction matrix as defined in the rooftop basis is a dense matrix, that is, each r
function interacts with every other rooftop function. This electromagnetic interaction between
basis functions can either be strong or weak, depending on their relative position and their 
scale. The matrix filling process is essentially a process of order (N2), i.e. the computation time
goes up with the square of the number of unknowns.

In the solving step, the interaction matrix equation is solved for the unknown current expan
coefficients. The solution yields the amplitudes of the rooftop basis functions which span th
surface current in the planar circuit. Once the currents are known, the field problem is solve
because all physical quantities can be expressed in terms of the currents. In Momentum, the
equation is solved with a standard matrix factorization technique. This implies that the matr
solve process is essentially a process of order (N3).

Calibration and De-embedding of the S-parameters

Momentum performs a calibration process on the single type port, the same as any
accurate measurement system, to eliminate the effect of the sources connected to the
transmission line ports in the S-parameter results. Feedlines of finite length are
added to the transmission line ports of the circuit. Lumped sources are connected to
the far end of the feedlines. These sources excite the eigenmodi of the transmission
lines without interfering with the circuit. The effect of the feedlines is computed by
the simulation of a calibration standard and subsequently removed from the
S-parameter data. A built-in cross section solver calculates the characteristic
impedance and propagation constant of the transmission lines. This allows to shift
the phase reference planes of the S-parameters, a process called de-embedding.
Results of the calibration process includes the elimination of low-order mode
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mismatches at the port boundary, elimination of high-order modes, and removal of all
port excitation parasitics.

Besides transmission line ports, Momentum offers the user the ability to define direct excitati
internal ports. These ports can be specified at any location on the planar metallization patte
either a point or a line feed. They allow to connect both passive and active lumped compon
the distributed model of the planar circuits. The S-parameters associated with these ports a
calculated from the excitation consisting of a lumped source connected to the equivalent ne
model at the locations of the internal ports. The parasitic effects of these lumped sources anot
calibrated out of the S-parameters results.

Reduced Order Modeling by Adaptive Frequency Sampling

A key element to providing fast, highly accurate solutions using a minimum of
computer resources is the Adaptive Frequency Sampling (AFS) technology. When
simulating over a large frequency range, oversampling and straight line interpolation
can be used to obtain smooth curves for the S-parameters. Oversampling however
implies a huge amount of wasted resources. Momentum allows the user to benefit
from a smart interpolation scheme based on reduced order modeling techniques to
generate a rational pole/zero model for the S-parameter data. The Adaptive
Frequency Sampling algorithm selects the frequency samples automatically and
interpolates the data using the adaptively constructed rational pole/zero model. This
feature allows important details to be modeled by sampling the response of the
structure more densely where the S-parameters are changing significantly. It
minimizes the total number of samples needed and maximizes the information
provided by each new sample. In fact, all kinds of structure can take advantage of the
AFS module. The Adaptive Frequency Sampling technology reduces the computation
time needed for simulating large frequency ranges with Momentum significantly.
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Special Simulation Topics
Some special simulation topics are discussed in this section:

• Simulating slots in ground planes

• Simulating metallization loss

• Simulating internal ports and ground references

Simulating Slots in Ground Planes

Slots in ground planes are treated in a special manner by Momentum. An
electromagnetic theorem called the equivalence principle is applied. Instead of
attempting to simulate the flow of electric current in the wide extent of the ground
plane, only the electric field in the slot is considered. This electric field is modeled as
an equivalent magnetic current that flows in the slot.

Momentum does not model finite ground plane metallization thickness. Ground
planes and their losses are part of the substrate definition.

By using slot metallization definitions, entire structures, such as slot lines and
coplanar waveguide circuits, can be built. Slots in ground planes can also be used to
simulate aperture coupling through ground planes for multi-level circuits. Structure
components on opposite sides of a ground plane are isolated from each other, except
for intermediate coupling that occurs through the slots. This treatment of slots allows
Momentum to simulate slot-based circuits and aperture coupling very efficiently.

Simulating Metallization Loss

When using Momentum, losses in the metallization patterns can be included in the
simulation. Momentum can either treat the conductors as having zero thickness or
include the effects of finite thickness in the simulation. In the substrate definition,
the expansion of conductors to a finite thickness can be turned on/off for every layer.
For more information, refer to “Via Structures and Metallization Thickness
Limitation” on page A-25.

Momentum uses a complex surface impedance model for all metals that is a function
of conductor thickness, conductivity, and frequency. At low frequencies, current flow
will be approximately uniformly distributed across the thickness of the metal.
Momentum uses this minimum resistance and an appropriate internal inductance to
form the complex surface impedance. At high frequencies, the current flow is
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dominantly on the outside of the conductor and Momentum uses a complex surface
impedance that closely approximates this skin effect. At intermediate frequencies,
where metal thickness is between approximately two and ten skin depths, the surface
impedance transitions between those two limiting behaviors. This treatment of metal
loss is a good approximation for many cases but can be less accurate for very narrow
conductors. The surface impedance model for thick conductors includes mutual
internal coupling for currents at the top and bottom plane of the thick conductor. This
provides an improved model for low frequency to high frequency vertical current
redistribution inside the conductor.

The meshing density can affect the simulated behavior of a structure. A more dense
mesh allows current flow to be better represented and can slightly increase the loss.
This is because a more uniform distribution of current for a low density mesh
corresponds to a lower resistance.

Losses can be defined for groundplanes defined in the substrate definition. This uses
the same formulation as for loss in microstrips (i.e., through a surface impedance
approximation). It should be noted however that since the groundplanes in the
substrate description are defined as infinite in size, only HF losses are incorporated
effectively. DC losses are 0 by definition in any infinite groundplane. DC
metallization losses in groundplanes can only be taken into account by simulating a
finite size groundplane as a strip metallization level.

Simulating with Internal Ports and Ground
References
Momentum offers the ability to use internal ports within a structure. Internal ports can be spe
at any location on the planar metallization patterns, and they make possible a connection fo
passive and active lumped components to the distributed model of the planar circuits. Refe
Figure A-4.

The S-parameters associated with these ports are calculated from the excitation consisting
lumped voltage source connected to the equivalent network model, as shown inFigure A-3. The
ground reference for these ports in the resulting S-parameter model is the ground of the equ
network, and this ground correspondsphysically to the infinite metallization layers taken up in
the layer stack. In the absence of infinite metallization layers, the ground no longer has a p
meaning and correspondsmathematically with the sphere at infinity.

It is important to mention that in this case, the associated S-parameters also lose
their physical meaning, as the applied voltage source is assumed to be lumped, that
is electrically small, since it sustains a current flow from the ground to the circuit
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without phase delay. To overcome this problem, a ground reference must be specified
at a distant electrically small from the internal port. Failure to do so may yield
erroneous simulation results.

Figure A-4. Internal port and equivalent network model.

The following sections illustrate the use of internal ports with ground planes and
with ground references, and the results.

Internal Ports and Ground Planes in a PCB Structure

Figure A-5 shows the layout for a PCB island structure with two internal ports. The infinite
ground plane is taken up in the substrate layer stack and provides the ground reference for
internal ports. The magnitude and phase of the S21-parameter calculated with Momentum 

direct excitation point feed
A-11



Theory of Operation

red

rts, so
shown inFigure A-6. The simulation results are validated by comparing them with the measu
data for the magnitude and the phase of S21.

Figure A-5. PCB Substrate layer stack and metallization layer.

Figure A-6. Magnitude and phase of S21.

The thicker line is Momentum results, the thinner line is the measurement.

Finite Ground Plane, no Ground Ports

The same structure was resimulated with a finite groundplane (Figure A-7). The substrate layer
stack contains no infinite metallization layers. No ground reference was specified for the po

substrate layer stack metallization layer

L = 3 inches

W = 2 inches

infinite ground plane taken
up in the layer stack two internal ports

air: εr = 1.0

FR4: H = 59 mil, εr = 4.4
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the sphere at infinity acts as the ground reference for the internal ports. The S-parameters o
from a simulation for these ports no longer have a physical meaning. Using such ports in th
simulation yields incorrect simulation results as shown inFigure A-8.

Figure A-7. PCB substrate layer stack and metallization layers.

Figure A-8. Magnitude and phase of S21.
The thicker line is Momentum results, the thinner line is the measurement.

substrate layer stack metallization layer

L = 3 inches

W = 2 inches

finite ground plane not taken up
in the layer stack

two internal ports

air: εr = 1.0

air: εr = 1.0

FR4: H = 59 mil, εr = 4.4
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Finite Ground Plane, Internal Ports in the Ground Plane

One way to define the proper grounding for the internal ports is to add two extra internal po
the ground plane (Figure A-9). The resulting four-port structure is simulated with Momentum
Note that because no ground reference is specified for the internal ports, the resulting S-para
for the four port structure have no physical meaning. However, by properly recombining the
ports, a two-port structure is obtained with the correct ground references for each of the ports
should be taken with this recombination, as the ground reference for the four individual ports
not act as the ground reference for the two recombined ports. Therefore, the top recombina
scheme shown inFigure A-10 is incorrect. The correct recombination scheme is the bottom 
shown inFigure A-10.

Figure A-9. PCB substrate layer stack and metallization layers.

substrate layer stack metallization layer

L = 3 inches

W = 2 inches

air: εr = 1.0

FR4: H = 59 mil, εr = 4.4

air: εr = 1.0

finite groundplane not taken up
in the layer stack

four internal ports

1.i

3.i 4.i

2.i

2 extra internal ports
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Figure A-10. Simulation results.
The bottom illustration shows the correct recombination of ports.

Finite Ground Plane, Ground References

The process of adding two extra internal ports in the ground plane and recombining the ports
correct way can be automated in Momentum by defining two ground reference ports

1 21.i 2.i

3.i 4.i

1 21.i 2.i

3.i 4.i

Momentum
4-port

Momentum
4-port
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(Figure A-11). The S-parameters obtained with Momentum are identical to the S-paramete
the two-port after the correct recombination in the section above, also shown inFigure A-12.

Figure A-11. Substrate layer stack and metallization layers.

Figure A-12. Magnitude and phase of S21.
The thicker line is Momentum results, the thinner line is the measurement.

substrate layer stack

air: εr = 1.0

FR4: H = 59 mil, εr = 4.4

air: εr = 1.0

finite groundplane not taken up
in the layer stack

metallization layer

L = 3 inches

W = 2 inches

four internal ports with associated
ground reference ports

1.i 2.i

-1.i -2.i

2 ground reference ports
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Internal Ports with a CPW Structure

Figure A-13 andFigure A-14 show the layout for a CPW step in width structure with an
integrated sheet resistor (45 m x 50 m, 50 ). Six internal ports are added to the metalli
layers. The six-port S-parameter model is recombined into a two-port model to describe the
CPW-mode S-parameters. Different recombination schemes are possible, yielding different
simulation results. Scheme (c) is the correct one, as the ground reference for the internal p
the sphere at infinity and this cannot act as the ground reference for the CPW ports.

Figure A-13. CPW step-in-width with integrated sheet resistor

µ µ Ω

GaAs: H = 100 µm, εr = 12.9

air: εr = 1.0

air: εr = 1.0

substrate layer stack

sheet resistor

metallization layer

1.i
2.i

3.i 4.i

5.i
6.i
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Figure A-14. CPW Step-in-width structure with integrated
sheet resistor, port configurations and results.

The process of adding extra internal ports to the ground metallization patterns and recombini
ports in the correct way can be automated in Momentum by defining ground reference port

a

b
c

a

b

c
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(Figure A-15). The S-parameters obtained with Momentum are identical to the S-paramete
the two-port for the correct recombination scheme (Figure A-14 (c)).

Figure A-15. CPW step-in-width structure with ground
references for the internal ports.

Limitations and Considerations
This section describes some software limitations and physical considerations which
need to be taken into account when using Momentum:

• Comparing the microwave and RF simulation modes

• Matching the simulation mode to circuit characteristics

• Higher-order modes and high frequency limitation

• Substrate waves and substrate thickness limitation

• Parallel-plate modes and high frequency limitation

• Slotline structures and high frequency limitation

• Via structures and metallization thickness limitation

• Via structures and substrate thickness limitation

• CPU time and memory requirements

substrate layer stack

air: εr = 1.0

GaAs: H = 100 µm, εr = 12.9

air: εr = 1.0

sheet resistor

metallization layer

-1.i
-2.i

1.i 2.i

-1.i
-2.i
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Comparing the Microwave and RF Simulation Modes

Momentum has two simulation modes: the Microwave and RF mode. The Microwave
mode uses full-wave formulation, the RF mode uses a quasi-static formulation. In the
quasi-static formulation, the Green functions are low-frequency approximations to
the full-wave and more general Green functions. Because of the approximations made
in the RF mode, the simulations are more efficient. The approximation is valid for
structures that are small compared to the wavelength (size of the circuit smaller than
half a wavelength).

Another advantage of Momentum RF over the Momentum mode is its use of star-loop
technology to eliminate low-frequency breakdown of numerical solutions, and give
stable solutions down to DC. Momentum mode simulations use rooftop basis
functions defined over the rectangular and triangular cells in a mesh. While a
formulation based on rooftop functions produces accurate results at microwave
frequencies, it becomes unstable at lower, RF frequencies and a break-down of the
solution occurs. To eliminate the instability, Momentum RF uses a formulation based
on star-loop technology, which regroups the rooftop functions into star and loop
functions. The loop functions model the solenoidal part of the current solution, while
the star functions model the non-rotational part. This allows the elimination of the
low-frequency instability in the numerical solution.

Note Conductor loss is not included in boundry groundplanes and slot layers for
Momentum RF.

Matching the Simulation Mode to Circuit Characteristics

The Momentum RF mode can be used to simulate RF and microwave circuits, depending o
requirements. However, Momentum RF is usually the more efficient mode when a circuit is
electrically small, geometrically complex, and does not radiate. This section describes thes
characteristics.

Radiation

Momentum RF provides accurate electromagnetic simulation performance at RF
frequencies. However, this upper limit depends on the size of your physical design. At
higher frequencies, as radiation effects increase, the accuracy of the Momentum RF
models declines smoothly with increased frequency.
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Electrically Small Circuits

Momentum RF works best for electrically small circuits as its accuracy smoothly decreases
increasing electrical size relative to a given frequency. A circuit is considered electrically sm
relative to a given frequency if its physical dimension is smaller than half the wavelength of
frequency. Depending on which value you know, maximum circuit dimension or maximum
simulation frequency, you can determine a qualitative approximation of the circuit’s electrical
Suppose you have a circuit with dimensionD as shown in the following figure:

For space wave radiation, you can use one of the following two expressions strictly as a gu
to have an awareness about the circuit’s electrical size relative to the maximum frequency yo
to run the simulation. When you know the value ofD, use the first expression to approximate th
maximum frequency up to which the circuit is electrically small. When you know the maxim
simulation frequency, use the second expression to approximate the maximum allowable
dimension:

or

where:

D = the maximum length inmm diagonally across the circuit.

F = the maximum frequency inGHz.

F 150
D

---------<

D 150
F

---------<
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The following expression provides a guideline up to which frequency the substrate is
electrically small for surface wave radiation.

During a simulation, Momentum RF calculates the maximum frequency up to which
the circuit is considered electrically small, and displays that value in the status
display. This is similar to using the expressions above since the dimension and
thickness of a layout is typically fixed, and it is the simulation frequency that is
swept.

T

α 20=

α 10=

(with groundplane)
(without groundplane)

εr

Freq GHz
300

εr 1–( )α T m m

--------------------------------------------------<

Thickness WaveLength

εr 1–( )α
-------------------------------------<
A-22
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Geometrically Complex Circuits

The mesh generated for a simulation establishes a geometric complexity for a circuit.
A circuit is considered geometrically complex if its shape does not fit into a uniform,
rectangular mesh, and the mesh generation produces a lot of triangles. Layouts
containing shapes such as circles, arcs, and non-rectangular polygons usually result
in meshes with many triangles. A measure of increasing geometric complexity is
when the ratio of triangular cells to rectangular cells grows larger:

The mesh-reduction technology offered by Momentum RF and Microwave eleminates
electromagnetically redundant rectangular and triangular cells. This reduces the
time required to complete the simulation thus increasing efficiency. This mesh
reduction algorithm can be turned on or off, using a toggle switch.

Higher-order Modes and High Frequency Limitation

Since Momentum does not account for higher-order modes in the calibration and
de-embedding process, the highest frequency for which the calibrated and
de-embedded S-parameters are valid is determined by the cutoff frequency of the port
transmission line higher-order modes. As a rule of thumb for microstrip transmission
lines, the cutoff frequency (in GHz) for the first higher-order mode is approximately
calculated by:

Cutoff frequency fc = 0.4 Z0 / height

where Z0 is the characteristic impedance of the transmission line. For a 10 mil alumina subs

with 50 ohm microstrip transmission line, we obtain a high frequency limit of approximatelyc =

80 GHz.

Parallel Plate Modes

In the region between two infinite parallel plates or ground planes, parallel plate
modes exist. Any current flowing in the circuit will excite all of these modes. How
strong a mode will be excited depends on how well the field generated by the current
source matches with the field distribution of the parallel plate mode.

A distinction can be made between the fundamental mode and the higher order
modes. The fundamental mode, which has no cut-off frequency, propagates at any

Complexity Triangles
Rectangles
--------------------------=
A-23
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frequency. The higher order modes do have a cut-off frequency. Below this frequency,
they decay exponentially and only influence the local (reactive) field around the
source. Above this frequency, they propagate as well and may take real energy away
from the source.

Momentum takes the effect of the fundamental mode into account. The higher order
modes are taken into account as long as they are well below cut-off. If this is not the
case, a warning is issued saying that higher-order parallel plate modes were detected
close to their cut-off frequency. Simulation results will start to degrade from then on.

The Effect of Parallel Plate Modes

Let’s concentrate on the fundamental mode since this one is always present. The
fundamental mode has its electric field predominantly aligned along the Z-axis from
the top plate to the bottom plate. This means that this mode creates a difference in
the potential between both plates. This mode can be excited by any current in your
circuit: electric currents on a strip or via, magnetic currents on a slot. It behaves as a
cylindrical wave that propagates to infinity where it feels a short circuit (since both
plates are connected there). However, since infinity is very far away, no reflected wave
ever comes back.

In a symmetric strip line structure, the current on the strip won't excite the
fundamental mode due to this symmetry. However, the presence of a feature such as
a slot in one of the plates creates an asymmetry. The slot will excite the fundamental
mode!

The accuracy of the Momentum results for calibrated ports degrades when the
parallel plate modes become important. For calibrated ports is assumed that they
excite the circuit via the fundamental transmission line mode. However, this
excitation is not pure. The source will excite the circuit via the parallel plate modes,
too. This effect cannot be calibrated out, since those contributions are not orthogonal.
The consequence is that the excitation doesn’t correspond with a pure fundamental
transmission line mode excitation.

Avoiding Parallel Plate Modes

Since we know the field orientation of the parallel plate modes, it is easy to
understand that you can short circuit them by adding vias to your structure at those
places where parallel plate modes will be excited.

Similar problems will exist with the measurements. Both plates must be connected
explicitly with each other! This won't take place at infinity but somewhere at the side
A-24
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of the board. If no vias are used in the real structure, the fundamental mode may be
excited. This mode will propagate to the borders and reflect. Thus, the real structure
differs in that from the simulations where no reflection will be seen since a reflection
only happens at infinity.

One way to counter the difference between measurements in reality and simulation
is to take into account the package (box) around the structure. Another possibility is
adding vias to your structure, both in real life and in the simulations. Try to make the
physical representation of your circuit as close as possible to reality. However, the
actual shape of the via should not be that important. Small sheets can be used to
represent the small circular vias that are realized in the real structure.

Surface Wave Modes

If the substrate is not closed (open or half open), and not homogeneous, surface wave mod
exist. The parallel plate mode can be seen as a special case of a surface wave mode. Their b
is identical. Both are cylindrical waves that propagate radially away from the source. They a
guided by the substrate. Both fundamental and higher order surface wave modes exist. Sim
conclusions can be drawn with respect to limitations such as the effects of the modes.

Slotline Structures and High Frequency Limitation

The surface wave accuracy deterioration of the calibration process is somewhat more
prominent for slotline transmission lines than for microstrip transmission lines.
Therefore, slotline structures simulated with Momentum will exhibit a somewhat
higher noise floor (10-20 dB higher) than microstrip structures. For best results, the
highest simulation frequency for slotline structures should satisfy:

Substrate thickness < 0.15 * effective wavelength

Simulation of narrow slot lines are accurate at frequencies somewhat higher than the
high frequency limit determined by this inequality, but wide slotlines will show
deteriorated accuracy at this frequency limit.

Via Structures and Metallization Thickness Limitation

In Momentum, the current flow on via structures is only allowed in the vertical
direction; horizontal or circulating currents are not modeled. As via structures are
metallization patterns, the modeling of metallization losses in via's is identical to the
modeling of metallization loss in microstrip and slotline structures. Simulation of
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finite metallization thickness can be approximated in Momentum by defining two
horizontal metallization patterns and joining the edges with via structures. This
however will give only first-order accurate simulation results, as the horizontal via
currents are not modeled. There is also an automated feature that allows for the
expansion of the finite thickness conductor.

Via Structures and Substrate Thickness Limitation

The vertical electrical currents on via structures are modeled with rooftop basis
functions. In this modeling, the vertical via structure is treated as one cell. This
places an upper limit to the substrate layer thickness as the cell dimensions should
not exceed 1/20 of a wavelength for accurate simulation results. Momentum
simulations with via structures passing through electrically thick substrate layers
will become less accurate at higher frequencies. By splitting the thick substrate layer
into more than one layer, more via-cells are created and a more accurate solution is
obtained.

CPU Time and Memory Requirements

Both CPU time and memory needed for a Momentum simulation increase with the
complexity of the circuit and the density of the mesh. The size N of the interaction
matrix equation is equal to the number of edges in the mesh. For calibrated ports, the
number of unknowns is increased with the edges in the feedlines added to the
transmission line ports.

CPU Time

The CPU time requirements for a Momentum simulation can be expressed as:

CPU time = A + B N + C N2 + D N 3

where

N = number of unknowns

A, B, C, D = constants independent of N

The constant term A accounts for the simulation set up time. The meshing of the
structure is responsible for the linear term, BN. The loading of the interaction matrix
is responsible for the quadratic term and the solving of the matrix equation accounts
for the cubic term. It is difficult to predict the value of the constants A, B, C and D, as
they depend on the problem at hand.
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The quadratic and the cubic terms are dominating the overall CPU-time
requirements. For small to medium size problems, as the constant C is much larger
than D, the solution time is dominated by the loading of the matrix. For larger
problems the matrix solve time with its cubic term will eventually dominate the
CPU-time requirements.

Memory Usage

The memory requirement for a Momentum simulation can be expressed as:

Memory = X + Y N + Z N2

where

N = number of unknowns

X, Y, Z constants independent of N

Like with the CPU time expression, the constants X, Y and Z are difficult to predict
for any given structure.

For medium to large size problems, the quadratic term, which accounts for storing of
the interaction matrix, always dominates the overall memory requirement. For small
structures, memory usage can also be dependent upon the substrate. The substrate
database must be read and interpolated, which requires a certain amount of memory.
Algorithms to make trade-off between time and memory resources are implemented
in the simulator. These algorithms result in additional usage above that required to
solve the matrix. Total memory consumption is typically less than 1.5 times what is
required to store the matrix, for large matrices.

References
[1]R. F. Harrington, Field Computation by Moment Methods. Maxillan, New York

(1968).
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Appendix B: Drawing Tips
This chapter provides suggestions and examples when drawing layouts to be
simulated using Momentum. These examples take into consideration things that are
necessary during the drawing phase to ensure that requirements for Momentum are
met.

Using Grid Snap Modes
Working in Layout enables you to control all geometry precisely. The variety of
available snap modes can help you draw and position shapes. As an example, if you
are connecting shapes, you should have the vertex snapping mode turned on. You will
also want to review snap mode settings prior to adding ports to a layout.

Snap grid spacing also helps control the positioning shapes. In general, snap grid
spacing should be about 1/2 of the minor grid point value. For example, if the minor
grid points are 1.0, then the snap grid spacing should be 0.5. This makes it easy to
know how your geometry will snap into place.

For more information on snap modes and snap grid spacing, refer to Chapter 2 of
Layout.

Choosing Layout Layers
The standard set of layout layers begins with the layer named default. Do not use
this layer for drawing your circuit. The first valid layer for Momentum is cond. For
more information on layout layers, refer to the Schematic Capture and Layout
manual.

Keeping Shapes Simple
In general, when drawing shapes, you should use a minimal number of vertices per
shape, since this will make the mesh easier to compute. When drawing curved
objects, consider using a relatively large value for Arc/Circle Radius (under Options >
Preferences > Entry/Edit). This will minimize the number of vertices, and facets used
to represent the shape.
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Merging Shapes
Merging shapes is often useful for eliminating small geometry overlaps and can also,
in some cases, result in simpler mesh patterns. For example, if you draw a layout
using multiple polygons and you suspect there is some overlap, merging the polygons
will prevent the system from returning an overlap error. To merge the shapes, select
each shape that you want to merge, then choose Edit > Merge.

Viewing Port and Object Properties
Any item selected in a layout, including ports, shapes, or other components, has
associated properties. One way to view the properties is to select the object of
interest, then choose Edit > Properties. This method also enables you to change object
properties. If you want to change properties that have been attributed to an object for
Momentum, you should change these properties only through the Momentum Menu
selections.

To view the properties of the entire layout, choose Options > Info.

Using Layout Components
There are some limitations on the components that are available from the layout
palettes:

• Do not use substrate components that might appear on layout component
palettes. You must use the dialog box under Momentum > Substrates >
Create/Modify to create or edit substrate definitions.

• Lumped elements cannot be included in a layout that is to be simulated by
Momentum.

• Components from the Microstrip palette can be used, with limitations:

• The substrate name (for example, Subst = MSub1) is not used in Momentum.
Substrate definitions must be loaded from the Momentum > Substrates
menu.

• Any electrical properties, if defined, are not used. For example, the
parameters CPUA, RsT, and RsB in MFTC are ignored.
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• For most of the components in Layout, only the geometry is transferred to
Momentum. Any electrical properties must be defined from the Momentum
menus.

• Components from the Printed Circuit Board or Waveguide palette cannot be
used in a layout that will be simulated using Momentum.

• Stripline and suspended substrates components can be used, but the substrate
name parameters for these components will be ignored.

Drawing Coplanar Waveguide in Layout
Coplanar waveguide is, generally, slots filled with a dielectric or air, surrounded by
metal, as shown in the illustration below.

There are two basic methods for constructing coplanar waveguide in layout:

• The objects that you draw are the slots on a groundplane. In the substrate
definition, the layout layer that the slots are drawn on is mapped to a slot
metallization layer. Additionally, the top plane of the substrate definition is
defined as a ground plane. This method gives you infinite grounds on the
coplanar plane. An example is the coplanar waveguide bend, shown below.

You draw the slots.
By choosing a slot
metallization layer, the
area around the slots is
treated as a ground plane,
the slots are not metal.
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• The objects that you draw represent ground. For example, you can draw strips
with gaps in between. The gaps are treated as slots, the strips are treated as
ground. This layer is mapped to a metallization layer defined as a strip.
Additionally, the top plane of the substrate definition is defined as a ground
plane. This method gives you infinite grounds on the coplanar plane. Typically,
this method is used when coupled microstrip lines are created initially as
schematic elements.

Drawing slots on a ground plane the preferred method because a mesh with fewer
edges or unknowns will result, compared to meshing the strips. If a coplanar
waveguide design is drawn with strips, it can be converted to a slot pattern with a
boolean operation if a bounding box is provided.

Adding a Port to a Circuit
You can add a port to a circuit either from the Schematic window or a Layout window.
The procedures below include considerations for adding ports to a circuit that will be
simulated using Momentum.

Adding a Port to a Schematic

1. Select a port using by choosing the menu item Component > Port , or the port

icon from the tool bar:
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2. Position the mouse where you want the port and click. Verify the connection has
been made.

3. Select the port and choose Edit > Component > Edit Component Parameters .

4. The parameter layer= indicates the layer that the port is applied to. When you
convert your schematic to a layout, all components will be assigned to layout
layers. You can assign the port to a specific layer at this time. To change the
layer, select layer=  from the Select Parameter list, and choose a new layer from
the Parameter Entry Mode listbox. Make sure that the layer you choose will also
be mapped as a strip or slot metallization layer. For more information about
metallization layers, refer to Chapter 3, Substrates.

5. Click OK to accept the new layer specification.

When you generate a layout from the schematic, you should verify that the port is
positioned correctly. For more information, refer to the procedure for adding a port to
a layout and to “Considerations” on page B-7.

Adding a Port to a Layout

To add a port:

1. Determine where you want to position the port. A port can be applied to:

• The pin of a component

• The edge of a component or object (such as a rectangle or polygon), usually at
the midpoint

Connected

Not connected
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• The surface of an object

Note Do not place a port on the corner of an object. When you add a port to an
edge, make sure the appropriate snap modes are enabled. It is a good practice to
enable the modes Midpoint Snap and Edge Snap (under the Options menu) to
ensure accurate simulation results.

2. If you want to add a port to the surface of a polygon, you may need to disable
the following or other snap modes (under the Options menu):

• Pin snap

• Edge snap

• Midpoint snap

3. Identify the name of the layer on which the component or shape is entered. If
you don’t know the name of the layout layer, choose Options > Layers . Select
each layer, noting the color in the dialog box. When the color matches that of the
one in the Layout window, note the name of the layout layer. Dismiss the dialog
box.

4. Select a port using by choosing the menu item Component > Port , or the port

icon from the tool bar:

5. The Port parameters dialog box is displayed. The parameter layer indicates the
layer that the port will be applied to. The parameter defaults to the currently
active drawing layer.

6. This should be the same as the layer you noted in step 3. To change the layer,
select layer=  from the Select Parameter list, and choose a new layer from the
Parameter Entry Mode listbox. Make sure that the layer you choose is also a

Port connected to
a pin

Port connected to
an edge

Port connected to
a surface
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strip or slot metallization layer. Do not apply ports to shapes that are on layers
that are mapped to via metallization layers. For more information about
metallization layers, refer to Chapter 3, Substrates.

Note If you cannot find the layer name, choose Options > Layers, then select
the layer name of interest from the Layers list. Note the layer number in the
Number field. In the Port dialog box, select the layer= parameter and, under
Parameter Entry Mode, select Integer Value. Enter the layer number, then click
Apply.

7. Click Apply to accept the new layer specification.

8. Position the mouse where you want to place the port and click. The port is
added to the circuit.

Note If you are applying a port to an edge, the port must be positioned so that
the arrow is outside of the object, pointing inwards, and at a straight angle.
Generally, this happens automatically when you add a port to an edge. You may
need to zoom in to verify this.

9. The Instance Name in the Port dialog box is incremented if you want to add
another port. Verify the layer= parameter, then use the mouse to add the next
port.

10. When you are finished adding ports, click OK to dismiss the dialog box.

Considerations

Keep the following points in mind when adding ports to circuits to be simulated using
Momentum:

• The components or shapes that ports are connected to must be on layout layers
that are mapped to metallization layers that are defined as strips or slots. Ports
cannot be directly connected to vias. For information on how to define strips and
slots, refer to “Defining Metallization Layers” on page 3-12.
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• Make sure that ports on edges are positioned so that the arrow is outside of the
object, pointing inwards, and at a straight angle.

• Make sure that the port and the object you are connecting it to are on the same
layout layer. For convenience, you can set the entry layer to this layer; the
Entry Layer listbox is on the Layout tool bar.

• A port must be applied to an object. If a port is applied in open space so that is
not connected to an object, Momentum will automatically snap the port to the
edge of the closest object. This will not be apparent from the layout, however,
because the position of the port will not change.

• If the Layout resolution is changed after adding ports that are snapped to edges,
you must delete the ports and add them again. The resolution change makes it
unclear to which edges the ports are snapped, causing errors in mesh
calculations.

Note Do not use the ground port component in circuits that will be simulated using

Momentum (Component > Ground or the toolbar button ).

Either add ground planes to the substrate or use the ground reference ports that are
described later in this chapter.

Drawing Vias in Layout
Vias are drawn as lines or closed polygons. A simple line segment via is the simplest
and most practical way of drawing a via. Momentum creates a via by extruding the
object that is mapped as via through the substrate layer it is applied to. Vias drawn
as lines are often called sheet vias because, when the line is extruded through the
substrate, it is treated as a horizontal metal sheet. For vias of other shapes, you draw
a closed polygon. So, for example, for a cylinder via you draw a circle. When the shape
is mapped to a via metallization layer in Momentum, another dimension is added to
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the object in order for the shape to cut through the substrate. Thus a line becomes a
sheet, a circle becomes a cylinder.

Regardless of how you draw vias, avoid having them extend over the sides of the
objects that they connect to. Vias must be on the edge or inside the object. Any
portion of the via outside of the object boundaries will not be taken into account
during the simulation. The figure below illustrates various vias connecting two
strips.

Vias are treated in the following manner:

• Vias are represented as infinitely thin vertical sheets of metal. If a cylinder is
drawn as a via, then it is also treated as separate sheets of metal that comprise
the cylinder walls.

representations
of vias in Layout

vias extruded
through a
substrate layer
in Momentum

strip

via

bridge

via

strip via

Incorrect:
vias overlap the
object edges.

Efficient via:
sheet via with
width matching
width of strip.

Correct, but
not as efficient
as sheet via
with matching
width to strip.

Circular Via:
correct, but
may not be efficient.
Use an appropriate
arc recognition.
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• Vias are assumed to be opened, not covered, with current traveling on the sheet.
Vias can be drawn as covered, using a cap (cover) of the same size as the via
end, which is a terminating metal strip layout layer.

• A via cannot be coincident with another via if they cut through the same
substrate layer and they are on different layout layers. But two vias can be
coincident on the same layout layer.

• Vias should be wholly contained within any primitives that are to be connected.

• Vias can be specified with loss but are considered to have zero thickness, as are
all metals in Momentum.

Vias through Multiple Substrate Layers

When drawing vias that cut through multiple substrate layers, each via must be
drawn once on a single layout layer. This layout layer must then be mapped as Via to
each substrate layer that the via cuts through (using the Metalization tab) to assign
the via layer to all substrate layers.

Using Vias to Model Finite Thickness
You can use vias to model the finite thickness of a metal structure in the following
way:

(Top view)

(Side view)

In Layout:
One via drawn on
one Layout layer.

In Momentum:
Four substrate layers
have one via (process
layers) mapped to
each one.

via 1

via 1

via 1

via 1
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• Draw the top surface of the structure.

• Copy the shape onto another layout layer, positioning the shape exactly over the
first one. The shapes must match exactly.

• Draw a sheet via on the perimeter of one shape, but make sure the via is on a
third layout layer.

• As part of the substrate definition, make one layer an interface layer, with a
finite thickness and characteristics of the metal that you want to model.

When you apply this layout to a substrate definition, you will map the via to the
interface layer described above, then map the shapes to the metallization layers that
appear above and below this substrate layer. Recall that metallization layers will be
present only between two substrate layers, so you may need to add layers, such as air,
above and below the interface layer. The following drawing illustrates how to draw
the metal structure.

Drawing Air Bridges in Layout
If you are simulating an air bridge, you will have to create a layout and a substrate
definition that will support the geometry. This means adding an air layer (height
equal to the air bridge) which the vias will cut through. For example, you would have
some geometry (like a spiral) on a dielectric layer. Then a via would rise vertically,
cutting through the air layer, where it would connect to a metal bridge. Then another
via would connect from the bridge, down to the previous layer, and onto another path.

Draw the via along the perimeter of one of the strips.
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Drawing Tips
For further information refer to “Substrate for Designs with Air Bridges” on
page 3-29.

Ports and Air Bridges in Coplanar Designs
When you draw coplanar waveguide as slots on a ground plane, it is treated, by
default, as a four-port device composed of two, coupled slot lines. To make sure that it
will be simulated as coplanar waveguide, be sure to apply the Coplanar port type to
the ports on the circuit. This port type combines the two ports on the same reference
plane, and the two ports are treated as one. For instructions on how to apply the
Coplanar port type, refer to “Defining a Coplanar Port” on page 4-14.

If you do not use the Coplanar port type, a moding problem can result when a
coplanar waveguide transmission line also propagates a slot mode. If Coplanar ports
are used, the slot modes are short-circuited at the port interfaces. However, if the slot
modes are excited somewhere in the circuit, they can cause resonances at certain
frequencies. This will appear as non-physical results because the external boundary
conditions are critical to the electrical behavior in such cases. By adding air bridges
(straps) near the discontinuities the voltage level of the two grounds can be equalized
to eliminate the slot mode. An example of air bridges can be found on the coplanar
waveguide bend example, CPW_bend_prj. For information on how to include air
bridges in a circuit, refer to “Substrate for Designs with Air Bridges” on page 3-29.

metal

via 1

air bridge

via 2

metal
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Appendix C: Exporting Momentum Data
Momentum data can be exported to a 3D EM modeling tool and to IC-CAP for
additional analysis. The method you use to export data depends on the target
application.

Exporting Momentum Data to IC-CAP
Momentum can write S-parameter output files in the IC-CAP Measured Data
Management (MDM) File Format. These ASCII data files can easily be read and used
for modeling purposes in IC-CAP 5.x.

Enabling the IC-CAP MDM File Output

The IC-CAP MDM files are not created by default. You must create or edit the
Momentum configuration file:

 ($HOME)/hpeesof/config/momentum.cfg

and add the line:

 MOM_MDM_OUTPUT = TRUE

If this variable is set, you will find the IC-CAP MDM file once the Momentum
simulation is complete:

 (current_ADS_project_name)/mom_dsn/(current_layout_name)/proj.mdm

This file will only be available for 1-port and 2-port structures.

The data is densely sampled (as a function of frequency) if the adaptive simulation
mode was used during the Momentum simulation, otherwise, only the requested
sample points appear in the proj.mdm file.

Disabling the IC-CAP MDM File Output

If you do not want output in an .mdm file, you must disable the
MOM_MDM_OUTPUT variable.

You must set:

 MOM_MDM_OUTPUT = FALSE

or remove that line in the Momentum configuration file:
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Exporting Momentum Data
 ($HOME)/hpeesof/config/momentum.cfg

Example

This is an example of the contents of an .mdm file that was created from a
Momentum simulation.

! VERSION = 6.00
BEGIN_HEADER

ICCAP_INPUTS

freq F LIST 1 16   0.000000e+00 1.000000e+07 5.008333e+09 8.965347e+09
     1.000667e+10 1.667111e+10 2.666778e+10 3.000000e+10

ICCAP_OUTPUTS
s S B C GROUND
END_HEADER

BEGIN_DB
#freq R:s(1,1) I:s(1,1) R:s(1,2) I:s(1,2) R:s(2,1) I:s(2,1) R:s(2,2) I:s(2,2)

0.000000e+00 0.00000 0.00000 1.00000 0.00000 1.00000 0.00000 0.00000
0.00000

1.000000e+07 0.00000 -0.00139 0.99999 -0.00238 0.99999 -0.00238 0.00000
-0.00139
5.008333e+09 -0.57309 -0.24306 0.30188 -0.71430 0.30188 -0.71430 -0.57309
-0.24306
8.965347e+09 -0.59290 -0.28893 -0.38554 0.39683 -0.38554 0.39683 -0.59291
-0.28893
1.000667e+10 -0.85726 0.47812 -0.00500 -0.00983 -0.00500 -0.00983 -0.85726

0.47812
1.667111e+10 0.38444 0.32013 0.52995 -0.65935 0.52995 -0.65935 0.38444

0.32013
2.666778e+10 -0.44899 -0.19974 -0.39885 0.68719 -0.39885 0.68719 -0.44899
-0.19974
3.000000e+10 0.03191 0.96691 -0.01394 -0.00395 -0.01394 -0.00395 0.03191

0.96691

 END_DB
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Exporting Momentum Data for 3D EM simulation
You can export Momentum data for 3D EM simulation without running a Momentum
simulation first. A complete set of files that describe the design geometry and
Momentum setup, including the technology and stimulus information, can be written
to a special directory by using a menu command in the ADS Layout window.

• To generate files and for use in 3D EM simulation:
In the ADS Layout window, choose Momentum > 3D EM > Save Files for 3D EM .

The files are then generated and saved in the current project under
<project_name>/mom_dsn/<design_name>/3DEM. They contain both the
design geometry and Momentum setup.

• For more information on how to import Momentum files into your 3D EM
modeling tool, refer to the documentation supplied with the tool, or check with
the tools manufacturer.

Exporting the Momentum Substrate to RFDE
Do the following to export the momentum substrate for use in RFDE:

1. Define the substrate.

2. Perform a Momentum Simulation (e.g., Momentum > Substrate > Precompute... ).

3. Save the project.

4. In RFDE, select the proj.tch file located under
<projectDir>/mom_dsn/<designName>.

If the mask numbers in RFDE and ADS do NOT match, edit the proj.tch file and
replace the ADS mask numbers with the ones found in RFDE.

Note You can access the proj.tch file from the temporary simulation directory before
the simulation is finished. The location of the temporary simulation directory
depends on the operation system settings. Generally, for UNIX and Linux, it is found
under /var/tmp/<somedirectory>. On the PC it depends on the value of the TEMP
system environment variable.
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Appendix D: Momentum Optimization -
Background Information
Optimization is an area of applied mathematics dealing with minimization (a
maximization problem can be formulated as minimization) of an objective function.
Many optimization algorithms have been developed over the years. Some of the best
are made available here for the purpose of layout design. Momentum Optimization
employs a comprehensive set of optimizers including L1, L2 (least squares), Minimax,
quasi-Newton, random and simulated annealing algorithms. All of these have been
adapted specifically to handle engineering design problems.

Optimization Variables
In the process of minimizing an objective function the optimizer makes changes to
optimization variables. In Momentum Optimization some or all of the parameters
defined in layout parameterization can be designated as optimization variables. You
can designate parameters as variables by clicking on the Allowed to vary box in the
Optimization Parameters Editor so a check mark appears. At least one parameter
must be selected as an optimization variable in order to perform an optimization.

There are several reasons why you may want to fix a parameter value and not allow
the optimizer to vary it. For example, you may want to parameterize one layout for
different applications where different constraints may be required. Then you use
different subsets of all parameters as optimization variables in separate
optimizations of the layout. A typical situation, however, is when you may want to
carry out the optimization process in a few phases. You start with one or two
optimization variables that may influence the responses most significantly. Once that
phase is finished you may release more variables and restart optimization to further
refine the responses.

The values relevant to optimization are:

• The Starting value is the value at which the optimizer begins its search

• The Optimal value is the value declared by the optimizer as the best when the
search is finished

By default (if the Starting Value entry is not filled in) the nominal value is taken as
the starting value. The assumption is that the nominal design is not far from the final
design. However, you are free to enter a different value as the starting value. This is
useful if you want to restart optimization from a different starting point or if the
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Momentum Optimization - Background Information
nominal design is drawn far away from the expected solution simply for drawing
convenience.

Whenever possible you should run optimization with a good selection of the starting
values. The closer the starting point is to the solution, the faster the optimization
process might be, requiring fewer Momentum simulations. There is also a better
chance of avoiding traps of local minima.

If a parameter is not allowed to vary, its value is fixed at the Starting Value, as
entered in the Optimization Parameters Editor. If no entry is made, its value is fixed
at the nominal value (the default Starting Value).

The optimal values are reported in the “Parameters” list in the Optimization
Parameters Editor after optimization is finished. They are stored with your nominal
design and can only be changed by the optimizer after another optimization run
leading to a different solution.

A mechanism is provided to update the starting values with the optimal values. By
clicking the Back Annotate Optimal Values button, you can replace the current
starting values with the optimal values. This might be useful if you want to restart
optimization under different conditions and you believe this would be a good selection
of the starting values. The starting values can still be modified manually.

Two additional values are relevant to optimization:

• The Lower bound is the lowest value the optimizer is allowed to generate

• The Upper bound is the highest value the optimizer is allowed to generate

The bounds establish the limits of the exploration region for the optimizer. It is
highly recommended to limit the exploration region if you can. The importance of
reasonably setting the lower and upper bounds on the optimization variables is
particularly evident in the case of random optimizers. By exploring vast areas far
away from the solution, a significant computational effort may be wasted.

Design Goals/Specifications
A single design goal consists of a frequency plan, a response of interest, the
specification type, and a numeric value that the response should either exceed or
achieve. The latter is referred to as the goal value. A common term for a design goal is
“design specification”. It will be used here as well. Design goals are defined in the
Optimization Goals Editor (Momentum > Optimization > Goals).
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A frequency plan can consist of either a single point or a linear sweep. As a response
of interest you can select an S parameter in any of the following forms:

• Magnitude in dB

• Magnitude

• Phase (in degrees)

• Real part

• Imaginary part

The S-parameters available for optimization are with respect to the reference
impedance of 50 . Any combination of the above forms for any selection of port
indices can be optimized simultaneously. Two different forms for the magnitude are
provided intentionally. It makes a difference for the optimizer what form is used, and
thus the optimization process may proceed and converge differently. The first form
describes relative variations, while the other describes the absolute variations.

The specification type is defined using one of the following symbols:

• <

• =

• >

They are called an upper specification, an equality specification and a lower
specification, respectively. The first and the third type together are referred to as
inequality specifications. For window specifications you need to define two design
goals for the same frequency plan: one using an upper specification and the other one
using a lower specification.

You can define multiple design goals for different frequency plans, and using different
specification types. You can emphasize/de-emphasize their relative importance using
weights associated with each goal.

You can run optimization using a subset of all design goals that have been defined.
Each design goal can be activated (this is the default setting) or deactivated. At least
one design goal needs to be defined and activated to be able to run optimization.

The Momentum simulation results, subsequently stored in the database (see Actual
EM Simulations and Database), are generated for all frequency points defined in the
Optimization Goals Editor. Any frequency plan that may have been defined using
Momentum > Simulation is not used. All the design goals, whether activated or not,
are used to determine the frequency points for EM simulations. Thus, activation or

Ω
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Momentum Optimization - Background Information
deactivation of any of the goals does not obsolete the database. This is very useful if
you want to refine your design by restarting optimization with a different subset of
design goals. In other words, you may simply define additional “design goals” that are
deactivated in initial optimization and this will allow you to monitor the circuit
behavior at the corresponding frequency points.

How Design Goals are used by the Optimizers
Momentum Optimization creates a single function to quantify the deviation of the
circuit responses from the design goals. It is called an objective function. A minimum
of the objective function corresponds to the optimal solution. There are many ways to
define an objective function. One important feature of various formulations is that
the objective function is

• Positive  if at least one design goal is not met (one design specification is
violated)

• Zero if all design goals are met but at least one of them is just met (the response
becomes equal to goal value)

• Negative or zero  if all design goals are met with some margin

It is worth noticing that design goals may be defined too tight so that no solution
satisfying all goals exists. Thus, negative values of the objective function may not be
attainable.

An error function for every goal and at every frequency point is formulated based on
the response value, goal value, the type of specification and the weight. The
formulation follows the same rule that a positive value means violation of the
specification. In the following discussion, we use the notation

Fj   j=1, 2, ...., m

to denote all individual error function values. Momentum optimization uses the
following objective functions formulated from individual error function values:

• Max Error  (minimax objective function) defined as

U max Fj{ }=
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• L1 Error  (least-one objective function) defined as

• L2 Error (the classical least-squares objective function) defined as

• GL2 Error (the generalized least-squares objective function) defined as

The Max Error and the GL2 Error objective functions are more suitable for inequality
and window specifications, as they become negative when all goals are exceeded by
some margin. The L1 Error and L2 Error objective functions do not account for design
goals that have been exceeded. The individual error functions corresponding to
inequality specifications are set to zero when they become negative.

Each objective function has specific advantages over other formulations. They are
briefly discussed in “Optimization Algorithms” on page D-6. The optimal solution in
terms of one objective function may be different (and it usually is) from the optimal
solution in terms of another objective function.

The user's choice of the objective function is made indirectly by selecting the
Optimization Type in the Optimization Control Editor.
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Momentum Optimization - Background Information
Optimization Algorithms
Many different methods exist for solving minimization problems. None of them is
universally applicable. Momentum Optimization employs several state-of-the-art
optimization types (algorithms/objective function formulations) to help you achieve
your design goals. An algorithm together with its implementation in the program is
referred to as an optimizer. Each optimizer constructs an objective function from the
design goals and then employs a unique algorithm to minimize the object function.

• The Minimax optimizer uses the Max Error objective function. It concentrates
its effort on minimizing the largest violation of specifications. Once all the
specifications are satisfied it continues its effort on maximizing the smallest
design margin (minimizing the negative objective function). Thus, it is most
suitable for optimization with upper and lower specifications. The Minimax
optimizer tends to achieve an equi-ripple solution: while attempting to
minimize the largest individual error another “opposing” error may be
increased. The optimizer will stop when such “opposing” errors become equal.

• The L1 optimizer uses the L1 Error  objective function. It tries to drive as many
individual errors as possible to exactly zero. Thus, it is most suitable for
optimization involving equality specifications. In the case of inequality
specifications this optimizer will stop once all design goals are met.

• The L2 optimizer uses the L2 Error  classical least-squares objective function.
The smoothness of the objective function makes it a very robust and reliable
technique. In the case of inequality specifications this optimizer will stop once
all design goals are met.

• The Quasi-Newton  optimizer uses the GL2 Error  objective function. It
implements the Fletcher-Powell-Davidon algorithm. The objective function
formulated for this optimizer, similarly to Minimax, facilitates improving the
design margin when all specifications are satisfied (design centering).

• The Random  optimizer also uses the GL2 Error  objective function. The Random
optimizer uses a random search algorithm and does not require a gradient. It is
less susceptible to potential traps of local minima when compared with
gradient-based optimizers, but it also converges less efficiently. This optimizer
searches the entire exploration region determined by the lower and upper
bounds on the optimization variables. It is thus important to reasonably set
those bounds.
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• The Simulated Annealing  optimizer uses the GL2 Error objective function. It
employs a global optimization strategy, but requires a large number of
simulations to reach a solution.

The first four optimizers are so-called gradient-based. They need first-order partial
derivatives in addition to the value of the objective function to make a decision on the
subsequent steps. They usually move fairly quickly towards a minimum particularly
if one exists close to the starting point. If possible, they tend to search fairly limited
areas of available exploration regions and are susceptible to traps of local minima.
The last two optimizers do not require gradient information. Since they normally use
a large number of steps, a caution is recommended when trying to use them in
conjunction with more time consuming EM simulations.

The first three optimizers have been specifically developed for minimization of their
corresponding objective functions. Therefore, their performance in handling their
objective functions is likely to be far superior over any other optimizer. The last three
optimizers are general purpose techniques.

Momentum Optimization provides the default Optimization Type such that it is best
suited to the design goals provided.

• If there are inequality design goals the default optimizer is Minimax.

• If there are only equality design goals the default optimizer is L1.

It is recommended to accept the default setting unless you have a good reason to
change it.

Stopping Criteria for the Optimization Process
The optimizer stops when it cannot minimize the objective function anymore. Except
for local minima, improperly set design goals, or rare numerical deficiencies, this
should be the desired solution. Momentum Optimization provides two additional
stopping criteria for the optimization process. The optimizer will stop even if it would
otherwise continue if:

• The Maximum Number of Iterations specified in the Optimization Control
Editor is reached; if the optimization does not converge to an optimal solution
before reaching this limit, it will stop and present the best result up to that
point as the solution
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Momentum Optimization - Background Information
• The Stop as soon as the specs are met radio button in the Optimization Control
Editor is on (the default setting); this instructs the optimizer to stop
immediately when all design goals are met for the first time

The first stopping criterion is essential for making sure the optimizer stops in the
rare cases of numerical instability, slow convergence, or excessive iterations making
insignificant refinements to find the solution. This limit is fairly predictable for
typical optimization problems. For the L1, L2 and Minimax optimizers it usually
takes between 10 and 30 iterations to reach the solution. This is fairly independent of
the number of optimization variables. The limit on the number of iterations is not a
limit on the number of actual Momentum simulations. The number of Momentum
simulations needed to reach a solution is far less predictable. It may vary
significantly depending on the number of variables, whether interpolation is used or
not, the size of the interpolation interval, and the size of the exploration region.

The second criterion is intended for use in conjunction with inequality specifications.
It makes no difference for the L1 and L2 optimizers since their objective functions do
not account for exceeding the specifications. In the case of other optimizers this
criterion does not require the goals to be met exactly. Depending on the optimization
trajectory the solution may already feature some goal margin when the process is
stopped. If you want to achieve a design goal exactly you should use an equality
specification instead.

You can override the second stopping criterion by selecting the Continue to obtain a
centered design option. This is a preferred choice to achieve good designs for circuits
such as filters, particularly if manufacturing tolerances are of concern. However, if
there are no “opposing” individual errors, this option may lead to excessive iterations
and undesired solutions. For example, if you want to minimize coupling between two
strips by adjusting the spacing, the optimizer will attempt to drive the strips as far
apart as allowed by the upper bound imposed on the spacing.

You do not need to be afraid of wasting valuable computer resources and time if you
want to interrupt or stop optimization. If you restart optimization under identical
conditions, the optimization process will repeat itself using data from the database
and it will arrive almost instantly at the same stage where the interrupt occurred.
Similarly, if optimization is stopped because either the maximum number of
iterations has been reached or all the goals have been met you can restart
optimization after changing the corresponding stopping criterion. Again, the
optimizer will arrive almost instantly at the stage where the stop occurred.
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Appendix E: Momentum Optimization -
Response Interpolation
In order to improve the overall efficiency of the optimization process, Momentum
Optimization employs parameter discretization and response (S parameters)
interpolation. It also maintains a database that contains the results of every
Momentum simulation performed by the optimizer.

It is under the user's control how each of the parameters is discretized (see
“Interpolation Grid and Resolution” on page E-1) and what interpolation scheme is
applied (see “Types of Interpolation” on page E-8). The interpolation feature can be
turned off (see ““No interpolation” Option” on page E-7).

The database is created and maintained by the program. The user can delete an
obsolete database (see “Removing Obsolete Databases” on page E-3). The database is
specific to Momentum Optimization. Any results (datasets) obtained using the menu
option Momentum > Simulation are not stored in the database because they do not
contain any information on layout parameterization.

Interpolation Grid and Resolution
If the interpolation feature is used (default setting) then the parameter values are
discretized. The resulting discrete parameter values establish a rectangular,
multidimensional interpolation grid. The size of the grid can be controlled by the user
by means of the Interpolation Resolution defined in the More dialog in the parameter
definition area of the Optimization Parameters Editor. Momentum Optimization
associates each parameter with an interpolation interval whose size (length) is
defined as:

Two consecutive grid points in the respective direction are Interpolation Interval
apart. Coarser grids correspond to smaller interpolation resolutions while higher
interpolation resolutions mean finer grids. The interpolation resolution can only be a
positive integer. The coarsest grid available corresponds to an interpolation
resolution of 1. Then, Interpolation Interval is equal to the distance between the
nominal and perturbed parameter values.

Interpolation Interval Perturbed Value Nominal Value–
Interpolation Resolution

-------------------------------------------------------------------------------------=
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Momentum Optimization - Response Interpolation
Since a separate interpolation resolution is defined for each parameter, a grid can be
coarser for one parameter and finer for another. This provides the flexibility in
accommodating different sensitivities of responses with respect to different
parameters.

By definition, the parameter values corresponding to the nominal and perturbed
designs are on the grid. The grid thus expands from those two points in both positive
and negative directions of each parameter. The grid is not bounded by the nominal
and perturbed values, but may be limited for other reasons (see “Zero Parameter
Values” on page E-5 and “The Impact of Parameter Bounds on Interpolation” on
page E-6).

How Does the Interpolation Feature Work?
If the interpolation feature is enabled, the only points (sets of parameter values) that
can be submitted for Momentum simulation are on-grid points.

A point is off the grid if at least one of the parameter values falls in the interior of its
interpolation interval. If a point of interest (requested by the optimizer) is off the grid
then a number of neighboring on-grid points, called the base points, are selected by
the program. Momentum simulation is requested at all of those base points. The
responses at the point of interest are then calculated by interpolation. This
interpolation is performed with respect to the parameter values.

The aforementioned rule applies to all situations, including a single point simulation
such as for the optimal parameter values. Therefore, the optimal results (displayed
after optimization is finished) are normally obtained by interpolation. Similarly, if
you define two parameters, allow one to vary by the optimizer, and keep the other one
fixed at an off-grid value, it may look like the optimizer “changes” the “fixed”
parameter for EM simulations. This is correct. Indeed, the neighboring on-grid values
are used in order to interpolate the responses at the requested fixed value.
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Actual EM Simulations and Database
Before calling Momentum to actually perform a simulation at a base point, the
database is checked to see whether the requested dataset is already there. If it is, the
results from that dataset are reused instead of performing an actual EM simulation.
If not, Momentum is invoked to simulate the design corresponding to that base point.
After simulation is completed, the database is augmented by the new results. Once in
the database, these results can be reused whenever the responses at the same base
point are needed.

During optimization, Momentum is invoked for an EM simulation only if at least one
parameter has moved beyond its interpolation interval from the previous iteration.
For small changes in parameter values, interpolation is used to obtain the responses
instead of calling for additional Momentum simulations. This can substantially
reduce the total number of EM simulations needed for optimization.

Removing Obsolete Databases
A Delete Previous Database check box is available in the Optimization Control Editor.
The default setting is “unchecked” so that the database, if one exists, will be reused.

The database is a very valuable asset since it may contain the results of hours or days
of EM simulation time. Therefore, care should be exercised while asking the program
to remove an existing database.

There are several reasons why an existing database may become obsolete. All of them
are related to the information contained in the database being no longer compatible
with the current setup for optimization.

The database contains the information on:

• The number of parameters

• The number of frequencies

• The number of ports

Each dataset in the database contains information on:

• Parameter values

• Frequency point values

• S-parameters for each frequency point
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The database has no knowledge of the layout information, including the nominal and
perturbed designs, or the actual parameter values associated with those designs.
Meshing setup, units, etc., are also not known to the database.

Therefore, in order to preserve the validity of an existing database, you should not
change:

• The nominal and perturbed design layouts, including material properties and
port definitions

• The number and definition of parameters, except for allowing/disallowing them
to vary

• The sequence in which the parameters are listed in the Optimization
Parameters Editor

• Meshing parameters

• The nominal and perturbed parameter values

• Frequency plans, except for activation/deactivation of individual goals or
changing the selection of individual S-parameter responses

Whenever possible, the program will detect potential incompatibility with the
existing database and issue a warning. Certain changes such as layout modifications
cannot be detected. If the existing database is not deleted, additional results of
Momentum simulations will be added to it. This may lead to a database containing,
for example, some datasets simulated by Momentum with an edge mesh, and others
without it.

Before deleting a database, it is advisable to consider other options. The simplest is to
rename the current design using “Save As” or “Copy Design” and institute desired
changes within the new design.

Hints for Selecting the Interpolation Resolution
A good choice for the interpolation interval is obviously problem dependent. If the
interval is too large, then the interpolated responses may not be accurate. On the
other hand, a very small interpolation interval increases the number of EM
simulations and ultimately defeats the purpose of using interpolation.

A practical approach is to start with a coarse resolution (for example, 4) and then
increase the resolution if the optimized solution is not sufficiently accurate. The
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choice of the resolution also depends on how large an increment in parameter value
has been established by the nominal and perturbed designs.

For small perturbations, say less than 10%, a value lower than the default setting for
the interpolation resolution might be acceptable. If a large perturbation is used (for
example one value is twice as large in magnitude as the other) the default resolution
is unlikely to be adequate. The sensitivity of the response with respect to the
parameter value is an important factor. In many designs, fortunately, designers may
have a good insight into their design sensitivity before setting up the optimization
task.

If an increasing sequence of interpolation resolution values is used, it is advisable to
use an exact multiple of the previous value to set the subsequent value. This will
guarantee that all previous grid points will be on the new grid, thus making the
previously simulated points available for reuse if needed.

Zero Parameter Values
As already mentioned, the parameter values corresponding to the nominal and
perturbed designs are on the grid. Depending on your definition of the nominal and
perturbed layouts, as well as of the interpolation resolution, the zero value of a
parameter may or may not be on the grid.

A zero value of a parameter may require special handling if it falls on the grid. If the
parameter represents a geometrical dimension such as length, the value of zero may
lead to a degenerate geometry. In order to avoid Momentum simulation of a
degenerate geometry, the selection of base points is modified in cases when a zero
value would normally be needed. When the point of interest falls into the first
interpolation interval (with zero as one of its endpoints) the next two grid points are
selected as the base points and the results are determined by extrapolation.

As an exception, a zero value grid point is treated like any other grid point in the
following three situations.

• Either the nominal or perturbed value is exactly zero

• The nominal and perturbed values are of the opposite signs

• At least one of the parameter bounds is of the opposite sign than the nominal
and perturbed values which are of the same signs

In any of the above cases it is assumed that the zero value corresponds to a legitimate
geometry, and thus the process of selecting the base points is not modified.
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Momentum Optimization - Response Interpolation
A typical situation when both the nominal and perturbed values are positive and the
lower bound is zero is treated by the modified approach. Thus, for any parameter
value within the first interval including zero the responses are obtained by
extrapolation from the results at the first two nonzero grid points.

The Impact of Parameter Bounds on Interpolation
The Lower and Upper parameter Bounds in the More dialog box in the parameter
definition area of the Optimization Parameters Editor serve a dual purpose.

In optimization, the bounds establish the limits of the exploration region. It is
advantageous to limit the exploration region if one has the knowledge to do it. This is
similar to a good selection of the starting point. The closer we are to the solution and
the smaller the exploration region the faster the optimization process might be. This
translates directly to the time required for finding the optimal solution. With time
consuming EM simulations in the background, these advantages cannot be
underestimated. Fortunately, a designer’s own experience may help in setting these
quantities. The importance of reasonably setting the lower and upper bounds on the
optimization variables is particularly evident in the case of random optimizers. By
exploring vast areas far away from the solution, a significant computational effort
may be wasted.

In the case of EM optimization where the variables are geometrical dimensions the
bounds play another very important role. They are effective in preserving the
physical meaning of the layout. By the term “preserving the physical meaning” we
mean primarily that the topology of the layout remains unchanged within the
parameter bounds. Varying the parameter values should not create gaps or overlaps.
Any such creation would inevitably lead to discontinuities in the responses. Then,
interpolation would not only be misleading to the optimizer. It may also be highly
inaccurate.

The term preserving the physical meaning also means that generation of extreme
layouts can be avoided. As an example, consider varying the length of a rectangle to
the extent that the length becomes several orders of magnitude larger than the
width.

If the interpolation feature is enabled, none of the base points is generated outside
the parameter bounds. The largest base point can coincide with the upper bound, if
the upper bound is on the grid. Similarly, the smallest base point can coincide with
lower bound, if the lower bound is on the grid. The only exception to these rules is if
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the bound is exactly zero. The special handling of zero parameter values, if
applicable, takes precedence (see “Zero Parameter Values” on page E-5).

The optimizer will not generate parameter values outside the bounds. However, it
may generate points very close to the bounds. If the bound is not on the grid then for
any value between the last grid point and the bound (inclusive) the results are
generated by extrapolation. Similarly, extrapolation applies to any parameter value
outside the bounds at which the user may choose to perform simulation.

“No interpolation” Option
You can choose No interpolation under Interpolation Type in the Optimization
Control Editor. Selecting No interpolation disables the feature and every single point
(set of parameter values) requested by the optimizer will be submitted for
Momentum simulation. The results are stored in the database regardless of whether
the point is on or off the grid.

It is important to remember that, in order to estimate response gradients,
Momentum will additionally be invoked for a number of points at every iteration of
optimization.

Interpolation in Gradient Evaluation
Momentum Optimization estimates the gradients by extracting the difference in a
response at slightly different parameter values. If the field solver is invoked to
simulate two structures with slightly different dimensions, the difference in the
response may not be reliably extracted due to inherent numeric noise.

Numerical stability in gradient evaluation comes as an important benefit of
interpolation. The interpolating function is well defined since it is based on more
significant differences in parameter values. The gradient is calculated from the
interpolating function. And, it is a true gradient of the function that is actually seen
by the optimizer.
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Momentum Optimization - Response Interpolation
Types of Interpolation
The Interpolation Type entry in the Optimization Control Editor allows you to choose
the interpolation algorithm. This, in turn, has an impact on how many and which
neighboring on-grid points are selected as the base points.

Linear Interpolation

Linear interpolation at an off-grid point requires EM analyses at n + 1 base points,
where n is the number of parameters with off-grid values. The placement of the grid
points for n = 2 is illustrated in Figure E-1.

Figure E-1. The Base Points (Shaded) Required for Linear Interpolation at an
Off-Grid Point (Solid)

Linear interpolation is adequate when the grid size is sufficiently small such that a
linear function can approximate the response of interest within the interpolation
interval with a reasonable accuracy.
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Quadratic Interpolation

Quadratic interpolation generally provides more accurate results than linear
interpolation, at the expense of increased computational effort. Quadratic
interpolation at an off-grid point requires EM analyses at 2n + 1 base points, where n
is the number of parameters with off-grid values. The placement of the base points
for quadratic interpolation for n = 2 is illustrated in Figure E-2.

Figure E-2. The Base Points (Shaded) Required for Quadratic Interpolation at an
Off-Grid Point (Solid)
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Appendix F: Momentum Optimization -
Layout Parameterization
Momentum Optimization captures the user-defined design parameters movements
by comparing each perturbed design with the nominal design. The layout
parameterization is accomplished by determining a mapping, which links the
parameter values with the coordinate of all the vertices. It is normally assumed that
if one (any one) parameter is varied then each vertex moves along a straight line, or it
does not move. For simultaneous changes of more than one parameter the resulting
movements of the vertices are defined by superposition.

Note Rotation parameters define inherent non-linear vertex trajectories. Therefore
such parameters must be carefully defined to avoid inconsistencies. For instance, it is
advised to force the rotation parameters to stay within the [nominal, perturbed]
value range during optimization.

One should be careful when defining the optimization parameters, the nominal and
perturbed designs and their bounds. The optimizers within Momentum Optimization
may fail to converge when they encounter large discontinuities, such as connectivity's
being broken or newly created. The layout parameterization verifies that this does
not happen for the parameter values defined by the nominal and perturbed design,
but it does not do that for all the other values of the parameters.
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Momentum Optimization - Layout Parameterization
Guidelines for Preparing Perturbed Designs
The following are the general guidelines for setting up Momentum designs for layout
parameterization.

• The number of components and artshapes must remain the same between the
nominal and the perturbed designs.

• The number of ports must remain the same between the nominal and the
perturbed designs.

• The number of vertices of each object must remain the same. In other words,
the basic topology of the structure must not change. For instance, you can
change the size of a rectangle, but you cannot change a rectangle into a triangle.
Be careful when changing arc lengths, if by any operation they are translated to
polygons, the number of vertices may differ. Use the command Edit > Modify >
Arc/circle Resolution to assure the same number of vertices along the outline.

• The connectivity must remain the same between the nominal and the perturbed
designs. For instance, the following incremental change cannot be
parameterized:

• Components and ports mapped to a metallization layer must have the same
name in the nominal and perturbed designs.

Note The perturbed designs do not have to include the setup of substrate,
metallization and mesh.

Nominal
design

Perturbed
design
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Vias Parameterization
Sometimes it might help to redefine some parameters. For instance, the figure below
shows a non optimal solution for optimizing the width of a via and the width of the
hole the via passes through:

Because for certain parameter values the via might be bigger than the hole, which
would drastically change the connectivity of the circuit. For that reason a preferred
parameterization is:

This parameterization defines the width of the via and the distance between the via
and the hole as the parameters. Constraining this distance to be bigger than the
nominal value will eliminate connectivity changes.

Nominal Perturbed_via Perturbed_viahole

Nominal Perturbed_via Perturbed_viahole
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Appendix G: Command Reference

Momentum Menu

Layout Window

_____________________________________________________________________________

Simulation Mode

Enable RF Mode / Disable RF Mode

Toggles Momentum’s simulation mode setting between RF mode and microwave
mode. In each case, the Layout window’s Momentum menu label indicates the
current mode.

Substrate Menu

Open...

Provides you with a choice to open a predefined, supplied substrate (Yes) or a project
specific user defined substrate (No).

Save

Saves the substrate and defined metallization for the open design.

Save As...

Saves the substrate and defined metallization by a name of your choice.

Delete...

Deletes the substrates chosen.

Create/Modify...

Creates a substrate/metallization definition or modifies an existing one.

Update From Schematic

If the substrate used in a Momentum layout is defined in a schematic (for example,
with the MSUB component) and the substrate on the schematic is modified, you must
update the substrate information in the layout by choosing Momentum > Substrate >
Update From Schematic.
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Command Reference
Precompute...

• Substrate > Precompute - Computes the substrate function over a designated
range.

• Mesh > Precompute - Specifies the frequency for which the mesh will be
precomputed. The default value in the Global Mesh Setup Panel or the
Precompute Substrate dialog box is used if no value is specified here. You can
set the frequency to any value within the range of the substrate definition.

Summary...

Displays the summary of a Momentum process:

• Substrate > Summary - Displays a summary of the substrate processes which
have occurred.

• Mesh > Summary - Provides a count of the cell types. A count of the resources
used to compute the mesh is also provided. Every mesh computation completed
is reported.

• Simulation > Summary - Provides a summary of simulation data. Details about
mesh reduction and quasi-static calculations are included when using the RF
mode.

• Optimization > Summary - Displays a copy of the Optimization window data.

Port Editor...

Defines the Momentum specific characteristics of the ports in the layout. The port
editor cannot be activated until after the substrate dielectric layers and the circuit
metallization have been defined.

Box-Waveguide Menu

Add Box...

A box can be added onto a substrate that is between an upper and a lower ground
plane.

Delete Box

Click and the previously defined box will be deleted.
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Add Waveguide...

A waveguide can be added onto a substrate that is between an upper and a lower
ground plane. A waveguide can be defined parallel to either the X-axis or the Y-axis.

Delete Waveguide

Click and the previously defined waveguide will be deleted.

Component

Parameters...

Allows you to change a layout parameter to show how an incremental change in the
parameter value affects your original layout.

Create/Update...

Specifies settings for creating or updating a layout component.

Model Database...

Displays models already available for a component. The parameter settings for every
available model can be viewed and models can be deleted.

Mesh Menu

Setup...

Defines the parameters to be used in computing a mesh.

Precompute...

Specifies the frequency for which the mesh will be precomputed. The default value in
the Global Mesh Setup Panel or the Precompute Substrate dialog box is used if no
value is specified here. You can set the frequency to any value within the range of the
substrate definition.

Summary...

Provides a count of the cell types. A count of the resources used to compute the mesh
is also provided. Every mesh computation completed is reported.

Clear

Erases the mesh that is displayed on the structure after the mesh is computed.
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Command Reference
Simulation Menu

S-parameters...

Defines the parameters and performs a simulation.

Summary...

Provides a summary of simulation data. Details about mesh reduction and
quasi-static calculations are included when using the RF mode.

Optimization Menu

Parameters...

Specifies the layout parameters to be optimized. Opens any designs related to
optimization. Displays the optimal values of specified parameters.

Goals...

Specifies the goals of the optimization.

Run...

Runs the optimization. Specifies the type of optimization method to be used.

Summary...

Displays a copy of the Optimization window data.

Post-Processing Menu

Radiation Pattern...

Defines the properties for calculating a radiation pattern and performs the
calculations.

Visualization...

Opens the Momentum Visualization display tool for viewing simulation results in 3D.
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3D EM Menu

Save Files for 3D EM

Writes Momentum data to 3D EM project files for import into 3D EM
modeling tools. The files are saved in the current project under
<project_name>/mom_dsn/<design_name>/3DEM, and contain the design geometry
and the Momentum setup.
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Appendix H: Momentum Matrix Solver

Tuning the solve speed of Momentum
On a modern computer, there are major differences in bandwidth and latency
between the registers of the processor, the caches, the main memory and the swap
memory. Minimizing the number of memory levels that are crossed when accessing
data can have a dramatic impact on the speed of an algorithm. The linear equation
solver used in the solve stages of a Momentum simulation acts on the blocks of
elements in the equation matrix. The size of the matrix blocks must match the
machine’s memory hierarchy for the best performance. The optimal block size
depends on the computer type and to a lesser extent on the size of the Momentum
problem. The solve speed can be improved significantly by the block operations in the
algorithm. This occurs when the data locality induced by the size of the blocks
properly matches with the machine’s memory/cache configuration.

The MOM3D_USE_MATRIXSOLVER configuration variable allows you to select
between a non-blocked and a blocked solver algorithm. The non-blocked solver is used
when MOM3D_USE_MATRIXSOLVER = 0 and the blocked solver is used with
MOM3D_USE_MATRIXSOLVER = 1. On some platforms the blocked solver can give
a significant speed advantage.

On Unix platforms (HP-UX, Solaris and Linux), the value of the integer configuration
variable MOM3D_USE_MATRIXSOLVERBLOCKSIZE can be set in the
momentum.cfg file. This variable is used to tune the linear solver of Momentum for
optimal performance on the computer running Momentum.

The default value for this block size has been set to maximize performance for most
Momentum problems. However, for larger problems you may want to experiment
with this setting to try and speed up the simulations.

Example setting:

MOM3D_USE_MATRIXSOLVERBLOCKSIZE = 16

Values between 8 and 96 have been tested and the results are highly machine type
dependent. Example values found to improve speeds by machine type:

• HP-UX PA-RISC 8K: 16 to 40

• Solaris: 32 to 72

• Red Hat Linux
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Momentum Optimization - Layout Parameterization
Intel Pentium IV: 16 to 64

Intel Pentium III: 8 to 32

Note: A customized momentum.cfg file can be placed (in decreasing order of
priority) in a project directory, in $HOME/hpeesof/config or in
$HPEESOF_DIR/custom/config. The configuration value found at the highest priority
level takes precedence.
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Numerics
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and far-field calculations, 3-29
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3D field plots, 14-2

A
absorbing layers
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simulation messages, 8-8
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Add command, 3-10
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ports, 4-1
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example, 3-29
on coplanar designs, B-12

animating
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on plots, 11-6
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substrate example for, 3-29
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B
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overview, 1-3
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C
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and facets, 7-20
and mesh density, 7-14
in a mesh, 7-1

cells per wavelength, 7-14
Change Layer To command, 2-7
changing

substrates, 3-4
characteristic impedance

plotting, 15-3
viewing, 15-1, 15-2

circuits
analyzing in Momentum, 8-1
enclosures, 5-1
mesh parameters, 7-2

CITIfiles
of S-parameters, 12-6

clearing
mesh parameters, 7-10

closed boundary layers
defining, 3-9

commands
location of, 1-2

common mode ports
defining, 4-18
overview, 4-3
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viewing, 12-1

components
creating a layout, 6-11
EM/circuit cosimulation overview, 1-3
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model database, 6-18
using in schematics, 6-19
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mesh, 7-11
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conductivity loss
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designs
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drawing, B-3
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defining, 4-14
overview, 4-3

coplanar waveguide
drawing, B-3
ports, 4-14, A-17
tips for drawing, B-8
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coupled lines

and mesh, 7-26
coupling effects

ports, 4-9, 4-10
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CPU

requirements, A-26
current plots

animating, 13-3
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displaying, 13-1
plotting, 13-2

Cut command, 3-10

D
data

adding to plots, 11-10
controls, 11-11
erasing from plots, 11-13
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types to display, 11-8

Data Display window
viewing simulation results, 10-1
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of results, 10-5
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defaults

mesh parameters, 7-2
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defining
a box, 5-2
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a mesh, 7-2
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an open boundary, 3-6
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interface layers, 3-7
metallization layers, 3-11
ports, 4-1
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vias, 3-14
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substrates, 3-4
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of a mesh, 7-14
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designs

importing, 1-2
substrate examples, 3-28
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defining, 4-12
overview, 4-3
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mesh, 13-4
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plots, 11-9
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drawing
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application for, 7-25
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global setting, 7-3

editing
a box, 5-3
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for circuits, 5-1
equivalent network model, A-4
erasing

mesh parameters, 7-10
mesh settings, 7-5
meshes on designs, 7-13
substrates, 3-4

even modes
ports, 4-18

example
microstrip line with step in width, 2-13

examples
air bridges, 3-29
locating, 1-7
of substrates, 3-28
optimizing a filter, 16-33
optimizing a microstrip line, 16-23

exporting
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substrate, C-3

F
far-field plots
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overview, 10-9
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in 3D, 14-2
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features
in Visualization, 11-2

fields
displayed in 3D, 14-2

file extension
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for substrates, 3-2

file names
for radiation datasets, 9-7

files
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locating, 3-3
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foreground mode, 8-4
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frequency

limitations, A-23
of a mesh, 7-14
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and simulations, 8-2
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deleting, 8-3
editing, 8-3
moving, 8-4
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plotting, 15-2
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and mesh, 7-26
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mesh parameters, 7-2
GND

defining, 3-9
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substrate layer, 3-5

Green’s functions, 1-3, A-6
and substrates, 3-21

grid snap mode, 2-12
grid snaps, B-1
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setting display spacing, 2-9
ground reference ports

defining, 4-20
internal ports, 4-10, 4-20
overview, 4-3
uses, 4-20

grounds
in layout, 4-2
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in Momentum, 4-20
reference ports, A-10

internal ports, A-17
grouping ports, 4-9

H
H_phi variables, 10-10
H_theta variables, 10-10
halting

a simulation, 8-9

I
IC-CAP

saving Momentum data for import, C-1
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importing
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plots, 11-20
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example, A-17
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overview, 4-3

items
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L
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and simulation, 3-13
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vias, A-25

linear
sweep type, 8-2

locating Momentum examples, 1-7
locations

of substrates, 3-3
logarithmic

sweep type, 8-2
loss
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Index-5



vias, 3-14
material characteristics

dielectric conductivity, 3-25
dielectric loss tangent, 3-25
magnetic loss tangent, 3-27
permeability, 3-26
permittivity, 3-24

matrix
discrete, A-3
interaction, A-3

loading and solving, A-7
physical interpretation, A-4

memory
for mesh calculations, 7-20
usage, A-27
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overlaps, B-2

mesh
and discontinuity, 7-25
and layout precision, 7-26
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and simulation time, 7-19
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density, 7-2, 7-14

adjusting, 7-14, 7-25
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displaying on a plot, 13-4
edge mesh, 7-3, 7-16
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function of, 7-1
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global settings, 7-2
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overview, 1-3
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defaults, 7-1
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for an object, 7-5
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patterns and simulation time, 7-24
precomputing, 7-11
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slots, 7-25
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viewing, 7-12
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vias, 7-25
viewing calculation status, 7-11

Mesh > Precompute command, 7-11
Mesh > Setup Controls command, 7-2
Mesh Control command, 7-10
mesh reduction

simulation accuracy, 7-15
messages

during simulation, 8-8
from mesh generator, 7-23

metallization layers, 3-1
and conductivity, 3-15
and layout layers, 3-12
and overlap, 3-19
defining, 3-12
layout layers, 3-1
mapping layout layers, 3-14
slots, 3-12
steps for defining, 3-13
strips, 3-12
types, 3-12
vias, 3-13

metallization loss, A-9
vias, A-25

method of moments, A-1
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microstrip
line with step in width example, 2-13

microwave simulation mode, 1-2, A-20
mixed potential integral equation, A-2
modes

parallel plate, A-23
avoiding, A-24
effect of, A-24

ports, 4-12, 4-18
process, 8-4
simulation, 1-2, A-20
surface wave, A-25

Momentum, 16-14, 16-17
limitations, A-19
loading a project, 11-12
matrix solver, H-1
optimization session, 16-2
simulation modes, 1-2, A-20

moving
a plot, 11-15
frequency plans, 8-4
substrate layers, 3-10

N
names

for radiation datasets, 9-7
of S-parameters, 12-1

network model, A-4
normalization impedance

for S-parameters, 12-1

O
o,u axis

and mesh seeding, 7-7
object properties

viewing, B-2
object seeding, 7-6
objects

displaying, 13-2
erasing mesh parameters, 7-10
mesh density, 7-25
mesh parameters, 7-6
overlapping, 7-22
transmission line mesh, 7-6

odd modes
ports, 4-12

offsets
ports, 4-6

open boundary
defining, 3-6

opening
a substrate, 3-2

optimization
2D layout objects, 16-1
examples, 16-23, 16-33
for automated electromagnetic designs,

16-1
in Momentum, 16-1
of planar structures, 16-1
shapes, 16-1

optimization, in Momentum
adding parameters, 16-10
assessing optimized layouts, 16-4
bounds on parameters, 16-8
Control Editor, 16-17
criteria for stopping, 16-18
database contents, 16-4
deleting parameters, 16-11
editing parameters, 16-5, 16-11
editing perturbed designs, 16-13
goals

working with, 16-14
interpolation resolution, 16-9
nominal designs, 16-3
options, 16-17
parameters

adding, 16-10
advanced settings, 16-8
bounds, 16-8
deleting, 16-11
editing, 16-5, 16-11

parameters not optimized, 16-2
perturbed designs, 16-3

editing, 16-13
viewing, 16-13

preparations
defining design goals, 16-4

process, 16-3
restarting, 16-5

caution with modifications, 16-5
results

viewing, 16-20
running, 16-4
saved data, 16-4
S-parameters, 16-2
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starting, 16-18
status, 16-19
stopping the process, 16-18
typical session, 16-2
verifying incremental changes, 16-12
viewing perturbed designs, 16-13
viewing results, 16-20
viewing status, 16-19

overlap precedence, 3-19
overlaps

and meshes, 7-22
merging, B-2
meshes, 7-4
ports, 4-6
thin layer capacitors, 7-4

P
Pan command, 11-15
parallel plate modes, A-23

avoiding, A-24
effect of, A-24

PC to PC remote simulations, 8-18
perfect conductor, 3-15
permeability, 3-26

constant, 3-7
for interface layers, 3-8
parameters, 3-7
using, 3-6

permittivity, 3-24
of an interface layer, 3-8
parameters, 3-6
using, 3-6

phases
in current plots, 13-3
viewing, 12-1

phi, 10-10
physical design

and Momentum, 1-2
planar structures

optimizing, 16-1
plots

adding data to, 11-10
annotation, 11-6
displaying, 11-9
editing axes, 11-15
editing controls, 11-15
erasing data, 11-13
importing, 11-20

legends, 11-17
loading radiation results, 14-1
moving, 11-15
of currents, 13-2
of the mesh, 13-4
reading data, 11-13
retrieving, 11-8
rotating, 11-14
saving, 11-18
scaling, 11-15
Smith chart, 12-5
tiling, 11-3
views, 11-3

plotting
characteristic impedance, 15-3
gamma, 15-2
S-parameters, 12-1

point V
and mesh seeding, 7-7

Port Editor command, 4-5
ports

adding, 4-1
calibration, 4-4, A-7
common mode

defining, 4-18
overview, 4-3

coplanar, 4-14
defining, 4-14
overview, 4-3

coplanar waveguide, A-17
coupling effects, 4-9
de-embedding, 4-8
defining, 4-1
differential

defining, 4-12
overview, 4-3

editing, 4-21
function in a circuit, 4-1
ground, A-10
ground references

defining, 4-20
overview, 4-3

grouping, 4-9
in layout, 4-14
internal, 4-10, A-10

overview, 4-3
on a layout, B-4
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on strips and slots, 4-2
overlap, 4-6
overview, 1-3
PCB structure, A-11
polarity for slot, 4-14
reference offsets, 4-6
renumbering, 4-22
shifting port reference planes, 4-10
single

defining, 4-4
overview, 4-3

single strip, 4-4
solution weights, 13-1
types, 4-2
where to connect, 4-2

PORTZ variable, 10-4
positioning ports, 4-3
post processor

features, 11-2
viewing results, 11-1

Power variables, 10-10
Prad, 9-4
Precompute Mesh command, 7-11
Precompute Substrate command, 3-21
precomputing

mesh, 7-11
halting, 7-12

substrate
halting, 3-22

substrates, 3-21
predefined substrates, 3-2
preferences

for plots, 11-5
in Visualization, 11-5

primitive seeding, 7-6
printed circuit board

ports, A-11
projects

loading radiation results, 14-1
Momentum

viewing, 11-12
viewing data, 11-12

propagation constant
viewing, 15-1

propagation modes
ports, 4-12, 4-18

Properties command, B-2

R
radiating antenna

substrate for, 3-29
radiation

intensity, 9-4
patterns

and designs, 9-1, 9-2
and substrates, 3-29
calculating, 9-6
of boxes and waveguides, 5-7
viewing, 10-10

results
loading, 14-1

raw snap mode, 2-12
reading data

plotted data, 11-13
reference offsets

ports, 4-6
refreshing

plot windows, 11-8
remote simulations, 8-14

PC to PC, 8-18
See also Installation Guides
UNIX to UNIX, 8-15

renaming substrate layers, 3-10
resetting

mesh parameters, 7-4, 7-10
results

of a simulation, 10-1
overview, 1-4
stored in dataset variables, 10-4
types to view, 10-1
viewing, 10-1
viewing in Visualization, 11-1

reusing
simulation data, 8-5
substrates, 3-23

RF simulation mode, 1-2, A-20
rooftop function, A-2
Rotate command, 11-14
rotating

plots, 11-14

S
S matrix, 10-4
S variable, 10-4
S_50 variables, 10-4
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S_CONV
viewing, 10-7

S_CONV variables, 10-4
S_ERROR

viewing, 10-6
S_ERROR variables, 10-5
S_Z0 variables, 10-5
sample points

and simulation, 8-22
saving

a substrate, 3-3
Momentum data for 3D EM, C-3
Momentum data for IC-CAP, C-1
plots, 11-18
simulations, 8-5

Scale command, 11-15
scaling

axes, 11-16
plots, 11-15

schematics
using substrates, 3-3

seeded objects
data for, 7-8

seeding objects
editing, 7-26

Set Port Solution Weights command, 14-1
shapes

and properties, B-2
drawing, B-1
merging, B-2
optimizing, 16-1

sheet impedance, 3-17
sigma

and metallization layers, 3-17
silicon substrate layers, 3-11
Simulate Circuit command, 8-2
simulation data

reusing, 8-5
saving, 8-5

simulation modes, 1-2, A-20
matching to circuits, A-20
selecting, 1-5

simulations
and datasets, 8-5
and effects from mesh, 7-19
and layout layers, 3-13
and mesh reduction, 7-15
EM and circuit cosimulation, 6-2

far-field calculations, 9-1
frequency plans, 8-2
halting, 8-9
modes, 1-2, A-20
of metallization loss, A-9
of slots, A-9
overview, 1-4
prerequisites, 8-1
process, 8-1
process modes, 8-4
remote, 8-14

See also Installation Guides
setting sample points, 8-22
starting, 8-7
steps for defining, 8-1
stopping, 8-9
summary, 8-9
viewing results, 8-6, 9-9, 10-1, 11-1
viewing status, 8-8

single point
sweep type, 8-2

single ports
defining, 4-4
overview, 4-3

slots
and metallization layers, 3-12
defining, 3-14
drawing, B-3
limitations, A-25
meshing, 7-25
ports, 4-2
simulated, A-9

Smith charts
S-parameters, 12-5

snap
modes

mesh seeding, 7-7
snap modes

grid, 2-12
raw, 2-12

solution process
theory of operation, A-6

solve speed, H-1
solving a substrate, 1-3
S-parameters

displaying, 12-1
exporting, 12-6
in a table, 12-1
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magnitude plot, 12-3
names, 12-1
normalization impedance, 12-1
on a Smith chart, 12-5
optimizing, 16-2
overview, 12-1
phase plot, 12-3
plotting real and imaginary parts, 12-5
variables, 10-4

starting
a simulation, 8-7

status
of substrate calculation, 3-22

status messages, 8-8
stopping

a simulation, 8-9
stored

substrates, 3-3
strips

and metallization layers, 3-12
defining, 3-14
ports, 4-2

Substrate > Create/Modify command, 3-5,
3-14

Substrate > Delete command, 3-4
Substrate > Open command, 3-2
Substrate > Save As command, 3-3
Substrate > Save command, 3-3
Substrate > Update from Schematic

command, 3-3
substrate layers

adding, 3-10
closed boundary, 3-5
defining, 3-5
defining silicon, 3-11
deleting, 3-10
dielectric, 3-5
exporting to rfde, C-3
moving, 3-10
open boundary, 3-5
renaming, 3-10
types of, 3-5

substrates
and database, 3-21
and Green’s functions, 3-21
and radiation patterns, 3-29
changing, 3-4
defined, 3-1

definition of, 3-1
deleting, 3-4
editing, 3-4
examples, 3-28
file extension, 3-2
halting computations, 3-22
layers, 3-1
metallization layers, 3-1
on schematics, 3-3

when to update, 3-3
overview, 1-3
precomputing, 3-21

summary, 3-22
viewing status, 3-22

predefined, 3-2
requirements, 3-5
restrictions, 3-5
reusing, 3-1, 3-23
saved

default location, 3-3
saving, 3-3
solving, 1-3
steps for defining, 3-2
summary, 3-28
supplied with ADS, 3-2
thick, 3-7
thin, 3-7

subtracting geometries, 3-19
summary

of substrate calculations, 3-22
surface currents

displaying, 13-1
plotting, 13-2

surface wave modes, A-25
sweeps

types, 8-2
adaptive frequency sampling, 8-20
and sample points, 8-22

T
tables

of S-parameters, 12-1
technology files, 6-17
The, 6-2
theory of operation

overview, A-1
theta, 10-10
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thick substrates
requirements, 3-7

thin layer capacitors
overlaps, 7-4

thin layers
meshes, 7-4
meshing, 7-24

thin lines
meshing, 7-25

thin substrates
requirements, 3-7

tiling plots, 11-3
Touchstone files

of S-parameters, 12-6
transmission lines

data
viewing, 15-1, 15-2

mesh
application for, 7-25
for layout layers, 7-5
for objects, 7-6
global setting, 7-3

triangular cells
controlling, 7-20

U
Umax, 9-4
UNIX to UNIX remote simulations, 8-15
unmapping

layout layers, 3-14, 3-15

V
variables

containing results, 10-4, 10-10
of convergence data, 10-6

vias
and finite thickness, B-10
defining, 3-14
drawing, 3-32, B-8
drawing and mapping, B-10
examples, 3-32
limitations, A-25
metallization layers, 3-13
multiple, B-10
restrictions, 3-32
through multiple layers, B-10
treatment in Momentum, B-9

viewing

AFS parameters, 8-22
antenna parameters, 14-6
component model database, 6-18
data types, 11-8
far-field results, 9-9
far-fields, 14-2
far-fields in 2D, 14-5
mesh status, 7-11
mesh summary, 7-12
object properties, B-2
project results, 11-12
S_CONV, 10-7
S_ERROR, 10-6
simulation results, 8-6, 9-9, 10-1
simulation status, 8-8
simulation summary, 8-9
S-parameter magnitude, 12-3
S-parameter phase, 12-3
substrate status, 3-22
substrate summary, 3-22
transmission line data, 15-1
Visualization results, 11-1
windows, 11-3

views
annotation, 11-6
of plots, 11-3
preferences, 11-5
retrieving plots in, 11-8
selecting, 11-4

Visualization
data controls, 11-11
features, 11-2
preferences, 11-5
viewing results, 11-1

W
waveguides, 5-1

and layout layers, 5-5
and radiation patterns, 5-7
applications, 5-5
defining, 5-4
deleting, 5-5
editing, 5-4
overview, 1-3

weighting port solutions, 13-1
windows

refreshing, 11-8
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Z
Z0 variables, 10-5
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