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Getting Started with HFSS: A Waveguide T-Junction
Conventions Used in this Guide
Please take a moment to review how instructions and other useful infor-
mation are presented in this guide. 

•    Procedures are presented as numbered lists. A single bullet indicates 
that the procedure has only one step.

•    Bold type is used for the following:
- Keyboard entries that should be typed in their entirety exactly as 
shown. For example, “copy file1” means to type the word copy, to 
type a space, and then to type file1.

- On-screen prompts and messages, names of options and text boxes, 
and menu commands. Menu commands are often separated by car-
ats. For example, click HFSS>Excitations>Assign>Wave Port.

- Labeled keys on the computer keyboard. For example, “Press 
Enter” means to press the key labeled Enter.

•    Italic type is used for the following:
- Emphasis.
- The titles of publications. 
- Keyboard entries when a name or a variable must be typed in place 
of the words in italics. For example, “copy file name” means to 
type the word copy, to type a space, and then to type a file name.

•    The plus sign (+) is used between keyboard keys to indicate that you 
should press the keys at the same time. For example, “Press 
Shift+F1” means to press the Shift key and the F1 key at the same 
time.

•    Toolbar buttons serve as shortcuts for executing commands. Toolbar 
buttons are displayed after the command they execute. For example,

“On the Draw menu, click Line ” means that you can click the 
Draw Line toolbar button to execute the Line command.

Alternate methods or 
tips are listed in the left 
margin in blue italic 
text. 
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Getting Started with HFSS: A Waveguide T-Junction
Getting Help

Ansoft Technical Support
To contact Ansoft technical support staff in your geographical area, 
please log on to the Ansoft corporate website, http://www.ansoft.com, 
click the Contact button, and then click Support. You will find phone 
numbers and e-mail addresses for the technical support staff. Your 
Ansoft account manager may also be contacted in order to obtain this 
information.
All Ansoft software files are ASCII text and can be sent conveniently by e-
mail. When reporting difficulties, it is extremely helpful to include very 
specific information about what steps were taken or what stages the 
simulation reached. This allows more rapid and effective debugging.

Context-Sensitive Help
To access online help from the HFSS user interface, do one of the follow-
ing:
•    To open a help topic about a specific HFSS menu command, press 

Shift+F1, and then click the command or toolbar icon.
•    To open a help topic about a specific HFSS dialog box, open the dia-

log box, and then press F1.
 iv 
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1 Introduction
This Getting Started guide is written for HFSS beginners as well as 
experienced users who are using HFSS version 9 for the first time. 
This guide will lead you step-by-step through creating, solving, and 
analyzing the results of a waveguide T-junction.
By following the steps in this guide, you will learn how to perform the 
following tasks in HFSS:
D Draw a geometric model.
D Modify a model’s design parameters.
D Assign variables to a model’s design parameters.
D Specify solution settings for a design.
D Validate a design’s setup. 
D Run an HFSS simulation.
D Create a 2D x-y plot of S-parameter results.
D Create a field overlay plot of results.
D Create a phase animation of results.

Estimated time to 
complete this guide:
45 minutes.
Introduction 1-1



Getting Started with HFSS: A Waveguide T-Junction
About the T-Junction
The waveguide you will create is T-shaped with an inductive septum.1 
This type of structure is used to split an incoming microwave signal into 
two outgoing signals. The septum divides the signal and directs it to the 
outgoing ports, while minimizing reflection at the signal’s point of entry.
A signal at a frequency of 10 GHz enters the waveguide at Port 1 (see 
below) and exits at Port 2 and Port 3. The waveguide’s transmission and 
reflection of the signal will depend on the position of the septum.

Expected Results
When the septum is located centrally opposite Port 1, it divides the sig-
nal and directs it evenly towards the output ports, Port 2 and Port 3. The 
magnitude of S-parameters at the output ports is expected to be about 
0.7. Small reflection is expected at Port 1.
You will move the septum 0.2 inches closer to Port 2 to reduce the trans-
mission through Port 2 to about 0.1 and increase the transmission 
through Port 3 to about 0.9.
To determine if the results are as expected, you will compare HFSS’s S-
parameter calculations at each septum position on a 2D x-y plot. You will 
also compare the E-field pattern at each septum position by creating 
phase-animated field plots on the model geometry. These will indicate if 
the field pattern changes as expected with the septum’s position.

[1] “Parametrics and Optimization Using Ansoft HFSS,” Microwave Journal, Product Reviews, November 1999.

Port 3

Port 1

Septum

Port 2
1-2 Introduction 



Getting Started with HFSS: A Waveguide T-Junction
Using HFSS 9.0 to Create and Improve the Design
It has never been easier or faster to create, analyze, and optimize a 
model using HFSS. As you step through this Getting Started guide, you 
will be introduced to several key concepts in version 9:
•    There are numerous ways to perform most tasks. For example, sev-

eral methods will be presented for selecting and for assigning design 
parameter values.

•    There is no required sequence of events when creating a design. A 
convenient method for creating the T-junction will be demonstrated, 
but the design setup steps can be completed in any logical order. 

•    You can quickly modify design properties at any time. For example, 
you will draw a box freehand, then specify its exact dimensions in the 
Properties window.

•    You can easily track modifications to your design in the history tree 
and the project tree. The branches provide access to setup dialogs, 
in which you can modify design properties.

•    You can modify the model view at any time. You will learn shortcut 
keys like Ctrl+D, which fits the model in the view window.

•    You can save time by parameterizing design properties. For example, 
you will assign a design variable to the septum’s position. This will 
enable you to quickly modify it and generate new results.

•    You can use HFSS’s extensive post processing features to evaluate 
solution results. For example, the animations you will create will 
help you visualize the difference in field pattern results for the two 
septum positions.

Parameterizing is most 
effective when paired 
with Ansoft’s Optimet-
rics software. It 
includes the capability 
to define and solve a 
series of variable val-
ues within a range, 
called parametric anal-
ysis. Or you 
can perform an optimi-
zation analysis, in 
which Optimetrics 
changes the design 
parameter values to 
meet a user-defined 
goal. Both of these 
capabilities are dem-
onstrated in “Getting 
Started with Optimet-
rics: Optimizing a 
Waveguide T-Junc-
tion Using HFSS and 
Optimetrics.”
Introduction 1-3
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2 Set up the Design
In this chapter you will complete the following tasks:
D Save a new project.
D Insert a new HFSS design into the project.
D Select a solution type for the project.
D Set the drawing units for the design.

Estimated time to 
complete this chapter:
5 minutes.
Set up the Design 2-1
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Open HFSS and Save a New Project
A project is a collection of one or more designs that is saved in a single 
*.hfss file. A new project is automatically created when HFSS is 
launched. Open HFSS and save the default project by a new name.
1  Double-click the HFSS 9 icon on your desktop to launch HFSS.

A new project is listed in the project tree in the Project Manager 
window and is named Projectn by default. Project definitions, such as 
material assignments, are stored under the project name. 

2  On the File menu, click Save As.
3  Use the file browser to locate the folder in which you want to save 

the project, such as C:\Ansoft\HFSS9\Projects, and then double-click 
the folder’s name.

4  Type Tee in the File name text box, and then click Save.
The project is saved in the folder you selected by the file name 
Tee.hfss.

If HFSS was already 
open and a default 
project is not listed in 
the project tree, add a 
new HFSS project: On 
the File menu, click 
New

.

2-2 Set up the Design 



Getting Started with HFSS: A Waveguide T-Junction
Insert an HFSS Design
You will now add an HFSS design to the project.
1  On the Project menu, click Insert HFSS Design .

The new design is listed in the project tree. It is named HFSSModeln 
by default. The 3D Modeler window appears to the right of the 
Project Manager. 

2  Rename the design: Right-click HFSSModeln in the project tree, and 
then click Rename on the shortcut menu.

3  Type TeeModel, and then press Enter.

Select a Solution Type
Now you will specify the design’s solution type. As you set up the design 
for analysis, available settings will depend upon the solution type. For 
this design, you will choose Driven Modal as the solution type, which is 
appropriate when calculating mode-based S-parameters of a passive, 
high-frequency waveguide that is being “driven” by a source. 
1  On the HFSS menu, click Solution Type.

2  In the Solution Type dialog box, select Driven Modal, and then click 
OK.

History Tree

3D Modeler Window
Project Manager

Window

To automatically 
expand the project tree 
when an item is added 
to the project: Click 
Tools>Options> Gen-
eral Options. 
Under Project Options, 
select Expand Project 
Tree on Insert.

If the Project Manager 
does not appear after 
you insert a new 
design, click 
View>Project Man-
ager.
Set up the Design 2-3



Getting Started with HFSS: A Waveguide T-Junction
Set the Drawing Units
You will now set the units of measurement for drawing the geometric 
model.
1  On the 3D Modeler menu, click Units. 

2  In the Set Model Units 
dialog box, click in in 
the Select units pull-
down list, and then click 
OK. 

The Rescale to new 
units option changes 
the current units of all 
objects in the design to 
the new units. For 
example, 1 mm would 
become 1 in.
2-4 Set up the Design 



3 Create the Model
In this chapter you will complete the following tasks:
D Draw a section of the T-junction.
D Assign a wave port with an integration line to the section.
D Duplicate the section to create the other two sections of the

T-junction.
D Unite the three sections to create the complete T-junction.
D Draw the septum.
D Assign a variable to the septum’s position.
D Subtract the septum from the T-junction.

Estimated time to 
complete this chapter:
15 minutes.
Create the Model 3-1



Getting Started with HFSS: A Waveguide T-Junction
Create the T-Junction
The T-junction is made up of three joined box objects. First you will 
draw a box that represents one section of the tee. You will assign it a 
name, confirm its material assignment, and then assign a wave port to 
one of its faces. 
You will then duplicate the box two times to create the second and third 
sections of the tee. Last, you will unite the three sections to create the 
complete T-junction.

Draw a Box
Draw a 3D box object to represent the first section of the tee. 

1  On the Draw menu, click Box . 
2  Specify the base corner of the box as (0, -0.45, 0):

a.  Press Tab to move to the X text box in the status bar. 
b.  Type 0 in the X box, and then press Tab to move to the Y box. 
c.  Type -0.45 in the Y box, and then press Tab.
d.  Type 0 in the Z box, and then press Enter.

3  Specify the length and width of the box by entering a point relative in 
distance to the base corner: Type (2, 0.9, 0) in the dX, dY, and dZ 
boxes, and then press Enter.

4  Specify the height of the box by entering a point on the z-axis relative 
in distance to the previously entered point: Type (0, 0, 0.4) in the 
dX, dY, and dZ boxes, and then press Enter.

To move to the previ-
ous coordinate box, 
press Shift+Tab.

If you make a mistake, 
click TeeModel in the 
project tree, and then 
click Undo on the Edit 
menu to undo design 
operations. HFSS lets 
you undo every com-
mand performed since 
the last save. 
3-2 Create the Model



Getting Started with HFSS: A Waveguide T-Junction
The Properties window appears, with the Command tab selected, 
enabling you to modify the dimensions or position of the box.

While the Properties window is open, you will use it to assign a name 
to the box, confirm its material assignment, and make it more trans-
parent.

Assign a Name to the Box
Assigning a name to the box will make it easier to track modifications 
you make to the design.

1  In the Properties window, click the Attribute tab.
2  Change the name of the box to Tee: Type Tee in the Value text box in 

the Name row, and then press Enter.

If you don’t want the 
Properties dialog box 
to appear after you 
draw an object: Click 
Tools>Options>3D 
Modeler Options. In 
the 3D Modeler 
Options window, click 
the Drawing tab, and 
then clear the Edit 
property of new primi-
tives option.
Create the Model 3-3



Getting Started with HFSS: A Waveguide T-Junction
Confirm the Material Assigned to the Box
By default, the material assigned to the box is vacuum. This is the mate-
rial you will use for the T-junction. Confirm that vacuum is the value in 
the Material row. so do not modify this material assignment.

Increase the Transparency of the Box
Increasing the box’s transparency will make it easy for you to distinguish 
separations between other objects you will draw.

1  Click the value in the Transparent row.
The Set Transparency window appears.

2  Move the slider until the transparency level is 0.4, and then click OK.
3  Click OK to close the Properties window.

The first box object in the 3D Modeler window.
It is selected by default when you exit the Properties window.

The name Tee
was assigned 
to the box. 
The commands 
performed on 
the box are 
tracked in the 
history tree.
3-4 Create the Model
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Assign a Wave Port to the Box
Now you will assign a wave port to the face of the box that is parallel to 
the yz plane at x = 2. As part of the setup process, you will define an 
integration line, which is a vector that specifies the direction of the 
excitation field pattern at the port. It will ensure that the field pattern 
is consistent at all ports.

1  Switch to face selection mode by pressing 
the shortcut key F.

2  Click the face of the box that is parallel to 
the yz plane at x = 2, as shown to the right.

3  Right-click the 3D Modeler window, and 
then click Assign Excitation>Wave Port on 
the shortcut menu.
The Wave Port wizard appears.

4  Type Port1 in the Name text box, and then 
click Next.

5  Select New Line from the Integration Line 
pull-down list.

6  In the 3D Modeler window, select the start 
point of the vector, (2, 0, 0), by clicking the 
edge center at the bottom of the face. By default, the cursor should 
snap to this point, appearing as a triangle.

7  Select the end point (2, 0, 0.4) by clicking the edge center at the top 
of the face.

The Wave Port dialog box reappears.
8  Accept the default settings by clicking Next.

The face of the box
that is parallel to the

yz plane at x = 2.

To magnify the view of 
the port face, press 
Alt+Shift while drag-
ging the mouse 
towards the top of the 
view window. Drag the 
mouse towards the 
bottom of the window 
to zoom out.
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9  Accept the default settings by clicking Finish.

The assigned port.

Duplicate the Box
Now you will duplicate the box to create the second and third sections of 
the T-junction. The attributes of the box will be duplicated along with its 
geometry. Boundary assignments, including wave port settings, can be 
duplicated along with the geometry if the option is set in the HFSS 
Options dialog box. You will make sure this setting is selected.

Set Duplicates to Copy Boundaries

1  On the Tools menu, point to Options, and then click HFSS Options.
2  Under the General tab of the HFSS Options dialog box, select Dupli-

cate boundaries with geometry, and then click OK.

Duplicate the Box to Create the Second Section
Duplicate the box 90 degrees around the z-axis to create the second sec-
tion.

1  Right-click Tee in the history tree, and then click Edit>Duplicate>

Around Axis  on the shortcut menu.
2  In the Duplicate Around Axis dialog box, select Z.
3  Type 90 in the Angle box. A positive angle causes the object to be 

placed in the counter-clockwise direction.
4  Type 2 in the Total Number box. This is the total number of objects, 

including the original, that will be created.
5  Click OK.

The parent object, Tee, is duplicated and the duplicate, named Tee_1 
by default, is placed around the z-axis at a 90-degree angle. The 
attributes of the parent object, including its dimensions, material, 
color, transparency, port, and integration line were duplicated with 
the box.
3-6 Create the Model
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Port1 was duplicated with the geometry of the box. The new port is named Port2 by 
default, which you can verify under Excitations in the project tree.

6  Press Ctrl+D to fit the objects in the view window.

The history tree shows 
that the Tee object 
was duplicated and a 
new object, named 
Tee_1, was created.

Port2
Create the Model 3-7



Getting Started with HFSS: A Waveguide T-Junction
Duplicate the Box to Create the Third Section
•    Duplicate the first box again using the same procedure, but this time, 

type -90 in the Angle box. A negative angle causes the object to be 
placed in the clockwise direction.

The parent object, still selected, and its duplicates.

Save your project fre-
quently: Click Save on
the File menu

.
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Getting Started with HFSS: A Waveguide T-Junction
Unite the Boxes
Now you will unite the three sections to create the complete T-junction. 
Before doing this, you want to be sure that HFSS will not create copies of 
the original objects before joining them, so you will clear the “clone 
before unite” option in the 3D Modeler Options dialog box.

1  On the Tools menu, point to Options, and then click 3D Modeler 
Options.

2  Under the Operation tab of the 3D Modeler Options dialog box, 
make sure the Clone tool objects before uniting option is clear, and 
then click OK.

3  Switch to object selection mode by pressing the shortcut key O.
4  Select the first box by clicking it in the view window.
5  Hold the Ctrl key and click the second and third boxes.
6  On the 3D Modeler menu, point to Boolean, and then click

Unite .
The objects are united at the points of intersection. The new object 
has the same attributes as the first object selected.

The united object.
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Create the Septum
The septum is a 3D box object that will be subtracted from the
T-junction. When you draw the septum, you will make its y position 
dependent on the value of a variable. 

Draw a Box
This time when you draw a box, you will draw it freehand, and then mod-
ify its dimensions and position in the Properties window.

1  On the Draw menu, click Box . 
2  Draw an arbitrarily shaped box in the 3D Modeler window: Select a 

corner of the base rectangle, then select a second corner of the base 
rectangle, and then select a point on the axis perpendicular to the 
base rectangle.
When you have selected the last point of the box, the Properties 
window appears, with the Command tab selected. 
Now you will assign the box’s exact position and dimensions.

As a guideline, aim for 
the first point to be 
near the coordinates 
(-0.45, 0, 0), the sec-
ond point near 
(0.45, 0.1, 0), and the 
third point near 
(0, 0, 0.4).
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Parameterize the Position of the Box
When you specify the box’s position, you will enter the following expres-
sion for the y position: offset - 0.05, where offset is the name of a vari-
able you will define. Because the variable offset will not yet be defined 
when you type it in the expression, the Add Variable dialog box will 
appear, enabling you to define value for offset.
When you specify the variable’s value, you must include its unit of mea-
surement as part of the value.

1  In the Position text box, type -0.45in, offset - 0.05in, 0in and then 
press Enter.
The Add Variable dialog box appears.

2  Type 0in in the Value text box, and then click OK.
You return to the Properties window.

Now you will set the exact dimensions of the box.

Modify the Dimensions of the Box
1  In the Properties window, under the Command tab, type 0.45 in the 

Xsize box.
2  Type 0.1 in the Ysize box.
3  Type 0.4 in the Zsize box.

While the Properties window is open, you will assign a name to the 
box.

Alternatively, you 
could define the vari-
able offset before you 
draw the septum. 
Local variables can be 
defined in the Proper-
ties window, which is 
accessed by right-
clicking the design in 
the project tree, and 
then clicking Design 
Properties.
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Assign a Name to the Box
1  In the Properties window, click the Attribute tab.
2  Type Septum in the Value text box in the Name row.
3  Click OK.

The septum object in the 3D Modeler window.

4  Optionally, rotate the view to get a better view of the septum object: 
Press Alt and drag the mouse in the direction you want to rotate the 
view.
3-12 Create the Model
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Subtract the Septum from the T-Junction
To complete the model geometry, you will now subtract the septum 
object from the T-junction.

1  Click Tee in the history tree to select the tee object.
2  Hold down the Ctrl key and click Septum in the history tree to select 

the septum.
3  On the 3D Modeler menu, point to Boolean, and then click

Subtract .
The Subtract dialog box appears. Septum is listed in the Tool Parts 
list and Tee is listed in the Blank Parts list, indicating that the sep-
tum object will be subtracted from the tee object. 

4  Make sure the Clone tool objects before subtracting option is clear.
5  Click OK.

The septum is subtracted from the tee. The new object has the same 
attributes as the first object you selected, the tee object.

The complete model geometry.
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4 Set up and Generate 
Solutions
In this chapter you will complete the following tasks:
D Add a solution setup.
D Add a frequency sweep to the solution setup.
D Validate the design.
D Run the analysis.
D Modify the septum’s position.
D Re-run the analysis using the new septum position.

Estimated time to 
complete this chapter:
15 minutes.
Set up and Generate Solutions 4-1
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Add a Solution Setup to the Design
Specify how HFSS will compute the solution by adding a solution setup to 
the design. 
In the solution setup, you will instruct HFSS to perform an adaptive anal-
ysis at 10 GHz. During an adaptive analysis, HFSS refines the mesh itera-
tively in the areas of highest error. 

1  In the project tree, under the TeeModel design, right-click Analysis,

and then click Add Solution Setup  on the shortcut menu.
The Solution Setup dialog box appears.

2  Under the General tab, type 10 in the Solution Frequency text box, 
and leave the default unit set at GHz.

3  Under Adaptive Solutions, leave the Maximum Number of Passes set 
to 3. This is the maximum number of mesh refinement cycles that 
HFSS will perform. 

4  Accept the defaults for the other solution 
settings by clicking OK. 
The solution setup is listed in the project tree 
under Analysis. It is named Setup1 by default.

You want HFSS to solve over a range of frequen-
cies, so you will now add a frequency sweep to the solution setup.

Add a Frequency Sweep to the Solution Setup
A smooth frequency response is expected for this design, so you will 
select an Interpolating frequency sweep. An Interpolating sweep esti-
mates a solution for an entire frequency range. HFSS chooses the fre-
quency points at which to solve the field solution so that the entire 
interpolated solution lies within a specified error tolerance. The sweep 
is complete when the solution meets the error tolerance criterion or gen-
erates the maximum number of solutions. The sweep is solved after the 
adaptive analysis is complete.

1  Right click Setup1 in the project tree, and then click Add

Sweep .
The Edit Sweep dialog box appears.

2  Select Interpolating.
3  Accept the default settings for Error Tolerance and Max Solutions.

To learn more about 
solution parameters, 
see the HFSS online 
help.

The adaptive analysis 
will be performed at 
the solution fre-
quency, 10 GHz.

For the frequency 
sweep, HFSS will use 
the finite element 
mesh refined during 
the adaptive solution.
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4  Click Linear Step in the Type list.
5  Specify the following range of frequencies:

HFSS will solve the frequency point at each step in the specified fre-
quency range, including the start and stop frequencies. 
The dialog box will look like the following:

6  Click OK.
The frequency sweep is listed in the project tree under Setup1. It is 
named Sweep1 by default.

Start 8 GHz

Stop 10 GHz

Step Size 0.05 GHz

Click Display to verify 
the frequency points 
that will be solved.
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Validate the Design
Before you run an analysis, it is helpful to verify that all of the necessary 
setup steps have been completed and their parameters are reasonable. 

1  On the HFSS menu, click Validation Check .
HFSS checks the project setup, and then the Validation Check win-
dow appears.

2  Click Close.
Now you are ready to run the simulation.

Analyze the Design
Now you will run the simulation, which will generate results for the T-
junction when the septum is located centrally opposite Port 1.

•    On the HFSS menu, click Analyze .
HFSS computes the 3D field solution for every solution setup in the 
project. In this problem, Setup1 is the only setup.

The solution process is expected to take approximately 1 - 5 minutes. 
When the solution is complete, a confirmation message will appear in 
the Message Manager.

If there is a problem 
with the design setup, 
the Message Manager 
will list detailed error or 
warning messages. 
Click View>Message 
Manager to display the 
Message Manager.

You can monitor the 
solution’s progress in 
the Progress window If 
the Progress window 
is not visible, click 
View>Progress Win-
dow.

You should save the 
project before running 
the simulation. To 
automatically save 
projects before solv-
ing, click Tools>
Options>HFSS 
Options. Under the 
General tab, select 
Save before solving. 
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Move the Position of the Septum
When the analysis is complete, modify the septum’s position by changing 
the value of the variable offset.

1  Right-click the design name TeeModel in the project tree, and then 
click Design Properties. 
The Properties dialog box appears.

2  Under the Local Variables tab, select Value.
3  Type 0.2 in the Value text box for the variable offset.
4  Click OK.

The geometry is updated in the 3D Modeler window.

Top-down view of the septum in its new position, closer towards Port 2.

Re-analyze the Design
Now you will run a second simulation to generate results for the
T-junction when the septum is located closer to Port 2. The previous 
solution is saved and available for post processing. 
•    Right-click Analysis in the project tree, and then click

Analyze .
HFSS computes the new 3D field solution.

The solution process is expected to take approximately 1 - 5 minutes.
Proceed to the next step in the next chapter, creating a 2D x-y plot of S-
parameter results, while the analysis is running. HFSS will populate the 
plot with data when the solution is complete.
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5 Compare the Solutions 
In this chapter you will complete the following tasks:
D Create a 2D x-y plot of S-parameters.
D Create a field overlay plot on a surface of the T-junction.
D Animate the field overlay plot.
D Modify the septum’s position and re-animate the field overlay 

plot.
D Close the project and exit HFSS software.

Estimated time to 
complete this chapter:
10 minutes.
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Create a Rectangular Plot of S-Parameter Results
Now you will create a 2D x-y (rectangular) plot that compares the S-
parameter results at each port for the two septum positions.

1  Right-click Results in the project tree, and then click Create Report.
The Create Report dialog box appears.

2  Click Modal S Parameters in the Report Type list.
3  Click Rectangular Plot in the Display Type list, and then click OK.

The Traces dialog box appears.
4  Under the Y tab, specify the information to plot along the y-axis:

a.  In the Category list, click S parameter.
b.  In the Quantity list, press Ctrl and click S(Port1, Port1), S(Port1, 

Port2), and S(Port1, Port3). 
c.  In the Function list, click mag.

5  Under the X tab, select Use Primary Sweep.
The first (primary) sweep variable listed under the Sweeps tab will 
be plotted along the x-axis.

6  Click the Sweeps tab.
The primary sweep variable is Freq, which HFSS recognizes as the fre-
quency points solved during the frequency sweep.

7  Select Sweep Design and Project variable values.
This enables you to sweep the values of offset that were solved dur-
ing the analysis. The values will be represented as curves on the 
graph.

8  Click Add Trace.
A trace represents a line connecting data points on the plot. 
Three traces are added to the traces list at the top of the dialog box. 

9  Click Done.
The magnitude of the S-parameters at each offset value will be plot-
ted against frequency on an x-y graph, as shown on the next page. 
The plot is listed under Results in the project tree.
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The three blue-shaded lines show the S-parameter values at each port when offset = 0 in. 
The three red-shaded lines show the S-parameter values at each port when 

offset = 0.2 in. The line styles in the plot above were modified in the
Traces Properties dialog box for better visualization.

As expected, small reflection near 0.2 is occurring at the input port, 
Port 1, (see ) when the value of the offset variable is 0, that 
is, when the septum is located centrally opposite to Port 1. At the 
same time, large and equal transmission near 0.7 occurs at the two 
output ports, Port 2 (see ) and Port 3 (see ).
The plot shows that the reflection at Port 1 decreases slightly (see 

) when the value offset is 0.2 inches, that is, when the septum 
is moved 0.2 inches towards Port 2. The transmission at Port 2 
decreases (see ) and the transmission at Port 3 increases (see 

) with the septum at this position.
Next you will create and animate a field overlay plot that will display 
the difference in field pattern between the two septum positions.

The line styles in the 
plot were modified in 
the Trace Properties 
dialog box for better 
visualization. 
To add data markers 
to all lines on the plot 
as shown: Double-
click a line. In the 
Trace Properties dia-
log box, click the Line 
Style tab, select Show 
Symbols On All 
Traces, and then type 
2 in the text box. The 
symbols associated 
with each line, shown 
in the legend to the 
right of the plot, will be 
added to the lines at 
every other data point. 
To change a line’s 
color: Under the Color 
tab, modify the 
selected line’s color by 
specifying new RGB 
values. 
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Create a Field Overlay Plot
A field overlay plot is a representation of a field quantity on a surface or 
within an object. You will plot the magnitude of the E-field on the top 
surface of the T-junction. First, move the septum back to its original 
position centrally opposite Port 1.

Modify the Position of the Septum
Change the value of the variable offset back to 0 inches:

1  Make sure the Property window is being displayed. If it is not, click 
View> Property Window.
The Properties window appears.

2  Click the design name TeeModel in the project tree.
3  Under the Variables tab in the Properties window, type 0 in the 

Value text box for the variable offset, and then press Enter.

Create the Field Plot
1  Return to the 3D Modeler window: On the HFSS menu, click 3D Model 

Editor.
2  Switch to face selection mode: Right-click in the view window, and 

then click Select Faces on the shortcut menu.
3  Select the top face of the T-junction:
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4  Click HFSS>Fields>Plot Fields>Mag_E.
The Create Field Plot dialog box appears.

5  Select Setup1:LastAdaptive as the solution to plot in the Solution 
pull-down list.

6  Accept the default settings by clicking Done.
The plot appears on the top surface of the T-junction. It shows the E-
field distributed evenly towards Port 2 and Port 3. 
The new plot is listed under Field Overlays in the project tree. It is 
named Mag_E1, which was the default name set in the Create Field 
Plot dialog box.

The Mag_E1 plot of the E-field when the septum is located opposite Port 1. 
The new plot is listed in a default folder under Field Overlays in the project tree.

Now you will animate the field overlay plot.

To hide the color key 
that appears in the 
upper-left corner of the 
3D Modeler window: 
Right-click the color 
key, and then click 
Hide.

You can also open the 
Create Field Plot 
dialog by right-clicking 
the view window and 
then clicking Plot 
Fields>Mag_E on the 
shortcut menu.
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Animate the Field Overlay Plot
An animated plot is a series of frames that displays a field, mesh, or 
geometry at varying values. You specify the values of the plot that you 
want to include, just as an animator takes snapshots of individual draw-
ings that make up a cartoon. Each value is a frame in the animation.

1  Right-click Mag_E1 in the project tree, and then click Animate.
The Setup Animation dialog box appears.

2  Under the Swept Variable tab, click Phase on the Swept Variable 
list.

3  Specify the phase values to include in the animation:
a.  Type 0deg in the Start text box.
b.  Type 160deg in the Stop text box.
c.  Type 8 in the Steps text box. 

4  Click OK.
The animation begins in the view window. It shows the septum steer-
ing the electromagnetic wave evenly towards Port 2 and Port 3.
The Animation dialog box appears in the upper-left corner of the 
desktop, enabling you to stop, restart, and control the speed and 
sequence of the frames.

The animation will display the plot at 8 phase values between 0 and 
160. The start value will be the first frame displayed, resulting in a 
total of 9 frames in the animation.

5  In the Animation dialog box, click the stop button .

Animations can be 
exported to animated 
Graphics Interchange 
Format (GIF) or to 
Audio Video Inter-
leave (AVI) format by 
clicking Export in the 
Animation dialog box. 
that will appear.

You can modify the 
view of the animation 
while it is running. For 
example, click the 
Zoom In or Out button

and drag the 
mouse towards the top 
(to zoom in) or bottom 
(to zoom out) of the 
view window.
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Modify the Septum’s Position and Re-animate
Now you will move the septum’s position closer to Port 2 to see its effect 
on the E-field pattern on the T-junction’s top surface.

1  Click the design name TeeModel in the project tree. You may need to 
drag the Animation dialog box to see the design name in the project 
tree.

2  Under the Variables tab in the Properties window, type 0.2 in the 
Value text box for offset, and then press Enter.
The updated animation automatically starts. It shows more of the 
electromagnetic wave moving towards Port 3 than towards Port 2. 

The animated Mag_E1 plot of the E-field when the septum
is located 0.2 inches closer to Port 2.
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Close the Project and Exit HFSS
Congratulations! You have successfully completed this HFSS 9.0 Getting 
Started guide! You may stop the animation, close the Tee project, and 
exit the software.

1  In the Animation dialog box, click the stop button , and then 
click Close.

2  Save the project .
3  On the File menu, click Close.
4  On the File menu, click Exit.

At this point, you may 
choose to go on to 
Getting Started with 
Optimetrics: Optimiz-
ing a Waveguide T-
Junction Using HFSS 
and Optimetrics. It 
uses the T-junction 
design you created in 
this guide to demon-
strate Optimetrics soft-
ware.
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